Automation

Überwachung der Solaranlage per eMail oder Pushover und Steuerung von Geräten mit Smart Home Zentralen. PV-Monitoring und Geräten mit Tasmota Firmware

Moderator: Ulrich

Babyjoe1973
Beiträge: 12
Registriert: Mi 22. Apr 2020, 08:50

Re: Automation

Beitrag von Babyjoe1973 »

Irgendwie stimmt hier noch was nicht! Bekomme zwar die Seite aber wird nicht richtig angezeigt!!!
Screenshot (2).png

Benutzeravatar
Ulrich
Administrator
Beiträge: 2421
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 12 Mal
Danksagung erhalten: 129 Mal
Kontaktdaten:

Re: Automation

Beitrag von Ulrich »

Das PHP ist nicht in Odnung. Gebe mal auf der Konsole
php -v

ein. Ob das PHP funktioniert.
--------------------------------------
Ulrich [Admin]

solarfanenrico
Beiträge: 263
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 16 Mal
Danksagung erhalten: 19 Mal

Re: Automation

Beitrag von solarfanenrico »

gelöscht, weil nicht erwünscht.

Benutzeravatar
Ulrich
Administrator
Beiträge: 2421
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 12 Mal
Danksagung erhalten: 129 Mal
Kontaktdaten:

Re: Automation

Beitrag von Ulrich »

Enrico,

ich möchte dich bitten sich nicht in meine Vorschläge einzumischen. Es hat schon einen bestimmten Grund, wenn ich das so dem Mitglied mitteile.

Es ging hier nicht darum, ob PHP installiert ist, sondern ob es funktioniert.
--------------------------------------
Ulrich [Admin]

Babyjoe1973
Beiträge: 12
Registriert: Mi 22. Apr 2020, 08:50

Re: Automation

Beitrag von Babyjoe1973 »

Kommt das:

PHP 7.3.27-1~deb10u1 (cli) (built: Feb 13 2021 16:31:40) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.27, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.3.27-1~deb10u1, Copyright (c) 1999-2018, by Zend Technologies

Benutzeravatar
Ulrich
Administrator
Beiträge: 2421
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 12 Mal
Danksagung erhalten: 129 Mal
Kontaktdaten:

Re: Automation

Beitrag von Ulrich »

Der Fehler ist, dass der benutzte WEB Server kein PHP eingebunden hat. Danach musst du suchen.
Kann es sein dass du den WEB Server getauscht hast und nicht mehr den lighttpd benutzt?
Vielleich hilft das auch weiter: https://wiki.ubuntu.com/Lighttpd+PHP

Alternativ kannst du natürlich das aktuelle Image runterladen und benutzen. Das wird die einfachste Lösung sein.
--------------------------------------
Ulrich [Admin]

tomhei
Beiträge: 2
Registriert: Do 8. Apr 2021, 11:08
Hat sich bedankt: 1 Mal

Re: Automation

Beitrag von tomhei »

Hallo,

erstmal grosses Lob und danke an den Entwickler.
Super Projekt - mein Sonoff sprach nach 5 Minuten mit dem Pi, klasse Interface mit Grafana und gutes Support Forum

Wollte mich nun auf den Weg der Automation machen, und habe das selbe Problem mit der fehlerhaften Anzeige:
Bild

Installiert wurde das aktuellste Image, ohne weitere Modifikation.

pi@solaranzeige:~ $ php -v
PHP 7.3.27-1~deb10u1 (cli) (built: Feb 13 2021 16:31:40) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.27, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.3.27-1~deb10u1, Copyright (c) 1999-2018, by Zend

Browser Cache gelöscht etc.

danke für Support
Tom

Benutzeravatar
Ulrich
Administrator
Beiträge: 2421
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 12 Mal
Danksagung erhalten: 129 Mal
Kontaktdaten:

Re: Automation

Beitrag von Ulrich »

Bitte rufe einmal

http://solaranzeige.local/automation.web.php


auf. Das ist die richtige Seite. Bin schon ganz meschugge...
--------------------------------------
Ulrich [Admin]

tomhei
Beiträge: 2
Registriert: Do 8. Apr 2021, 11:08
Hat sich bedankt: 1 Mal

Re: Automation

Beitrag von tomhei »

Hallo Ulrich,

des dud ;-)

hatte ich wohl einen falschen Link - jetzt geht es.
Ich werde weiter testen

thx and stay safe & sound
Tom

Babyjoe1973
Beiträge: 12
Registriert: Mi 22. Apr 2020, 08:50

Re: Automation

Beitrag von Babyjoe1973 »

Bei mir geht es jetzt! Habe das System neu aufgesetzt!

Antworten