Verbindungsprobleme mit Growatt MIC 600TL-X

Alles was mit der Solaranzeige Image Installation und Betrieb zu tun hat. Einfache Konfiguration mit einem Gerät.

Moderator: Ulrich

Benutzeravatar
Ulrich
Administrator
Beiträge: 2985
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 38 Mal
Danksagung erhalten: 192 Mal
Kontaktdaten:

Re: Verbindungsprobleme mit Growatt MIC 600TL-X

Beitrag von Ulrich »

Nach dem Tauschen nicht vergessen, den Raspberry neu zu starten!
--------------------------------------
Ulrich [Admin]

maverickluke
Beiträge: 6
Registriert: Mo 12. Jul 2021, 09:34
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Verbindungsprobleme mit Growatt MIC 600TL-X

Beitrag von maverickluke »

Hi Simon,

du hattest vollkommen recht.
Es waren nur A und B vertauscht. Nachdem ich das richtig verkabelt hatte, blinkten die TX/RX LEDs am USB Adpater und die Daten konnten ausgelesen werden. Vielen Dank!

@Enrico: auch dir danke für den Tipp. Aber der rebott hatte nichts gebracht weil die Verkabelung nicht richtig war. Nach dem Reboot mit der richtigen Verkabelung ging alles.

@Ulrich: Vielleicht könntest du in der Liste der unterstützten Wechselrichter den Eintrag für den Growatt Wechselerichter noch anpassen bzw um den kleinen 600TL-X ergänzen. In deiner Liste steht nämlich RJ45-Belegung PIN 3 = B; PIN 4 = A. Ich denke, dass das für die großen Brüder stimmen könnte, beim kleinen 600TL-X ist es aber der COM-Port und PIN 3 = A; PIN 4 = B. Würde mich freuenwenn du das noch hinzufügen könntest und es könnte anderen helfen. Danke dir dafür im Voraus.
viewtopic.php?f=13&t=1069

Mit dem Raspberry Pi läuft jetzt alles super. Jetzt teste ich das Docker Image. Dort läuft auch erstmal alles gut, ausser das ich kein Dashboard für den Growatt im Grafana finde. Dazu habe ich aber im entsprechendem Threat bereits eine Frage gestellt.

Gruß Luke

Benutzeravatar
Ulrich
Administrator
Beiträge: 2985
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 38 Mal
Danksagung erhalten: 192 Mal
Kontaktdaten:

Re: Verbindungsprobleme mit Growatt MIC 600TL-X

Beitrag von Ulrich »

Hallo Luke,

habe ich eingegeben. Vielen Dank für den Hinweis. Das die Adern genau vertauscht sein bei den Modellen ist aber gemein. :mrgreen:
--------------------------------------
Ulrich [Admin]

solarfanenrico
Beiträge: 593
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 30 Mal
Danksagung erhalten: 37 Mal

Re: Verbindungsprobleme mit Growatt MIC 600TL-X

Beitrag von solarfanenrico »

maverickluke hat geschrieben:
So 25. Jul 2021, 16:41
.....

Mit dem Raspberry Pi läuft jetzt alles super. Jetzt teste ich das Docker Image. Dort läuft auch erstmal alles gut, ausser das ich kein Dashboard für den Growatt im Grafana finde. Dazu habe ich aber im entsprechendem Threat bereits eine Frage gestellt.

Gruß Luke
Hallo,
ist die Frage entsprechend beantwortet.
Spezielle Dashboards für extra Wechselrichter, sind eigentlich nicht nötig. Und für Growatt eigentlich gar nicht.
Die dienen in der solaranzeige.de eigentlcih nur dem schnellen Einstieg, und erstem Test.

Wenn man etwas länger damit umgeht und verstehen lernt, hat man ganz schnell seine eigene Version.

Über Export/Import kann man in Grafana auch fremde Dashboards nutzen.

LG Enrico

prozi
Beiträge: 7
Registriert: Do 3. Jun 2021, 23:59
Hat sich bedankt: 2 Mal

Re: Verbindungsprobleme mit Growatt MIC 600TL-X

Beitrag von prozi »

Nabend zusammen,

ich lese schon seit einer geraumer Zeit mit.
Ich habe meinen Pi3b+ mit Grafana schon mal zum laufen gebracht. Jetzt wollte ich meinen Growatt MIC 1500TL-X mit dem Pi verbinden und bin auf euren Thread gestoßen.
Derzeit bin ich zwar noch den Wetter-Daten dran, also diese einzubinden bis ich das Adapterkabel hier liegen habe.

Nun zur eigentlichen Frage:
Welches Adapter Kabel also USB/RS485 Adapter kann ich dafür nutzen? muss das genau der von der o.g. ebucht seite sein, also diese ART ?
Der COM Anschluss sieht genauso aus wie bei dem 600er. würde dann auch erstmal an die letzten genannten Ports gehen und schauen ob es funktioniert.

geht auch sowas?
1) https://www.amazon.de/WINGONEER-USB-485 ... -de&sr=1-3


oder besser wie der von euch angegebenen
2) https://www.amazon.de/ARCELI-FTDI-Schni ... rs&sr=1-15

Danke schon mal für Eure Antworten.

Eshco93
Beiträge: 9
Registriert: Fr 2. Jul 2021, 22:06
Danksagung erhalten: 6 Mal

Re: Verbindungsprobleme mit Growatt MIC 600TL-X

Beitrag von Eshco93 »

prozi hat geschrieben:
Mo 13. Dez 2021, 21:01
Nabend zusammen,

ich lese schon seit einer geraumer Zeit mit.
Ich habe meinen Pi3b+ mit Grafana schon mal zum laufen gebracht. Jetzt wollte ich meinen Growatt MIC 1500TL-X mit dem Pi verbinden und bin auf euren Thread gestoßen.
Derzeit bin ich zwar noch den Wetter-Daten dran, also diese einzubinden bis ich das Adapterkabel hier liegen habe.

Nun zur eigentlichen Frage:
Welches Adapter Kabel also USB/RS485 Adapter kann ich dafür nutzen? muss das genau der von der o.g. ebucht seite sein, also diese ART ?
Der COM Anschluss sieht genauso aus wie bei dem 600er. würde dann auch erstmal an die letzten genannten Ports gehen und schauen ob es funktioniert.

geht auch sowas?
1) https://www.amazon.de/WINGONEER-USB-485 ... -de&sr=1-3


oder besser wie der von euch angegebenen
2) https://www.amazon.de/ARCELI-FTDI-Schni ... rs&sr=1-15

Danke schon mal für Eure Antworten.
Hallo prozi,

du brauchst einen USB/RS485 Adapter mit einem FTDI Chip. Entsprechend ist der erste von dir genannte Adapter nicht geeignet. Du musst aber auch nicht unbedingt den zweiten Adapter nehmen, wenn dir Bauform, Anschlüsse oder das fehlende Gehäuse nicht zusagen. Solche Adapter mit FTDI Chip (in der Regel FT232RL) gibt es auch noch von anderen Herstellern.

Gruß, Simon

prozi
Beiträge: 7
Registriert: Do 3. Jun 2021, 23:59
Hat sich bedankt: 2 Mal

Re: Verbindungsprobleme mit Growatt MIC 600TL-X

Beitrag von prozi »

Danke für die schnelle Antwort, dann nehm ich den angegebenen "2) Zweiten " Adapter.

prozi
Beiträge: 7
Registriert: Do 3. Jun 2021, 23:59
Hat sich bedankt: 2 Mal

Re: Verbindungsprobleme mit Growatt MIC 600TL-X

Beitrag von prozi »

so ich nochmal.
17.12. 15:26:06 -Regler: 48
17.12. 15:26:06 -Regler erkannt: /dev/ttyUSB0
17.12. 15:26:06 -Device: /dev/ttyUSB0 wird in die user.config.php eingetragen.
17.12. 15:26:06 -Zeile gefunden. USB Device kann ausgetauscht werden. Index: 591 $USBRegler = "/dev/ttyUSB0";

17.12. 15:26:06 -Zeile gefunden. Raspberry Modell kann eingetragen werden. Index: 610 $Platine = "Raspberry Pi 3 Model B Plus Rev 1.3";

17.12. 15:27:12 |------------------------- Start growatt.php ---------------------
17.12. 15:27:14 -Keine Antwort vom Wechselrichter. Zu dunkel?
17.12. 15:27:14 |------------------------- Stop growatt.php ---------------------

USB Pin 3 und 4 auch mal getauscht , und neu gestartet.

Es waren beim test 13Volt. Ne idee ?

---
lsusb -t

/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
|__ Port 1: Dev 3, If 0, Class=Hub, Driver=hub/3p, 480M
|__ Port 1: Dev 5, If 0, Class=Vendor Specific Class, Driver=lan78xx, 480M
|__ Port 2: Dev 4, If 0, Class=Vendor Specific Class, Driver=ftdi_sio, 12M


--

Eshco93
Beiträge: 9
Registriert: Fr 2. Jul 2021, 22:06
Danksagung erhalten: 6 Mal

Re: Verbindungsprobleme mit Growatt MIC 600TL-X

Beitrag von Eshco93 »

prozi hat geschrieben:
Fr 17. Dez 2021, 16:27
Es waren beim test 13Volt. Ne idee ?
13V PV-Spannung? Also dein Wechselrichter startet erst ab 50V PV-Spannung. Und vorher wird er dem RPI auch nicht antworten ;-)

prozi
Beiträge: 7
Registriert: Do 3. Jun 2021, 23:59
Hat sich bedankt: 2 Mal

Re: Verbindungsprobleme mit Growatt MIC 600TL-X

Beitrag von prozi »

heute scheint mal die Sonne :)

Derzeit.
Grid 229,5V 50Hz
184,1V 384W

20.12. 10:00:14 -Keine Antwort vom Wechselrichter. Zu dunkel?
20.12. 10:00:14 |------------------------- Stop growatt.php ---------------------

user.conf.php "48" und auch auf
$WR_Adresse = "1";

geprüft

habe so gepinnt wie beschrieben
ROT = A = PIN3
Gelb = B = PIN4

Growatt 1500 TX-L

Antworten