Steca Solarix PLI 5000-48 - 3 Phasen + US2000

Wenn mehr als ein Gerät an den Raspberry angeschlossen werden sollen. Z.B. ein Regler und ein Wechselrichter oder mehrere Wechselrichter. Das Maximum sind 6 Geräte pro Raspberry Pi.

Moderator: Ulrich

Payback2
Beiträge: 45
Registriert: Di 26. Mai 2020, 06:48
Hat sich bedankt: 3 Mal

Re: Steca Solarix PLI 5000-48 - 3 Phasen + US2000

Beitrag von Payback2 »

Hallo Zusammen,

ich habe ja auch ein ähnliches Setup (3P MPP Solar + US2000) und evtl. ein ähnliches Problem. Ich habe heute einen weiteren Akku angeschlossen und habe das Problem, das für die US2000 keine MQTT Daten mehr verschickt werden... Die Daten der drei WR gehen problemlos. Im Log steht kein Fehler und die Config habe ich nicht geändert...
Evtl. auch ein Zeitproblem? Wobei das müsste dann ja als Fehler im Log stehen, oder?

Beste Grüße

mkummer
Beiträge: 10
Registriert: Mo 30. Nov 2020, 10:48
Hat sich bedankt: 1 Mal

Re: Steca Solarix PLI 5000-48 - 3 Phasen + US2000

Beitrag von mkummer »

Moin Zusammen,

ungewollt sitze ich wieder im Keller...WR2 sendet keine Daten.
Ich habe die WR an den USB Anschlüssen getauscht, es scheint an dem zu liegen wo WR1 dran hängt - wobei Tastatur und Maus dort funktionieren.
An dem USB Port wo Tastatur und Maus hängen, geht auch WR2 - dann ist allerdings WR3 weg (keine Daten). Da sieht der Log dann genauso aus - nur das WR2 Daten sendet und 3 nicht.
Hilfe? Von meinem Vorhaben die Akkus einzubinden bin ich weit entfernt...


UPDATE:
Ich habe in der 2.Config den Hidraw auf 3 geändert - wobei es seit Tagen immer 2 war...
jetzt geht es...ich versteh es nicht...

Code: Alles auswählen

30.12. 15:09:05    -Die seriellen Schnittstellen werden initialisiert.
30.12. 15:09:06    -Device: /dev/hidraw0 > Hidraw Schnittstelle.
30.12. 15:09:06    -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 160   $GeraeteNummer = "1";

30.12. 15:09:06    -Zeile gefunden. Platine kann ausgetauscht werden. Index: 546   $Platine = "Raspberry Pi 4 Model B Rev 1.2";

30.12. 15:09:06    -Device: /dev/hidraw2 > Hidraw Schnittstelle.
30.12. 15:09:06    -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 160   $GeraeteNummer = "2";

30.12. 15:09:06    -Zeile gefunden. Platine kann ausgetauscht werden. Index: 546   $Platine = "Raspberry Pi 4 Model B Rev 1.2";

30.12. 15:09:06    -Device: /dev/hidraw5 > Hidraw Schnittstelle.
30.12. 15:09:06    -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 160   $GeraeteNummer = "3";

30.12. 15:09:06    -Zeile gefunden. Platine kann ausgetauscht werden. Index: 546   $Platine = "Raspberry Pi 4 Model B Rev 1.2";

30.12. 15:10:17 MQT-Pipe exestiert nicht. Nur Info, kein Fehler...Exit.
30.12. 15:10:17    -Multi Regler Auslesen [Start].
30.12. 15:10:17    -Verarbeitung von: '1.user.config.php'   Regler: 7
30.12. 15:10:17 |--------------   Start  ax_wechselrichter.php   ----------------- 
30.12. 15:10:17    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

30.12. 15:10:18    -235.9 50.0 230.3 50.0 0092 0015 001 352 50.10 002 043 0023 0002 095.5 50.10 00000 00110110 00 00 00130 010  i: 51
30.12. 15:10:18    -Alle 10 Minuten werden die Statistikdaten übertragen.
30.12. 15:10:18 *  -Daten zur lokalen InfluxDB [ WR1 ] gesendet. 
30.12. 15:10:18    -Multi-Regler-Ausgang. 6
30.12. 15:10:24    -OK. Datenübertragung erfolgreich.
30.12. 15:10:24    -Solarleistung: 130 Watt -  WattstundenGesamtHeute: 1961.73
30.12. 15:10:24 |------------   Stop   ax_wechselrichter.php    ------------------ 
30.12. 15:10:24    -Verarbeitung von: '2.user.config.php'   Regler: 7
30.12. 15:10:24 |--------------   Start  ax_wechselrichter.php   ----------------- 
30.12. 15:10:26    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

30.12. 15:10:28    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

30.12. 15:10:30    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

30.12. 15:10:32    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

30.12. 15:10:35    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

30.12. 15:10:35 !! -Keine gültigen Daten empfangen.
30.12. 15:10:35 |------------   Stop   ax_wechselrichter.php    ------------------ 
30.12. 15:10:35    -Verarbeitung von: '3.user.config.php'   Regler: 7
30.12. 15:10:35 |--------------   Start  ax_wechselrichter.php   ----------------- 
30.12. 15:10:35    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

30.12. 15:10:36    -232.7 50.0 230.1 50.0 0253 0211 005 347 50.00 000 042 0022 0003 080.6 50.05 00001 00110110 00 00 00170 010  i: 52
30.12. 15:10:36    -Alle 10 Minuten werden die Statistikdaten übertragen.
30.12. 15:10:36 *  -Daten zur lokalen InfluxDB [ WR3 ] gesendet. 
30.12. 15:10:36    -Multi-Regler-Ausgang. 6
30.12. 15:10:42    -OK. Datenübertragung erfolgreich.
30.12. 15:10:42    -Solarleistung: 170 Watt -  WattstundenGesamtHeute: 2326.7
30.12. 15:10:42 |------------   Stop   ax_wechselrichter.php    ------------------ 
30.12. 15:10:42    -Multi Regler Auslesen [Stop].
Wechsel USB Anschluss aui Tasta/Maus mit WR2:

Code: Alles auswählen

30.12. 15:08:01    -Multi Regler Auslesen [Start].
30.12. 15:08:01    -Verarbeitung von: '1.user.config.php'   Regler: 7
30.12. 15:08:01 |--------------   Start  ax_wechselrichter.php   ----------------- 
30.12. 15:08:02    -235.4 50.0 229.9 50.0 0183 0128 003 347 50.10 000 043 0021 0003 083.3 50.15 00000 00110110 00 00 00150 010  i: 52
30.12. 15:08:02 *  -Daten zur lokalen InfluxDB [ WR1 ] gesendet. 
30.12. 15:08:02    -Multi-Regler-Ausgang. 6
30.12. 15:08:08    -OK. Datenübertragung erfolgreich.
30.12. 15:08:08    -Solarleistung: 150 Watt -  WattstundenGesamtHeute: 1959.57
30.12. 15:08:08 |------------   Stop   ax_wechselrichter.php    ------------------ 
30.12. 15:08:08    -Verarbeitung von: '2.user.config.php'   Regler: 7
30.12. 15:08:08 |--------------   Start  ax_wechselrichter.php   ----------------- 
30.12. 15:08:10    -232.2 50.0 230.1 50.0 0253 0203 005 347 50.10 000 043 0022 0003 077.8 50.05 00001 00110110 00 00 00150 010  i: 52
30.12. 15:08:10 *  -Daten zur lokalen InfluxDB [ WR2 ] gesendet. 
30.12. 15:08:10    -Multi-Regler-Ausgang. 5
30.12. 15:08:15    -OK. Datenübertragung erfolgreich.
30.12. 15:08:15    -Solarleistung: 150 Watt -  WattstundenGesamtHeute: 1263.55
30.12. 15:08:15 |------------   Stop   ax_wechselrichter.php    ------------------ 
30.12. 15:08:15    -Verarbeitung von: '3.user.config.php'   Regler: 7
30.12. 15:08:15 |--------------   Start  ax_wechselrichter.php   ----------------- 
30.12. 15:08:17    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

30.12. 15:08:19    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

30.12. 15:08:21    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

30.12. 15:08:23    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

30.12. 15:08:25    -Datenübertragung vom Wechselrichter war erfolglos! [Modus]

teutocat
Beiträge: 22
Registriert: Fr 18. Dez 2020, 20:51
Danksagung erhalten: 2 Mal

Re: Steca Solarix PLI 5000-48 - 3 Phasen + US2000

Beitrag von teutocat »

mkummer hat geschrieben:
Mi 30. Dez 2020, 15:15

ungewollt sitze ich wieder im Keller...WR2 sendet keine Daten.
Ich habe die WR an den USB Anschlüssen getauscht, es scheint an dem zu liegen wo WR1 dran hängt - wobei Tastatur und Maus dort funktionieren.
An dem USB Port wo Tastatur und Maus hängen, geht auch WR2 - dann ist allerdings WR3 weg (keine Daten). Da sieht der Log dann genauso aus - nur das WR2 Daten sendet und 3 nicht.
Hilfe? Von meinem Vorhaben die Akkus einzubinden bin ich weit entfernt...

UPDATE:
Ich habe in der 2.Config den Hidraw auf 3 geändert - wobei es seit Tagen immer 2 war...
jetzt geht es...ich versteh es nicht...
Ich befürchte das Problem wird uns immer wieder beschäftigen solange wir uns nur auf den Device-Namen im Device Filesystem (also unterhalb von /dev) verlassen. Ich habe nach mehreren Reboots, auch ohne das ich irgendwas an USB-Geräten geändert habe, also noch nicht einmal Tastatur umgesteckt oder so, immer wieder unterschiedliche Zuordnungen. Das Problem wird dadurch noch verschärft dass man dem hidrawX nicht ansehen kann welches pysikalische Gerät dazu gehört, da ja bei den WR die Vendor/Device-IDs identisch sind.
IMO ist die einzige Möglichkeit das in den Griff zu bekommen, wenn man sich ganz genau anschaut an welchem USB-Port (entweder am RPi oder am USB-Hub) ein WR angeschlossen ist. Dann kann man sich die Nummer dieses Ports mit

Code: Alles auswählen

ls -al /sys/class/hidraw
anzeigen lassen.
Ein tiefer verschachtelter Verzeichnispfad deutet auf einen Anschluss an einem USB-Hub hin.
Im Prinzip müsste man sich ein script machen was beim Hochfahren diese Werte ausliest und dann erst die X.user.config.php mit den gewünschten hidrawX patcht (mit sed oder so). Dann kann man wenigstens sicher stellen dass solaranzeige zumindest immer mit einem WR an einem bestimmten USB-Port korrespondiert.

teutocat
Beiträge: 22
Registriert: Fr 18. Dez 2020, 20:51
Danksagung erhalten: 2 Mal

Re: Steca Solarix PLI 5000-48 - 3 Phasen + US2000

Beitrag von teutocat »

Payback2 hat geschrieben:
Mi 30. Dez 2020, 14:20
Hallo Zusammen,

ich habe ja auch ein ähnliches Setup (3P MPP Solar + US2000) und evtl. ein ähnliches Problem. Ich habe heute einen weiteren Akku angeschlossen und habe das Problem, das für die US2000 keine MQTT Daten mehr verschickt werden... Die Daten der drei WR gehen problemlos. Im Log steht kein Fehler und die Config habe ich nicht geändert...
Evtl. auch ein Zeitproblem? Wobei das müsste dann ja als Fehler im Log stehen, oder?

Beste Grüße
Am Anfang von mqtt_prozess.php kannst du den $Tracelevel erhöhen, vielleicht erscheinen dann Hinweise im Log die dich weiter bringen.

Wie viele US2000 Packs hast du? Wie lange dauert(e) das Auslesen bei dir (als es noch funktionierte)?

teutocat
Beiträge: 22
Registriert: Fr 18. Dez 2020, 20:51
Danksagung erhalten: 2 Mal

Re: Steca Solarix PLI 5000-48 - 3 Phasen + US2000

Beitrag von teutocat »

Ulrich hat geschrieben:
Mi 30. Dez 2020, 13:51
Hört sich ja gut an, wenn du einen Schritt weiter bist. Kannst Du denn die serielle Geschwindigkeit des Console-Ports erhöhen? Die Geschwindigkeit im Raspberry kannst Du in der (multi-)usb-init.php ja angeben. Ich meine mich erinnern zu können das ein Mitglied einmal gesagt hat, dass man die Geschwindigkeit des Console Port auf 9600 erhöhen kann.

Die 1200 Baud sind ja nur genommenworden, weil das der default Wert des US2000B ist.

Der Wert $USBSpeed in der user.config.php ist für die Zukunft gedacht und wird bis jetzt noch nicht verwendet.
Das Auslesen der laufenden Daten über den Console-Port (RS232) geht nur mit 1200 Baud. Mit einem speziellen Befehl (also nur per Software) kann man den Console-Port auch auf 115200 umschalten, aber dann ist man in einem speziellen Admin-Debug-Modus, das ist nicht zum normalen Auslesen der Akkus geeignet.
Mit dem DIP-Switch kann man die Geschwindigkeit des RS232-Console-Ports nicht umschalten.
Bei dem RS485-Port kann man die Geschwindigkeit per DIP-Switch zwischen 9600 und 115200 umschalten (nur diese beiden Geschwindigkeiten möglich).
Vor ein paar Tagen wusste ich das alles noch nicht, aber weil bei mir zunächst einfach nichts funktionierte habe ich mich zwangsläufig tief in das Thema eingelesen.

Benutzeravatar
Ulrich
Administrator
Beiträge: 2171
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 4 Mal
Danksagung erhalten: 76 Mal
Kontaktdaten:

Re: Steca Solarix PLI 5000-48 - 3 Phasen + US2000

Beitrag von Ulrich »

Dann must du es mal mit dem RS485 Port versuchen. Ob das bei dem älteren US2000B funktioniert ist noch unklar. Die Geschwindigkeit muss aber auf 115200 eingestellt werden. Regler = 41
--------------------------------------
Ulrich [Admin]

teutocat
Beiträge: 22
Registriert: Fr 18. Dez 2020, 20:51
Danksagung erhalten: 2 Mal

Re: Steca Solarix PLI 5000-48 - 3 Phasen + US2000

Beitrag von teutocat »

Ulrich hat geschrieben:
Mi 30. Dez 2020, 20:17
Dann must du es mal mit dem RS485 Port versuchen. Ob das bei dem älteren US2000B funktioniert ist noch unklar. Die Geschwindigkeit muss aber auf 115200 eingestellt werden. Regler = 41
Ja, das hatte ich auch vor, ich warte noch auf den USB-RS485-Adapter ...
Abgesehen vom Interface und Baudrate, behandelt Solaranzeige Regler 15 und Regler 41 bzgl. der Datenauswertung identisch?

Ich habe ja genau genommen nicht US2000B sondern US2000 Plus. Soweit wie ich das verstanden habe unterscheiden die sich vor allem im Firmware-Level. Aber das könnte natürlich bzgl. des Datenformates schon einen Unterschied machen.

Payback2
Beiträge: 45
Registriert: Di 26. Mai 2020, 06:48
Hat sich bedankt: 3 Mal

Re: Steca Solarix PLI 5000-48 - 3 Phasen + US2000

Beitrag von Payback2 »

Hallo,

trace level werde ich hochsetzen, mal schauen. Mittlerweile habe ich folgenden Ablauf:
00:01 Start Multi Regler
00:01 Start WR1
00:08 Ende WR1 inkl MQTT Nachrichten
00:08 Start WR2
00:15 Ende WR2 inkl. MQTT Nachrichten
00:15 Start WR3
00:22 Ende WR3 inkl. MQTT Nachrichten
00:22 Start US2000
00:50 Ende US2000 OHNE MQTT Nachrichten
00:58 MQT-MQTT Ende

Vor dem 6.Modul war der Ablauf so:
00:01 Start Multi Regler
00:01 Start WR1
00:08 Ende WR1 inkl MQTT Nachrichten
00:08 Start WR2
00:15 Ende WR2 inkl. MQTT Nachrichten
00:15 Start WR3
00:22 Ende WR3 inkl. MQTT Nachrichten
00:22 Start US2000
00:45 Ende US2000 OHNE MQTT Nachrichten
00:57 Ende US2000 MQTT Nachrichten
00:58 MQT-MQTT Ende

Sieht also nach einem zeitlichen Problem aus...

teutocat
Beiträge: 22
Registriert: Fr 18. Dez 2020, 20:51
Danksagung erhalten: 2 Mal

Re: Steca Solarix PLI 5000-48 - 3 Phasen + US2000

Beitrag von teutocat »

Ulrich hat geschrieben:
Mi 30. Dez 2020, 20:17
Dann must du es mal mit dem RS485 Port versuchen. Ob das bei dem älteren US2000B funktioniert ist noch unklar. Die Geschwindigkeit muss aber auf 115200 eingestellt werden. Regler = 41
das habe ich mittlerweile gemacht und es funktioniert und ist erwartungsgemäß deutlich schneller als über den Console-Port.
Dadurch ist es nun auch wieder möglich innerhalb einer Minute drei WR und ein Pylontech Stack abzufragen.

Benutzeravatar
Ulrich
Administrator
Beiträge: 2171
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 4 Mal
Danksagung erhalten: 76 Mal
Kontaktdaten:

Re: Steca Solarix PLI 5000-48 - 3 Phasen + US2000

Beitrag von Ulrich »

Das sind gute Neuigkeiten, wenn is funktioniert.
--------------------------------------
Ulrich [Admin]

Antworten