leider funktionieren nur maximal 2 WR

Wenn mehr als ein Gerät an den Raspberry angeschlossen werden sollen. Z.B. ein Regler und ein Wechselrichter oder mehrere Wechselrichter. Das Maximum sind 6 Geräte pro Raspberry Pi.

Moderator: Ulrich

Antworten
albino
Beiträge: 6
Registriert: Fr 28. Aug 2020, 19:44
Hat sich bedankt: 2 Mal
Danksagung erhalten: 2 Mal

leider funktionieren nur maximal 2 WR

Beitrag von albino »

Ich habe "ein paar" SolarMax Wechselrichter auszulesen.
Leider funktionieren maximal zwei. Und ich komme nicht auf den Fehler..

Die Logdatei der Solaranzeige und auch Grafana sagt mir dass der erste Zugriff funktioniert (dabei ist es egal, welche RS485 WR-Adresse eintrage, es funktionieren alle; die IP-Adresse des ersten WR bleibt natürlich immer gleich)

Aber jetzt gerade beim zweiten Zugriff kommt die Meldung "kein Kontakt zum WR.." im solar.log.
Im php.log dann entsprechend die Meldung fsockopen(): ..connection refused.
Danach noch fclose() expects parameter 1 to resource bool given - aber das wird ja am Fehler des fsockopen hängen..

Gelernt habe ich nun manches - über php und auch die solaranzeige - auf den Fehler komme ich trotzdem nicht :cry:
Habt ihr eine Idee? Noch eine Pause einbauen zwischen den Abfragen irgendwo/irgendwie?
Danke und GRüssle von dr Alb runter
Andreas!

albino
Beiträge: 6
Registriert: Fr 28. Aug 2020, 19:44
Hat sich bedankt: 2 Mal
Danksagung erhalten: 2 Mal

Re: leider funktionieren nur maximal 2 WR

Beitrag von albino »

dass es bereits ausreicht im Forum zu Schreiben um auf die (oder besser eine?) Lösung zu kommen hätte mir mal schneller einfallen können...
--> Ich habe also ein sleep(1) eingefügt unten im solarmax_s.php und nun tut es. :D :D
Vielleicht hat ja noch jemand einen Vorschlag ob dass nun eine halbseidene Symptombekämpfung war oder man es gar als Lösung der Ursache ansehen kann?
VG Andreas!

Antworten