Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Wenn mehr als ein Gerät an den Raspberry angeschlossen werden sollen. Z.B. ein Regler und ein Wechselrichter oder mehrere Wechselrichter. Das Maximum sind 6 Geräte pro Raspberry Pi.

Moderator: Ulrich

Benutzeravatar
Ulrich
Administrator
Beiträge: 3784
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 80 Mal
Danksagung erhalten: 453 Mal
Kontaktdaten:

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von Ulrich »

Hallo Alex,

der Fehler ist ganz simpel "Keine Verbindung zum SDM630" Nur scheinst du Fehler in der Konfiguration zu haben.

Hier gibt es immer die aktuellsten Hinweise:

https://solaranzeige.de/phpBB3/viewtopic.php?t=1069


Wichtig sind folgende Einträge:

Code: Alles auswählen

$WR_IP = "0.0.0.0";
$WR_Port = "";
$WR_Adresse = "1";
Eine IP Adresse darf nicht eingetragen sein!

Die $WR_Adresse = ist die eingestellte Geräte ID, in deinem Fall "0" ???

In dem SDM630 muss die serielle Geschwindigkeit auf default 19200 Baud eingestellt sein.
--------------------------------------
Ulrich [Admin]

xhole_ja
Beiträge: 5
Registriert: Mi 19. Okt 2022, 16:24

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von xhole_ja »

Hallo Ulrich,

danke für deine Hinweise. Die Adresse "0" vom WR war ein Versuch meinerseits, nachdem ein User im Forum gepostet hat dass die Verbindung sogar mit Adresse "0" klappen sollte. Der WR hat wie der SDM630 die Adresse "10" am Modbus. Im Post vom Felix22

https://solaranzeige.de/phpBB3/viewtopi ... 260#p20260

hats funktioniert wenn SDM630 und WR die selbe Adresse hatten.

Wie gesagt da hab ich die Schreibweisen alle probiert, dh mit führender "0" dh "010" und ohne. Kann sein dass die 2 stellige Modbus Adresse ein Problem ist? Ich hab noch keinen Beitrag im Form gefunden wo jemand 2 stellige Modbus Adressen verwendet hat.

IP Adresse ist nicht eingetragen (wie in deinem Beispiel), 19200 baud, 1 stopp bit, no parity ist auch eingestellt beim SDM630 - und auch bei der Verbindung USB ttyUSB0, da müsste also alles richtig sein.

Wie gesagt, beim RS485Modbus Konverter flackern brav jede Minute die LEDs Rx und Tx dh ich hätte geglaubt dass zumindest eine Kommunikation stattfindet.

HAst sonst noch Ideen was ich noch machen könnte?
Danke für deine Unterstützung!

Viele Grüße,
Alex

Benutzeravatar
Ulrich
Administrator
Beiträge: 3784
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 80 Mal
Danksagung erhalten: 453 Mal
Kontaktdaten:

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von Ulrich »

Nein, die 2 stellige Geräte ID Adresse macht kein Problem. Ist bei dir die GeräteID 10 den Hexadezimal oder Dezimal? 10 Dezimal wäre "0A" in Hex und das müsstest du eintragen in die user.config.php
--------------------------------------
Ulrich [Admin]

xhole_ja
Beiträge: 5
Registriert: Mi 19. Okt 2022, 16:24

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von xhole_ja »

Hallo Ulrich,

super Tipp, hattest natürlich recht, die Einstellung am SDM 630 ist 10 dezimal dh in 2.userconfig muss ich "0A" eintragen. War sicher ein Fehler in meiner Konfiguration - aber leider hats nichts gebracht. Fehlermeldung ist genau die Selbe. Jetzt hab ich auch noch die WR Modbus karte kontrolliert - da stimmt die Adresse auch. Fehlerbild in solaranzeige.log ist genau das Selbe:

Code: Alles auswählen


16.11. 21:12:01    -Multi Regler Auslesen [Start].
16.11. 21:12:01    -Verarbeitung von: '1.user.config.php'   Regler: 9
16.11. 21:12:02 |----------------   Start  mpi_3phasen_serie.php   ---------------.
16.11. 21:12:43    -Es sieht so aus, als ob die Uhrzeit im Gerät nicht korrekt ist. Bitte prüfen!
16.11. 21:12:43    -Fehlercode. 0 Warnung: 1
16.11. 21:12:43 *  -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet..
16.11. 21:12:43    -Multi-Regler-Ausgang. -32
16.11. 21:12:43    -OK. Datenübertragung erfolgreich.
16.11. 21:12:43 |----------------   Stop   mpi_3phasen_serie.php   ---------------.
16.11. 21:12:43    -Verarbeitung von: '2.user.config.php'   Regler: 34
16.11. 21:12:43 +  -WR_ID: 0a
16.11. 21:12:43 |------------   Start  SDM630_meter.php  -------------------------.
16.11. 21:12:51    -AC Leistung:  Watt
16.11. 21:12:54    -InfluxDB  => [ Info Firmware="0",Produkt="SDM630",Objekt="sdm630Energymeter",Datum="16.11.2022"  1668629531
AC Spannung=,Strom=,Frequenz=,Leistung=,Leistungsfaktor=,Spannung_R=,Spannung_S=,Spannung_T=,Strom_R=,Strom_S=,Strom_T=,Leistung_R=,Leistung_S=,Leistung_T=,Leistungsfaktor_R=,Leistungsfaktor_S=,Leistungsfaktor_T=  1668629531
Summen Wh_GesamtBezug=0,Wh_GesamtEinspeisung=0,GesamtLeistungsbedarf=  1668629531
 ]
16.11. 21:12:54    -Daten nicht zur lokalen InfluxDB gesendet! info: array (
  'url' => 'http://localhost/write?db=DatenSDM630&precision=s',
  'content_type' => 'application/json',
  'http_code' => 400,
  'header_size' => 700,
  'request_size' => 556,
  'filetime' => -1,
  'ssl_verify_result' => 0,
  'redirect_count' => 0,
  'total_time' => 0.011734,
  'namelookup_time' => 0.001346,
  'connect_time' => 0.001838,
  'pretransfer_time' => 0.002216,
  'size_upload' => 400.0,
  'size_download' => 423.0,
  'speed_download' => 38454.0,
  'speed_upload' => 36363.0,
  'download_content_length' => 423.0,
  'upload_content_length' => 400.0,
  'starttransfer_time' => 0.011604,
  'redirect_time' => 0.0,
  'redirect_url' => '',
  'primary_ip' => '::1',
  'certinfo' =>.
  array (
  ),
  'primary_port' => 8086,
  'local_ip' => '::1',
  'local_port' => 34186,
  'http_version' => 2,
  'protocol' => 1,
  'ssl_verifyresult' => 0,
  'scheme' => 'HTTP',
  'appconnect_time_us' => 0,
  'connect_time_us' => 1838,
  'namelookup_time_us' => 1346,
  'pretransfer_time_us' => 2216,
  'redirect_time_us' => 0,
  'starttransfer_time_us' => 11604,
  'total_time_us' => 11734,
)
16.11. 21:12:59    -InfluxDB  => [ Info Firmware="0",Produkt="SDM630",Objekt="sdm630Energymeter",Datum="16.11.2022"  1668629531
AC Spannung=,Strom=,Frequenz=,Leistung=,Leistungsfaktor=,Spannung_R=,Spannung_S=,Spannung_T=,Strom_R=,Strom_S=,Strom_T=,Leistung_R=,Leistung_S=,Leistung_T=,Leistungsfaktor_R=,Leistungsfaktor_S=,Leistungsfaktor_T=  1668629531
Summen Wh_GesamtBezug=0,Wh_GesamtEinspeisung=0,GesamtLeistungsbedarf=  1668629531
 ]
16.11. 21:12:59    -Daten nicht zur lokalen InfluxDB gesendet! info: array (
  'url' => 'http://localhost/write?db=DatenSDM630&precision=s',
  'content_type' => 'application/json',
  'http_code' => 400,
  'header_size' => 700,
  'request_size' => 556,
  'filetime' => -1,
  'ssl_verify_result' => 0,
  'redirect_count' => 0,
  'total_time' => 0.011923,
  'namelookup_time' => 0.000214,
  'connect_time' => 0.000215,
  'pretransfer_time' => 0.000546,
  'size_upload' => 400.0,
  'size_download' => 423.0,
  'speed_download' => 38454.0,
  'speed_upload' => 36363.0,
  'download_content_length' => 423.0,
  'upload_content_length' => 400.0,
  'starttransfer_time' => 0.011802,
  'redirect_time' => 0.0,
  'redirect_url' => '',
  'primary_ip' => '::1',
  'certinfo' =>.
  array (
  ),
  'primary_port' => 8086,
  'local_ip' => '::1',
  'local_port' => 34186,
  'http_version' => 2,
  'protocol' => 1,
  'ssl_verifyresult' => 0,
  'scheme' => 'HTTP',
  'appconnect_time_us' => 216,
  'connect_time_us' => 215,
  'namelookup_time_us' => 214,
  'pretransfer_time_us' => 546,
  'redirect_time_us' => 0,
  'starttransfer_time_us' => 11802,
  'total_time_us' => 11923,
)
16.11. 21:13:02    -Zu viele PHP Scripte: multi_regler_auslesen.php
16.11. 21:13:02 !! -|---> Stop  PHP Script: multi_regler_auslesen.php **************
16.11. 21:13:04    -Multi-Regler-Ausgang. -12
16.11. 21:13:04    -OK. Datenübertragung erfolgreich.
16.11. 21:13:04 |------------   Stop   SDM630_meter.php    -----------------------.
16.11. 21:13:04    -Multi Regler Auslesen [Stop Timeout].

Fällt dir sonst noch was ein? Bin für jeden Tipp dankbar!

Danke und viele Grüße,
Alex

Benutzeravatar
Ulrich
Administrator
Beiträge: 3784
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 80 Mal
Danksagung erhalten: 453 Mal
Kontaktdaten:

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von Ulrich »

Kannst du bitte noch einmal in der InfluxDB nachsehen, ob es eine Datenbank "DatenSDM630" gibt. Auf Groß- und Kleinschreibung genau achten!
--------------------------------------
Ulrich [Admin]

SolarHeli
Beiträge: 20
Registriert: Mi 5. Jan 2022, 22:31
Wohnort: Bayern
Danksagung erhalten: 7 Mal

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von SolarHeli »

Es sieht so aus, als würden garkeine Werte empfangen:

Aus dem Log:
-AC Leistung: <WERT FEHLT>

AC Spannung=<WERT FEHLT>,Strom=<WERT FEHLT>,Frequenz=<WERT FEHLT> ,Leistung=...,Leistungsfaktor=...,Spannung_R=...,Spannung_S=...,Spannung_T=...


Es sieht so aus, als würder der Zähler nicht antworten.


Achtung! Die default USB Init entspricht NICHT der Defaulteinstellung des Zählers (9600 baud)!
Multi-usb-init.php > SMD360: $rc = exec("stty -F ".$USBDevice." raw speed 19200 cs8 -iexten -echo -echoe -echok -onlcr -hupcl ignbrk time 5");

xhole_ja
Beiträge: 5
Registriert: Mi 19. Okt 2022, 16:24

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von xhole_ja »

Hallo,

vielen vielen Dank an alle die mir geholfen haben. Jetzt funktionierts! Der Tipp mit der Verbindung war goldrichtig.

Udo hat mir die Easton SW geschickt für den Check der Verkabelung zum SDM630

https://solaranzeige.de/phpBB3/viewtopi ... 979#p19979

Und siehe da, die Verbindung war nur sporadisch da und ist meistens mitten im Empfang abgebrochen. Ich hab mir dann die Verkabelung genauer angeschaut und hab einen Kabelbruch gefunden, der wohl nur ab und zu mal Kontakt gemacht hat. Anscheinend hab ich das mit meinem Gefummel beim Probieren verschlechtert - mit meinem MODbus Sniffer, den ich am Anfang verwendet habe, sind mir die Verbindungsabbrüche nicht aufgefallen. Das in Kombination mit der falschen Konfiguration der Adresse (Dezimal 10 statt hexadezimal 0a - Danke Ulrich!!!) hat wohl dazu geführt dass nie verwertbare Daten am Raspi angekommen sind.

Vielen vielen Dank an alle die mir mit Tipps geholfen haben, Ulrich, Udo und Solarheli!

Viele Grüße,
Alex

PS. Spende ist unterwegs!

Antworten