Measurement 'Service' fehlt

PV Überschussladen mit Wallboxen. (intelligenten Ladestationen) Alles was mit der eingebauten Wallbox-Steuerung zu tun hat.

Moderator: Ulrich

hendock
Beiträge: 59
Registriert: Mo 19. Jul 2021, 13:57
Hat sich bedankt: 3 Mal

Measurement 'Service' fehlt

Beitrag von hendock »

N'Abend!

Ich bin gerade dabei, meine Wallbe Eco 2.0 mit der Solaranzeige zu verbinden. Aber in der Datenbank fehlt das Measurement 'Service'.

Code: Alles auswählen

 30.07. 22:26:01 INFO Grundlage der Steuerung ist die INI Datei '3.wallbox.steuerung.ini'.
30.07. 22:26:01 INFO Eigenverbrauch laut INI Datei: 0 Watt
30.07. 22:26:03 ERRO Es fehlt die Datenbank 'solaranzeige3' mit dem Measurement Service oder sie ist leer.
30.07. 22:26:03 ENDE ---------------------------------------------------------
30.07. 22:27:01 |--> - - - - - - - - - Start WB Steuerung - - - - - - - -
30.07. 22:27:01 INFO Grundlage der Steuerung ist die INI Datei '3.wallbox.steuerung.ini'.
30.07. 22:27:01 INFO Eigenverbrauch laut INI Datei: 0 Watt
30.07. 22:27:02 ERRO Es fehlt die Datenbank 'solaranzeige3' mit dem Measurement Service oder sie ist leer.
30.07. 22:27:02 ENDE ---------------------------------------------------------
30.07. 22:28:01 |--> - - - - - - - - - Start WB Steuerung - - - - - - - -
30.07. 22:28:01 INFO Grundlage der Steuerung ist die INI Datei '3.wallbox.steuerung.ini'.
30.07. 22:28:01 INFO Eigenverbrauch laut INI Datei: 0 Watt
30.07. 22:28:02 ERRO Es fehlt die Datenbank 'solaranzeige3' mit dem Measurement Service oder sie ist leer.
30.07. 22:28:02 ENDE ---------------------------------------------------------
30.07. 22:29:01 |--> - - - - - - - - - Start WB Steuerung - - - - - - - -
30.07. 22:29:01 INFO Grundlage der Steuerung ist die INI Datei '3.wallbox.steuerung.ini'.
30.07. 22:29:01 INFO Eigenverbrauch laut INI Datei: 0 Watt
30.07. 22:29:02 ERRO Es fehlt die Datenbank 'solaranzeige3' mit dem Measurement Service oder sie ist leer.
30.07. 22:29:02 ENDE ---------------------------------------------------------
30.07. 22:30:01 |--> - - - - - - - - - Start WB Steuerung - - - - - - - -
30.07. 22:30:01 INFO Grundlage der Steuerung ist die INI Datei '3.wallbox.steuerung.ini'.
30.07. 22:30:01 INFO Eigenverbrauch laut INI Datei: 0 Watt
30.07. 22:30:02 ERRO Es fehlt die Datenbank 'solaranzeige3' mit dem Measurement Service oder sie ist leer.
30.07. 22:30:02 ENDE ---------------------------------------------------------
30.07. 22:31:01 |--> - - - - - - - - - Start WB Steuerung - - - - - - - -
30.07. 22:31:01 INFO Grundlage der Steuerung ist die INI Datei '3.wallbox.steuerung.ini'.
30.07. 22:31:01 INFO Eigenverbrauch laut INI Datei: 0 Watt
30.07. 22:31:02 ERRO Es fehlt die Datenbank 'solaranzeige3' mit dem Measurement Service oder sie ist leer.
30.07. 22:31:02 ENDE ---------------------------------------------------------
30.07. 22:32:01 |--> - - - - - - - - - Start WB Steuerung - - - - - - - -
30.07. 22:32:01 INFO Grundlage der Steuerung ist die INI Datei '3.wallbox.steuerung.ini'.
30.07. 22:32:01 INFO Eigenverbrauch laut INI Datei: 0 Watt
30.07. 22:32:02 ERRO Es fehlt die Datenbank 'solaranzeige3' mit dem Measurement Service oder sie ist leer.
30.07. 22:32:02 ENDE ---------------------------------------------------------
30.07. 22:33:01 |--> - - - - - - - - - Start WB Steuerung - - - - - - - -
30.07. 22:33:01 INFO Grundlage der Steuerung ist die INI Datei '3.wallbox.steuerung.ini'.
30.07. 22:33:01 INFO Eigenverbrauch laut INI Datei: 0 Watt
30.07. 22:33:02 ERRO Es fehlt die Datenbank 'solaranzeige3' mit dem Measurement Service oder sie ist leer.
30.07. 22:33:02 ENDE ---------------------------------------------------------
solaranzeige3 ist die Datenbank zur WB. Was mache ich falsch?

Benutzeravatar
Ulrich
Administrator
Beiträge: 2866
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 32 Mal
Danksagung erhalten: 181 Mal
Kontaktdaten:

Re: Measurement 'Service' fehlt

Beitrag von Ulrich »

Schaue bitte einmal, ob die Datenbank "solaranzeige3" überhaupt angelegt ist.
--------------------------------------
Ulrich [Admin]

hendock
Beiträge: 59
Registriert: Mo 19. Jul 2021, 13:57
Hat sich bedankt: 3 Mal

Re: Measurement 'Service' fehlt

Beitrag von hendock »

Ist angelegt. Ich kann z.B. den Ladestrom auslesen. Die vorh. Measurements sind AC, Info Statistik und Summen.

Benutzeravatar
Ulrich
Administrator
Beiträge: 2866
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 32 Mal
Danksagung erhalten: 181 Mal
Kontaktdaten:

Re: Measurement 'Service' fehlt

Beitrag von Ulrich »

Dann schaue einmal in die LOG Datei /var/www/log/solaranzeige.log
Dort muss ja die Wallbe Wallbox die Daten in die solaranzeige3 Datenbank schreiben.
Ist die Datenbank solaranzeige3 denn überhaupt die Datenbank, die von der Wallbe benutzt wird?
--------------------------------------
Ulrich [Admin]

hendock
Beiträge: 59
Registriert: Mo 19. Jul 2021, 13:57
Hat sich bedankt: 3 Mal

Re: Measurement 'Service' fehlt

Beitrag von hendock »

Ulrich hat geschrieben:
Sa 31. Jul 2021, 09:27
Ist die Datenbank solaranzeige3 denn überhaupt die Datenbank, die von der Wallbe benutzt wird?
Zumindest habe ich das so in der entsprechenden user.config eingetragen.

hendock
Beiträge: 59
Registriert: Mo 19. Jul 2021, 13:57
Hat sich bedankt: 3 Mal

Re: Measurement 'Service' fehlt

Beitrag von hendock »

Hier mal ein Auszug aus der Logdatei:

Code: Alles auswählen

31.07. 10:02:21    -InfluxDB  => [ AC Spannung_R=0,Spannung_S=0,Spannung_T=0,Strom_R=0,Strom_S=0,Strom_T=0,Leistung_gesamt=0,Frequenz=0,Ladestrom=0  1627718531
Service Stationsstatus="A",StatusHex=41,ErrorCode=0,LadungAktiv=0,Ladezeit=0,LadestationEin=1,PerModbusAktiviert=0,Ladung_erlaubt=,Kabel_angeschlossen=,Kabel_entriegelt=,MaxLadestrom=1.6,Ladebedingungen_OK=0  1627718531
Summen Wh_Gesamt=0,Wh_Ladevorgang=0  1627718531
 ]
31.07. 10:02:21    -Daten nicht zur lokalen InfluxDB gesendet! info: array (
  'url' => 'http://localhost/write?db=solaranzeige3&precision=s',
  'content_type' => 'application/json',
  'http_code' => 400,
  'header_size' => 573,
  'request_size' => 551,
  'filetime' => -1,
  'ssl_verify_result' => 0,
  'redirect_count' => 0,
  'total_time' => 0.009857,
  'namelookup_time' => 0.000105,
  'connect_time' => 0.000106,
  'pretransfer_time' => 0.000312,
  'size_upload' => 393.0,
  'size_download' => 298.0,
  'speed_download' => 33111.0,
  'speed_upload' => 43666.0,
  'download_content_length' => 298.0,
  'upload_content_length' => 393.0,
  'starttransfer_time' => 0.009788,
  'redirect_time' => 0.0,
  'redirect_url' => '',
  'primary_ip' => '::1',
  'certinfo' => 
  array (
  ),
  'primary_port' => 8086,
  'local_ip' => '::1',
  'local_port' => 47314,
  'http_version' => 2,
  'protocol' => 1,
  'ssl_verifyresult' => 0,
  'scheme' => 'HTTP',
  'appconnect_time_us' => 106,
  'connect_time_us' => 106,
  'namelookup_time_us' => 105,
  'pretransfer_time_us' => 312,
  'redirect_time_us' => 0,
  'starttransfer_time_us' => 9788,
  'total_time_us' => 9857,
)
31.07. 10:02:26    -Multi-Regler-Ausgang. -4
31.07. 10:02:26    -OK. Datenübertragung erfolgreich.
31.07. 10:02:26 |----------------   Stop   wallbe_wallbox.php   --------------------- 
31.07. 10:02:26    -Multi Regler Auslesen [Stop].


Benutzeravatar
Ulrich
Administrator
Beiträge: 2866
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 32 Mal
Danksagung erhalten: 181 Mal
Kontaktdaten:

Re: Measurement 'Service' fehlt

Beitrag von Ulrich »

Wie du siehst, fehlen Werte, die in das Measurement Service geschrieben werden sollten. Da die Werte jedoch fehlen gibt es einen Fehler und es wird nichts in das Measurement geschrieben.

Deine Wallbe liefert nicht die nötigen Werte.
Alte Firmware?
Preiswerte Version?
--------------------------------------
Ulrich [Admin]

hendock
Beiträge: 59
Registriert: Mo 19. Jul 2021, 13:57
Hat sich bedankt: 3 Mal

Re: Measurement 'Service' fehlt

Beitrag von hendock »

Preiswerte Version? Keine Ahnung. Laut Typenschild ist es die Wallbe Eco 2.0 (ohne s). Ich denke, es liegt an der Firmware (anscheinend 0.95).

Jetzt habe ich in DIESEM Beitrag gelesen, dass man das Script 'wallbe_wallbox.php' modifizieren kann, wenn man die ältere Firmware hat. An welcher Stelle muss ich die Ergänzung denn einfügen? Ich bin Techniker, kein Programmierer.

hendock
Beiträge: 59
Registriert: Mo 19. Jul 2021, 13:57
Hat sich bedankt: 3 Mal

Re: Measurement 'Service' fehlt

Beitrag von hendock »

Ok, hat sich erledigt. Ich habe die Firmware upgedatet. Die neue Version 1.27 habe ich von DIESER Seite. Jetzt habe ich zwar kein Passwort mehr für die Wallbox aber die Werte werden geschrieben.

hendock
Beiträge: 59
Registriert: Mo 19. Jul 2021, 13:57
Hat sich bedankt: 3 Mal

Re: Measurement 'Service' fehlt

Beitrag von hendock »

Guten Morgen!

Nachdem im am WE noch ein paar Stunden mit der Solaranzeige verbracht habe, KÖNNTE es jetzt funktionieren. Zum Testen bräuchte ich aber ein E-Auto. ;)

Antworten