Measurement 'Service' fehlt

PV Überschussladen mit Wallboxen. (intelligenten Ladestationen) Alles was mit der eingebauten Wallbox-Steuerung zu tun hat.

Moderator: Ulrich

Bogeyof
Beiträge: 938
Registriert: Mi 13. Mai 2020, 10:04
Hat sich bedankt: 17 Mal
Danksagung erhalten: 103 Mal

Re: Measurement 'Service' fehlt

Beitrag von Bogeyof »

Wo wohnst Du denn, dann komme ich vorbei zum kostenlosen (Laden) Testen ;)

hendock
Beiträge: 59
Registriert: Mo 19. Jul 2021, 13:57
Hat sich bedankt: 3 Mal
Danksagung erhalten: 1 Mal

Re: Measurement 'Service' fehlt

Beitrag von hendock »

Wahrscheinlich ZU weit von dir entfernt... ;)

hendock
Beiträge: 59
Registriert: Mo 19. Jul 2021, 13:57
Hat sich bedankt: 3 Mal
Danksagung erhalten: 1 Mal

Re: Measurement 'Service' fehlt

Beitrag von hendock »

hendock hat geschrieben:
Sa 31. Jul 2021, 13:29
Jetzt habe ich zwar kein Passwort mehr für die Wallbox aber die Werte werden geschrieben.
Korrigiere: Nach dem Firmware-Update war das Passwort weg, also einfach das PW-Feld leer lassen und 'Submit' klicken. Ich komme jetzt also in die Konfi der WB und habe ein neues PW vergeben. :)

OveS
Beiträge: 3
Registriert: Mi 2. Dez 2020, 17:11

Re: Measurement 'Service' fehlt

Beitrag von OveS »

Moin!
Ich weiss nicht, ob es Sinn macht, an diesem Thread anzuknüpfen, oder einen neuen zu eröffnen, aber da mein Problem identisch zu obigem ist, versuche ich es mal hier.
Habe eine go-eCharger Wallbox Homefix 11, Hardwareversion V3, die auch ausgelesen werden kann, aber offensichtlich fehlt auch bei mir das Measurement "Service" in meiner DB für die Wallbox (DB heisst bei mir "goecharger")

Code: Alles auswählen

> show databases
name: databases
name
----
_internal
solaranzeige
steuerung
Kostal
KostalKSEM
goecharger
> use goecharger
Using database goecharger
> show measurements
name: measurements
name
----
AC
Info
Statistik
Summen
So kommt es dann auch bei mir immer zu dem Fehler:

Code: Alles auswählen

pi@solaranzeige:/var/www/log $ tail wallbox.log
31.12. 00:40:01 |--> - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
31.12. 00:40:01 INFO Die Konfig Datei '4.wallbox.steuerung.ini' ist vorhanden
31.12. 00:40:01 INFO Eigenverbrauch geschätzt: 0 Watt
31.12. 00:40:01 ERRO Es fehlt die Datenbank 'goecharger' oder sie ist leer.
31.12. 00:40:01 ENDE ---------------------------------------------------------
bzw. im solaranzeige.log:

Code: Alles auswählen

...
31.12. 00:51:24 |----------------   Stop   kostal_meter.php     -------------------
31.12. 00:51:24    -Verarbeitung von: '4.user.config.php'   Regler: 29
31.12. 00:51:24 |----------------   Start  go-e_wallbox.php   ---------------------
31.12. 00:51:24 o  -Hardware Version: 3B
31.12. 00:51:25    -Daten zum Gerät gesendet.
 Antwort: {"version":"B","tme":"3112210051","rbc":"65","rbt":"27740239","car":"1","amx":"16","amp":"16","err":"0","ast":"0","alw":"1","stp":"0","
cbl":"0","pha":"56","fsp":"0","tma":[14.25,18.625],"dws":"0","dwo":"180","adi":"1","uby":"0","eto":"22","wst":"3","fwv":"052.1","nrg":[231,235,23
3,1,0,0,0,0,0,0,0,0,0,0,0,0],"sse":"064231","wss":"blablaFritz24a","wke":"********","wen":"1","cdi":"0","tof":"101","tds":"1","lbr":"0","aho":"0"
,"afi":"6","azo":"0","ama":"16","al1":"6","al2":"10","al3":"12","al4":"14","al5":"16","cid":"255","cch":"65535","cfi":"65280","lse":"1","ust":"0"
,"wak":"********","r1x":"2","dto":"0","nmo":"0","sch":"AAAAAAAAAAAAAAAA","sdp":"0","eca":"0","ecr":"0","ecd":"0","ec4":"0","ec5":"0","ec6":"0","e
c7":"0","ec8":"0","ec9":"0","ec1":"0","rca":"1","rcr":"","rcd":"","rc4":"","rc5":"","rc6":"","rc7":"","rc8":"","rc9":"","rc1":"","rna":"User 1","
rnm":"User 2","rne":"User 3","rn4":"User 4","rn5":"User 5","rn6":"User 6","rn7":"User 7","rn8":"User 8","rn9":"User 9","rn1":"User 10","loe":0,"l
ot":32,"lom":6,"lop":50,"log":"","lof":0,"loa":0,"lch":0}
31.12. 00:51:25    -MQTT Daten zum [ 192.168.0.109 ] senden.
31.12. 00:51:25    -InfluxDB  => [
AC Spannung_R=231,Spannung_S=235,Spannung_T=233,Strom_R=0,Strom_S=0,Strom_T=0,Leistung_R=0,Leistung_S=0,Leistung_T=0,Leistung_gesamt=0,Leistungsf
aktor_R=0,Leistungsfaktor_S=0,Leistungsfaktor_T=0,Leistungsfaktor_N=0
Service Temperatur=,Stationsstatus=1,MaxAmpere=16,ErrorCode=0,Zugangskontrolle=0,Abschaltung=0,RFID_Karte=0,Karteninhaber="keine Karte"
Summen Wh_Gesamt=2200,Wh_Ladevorgang=0,Wh_Karte1=0,Wh_Karte2=0,Wh_Karte3=0,Wh_Karte4=0,Wh_Karte5=0,Wh_Karte6=0,Wh_Karte7=0,Wh_Karte8=0,Wh_Karte9=0,Wh_Karte10=0
 ]
31.12. 00:51:25    -Daten nicht zur lokalen InfluxDB gesendet! info: array (
  'url' => 'http://localhost/write?db=goecharger&precision=s',
  'content_type' => 'application/json',
  'http_code' => 400,
  'header_size' => 489,
  'request_size' => 667,
  'filetime' => -1,
  'ssl_verify_result' => 0,
  'redirect_count' => 0,
  'total_time' => 0.02214,
  'namelookup_time' => 0.001121,
  'connect_time' => 0.0021,
  'pretransfer_time' => 0.002382,
  'size_upload' => 512.0,
  'size_download' => 214.0,
  'speed_download' => 9727.0,
  'speed_upload' => 23272.0,
  'download_content_length' => 214.0,
  'upload_content_length' => 512.0,
  'starttransfer_time' => 0.022033,
  'redirect_time' => 0.0,
  'redirect_url' => '',
  'primary_ip' => '::1',
  'certinfo' =>
  array (
  ),
  'primary_port' => 8086,
  'local_ip' => '::1',
  'local_port' => 38232,
  'http_version' => 2,
  'protocol' => 1,
  'ssl_verifyresult' => 0,
  'scheme' => 'HTTP',
  'appconnect_time_us' => 0,
  'connect_time_us' => 2100,
  'namelookup_time_us' => 1121,
  'pretransfer_time_us' => 2382,
  'redirect_time_us' => 0,
  'starttransfer_time_us' => 22033,
  'total_time_us' => 22140,
)
31.12. 00:51:25 MQT-PIPE ausgelesen und Daten empfangen.
[.... MQT-solaranzeige/XXX Datenzeilen gelöscht ...]
31.12. 00:51:30    -InfluxDB  => [
AC Spannung_R=231,Spannung_S=235,Spannung_T=233,Strom_R=0,Strom_S=0,Strom_T=0,Leistung_R=0,Leistung_S=0,Leistung_T=0,Leistung_gesamt=0,Leistungsfaktor_R=0,Leistungsfaktor_S=0,Leistungsfaktor_T=0,Leistungsfaktor_N=0
Service Temperatur=,Stationsstatus=1,MaxAmpere=16,ErrorCode=0,Zugangskontrolle=0,Abschaltung=0,RFID_Karte=0,Karteninhaber="keine Karte"
Summen Wh_Gesamt=2200,Wh_Ladevorgang=0,Wh_Karte1=0,Wh_Karte2=0,Wh_Karte3=0,Wh_Karte4=0,Wh_Karte5=0,Wh_Karte6=0,Wh_Karte7=0,Wh_Karte8=0,Wh_Karte9=0,Wh_Karte10=0
 ]
31.12. 00:51:30    -Daten nicht zur lokalen InfluxDB gesendet! info: array (
  'url' => 'http://localhost/write?db=goecharger&precision=s',
  'content_type' => 'application/json',
  'http_code' => 400,
  'header_size' => 489,
  'request_size' => 667,
  'filetime' => -1,
  'ssl_verify_result' => 0,
  'redirect_count' => 0,
  'total_time' => 0.094865,
  'namelookup_time' => 0.000176,
  'connect_time' => 0.000177,
  'pretransfer_time' => 0.00055,
  'size_upload' => 512.0,
  'size_download' => 214.0,
  'speed_download' => 2276.0,
  'speed_upload' => 5446.0,
  'download_content_length' => 214.0,
  'upload_content_length' => 512.0,
  'starttransfer_time' => 0.094787,
  'redirect_time' => 0.0,
  'redirect_url' => '',
  'primary_ip' => '::1',
  'certinfo' =>
  array (
  ),
  'primary_port' => 8086,
  'local_ip' => '::1',
  'local_port' => 38232,
  'http_version' => 2,
  'protocol' => 1,
  'ssl_verifyresult' => 0,
  'scheme' => 'HTTP',
  'appconnect_time_us' => 178,
  'connect_time_us' => 177,
  'namelookup_time_us' => 176,
  'pretransfer_time_us' => 550,
  'redirect_time_us' => 0,
  'starttransfer_time_us' => 94787,
  'total_time_us' => 94865,
)
31.12. 00:51:35    -Multi-Regler-Ausgang. -4
31.12. 00:51:35    -OK. Datenübertragung erfolgreich.
31.12. 00:51:35 |----------------   Stop   go-e_wallbox.php   ---------------------
31.12. 00:51:35    -Multi Regler Auslesen [Stop].
D.h. auch hier kommt der Fehler "Daten nicht zur lokalen InfluxDB gesendet! info: array ("

Kann man das fehlende Measurement "Service" in der DB nachpflegen oder an welcher Stelle sollte dieses angelegt werden?

Gruß Ove
KOSTAL PLENTICORE plus 10
KOSTAL Smart Energy Meter (KSEM)
go eCharger HOMEfix 11 kW

Bogeyof
Beiträge: 938
Registriert: Mi 13. Mai 2020, 10:04
Hat sich bedankt: 17 Mal
Danksagung erhalten: 103 Mal

Re: Measurement 'Service' fehlt

Beitrag von Bogeyof »

Soweit ich das sehe ist die Temperatur nicht befüllt und deshalb wird der Datensatz nicht geschrieben, es kommt zur Fehlermeldung. Hier gibt es aber auch schon einige Hinweise zur neuen Version/ Firmware des GoE-Charger, mit dieser ist wohl ein Problem vorhanden:
viewtopic.php?p=14388#p14388

Wenn du ein wenig rumspielen willst, dann könntest Du in der Wechselrichter-PHP der Temperatur einen festen Wert geben (z.B. 0), damit das Feld befüllt ist und das Schreiben von "Service" erfolgreich ist...

OveS
Beiträge: 3
Registriert: Mi 2. Dez 2020, 17:11

Re: Measurement 'Service' fehlt

Beitrag von OveS »

Frohes Neues Jahr erstmal :-)

jo - Du hattest Recht.
Wohl durch die neue Hardwarerevision V3 des go-eChargers oder durch die aktuelle Firmware 052.1 wurde die Temperaturanzeige von der Stringvariable "tmp" zum Array "tma".
Durch Änderung der einen Zeile in der /var/www/html/phpinc/funktionen.inc.php

Code: Alles auswählen

$query .= "Temperatur=".$daten["tmp"];
nach

Code: Alles auswählen

$query .= "Temperatur=".$daten["tma"][0];
wurde der Wert nun sauber ausgelesen und das "Service"-measurement gefüllt.
Danke nochmal!

Gruß Ove :)
KOSTAL PLENTICORE plus 10
KOSTAL Smart Energy Meter (KSEM)
go eCharger HOMEfix 11 kW

Benutzeravatar
Ulrich
Administrator
Beiträge: 3685
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 63 Mal
Danksagung erhalten: 301 Mal
Kontaktdaten:

Re: Measurement 'Service' fehlt

Beitrag von Ulrich »

OveS hat geschrieben:
Sa 1. Jan 2022, 14:34
Frohes Neues Jahr erstmal :-)

jo - Du hattest Recht.
Wohl durch die neue Hardwarerevision V3 des go-eChargers oder durch die aktuelle Firmware 052.1 wurde die Temperaturanzeige von der Stringvariable "tmp" zum Array "tma".
Durch Änderung der einen Zeile in der /var/www/html/phpinc/funktionen.inc.php

Code: Alles auswählen

$query .= "Temperatur=".$daten["tmp"];
nach

Code: Alles auswählen

$query .= "Temperatur=".$daten["tma"][0];
wurde der Wert nun sauber ausgelesen und das "Service"-measurement gefüllt.
Danke nochmal!

Gruß Ove :)
Ich werde die Änderung in das Update übernehmen.
--------------------------------------
Ulrich [Admin]

OveS
Beiträge: 3
Registriert: Mi 2. Dez 2020, 17:11

Re: Measurement 'Service' fehlt

Beitrag von OveS »

unter https://github.com/goecharger/go-eCharg ... #parameter ist das beschrieben.
Es gibt zwei Temperaturen in dem Array.
Die erste ist bei mir niedriger (wohl die Außentemperatur) und die zweite höher (evtl. irgendwo im Gehäuseinneren oder an irgendeinem Chip?!)

Code: Alles auswählen

"tma":[14.875,19.125]
Da meine Wallbox leider gerade schwächelt, kann ich nicht verfolgen, wie sich die Temperaturen während eines Ladevorgangs verhalten...

Gruß Ove
KOSTAL PLENTICORE plus 10
KOSTAL Smart Energy Meter (KSEM)
go eCharger HOMEfix 11 kW

Antworten