Grafana startet nicht: operation not permiited

Solaranzeige und Docker
Alles was mit der Docker Version zu tun hat.

Moderatoren: Ulrich, DeBaschdi

Antworten
reini0815
Beiträge: 8
Registriert: So 30. Aug 2020, 14:33

Grafana startet nicht: operation not permiited

Beitrag von reini0815 »

Ich nutze docker compose mit Portainer und wollte heute den Solaranzeige Container auf meinem Raspi aktualisieren.
folgendes habe ich gemacht:

1. Das Raspi OS aktualisiert
2. Portainer aktualisiert.
3. Den vorhandenen Container Solaranzeige und das dazugehörende Image gelöscht
4. In der docker-compose.yml den neuen Pfad für die PVForecast ergänzt.
5. Den Stack deployed.

Solaranzeige und Apache laufen. Aber leider startet Grafana nicht. In den Logfiles finde ich folgenden Hinweis:

touch: setting times of '/var/run/grafana-server.pid': Operation not permitted

Hat jemand eine Idee?
-------------------------------------------------------------------
7,9 kWp Solarpanel
Kostal Plenticore mit BOYD Batterie
go-e Wallbox
Solaranzeige unter Docker auf einem Raspberry Pi
Hausautomatisierung mit Node-Red / MQTT / Zigbee

DeBaschdi
Beiträge: 157
Registriert: Mo 10. Aug 2020, 08:13
Hat sich bedankt: 7 Mal
Danksagung erhalten: 22 Mal

Re: Grafana startet nicht: operation not permiited

Beitrag von DeBaschdi »

Moin,
komisches verhalten...

versuch mal dich ins Image einzuloggen und den service neu zu starten.

Code: Alles auswählen

service grafana-server restart

Code: Alles auswählen

service grafana-server status
Wird was gemeckert ?
JA ?

dann

Code: Alles auswählen

service grafana-server stop

Code: Alles auswählen

rm /var/run/grafana-server.pid

Code: Alles auswählen

service grafana-server start
klappt immer noch nicht ?

Code: Alles auswählen

chown grafana grafana /var/run/grafana-server.pid

Code: Alles auswählen

chmod 777 /var/run/grafana-server.pid

Code: Alles auswählen

service grafana-server restart

reini0815
Beiträge: 8
Registriert: So 30. Aug 2020, 14:33

Re: Grafana startet nicht: operation not permiited

Beitrag von reini0815 »

Danke für deine Antwort. Das Setzen der Rechte über die Console hatte ich auch schon mal probiert. Aber leider erfolglos. Hier das Log der Aktion in der Console:

root@0f00b27eadd2:/# cd /var/run
root@0f00b27eadd2:/var/run# ls -l
total 24
drwxrwxrwx 1 root root 4096 Jul 5 16:17 apache2
-rwxrwxrwx 1 root root 4 Jul 5 16:17 crond.pid
--wx-wx-wx 1 root root 0 Jul 5 16:17 crond.reboot
-rwxrwxrwx 1 grafana root 3 Jul 9 10:29 grafana-server.pid
drwxrwxrwx 2 influxdb influxdb 4096 Jul 5 16:17 influxdb
drwxrwxrwt 1 root root 4096 May 22 07:14 lock
drwxrwxrwx 2 root root 4096 Jul 5 16:17 mosquitto
-rwxrwxrwx 1 root utmp 0 May 11 02:00 utmp

root@0f00b27eadd2:/var/run# service grafana-server start
Starting Grafana Server:touch: setting times of '/var/run/grafana-server.pid': Operation not permitted
start-stop-daemon: matching on world-writable pidfile /var/run/grafana-server.pid is insecure
failed!



Das Solaranzeige.log zeigt beim Start noch folgende Meldung:


sleep: cannot read realtime clock: Operation not permitted
touch: setting times of '/var/run/grafana-server.pid': Operation not permitted
start-stop-daemon: matching on world-writable pidfile /var/run/grafana-server.pid is insecure
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.19.0.2. Set the 'ServerName' directive globally to suppress this message
sleep: cannot read realtime clock: Operation not permitted
....
sleep: cannot read realtime clock: Operation not permitted
/sbin/start-stop-daemon: matching on world-writable pidfile /var/run/crond.pid is insecure


Ich werde es bei Gelegenheit versuchen nochmal komplett neu aufzusetzten
-------------------------------------------------------------------
7,9 kWp Solarpanel
Kostal Plenticore mit BOYD Batterie
go-e Wallbox
Solaranzeige unter Docker auf einem Raspberry Pi
Hausautomatisierung mit Node-Red / MQTT / Zigbee

Antworten