Solaranzeige bootet nicht mehr

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

nozzy
Beiträge: 19
Registriert: Di 2. Jun 2020, 15:03

Solaranzeige bootet nicht mehr

Beitrag von nozzy »

Moin,

heute morgen hing die Solaranzeige (wie alle paar Tage) mit dem Webbrowser-Fehler fest. Daran habe ich mich schon gewöhnt.
Die Software läuft im Hintergrund weiter und zeichnet weiter Daten auf. Da ich keine Maus dran habe, um auf "Seite neu laden" zu klicken, starte ich den Raspi per Steckdosenschalter neu.
Das war bisher auch nie ein Problem.

Nun sieht es so aus, als wenn sich da was zerschossen hat. Er kann sich scheinbar nicht mehr einloggen (siehe Foto).
Nach diesem Screen wird das Bild schwarz und bleibt auch so.
IMG_20210215_093543.jpg
Per ssh komme ich auch nicht mehr drauf, da das WLAN wohl an dieser Stelle noch nicht geladen ist.



Kann mir jemand helfen?

Benutzeravatar
Ulrich
Administrator
Beiträge: 1981
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 1 Mal
Danksagung erhalten: 33 Mal
Kontaktdaten:

Re: Solaranzeige bootet nicht mehr

Beitrag von Ulrich »

Das sieht ganz so aus, als ob deine SD-Karte voll wäre. Hast Du denn den Speicherplatz ganz zur Verfügung gestellt?
viewtopic.php?f=4&t=975&p=4675&hilit=sp ... latz#p4675
--------------------------------------
Ulrich [Admin]

andreas_n
Beiträge: 210
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 6 Mal
Danksagung erhalten: 1 Mal

Re: Solaranzeige bootet nicht mehr

Beitrag von andreas_n »

nozzy hat geschrieben:
Mo 15. Feb 2021, 09:52
starte ich den Raspi per Steckdosenschalter neu.
Das war bisher auch nie ein Problem.
Steckdosenschalter mag der Pi auf Dauer nicht, wenn der Pi wie du sagst, noch läuft, per putty/ssh einloggen und reboot.(meine beiden dry ager Reifeschränke auf pi zero Basis zB kannste nach 2-3mal Steckdose die SD gleich in die Tonne schieben)

Der Fehler mit dem Browser muss weg, warum kommt der? Liegts am Browser?Cache??
Falls du das lästige Hardware resetten umgehen willst, bau in die crontab täglichen reboot ein, so habs ich derzeit laufen weil mir aus noch unerklärlichen Gründen ab und zu die Anzeige samt influx hängt (angeblich zuviele .php scripts beim Auslesen der SMAwr.php, was ich aber kaum glauben kann), so einmal im Monat.

Gruss Andreas

nozzy
Beiträge: 19
Registriert: Di 2. Jun 2020, 15:03

Re: Solaranzeige bootet nicht mehr

Beitrag von nozzy »

Das ist eine 32 GB SD-Karte und ich bin der Meinung, bei der Installation den ganzen Speicherplatz zur Verfügung gestellt zu haben.

Ich habe die Karte mal in einen Kartenleser gesteckt und unter Windows wird mir folgende Größe angezeigt:
sd.PNG
sd.PNG (18.62 KiB) 240 mal betrachtet
Sieht schon ziemlich seltsam aus.

nozzy
Beiträge: 19
Registriert: Di 2. Jun 2020, 15:03

Re: Solaranzeige bootet nicht mehr

Beitrag von nozzy »

andreas_n hat geschrieben:
Mo 15. Feb 2021, 10:21
nozzy hat geschrieben:
Mo 15. Feb 2021, 09:52
starte ich den Raspi per Steckdosenschalter neu.
Das war bisher auch nie ein Problem.
Der Fehler mit dem Browser muss weg, warum kommt der? Liegts am Browser?Cache??
Hier wurde mal erwähnt, dass das mit dem Chrome zusammenhängt und auch nicht umgehbar ist. Man konnte da einen Wert hochsetzen, damit das seltener passiert. Das hatte ich auch gemacht.
Wenn ich das alles wieder zum laufen kriege, werde ich ne Maus dran hängen. 8-)

andreas_n
Beiträge: 210
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 6 Mal
Danksagung erhalten: 1 Mal

Re: Solaranzeige bootet nicht mehr

Beitrag von andreas_n »

nozzy hat geschrieben:
Mo 15. Feb 2021, 10:34


Hier wurde mal erwähnt, dass das mit dem Chrome zusammenhängt und auch nicht umgehbar ist.
okay, ich hab kein chrome, aber das wär Grund den in die Tonne...
schon mal mit anderen Browsern getestet?

Auf der neuen Linux Maschine hier hab ich zB FF ESR drauf, keine Updates, keine nervigen Fragen, keine Probleme und alles geht.

nozzy
Beiträge: 19
Registriert: Di 2. Jun 2020, 15:03

Re: Solaranzeige bootet nicht mehr

Beitrag von nozzy »

Ich benutze ja nur das original Image und will da auch nicht drin rum fummeln, deswegen lasse ich den Chrome so drauf.

Das mit dem täglichen reboot über cronjob werde ich aber rein machen, sobald die Geschichte wieder läuft.

Gibt es irgendwas, was ich mit Windows tun kann?

Zumindest Daten retten und alles neu aufsetzen, wenn es nicht anders geht.

andreas_n
Beiträge: 210
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 6 Mal
Danksagung erhalten: 1 Mal

Re: Solaranzeige bootet nicht mehr

Beitrag von andreas_n »

nozzy hat geschrieben:
Mo 15. Feb 2021, 11:38
Gibt es irgendwas, was ich mit Windows tun kann?
jo, nen Haufen..die Original IMG SW ist ja nur Basis setup

den Pi so aufrüsten, dass er:
mit externer SSD / HDD gemountet ist, da täglich backup drauf, geht mit ner Fritzbox und oder wer hat , mit nem Server
dann selbiges backup auch mal zurückspielen, ob das prinzipiell lauffähig ist, also worst case auch der pi restauriert werden könnte(muss ich selber noch testen)
den pi wlan fähig machen
usb boot fähig machen
wenn möglich, SD eliminieren, pi und SD stehen absolut auf Kriegsfuss, ich kenne pi's, die rennen seit 4 Jahren durch, booten aber einmal nachts und schreiben nur wenig drauf, so alle 5min ein Datensatz (meine WE Haus Heizungsfernsteuerung), ich kenne aber pi's die zerschreiben ne nagelneue SD binnen Monat.Die Foren sind voll davon
Ich hab deswegen konsequent SSD/HDD dran und seither Ruhe, vor allem beim boot ist der pi wesentlich schneller

Was auch geht...die Schreibzugriffe drastisch verringern, gibts hier irgendwo Beispiel im Forum, schon die SD, aber um es mit den Worten eines ITlers zu sagen..es gibt zwei Arten von Daten..ungesicherte und gesicherte, hat er net ganz unrecht.

Gruss
Andreas

nozzy
Beiträge: 19
Registriert: Di 2. Jun 2020, 15:03

Re: Solaranzeige bootet nicht mehr

Beitrag von nozzy »

Also die SD-Karte ist scheinbar nicht kaputt. Auf nem Linux kann ich sie auslesen und drauf zugreifen. Es sind 6 GB von 32 GB belegt. Unter Windows sehe ich die Partition auch in der Datenträgerverwaltung, aber mit dem Dateisystem kann Windows nicht viel anfangen.

Ich könnte jetzt also alle nötigen Dateien (configs, DBs, php, Dashboard ...) manuell raus kopieren, dann alles neu aufsetzen und die Dateien wieder zurück schieben.

Oder den Fehler finden und direkt beheben. Das wäre mir natürlich lieber. Der Fehler scheint ja beim Login zu liegen. Vielleicht könnte man da irgendeine Datei gegen die originale ersetzen...?

andreas_n
Beiträge: 210
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 6 Mal
Danksagung erhalten: 1 Mal

Re: Solaranzeige bootet nicht mehr

Beitrag von andreas_n »

Wenn das nur ne "einfache" Singleversion ist, und vermutlich auch noch fast unverändert..Influx wegsichern,Dashboard und die user.config
Hab ich eine vergessen?hmm.
Ich würde aber sicherheitshalber die jetzige SD erst resetten, wenn eine andere sauber läuft.
Warum login nicht geht, kA..hatte ich nie

Antworten