Effekta ax +Licom+solaranzeige

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
easy
Beiträge: 30
Registriert: Fr 28. Aug 2020, 16:38

Effekta ax +Licom+solaranzeige

Beitrag von easy »

hallo miteinander,
nachdem mein System richtig gut funktioniert:

2 x Effekta ax 5000
3 x us 2000

hatte ich mir gedacht holst du ma die licom box.also alles angeschlossen und siehe da die pylontechs kommunizieren mit den Effekta. soweit alles gut .

wie bekannt ist geht nun nicht mehr der usb Anschluss zum auslesen der Daten in der Solaranzeige. nun stellt sich die frage wie ich es ermöglichen kann trotzdem die Daten sichtbar zu machen . ich müsste jetzt am Netzwerk Anschluss von der licom box ins raspberry rein und die Daten die gesendet werden einfügen . hab es aber bisher nicht geschafft . wie sieht es bei euch aus ? hat einer von schon was erreichen können ???
lg

SunnyB
Beiträge: 5
Registriert: Sa 26. Sep 2020, 21:35
Hat sich bedankt: 1 Mal

Re: Effekta ax +Licom+solaranzeige

Beitrag von SunnyB »

Hi easy,
Danke, dass du den neuen Betrag aufgemacht hast.
Ich bin noch nicht weiter mit dem Anschluss der Solaranzeige an die LiCom Box.
Habe mich inzwischen durch diverse Foren gelesen, wie man die Kommunikation zum Laufen bekommt,
leider mit bisher wenig Erfolgt.
Da die Kommunikation mit Watchpower an der LiCom Box direkt funktioniert, sind die notwendigen Daten
vom Wechselrichter ja zumindest dort verfügbar. Für die Funktion mit Watchpower muss man in den Schnittstelleneinstellungen
eine Anpassung machen. Und ich denke, genau an dem Punkt hängt es in der Solaranzeige, da diese Einstellung dort nicht
gesetzt werden kann bzw. ich leider keine Ahnung habe, wo ich das könnte.

Gruss
Sunny

easy
Beiträge: 30
Registriert: Fr 28. Aug 2020, 16:38

Re: Effekta ax +Licom+solaranzeige

Beitrag von easy »

Hey sunny

Ja recht hast du , direkt aus der Box bekomm ich die Verbindung in watchpower aber wenn ich den mitgelieferten usb ins raspberry einstecke bekomm ich die Signale nicht weitergeleitet. Egal ob Single oder multi Modus. Ich bekomm keine Verbindung. Ich schau mal morgen ob es noch einen Weg gibt. Lg

SunnyB
Beiträge: 5
Registriert: Sa 26. Sep 2020, 21:35
Hat sich bedankt: 1 Mal

Re: Effekta ax +Licom+solaranzeige

Beitrag von SunnyB »

Könnte es mit der Modbus Kommunikation und der Adressierung der Geräte zusammenhängen?
Ich kenne mich leider mit Modbus null aus.
Es sind ja schon mindestens 2 Geräte (der WR und min. 1 Pylon) am Bus. Kann es sein, dass
die Solaranzeige "nur" auf die richtige Adresse eingestellt werden muss?

easy
Beiträge: 30
Registriert: Fr 28. Aug 2020, 16:38

Re: Effekta ax +Licom+solaranzeige

Beitrag von easy »

Guten Morgen,
Mit modbus kenn ich mich auch überhaupt nicht aus. Ich hab zwei Effekta mit parallel Karten drin. Dazu 3 us2000 dran. Ich werd heut mal ein wenig rumbprobieren. Vielleicht gibt es ja eine Lösung. Lg

Lukas201099
Beiträge: 2
Registriert: So 19. Jul 2020, 05:45

Re: Effekta ax +Licom+solaranzeige

Beitrag von Lukas201099 »

So einfach ist das leider nicht, Da die "überstzung" nicht passt.
Eine Verbindung kann man herstellen, (ich habe Geräte 21 benutzt (weis gerade nicht wie es heist) selbe Verbindung + Richtige Baudrate) allerdings ist es da nicht möglich die Daten auszulesen. Heißt es wird falsch "übersetzt" und es wird nicht in die influxDB geschrieben.
Es ist auch nicht möglich Die richtige baudrate etc von gerät 21 mit dem "übersetztungsteil" von dem Effekta wechselrichter (Gerät 7) zu nutzen da dies verschiedene Verbindungen sind (damit auch verschieden "codiert").

In der neusten Version Sind die Pylontech US3000 mit der selben Verbindung wie von der licom box verfügbar (allerdings Falsche baudrate) Ich werde bei Gelegenheit versuchen die Verbindung von Geräte 21 mit der Decodierung von den Pylontech zu kombinieren.
Wenn ich neue Erkenntnisse habe werde ich mich wieder melden!

Lukas201099
Beiträge: 2
Registriert: So 19. Jul 2020, 05:45

Re: Effekta ax +Licom+solaranzeige

Beitrag von Lukas201099 »

Hier noch die Log Datei!


01.03. 08:47:15 -Verarbeitung von: '3.user.config.php' Regler: 21
01.03. 08:47:15 |---------------- Start kostal_piko.php ---------------------
01.03. 08:47:15 + -Die Daten werden ausgelesen...
01.03. 08:47:17 -InfluxDB => [
AC Spannung_R=0,Spannung_S=0,Spannung_T=0,Strom_R=0,Strom_S=0,Strom_T=0,Leistung_R=,Leistung_S=,Leistung_T=
PV String1_Spannung=0,String2_Spannung=0,String3_Spannung=0,String1_Strom=0,String2_Strom=0,String3_Strom=0,String1_Leistung=,String2_Leistung=,String3_Leistung=,String1_Nummer="1",String2_Nummer="2",String3_Nummer="3"
Service FehlerCode=,Status=,Fehler=,Strings=0,Phasen=0
Summen Wh_Heute=0,Wh_Gesamt_=0 ]
01.03. 08:47:17 -Daten nicht zur lokalen InfluxDB gesendet! info: array
(
'url' => 'http://localhost/write?db=solaranzeige2&precision=s',
'content_type' => 'application/json',
'http_code' => 400,
'header_size' => 813,
'request_size' => 571,
'filetime' => -1,
'ssl_verify_result' => 0,
'redirect_count' => 0,
'total_time' => 0.208997,
'namelookup_time' => 0.001174,
'connect_time' => 0.002144,
'pretransfer_time' => 0.002417,
'size_upload' => 413.0,
'size_download' => 544.0,
'speed_download' => 2615.0,
'speed_upload' => 1985.0,
'download_content_length' => 544.0,
'upload_content_length' => 413.0,
'starttransfer_time' => 0.208866,
'redirect_time' => 0.0,
'redirect_url' => '',
'primary_ip' => '::1',
'certinfo' =>
array (
),
'primary_port' => 8086,
'local_ip' => '::1',
'local_port' => 46452,
'http_version' => 2,
'protocol' => 1,
'ssl_verifyresult' => 0,
'scheme' => 'HTTP',
'appconnect_time_us' => 0,
'connect_time_us' => 2144,
'namelookup_time_us' => 1174,
'pretransfer_time_us' => 2417,
'redirect_time_us' => 0,
'starttransfer_time_us' => 208866,
'total_time_us' => 208997,
)
01.03. 08:47:22 -InfluxDB => [
AC Spannung_R=0,Spannung_S=0,Spannung_T=0,Strom_R=0,Strom_S=0,Strom_T=0,Leistung_R=,Leistung_S=,Leistung_T=
PV String1_Spannung=0,String2_Spannung=0,String3_Spannung=0,String1_Strom=0,String2_Strom=0,String3_Strom=0,String1_Leistung=,String2_Leistung=,String3_Leistung=,String1_Nummer="1",String2_Nummer="2",String3_Nummer="3"
Service FehlerCode=,Status=,Fehler=,Strings=0,Phasen=0
Summen Wh_Heute=0,Wh_Gesamt_=0 ]
01.03. 08:47:22 -Daten nicht zur lokalen InfluxDB gesendet! info: array
(
'url' => 'http://localhost/write?db=solaranzeige2&precision=s',
'content_type' => 'application/json',
'http_code' => 400,
'header_size' => 813,
'request_size' => 571,
'filetime' => -1,
'ssl_verify_result' => 0,
'redirect_count' => 0,
'total_time' => 0.174553,
'namelookup_time' => 0.000214,
'connect_time' => 0.000216,
'pretransfer_time' => 0.000486,
'size_upload' => 413.0,
'size_download' => 544.0,
'speed_download' => 3126.0,
'speed_upload' => 2373.0,
'download_content_length' => 544.0,
'upload_content_length' => 413.0,
'starttransfer_time' => 0.174421,
'redirect_time' => 0.0,
'redirect_url' => '',
'primary_ip' => '::1',
'certinfo' =>
array (
),
'primary_port' => 8086,
'local_ip' => '::1',
'local_port' => 46452,
'http_version' => 2,
'protocol' => 1,
'ssl_verifyresult' => 0,
'scheme' => 'HTTP',
'appconnect_time_us' => 216,
'connect_time_us' => 216,
'namelookup_time_us' => 214,
'pretransfer_time_us' => 486,
'redirect_time_us' => 0,
'starttransfer_time_us' => 174421,
'total_time_us' => 174553,
)
01.03. 08:47:27 -Multi-Regler-Ausgang. -3
01.03. 08:47:27 -OK. Datenübertragung erfolgreich.
01.03. 08:47:28 |---------------- Stop kostal_piko.php --------------------

Antworten