Effekta ax +Licom+solaranzeige

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Lukas201099
Beiträge: 17
Registriert: So 19. Jul 2020, 05:45
Hat sich bedankt: 2 Mal

Re: Effekta ax +Licom+solaranzeige

Beitrag von Lukas201099 »

Hallo,
Mich freut es sehr das die Licombox ihren weg in die Solaranzeige gefunden hat :D .
Leider bekomme ich sie nicht dazu etwas anzuzeigen, weder bei meiner laufenden Konfiguration(4.7.8) noch bei einer neue Eingerichteten Version 5.0.3). Ich wäre sehr erfreut über Lösungsvorschläge :idea:

Hier noch mein Log aus der Alten Konfiguration:
12.06. 10:23:01 -Multi Regler Auslesen [Start].
12.06. 10:23:01 -Verarbeitung von: '1.user.config.php' Regler: 7
12.06. 10:23:01 |-------------- Start ax_wechselrichter.php -----------------
12.06. 10:23:02 -237.7 50.0 230.1 49.9 0230 0175 004 430 53.60 027 074 0038 0030 105.9 53.63 00000 00110110 00 00 01651 110 i: 51
12.06. 10:23:02 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
12.06. 10:23:02 -Multi-Regler-Ausgang. 6
12.06. 10:23:08 -OK. Datenübertragung erfolgreich.
12.06. 10:23:08 -Solarleistung: 1651 Watt - WattstundenGesamtHeute: 4161.02
12.06. 10:23:08 |------------ Stop ax_wechselrichter.php ------------------
12.06. 10:23:08 -Verarbeitung von: '2.user.config.php' Regler: 7
12.06. 10:23:08 |-------------- Start ax_wechselrichter.php -----------------
12.06. 10:23:10 -237.1 50.0 229.9 50.0 0460 0387 009 428 53.50 000 073 0034 0006 112.1 53.53 00001 00110110 00 00 00342 010 i: 52
12.06. 10:23:10 * -Daten zur lokalen InfluxDB [ solaranzeige1 ] gesendet.
12.06. 10:23:10 -Multi-Regler-Ausgang. 5
12.06. 10:23:15 -OK. Datenübertragung erfolgreich.
12.06. 10:23:15 -Solarleistung: 342 Watt - WattstundenGesamtHeute: 4442.02
12.06. 10:23:15 |------------ Stop ax_wechselrichter.php ------------------
12.06. 10:23:15 -Verarbeitung von: '3.user.config.php' Regler: 77
12.06. 10:23:15 |------------------------- Start licom-box.php ---------------------
12.06. 10:23:19 -Lesefehler > [ ]
12.06. 10:23:23 -Lesefehler > [ ]
12.06. 10:23:27 -Lesefehler > [ ]
12.06. 10:23:30 -Lesefehler > [ ]
12.06. 10:23:35 -Lesefehler > [ ]
12.06. 10:23:41 -Lesefehler > [ ]
12.06. 10:23:45 -Lesefehler > [ ]
12.06. 10:23:51 -Lesefehler > [ ]
12.06. 10:23:56 -Lesefehler > [ ]
12.06. 10:24:01 -Zu viele PHP Scripte: multi_regler_auslesen.php
12.06. 10:24:01 !! -|---> Stop PHP Script: multi_regler_auslesen.php **************
12.06. 10:24:01 -Lesefehler > [ ]
12.06. 10:24:06 -Lesefehler > [ ]
12.06. 10:24:12 -Lesefehler > [ ]
12.06. 10:24:15 -Lesefehler > [ ]
12.06. 10:24:20 -Lesefehler > [ ]
12.06. 10:24:26 -Lesefehler > [ ]
12.06. 10:24:30 -Lesefehler > [ ]
12.06. 10:24:36 -Lesefehler > [ ]
12.06. 10:24:41 -Lesefehler > [ ]
12.06. 10:24:46 -Lesefehler > [ ]
12.06. 10:24:51 -Lesefehler > [ ]
12.06. 10:24:57 -Lesefehler > [ ]
12.06. 10:25:00 -Lesefehler > [ ]
12.06. 10:25:01 -Zu viele PHP Scripte: multi_regler_auslesen.php
12.06. 10:25:01 !! -|---> Stop PHP Script: multi_regler_auslesen.php **************
12.06. 10:25:05 -Lesefehler > [ ]
12.06. 10:25:10 -Lesefehler > [ ]
12.06. 10:25:15 -Lesefehler > [ ]
12.06. 10:25:21 -Lesefehler > [ ]
12.06. 10:25:25 -Lesefehler > [ ]
12.06. 10:25:31 -Lesefehler > [ ]
12.06. 10:25:36 -Lesefehler > [ ]
12.06. 10:25:41 -Lesefehler > [ ]
12.06. 10:25:45 -Lesefehler > [ ]
12.06. 10:25:50 -Lesefehler > [ ]
12.06. 10:25:55 -Lesefehler > [ ]
12.06. 10:26:00 -Lesefehler > [ ]
12.06. 10:26:02 -Zu viele PHP Scripte: multi_regler_auslesen.php
12.06. 10:26:02 !! -|---> Stop PHP Script: multi_regler_auslesen.php **************
12.06. 10:26:06 -Lesefehler > [ ]
12.06. 10:26:10 -Lesefehler > [ ]
12.06. 10:26:16 -Lesefehler > [ ]
12.06. 10:26:21 -Lesefehler > [ ]
12.06. 10:26:26 -Lesefehler > [ ]
12.06. 10:26:30 -Lesefehler > [ ]
12.06. 10:26:35 -Lesefehler > [ ]
12.06. 10:26:40 -Lesefehler > [ ]
12.06. 10:26:45 -Lesefehler > [ ]
12.06. 10:26:50 -Lesefehler > [ ]
12.06. 10:26:55 -Lesefehler > [ ]
12.06. 10:27:01 -Lesefehler > [ ]
12.06. 10:27:01 -Zu viele PHP Scripte: multi_regler_auslesen.php
12.06. 10:27:01 !! -|---> Stop PHP Script: multi_regler_auslesen.php **************
12.06. 10:27:05 -Lesefehler > [ ]
12.06. 10:27:11 -Lesefehler > [ ]
12.06. 10:27:15 -Lesefehler > [ ]
12.06. 10:27:19 -Lesefehler > [ ]
12.06. 10:27:25 -Lesefehler > [ ]
12.06. 10:27:30 -Lesefehler > [ ]
12.06. 10:27:35 -Lesefehler > [ ]
12.06. 10:27:40 -Lesefehler > [ ]
12.06. 10:27:46 -Lesefehler > [ ]
12.06. 10:27:50 -Lesefehler > [ ]
12.06. 10:27:56 -Lesefehler > [ ]
12.06. 10:27:56 -Die Seriennummer 9293200410xxxx gibt es nicht.
12.06. 10:27:56 |------------------------- Stop licombox.php ---------------------
12.06. 10:27:56 -Multi Regler Auslesen [Stop Timeout].

Benutzeravatar
Ulrich
Administrator
Beiträge: 3698
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 63 Mal
Danksagung erhalten: 305 Mal
Kontaktdaten:

Re: Effekta ax +Licom+solaranzeige

Beitrag von Ulrich »

So wie es aussieht, ist das der Fehler:

12.06. 10:27:56 -Die Seriennummer 9293200410xxxx gibt es nicht.

Ist da eventuell ein Zahlendreher drin?
--------------------------------------
Ulrich [Admin]

Lukas201099
Beiträge: 17
Registriert: So 19. Jul 2020, 05:45
Hat sich bedankt: 2 Mal

Re: Effekta ax +Licom+solaranzeige

Beitrag von Lukas201099 »

Ulrich hat geschrieben:
So 12. Jun 2022, 11:52
So wie es aussieht, ist das der Fehler:

12.06. 10:27:56 -Die Seriennummer 9293200410xxxx gibt es nicht.

Ist da eventuell ein Zahlendreher drin?
Nein, war auch meine Vermutung, bin ich aber schon paar mal durchgegangen.

Benutzeravatar
Ulrich
Administrator
Beiträge: 3698
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 63 Mal
Danksagung erhalten: 305 Mal
Kontaktdaten:

Re: Effekta ax +Licom+solaranzeige

Beitrag von Ulrich »

Hast du die Seriennummer in der 3.user.config.php auch in Gänsefüßchen gesetzt?

Bitte erhöhe vorübergehend einmal in der Datei licom-box.php den Tracelevel auf 8 und schaue dann in die LOG Datei:
/var/www/log/solaranzeige.log

Kann man dort etwas sehen? Eventuell hier einen Auszug posten.
--------------------------------------
Ulrich [Admin]

Lukas201099
Beiträge: 17
Registriert: So 19. Jul 2020, 05:45
Hat sich bedankt: 2 Mal

Re: Effekta ax +Licom+solaranzeige

Beitrag von Lukas201099 »

$Seriennummer = "9293200410xxxx"; das ist die Zeile der Seriennummer, dürfte so eigentlich passen?

Das ist ein auszug aus dem Log mit Tracelevel 8

-Verarbeitung von: '3.user.config.php' Regler: 77
12.06. 18:46:15 |------------------------- Start licom-box.php ---------------------
12.06. 18:46:15 -Zentraler Timestamp: 1655052361
12.06. 18:46:15 o -Hardware Version: Raspberry Pi 3 Model B Rev 1.2
12.06. 18:46:15 -WattstundenGesamtHeute: 0
12.06. 18:46:15 + -WR_ID: 01
12.06. 18:46:18 -Lesefehler > [ ]
12.06. 18:46:23 -Lesefehler > [ ]
12.06. 18:46:23 -Index in: 0 Index out: 0
12.06. 18:46:27 -Lesefehler > [ ]
12.06. 18:46:27 -Aktuelle Seriennummer
12.06. 18:46:30 -Lesefehler > [ ]
12.06. 18:46:35 -Lesefehler > [ ]
12.06. 18:46:35 -Index in: 1 Index out: 0
12.06. 18:46:41 -Lesefehler > [ ]
12.06. 18:46:45 -Lesefehler > [ ]
12.06. 18:46:45 -Index in: 1 Index out: 0
12.06. 18:46:51 -Lesefehler > [ ]
12.06. 18:46:56 -Lesefehler > [ ]
12.06. 18:46:56 -Index in: 1 Index out: 0
12.06. 18:47:01 -Zu viele PHP Scripte: multi_regler_auslesen.php
12.06. 18:47:01 !! -|---> Stop PHP Script: multi_regler_auslesen.php **************

...

12.06. 18:50:05 -Lesefehler > [ ]
12.06. 18:50:05 -Index in: 5 Index out: 0
12.06. 18:50:11 -Lesefehler > [ ]
12.06. 18:50:11 -Aktuelle Seriennummer
12.06. 18:50:15 -Lesefehler > [ ]
12.06. 18:50:19 -Lesefehler > [ ]
12.06. 18:50:19 -Index in: 6 Index out: 0
12.06. 18:50:25 -Lesefehler > [ ]
12.06. 18:50:28 |------------------- Start wetterdaten.php --------------------
12.06. 18:50:28 o---Wetterdaten ausgeschaltet.
12.06. 18:50:28 |------------------- Stop wetterdaten.php ---------------------
12.06. 18:50:29 -Lesefehler > [ ]
12.06. 18:50:29 -Index in: 6 Index out: 0
12.06. 18:50:35 -Lesefehler > [ ]
12.06. 18:50:40 -Lesefehler > [ ]
12.06. 18:50:40 -Index in: 6 Index out: 0
12.06. 18:50:45 -Lesefehler > [ ]
12.06. 18:50:50 -Lesefehler > [ ]
12.06. 18:50:50 -Index in: 6 Index out: 0
12.06. 18:50:56 -Lesefehler > [ ]
12.06. 18:50:56 -Aktuelle Seriennummer
12.06. 18:50:56 -Die Seriennummer 9293200410xxxx gibt es nicht.
12.06. 18:50:56 |------------------------- Stop licombox.php ---------------------
12.06. 18:50:56 -Multi Regler Auslesen [Stop Timeout].

Benutzeravatar
Ulrich
Administrator
Beiträge: 3698
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 63 Mal
Danksagung erhalten: 305 Mal
Kontaktdaten:

Re: Effekta ax +Licom+solaranzeige

Beitrag von Ulrich »

Die 4 x "x" hast du doch nachträglich geändert? Da sind doch die richtigen Zahlen vorhanden?

Kannst du bitte einmal prüfen, ob die Geräte ID in der Licom Box wirklich 01 ist. Sie könnte auch 00 sein oder 02
Die Geräte ID muss mit dem Eintrag in der user.config.php übereinstimmen:

$WR_Adresse = "1"; Ob dort "01" oder "1" steht ist egal.
--------------------------------------
Ulrich [Admin]

Lukas201099
Beiträge: 17
Registriert: So 19. Jul 2020, 05:45
Hat sich bedankt: 2 Mal

Re: Effekta ax +Licom+solaranzeige

Beitrag von Lukas201099 »

Ja die 4x Habe ich geändert, da steht die richtige Nummer.
Wie kann ich die Geräte ID prüfen?

$WR_Adresse = "1"; ist bei mir so eingestellt.

Lukas201099
Beiträge: 17
Registriert: So 19. Jul 2020, 05:45
Hat sich bedankt: 2 Mal

Re: Effekta ax +Licom+solaranzeige

Beitrag von Lukas201099 »

Wird 19200 Baud 8N1 eigentlich automatisch eingestellt oder liegt es daran das ich es noch nicht eingestellt habe?

soltina
Beiträge: 5
Registriert: So 27. Mär 2022, 19:16
Danksagung erhalten: 1 Mal

Re: Effekta ax +Licom+solaranzeige

Beitrag von soltina »

Funtioniert es denn mit Watchpower??
Bei mir war es so, das der mitglieferte Adapter zwar wie wild geblinkt hat, es aber keine Daten kamen. Nun habe ich einen einfachen RS485 Adapter angeschlossen und es funktioniert tadellos.

Lukas201099
Beiträge: 17
Registriert: So 19. Jul 2020, 05:45
Hat sich bedankt: 2 Mal

Re: Effekta ax +Licom+solaranzeige

Beitrag von Lukas201099 »

Mit Whatchpower funktioniert es ohne Probleme.
Blinken tut es, aber nur Rot, bei Whatchpower blinkt es grün.
Kannst du mir ein Link zum Kabel schicken oder die genaue Bezeichnung, das ich das ausschließen kann?

Antworten