Datenbanken weg

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
andreas_n
Beiträge: 347
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 10 Mal
Danksagung erhalten: 13 Mal

Datenbanken weg

Beitrag von andreas_n »

Hallo ins Forum,

kämpfe seit 2 Tagen mit unerklärlichem DB Verlust.

im logfile erscheint dieses:

2.04. 03:08:03 |---------------- Start sonoff_mqtt.php ---------------------.
12.04. 03:08:03 -Zentrale12.04. 04:26:21 -Die seriellen Schnittstellen werden initialisiert.
12.04. 04:26:24 -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 148 $GeraeteNummer = "1";

12.04. 04:26:24 -Zeile gefunden. Platine kann ausgetauscht werden. Index: 528 $Platine = "Raspberry Pi 4 Model B Rev 1.1";

12.04. 04:26:24 -Sonoff hat keine USB / Serielle Schnittstelle.
12.04. 04:26:24 -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 148 $GeraeteNummer = "2";

12.04. 04:26:24 -Zeile gefunden. Platine kann ausgetauscht werden. Index: 528 $Platine = "Raspberry Pi 4 Model B Rev 1.1";

12.04. 04:26:24 -Sonoff hat keine USB / Serielle Schnittstelle.
12.04. 04:26:24 -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 148 $GeraeteNummer = "3";

12.04. 04:26:24 -Zeile gefunden. Platine kann ausgetauscht werden. Index: 528 $Platine = "Raspberry Pi 4 Model B Rev 1.1";

12.04. 04:26:24 -Sonoff hat keine USB / Serielle Schnittstelle.
12.04. 04:26:24 -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 148 $GeraeteNummer = "4";

12.04. 04:26:24 -Zeile gefunden. Platine kann ausgetauscht werden. Index: 528 $Platine = "Raspberry Pi 4 Model B Rev 1.1";

12.04. 04:26:25 -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 148 $GeraeteNummer = "5";

12.04. 04:26:25 -Zeile gefunden. Platine kann ausgetauscht werden. Index: 528 $Platine = "Raspberry Pi 4 Model B Rev 1.1";

12.04. 04:26:25 -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 173 $GeraeteNummer = "6";

12.04. 04:26:25 -Zeile gefunden. Platine kann ausgetauscht werden. Index: 575 $Platine = "Raspberry unbekannt";
12.04. 04:26:24 -Zeile gefunden. Platine kann ausgetauscht werden. Index: 528 $Platine = "Raspberry Pi 4 Model B Rev 1.1";

12.04. 04:26:24 -Sonoff hat keine USB / Serielle Schnittstelle.
12.04. 04:26:24 -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 148 $GeraeteNummer = "2";

12.04. 04:26:24 -Zeile gefunden. Platine kann ausgetauscht werden. Index: 528 $Platine = "Raspberry Pi 4 Model B Rev 1.1";

12.04. 04:26:24 -Sonoff hat keine USB / Serielle Schnittstelle.
12.04. 04:26:24 -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 148 $GeraeteNummer = "3";

12.04. 04:26:24 -Zeile gefunden. Platine kann ausgetauscht werden. Index: 528 $Platine = "Raspberry Pi 4 Model B Rev 1.1";

12.04. 04:26:24 -Sonoff hat keine USB / Serielle Schnittstelle.
12.04. 04:26:24 -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 148 $GeraeteNummer = "4";


Ab da geht dann nix mehr..
Screenshot_2021-04-12 fu26sol - Grafana.png
Screenshot_2021-04-12 fu26sol - Grafana.png (47.17 KiB) 292 mal betrachtet
sieht man zB, das ein mitternächtliches Backup die DB Werte vom Vortag NICHT wegsichern konnte, warum?

Das Merkwürdige ist...die Solaranzeige lief zB am Freitag völlig normal, das komplette Backup wurde wie immer geschrieben, aber die DB waren Schrott, (also während die solaranzeige normal lief, backup schreiben lassen und das war schon nimmer mit den DB) also Vortagesversion aufgesetzt und mit dieser Tageslücke in den Daten weiter gemacht, das ging jetzt 48h soweit gut, nun wieder das Problem, die Solaranzeige läuft, aber sobald einmal reload gedrückt wurde, baut sich die Seite neu auf und hat das Gedächtnis verloren.
DB restart etc pp was ich im Netz finden konnte half nix und heute war nichtmal mehr die DB aufrufbar, als wäre sie nie vorhanden gewesen..

Ist mir jetzt der PI4 verreckt oder was haben obige Zeilen im .log für tieferen Sinn? Wenn ich älteres backup einspiele, geht er ja wieder, so richtig erklären kann ich mir das nicht

Die Soft lief jetzt ohne grössere Abstürze seit August durch,seufz

gruss
Andreas
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)

Benutzeravatar
Ulrich
Administrator
Beiträge: 2312
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 9 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: Datenbanken weg

Beitrag von Ulrich »

Diese LOG Meldungen kommen von der Datei "multi_usb_init.php" Diese Datei wird nur beim booten des Raspberry einmal durchlaufen. Wenn die Meldungen im laufenden Betrieb kommen, dann muss der cronjob die Datei plötzlich ohne Grund starten. Warum musst Du heraus bekommen. Ich gehe davon aus, dass deine SD-Karte langsam den Geist aufgibt. Es können eigentlich nur Speicherfehler dafür die Ursache sein.
--------------------------------------
Ulrich [Admin]

andreas_n
Beiträge: 347
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 10 Mal
Danksagung erhalten: 13 Mal

Re: Datenbanken weg

Beitrag von andreas_n »

Hallo Ulrich,

in der Nacht wird ausser dem Backup kein weiterer Cronjob gestartet, was mich ja verwundert ist, dass das kpl Backup mit nicht mehr lesbaren DB weggesichert wird, obwohl zum Zeitpunkt der Sicherung die Soft perfekt läuft.

SD Karte ist es nicht,keine verbaut, der PI 4 hing bis heute frühmorgens an einer HDD, jetzt hängt er an einer neuen SSD via USB

Auch die einzeln weggesicherten DB kurz zuvor sind alle nicht mehr lesbar.(6Stück) und warum fallen nur die DB aus, aber sonst keine weiteren files auf der Scheibe...

Notfalls kann ich auf Reserve Pi umklemmen um Hardware Defekte gänzlich auszuschliessen.

Gruss

Andreas
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)

andreas_n
Beiträge: 347
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 10 Mal
Danksagung erhalten: 13 Mal

Re: Datenbanken weg

Beitrag von andreas_n »

Sodele,

neue Erkenntnisse..

die zuvor weggesicherten Datenbanken waren alle ok, scheinbar bringt das komplette Schreiben eines Images den Pi etwas durcheinander und deswegen sind dann keine DB mehr aktiv, bzw weg. Hätte ich neulich 2mal nächtens anstelle eines Images nur die DB zurückgespielt (da wusste ich es halt noch nicht besser), hätte sich der Datenverlust auf die Nachtstunden und somit mehr als verschmerzbar begrenzt.

Hab jetzt umgestellt, es werden stündlich alle Datenbanken auf den Server weggesichert und nur noch bei Bedarf ein komplettes Image.
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)

Benutzeravatar
Ulrich
Administrator
Beiträge: 2312
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 9 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: Datenbanken weg

Beitrag von Ulrich »

Kann es sein, dass die Partition für das Betriebssystem nicht groß genug ist. Eventuell noch auf 8GB steht.
--------------------------------------
Ulrich [Admin]

andreas_n
Beiträge: 347
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 10 Mal
Danksagung erhalten: 13 Mal

Re: Datenbanken weg

Beitrag von andreas_n »

Hallo Ulrich,

auch nicht, ist seit geraumer Zeit schon auf 16GB, die HDD hat 250GB, der Rest mit 234GB wurde so partitioniert, dass ich auch dort backups ablegen konnte und die Pi-Systempartition nicht aufblase und das eigentliche Image noch immer auf ne SD / Stick passen würde
Was mir aber gestern Nacht auffiel als ich die HDD testweise wieder in Betrieb setzen wollte am ReservePI..ich konnte mit dem "abgestürzten" Image keine DB mehr anpacken,bzw neu aufspielen, da kam dann Meldung bei influx restore so ähnlich "..kein Speicherplatz vorhanden.." :?
Das konnte ich aber nicht nachvollziehen weil noch 7,1GB frei sind...
Höchstwahrscheinlich hat der Pi geraume Zeit ins RAM geschrieben bis es voll war und deswegen lief bei dem nächtlichen Image die DB nicht mit, soweit ich weiss, wird das RAM nicht mit erfasst..und dann fehlt logischerweise der Tagessatz..die DB selber stand alone weggesichert, wenige Minuten zuvor, enthielt aber die Daten, richtig erklären kann ichs mir aber nicht

Zur Zeit läuft der MasterPI an einer 120er SSD durch..die DB werden alle 3h weggesichert, die kpl. Images brauch ich nimmer so oft weil ich jetzt die DB selber zurückspielen kann, was auch wieder Schreiblast auf dem Netzwerk reduziert.

Sobald ich sicher bin, dass alles wieder so läuft wie gewohnt, aktiviere ich wieder die HDD.
Plattenfehler und Pi Hardware kann ich eigentlich ausschliessen..ich vermute das irgendwie das RAM voll war und deswegen die Probleme...

Sonnige Grüsse
Andreas
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)

Benutzeravatar
solarfanenrico
Beiträge: 192
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 15 Mal
Danksagung erhalten: 17 Mal

Re: Datenbanken weg

Beitrag von solarfanenrico »

Hallo
was bringt der Konsolenbefehl

Code: Alles auswählen

lsblk
bei mir erscheint folgende Auskunft. Zur Erklärung:
keine MicroSD
eine 32GB Platte mit /boot und den Rest von Grafana als /sda aufgeteilt in /sda1 und /sda2

und einen 32GB USB-Stick als /sdb gemountet für die Backups
lsblk.png
lsblk.png (17.33 KiB) 195 mal betrachtet

Antworten