HUAWEI SUN2000-6KTL M1 keine Daten

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
BePe82
Beiträge: 4
Registriert: Mo 22. Mär 2021, 20:00

HUAWEI SUN2000-6KTL M1 keine Daten

Beitrag von BePe82 »

Guten Abend zusammen,

ich bekomme in der Solaranzeige leider keine Daten.

Hat jemand eine Idee woran es liegen kann?

Folgendes habe ich gemacht.
Image 4.7.2 auf SD geschrieben
Setup aufgerufen und den WR Nr. 56 gewählt.
PI neu gestartet

Fazit keine Daten.

Dann das Update von Ulrich (Mo 19. Apr 2021, 17:47) importiert.

Auch damit wieder keine Daten.

Die Pins 1 und 3 am Wechselrichter und am USB Stick kontrolliert. Dort ist alles in Ordnung.
Pin 1 geht auf A+ und Pin 3 auf B-

Als USB Stick verwende ich den Waveshare Industrial USB to RS485 Converter with original FT232RL 300-921600bps "https://www.amazon.de/gp/product/B082D5 ... UTF8&psc=1"

Mittlerweile weiß ich nicht was ich noch ändern soll.
Muss im WR vielleicht noch was aktiviert werden?

Viele Grüße
BePe

Benutzeravatar
solarfanenrico
Beiträge: 192
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 15 Mal
Danksagung erhalten: 17 Mal

Re: HUAWEI SUN2000-6KTL M1 keine Daten

Beitrag von solarfanenrico »

BePe82 hat geschrieben:
Di 4. Mai 2021, 17:14
Guten Abend zusammen,

ich bekomme in der Solaranzeige leider keine Daten.

Hat jemand eine Idee woran es liegen kann?

Folgendes habe ich gemacht.
Image 4.7.2 auf SD geschrieben
Setup aufgerufen und den WR Nr. 56 gewählt.
PI neu gestartet

Fazit keine Daten.

Dann das Update von Ulrich (Mo 19. Apr 2021, 17:47) importiert.

Auch damit wieder keine Daten.

Die Pins 1 und 3 am Wechselrichter und am USB Stick kontrolliert. Dort ist alles in Ordnung.
Pin 1 geht auf A+ und Pin 3 auf B-

Als USB Stick verwende ich den Waveshare Industrial USB to RS485 Converter with original FT232RL 300-921600bps "https://www.amazon.de/gp/product/B082D5 ... UTF8&psc=1"

Mittlerweile weiß ich nicht was ich noch ändern soll.
Muss im WR vielleicht noch was aktiviert werden?

Viele Grüße
BePe
Hallo,
viel ist es noch nicht, was Du gemacht hast. In dieser Anleitung muß man u.a. noch Datasources im Grafana hinzufügen. Ich denke die Datenbank in Influx könnte schon angelegt sein, aber nachschauen ist besser. Ansonsten viel Erfolg und die Anweisung befolgen.
Enrico
viewtopic.php?f=13&t=161

Benutzeravatar
Ulrich
Administrator
Beiträge: 2311
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 8 Mal
Danksagung erhalten: 109 Mal
Kontaktdaten:

Re: HUAWEI SUN2000-6KTL M1 keine Daten

Beitrag von Ulrich »

Ich würde einen anderen Adapter einmal ausprobieren, einen der auf jeden Fall einen FTDI Chipsatz hat. Die kosten ja nur noch 10,- €
--------------------------------------
Ulrich [Admin]

BePe82
Beiträge: 4
Registriert: Mo 22. Mär 2021, 20:00

Re: HUAWEI SUN2000-6KTL M1 keine Daten

Beitrag von BePe82 »

Vielen Dank für Eure Unterstützung.
Das Problem lag am/im Wechselrichter.

Im Wechselrichter habe ich bei RS485_1 die Komm.adresse von 2 auf 1 geändert.

Nach dem Neustart waren die Daten plötzlich da :-)

BePe82
Beiträge: 4
Registriert: Mo 22. Mär 2021, 20:00

Re: HUAWEI SUN2000-6KTL M1 keine Daten

Beitrag von BePe82 »

Lieder klappt es bei mir doch nicht.
Sobald ich die komm.adresse auf 1 ändere kommen sofort Daten bei Solaranzeige an.

Leider ändert der Wechselrichter nach kurzer Zeit die komm.adresse automatisch wieder zu 2 und dann kommt wieder nicht mehr an.

Hat jemand eine Idee wie ich dauerhaft die komm.adresse ändern kann oder ob ich womöglich noch was anderes im Wechselrichter einstellen muss?

Benutzeravatar
Ulrich
Administrator
Beiträge: 2311
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 8 Mal
Danksagung erhalten: 109 Mal
Kontaktdaten:

Re: HUAWEI SUN2000-6KTL M1 keine Daten

Beitrag von Ulrich »

Ändere einmal in der user.config.php folgenden Eintrag:

Code: Alles auswählen

//  Ethernet Kabelverbindung:          Local Area Network  (LAN)
//  Alle Geräte, die über das LAN angesprochen und ausgelesen werden,
//  oder ein Serial Device Server, wie z.B. der HF2211 oder der Elfin-EW11,
//  dazwischen geschaltet haben, bitte hier IP und Port eintragen und
//  falls erforderlich die Device ID. (Geräteadresse = WR_Adresse)
//  Die Geräte Adresse wird auch manchmal bei RS485 Verbindungen benutzt.
//  -------------------------------------------------------------------
//  Bitte die Daten aus dem Gerät übernehmen
//
$WR_IP = "0.0.0.0";    //  Keine führenden Nullen!  67.xx Ja!, 067.xx Nein!
$WR_Port = "12345";
$WR_Adresse = "1";
Ändere bitte $WR_Adresse = "2";

Danach muss kein reboot gemacht werden, nur 1-2 Minuten warten.
--------------------------------------
Ulrich [Admin]

BePe82
Beiträge: 4
Registriert: Mo 22. Mär 2021, 20:00

Re: HUAWEI SUN2000-6KTL M1 keine Daten

Beitrag von BePe82 »

Jetzt kommen die Daten wieder. :D

Vielen dank.

Mal schauen ob es jetzt auch dabei bleibt.

Antworten