InfiniSolar Hybrid 10kW Erstinstallation klappt nicht

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
michu
Beiträge: 6
Registriert: Sa 18. Dez 2021, 20:22

InfiniSolar Hybrid 10kW Erstinstallation klappt nicht

Beitrag von michu »

Hi
Leider bringe ich die Verbindung zu meinem grünen 10kW InfiniSolar Hybrid Wechselrichter nicht zustande.
Die Installation auf dem Raspberry 3 hat gut funktioniert. Was mir aufgefallen ist, ist dass die Konfig des WR's im Setup nicht auf anhieb klappte.
Beim nachschauen in der user.config.php Datei, stand beim Regler wieder die Zahl 0.
Ich habe auch noch die user.config,php~ und eine user.config.neu.php gefunden.
Schlussendlich konnte ich beim Regler die Nr. 24 eintragen.
Nach dem Reboot kommen jedoch auch nach Stunden noch keine Daten über das USB Kabel.
Was kann ich noch testen?
Grüsse M

Benutzeravatar
Ulrich
Administrator
Beiträge: 2990
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 38 Mal
Danksagung erhalten: 193 Mal
Kontaktdaten:

Re: InfiniSolar Hybrid 10kW Erstinstallation klappt nicht

Beitrag von Ulrich »

Hast Du eventuell die Image Version 4.7.4? Die ist defekt. Falls ja, bitte 4.7.5 noch einmal herunterladen.
--------------------------------------
Ulrich [Admin]

michu
Beiträge: 6
Registriert: Sa 18. Dez 2021, 20:22

Re: InfiniSolar Hybrid 10kW Erstinstallation klappt nicht

Beitrag von michu »

Ja ich hatte diese Version. Jetzt habe ich 4.7.5 installiert.
In Grafana finde ich jedoch nur das Infini-V-Serie Dashboard.
Kann es sein, dass ich deswegen keine Daten sehe?
wünsche schöne Weihnachten

Benutzeravatar
Ulrich
Administrator
Beiträge: 2990
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 38 Mal
Danksagung erhalten: 193 Mal
Kontaktdaten:

Re: InfiniSolar Hybrid 10kW Erstinstallation klappt nicht

Beitrag von Ulrich »

Es muss Regler = 24 eingestellt werden und das Dashboard heißt "Wechselrichter Hybrid 1 Phase"
--------------------------------------
Ulrich [Admin]

trilobyte
Beiträge: 23
Registriert: Do 21. Jan 2021, 22:44

Re: InfiniSolar Hybrid 10kW Erstinstallation klappt nicht

Beitrag von trilobyte »

sollte da nicht der regler 9 gewählt werden?

Wechselrichter der MPI Hybrid 10kW 3-Phasen und Baugleiche [Regler 9]

der 10kw infini sollte baugleich sein mit dem MPI Hybrid 10k?

gruss
siegi

michu
Beiträge: 6
Registriert: Sa 18. Dez 2021, 20:22

Re: InfiniSolar Hybrid 10kW Erstinstallation klappt nicht

Beitrag von michu »

Leider schaffen es noch immer keine Daten bis ins Grafana Dashboard.
Ich habe bereits ein paar Regler versucht. Von 8 über 24 zu 9.

Im PHP Log kommt folgendes raus:
INV Wechselrichter
[25-Dec-2021 23:32:49 Europe/Berlin] PHP Notice: Undefined offset: 2 in /var/www/html/usb_init.php on line 121
[26-Dec-2021 19:57:13 Europe/Berlin] PHP Warning: fopen(): Filename cannot be empty in /var/www/html/phpinc/funktionen.inc.php on line 10
Solaranzeige log dazu:
27.12. 20:57:19 -Regler: 8
27.12. 20:57:19 -Regler erkannt: /dev/hidraw3
27.12. 20:57:19 -Device: /dev/hidraw3 wird in die user.config.php eingetragen.
27.12. 20:57:19 -Zeile gefunden. USB Device kann ausgetauscht werden. Index: 588 $USBRegler = "/dev/hidraw3";
27.12. 20:57:19 -Zeile gefunden. USB Device kann ausgetauscht werden. Index: 589 // $USBWechselrichter = "/dev/ttyUSB1"; // wird nicht mehr gebraucht.
27.12. 20:57:19 -Zeile gefunden. Raspberry Modell kann eingetragen werden. Index: 608 $Platine = "Raspberry Pi 3 Model B Rev 1.2";
27.12. 20:58:13 |---------------- Start infini_v_serie.php -------------------
27.12. 20:58:27 -
27.12. 20:59:24 -InfluxDB => [ Netz Spannung=,Frequenz= 1640635103
AC Spannung=,Frequenz=,Scheinleistung=,Wirkleistung=,Ausgangslast= 1640635103
Batterie Spannung=,Spannung_WR=,Ladestrom=,Kapazitaet=,Entladestrom= 1640635103
PV Spannung=,Leistung=0,Spannung1=,Spannung2=,Leistung1=,Leistung2= 1640635103
Service Laststatus=0,Ladestatus=,Ladestatus2=,Stromrichtung_Batt=,Stromrichtung_WR=,Stromrichtung_Netz=,Modus=,Device_Status=0,Temperatur=,MPPT1_Temperatur=,MPPT2_Temperatur=,Fehlercode=,Warnungen= 1640635103
Summen Wh_Heute=0 1640635103
]
27.12. 20:59:24 -Daten nicht zur lokalen InfluxDB gesendet! info: array (
'url' => 'http://localhost/write?db=solar&precision=s',
'content_type' => 'application/json',
'http_code' => 400,
uvm...

---------------
Infini V Serie 1 Phase
[27-Dec-2021 22:39:11 Europe/Berlin] PHP Notice: Undefined index: Solarspannung1 in /var/www/html/phpinc/funktionen.inc.php on line 842
[27-Dec-2021 22:39:11 Europe/Berlin] PHP Notice: Undefined index: WR_Stromrichtung in /var/www/html/phpinc/funktionen.inc.php on line 853
[27-Dec-2021 22:39:11 Europe/Berlin] PHP Notice: Undefined index: Fehlercode in /var/www/html/phpinc/funktionen.inc.php on line 860
[27-Dec-2021 22:39:11 Europe/Berlin] PHP Notice: Undefined index: Warnungen in /var/www/html/phpinc/funktionen.inc.php on line 861
[27-Dec-2021 22:39:21 Europe/Berlin] PHP Warning: sleep(): Number of seconds must be greater than or equal to 0 in /var/www/html/infini_v_serie.php on line 419
27.12. 00:16:18 -Regler: 24
27.12. 00:16:18 -Regler erkannt: /dev/hidraw3
27.12. 00:16:18 -Device: /dev/hidraw3 wird in die user.config.php eingetragen.
27.12. 00:16:18 -Zeile gefunden. USB Device kann ausgetauscht werden. Index: 588 $USBRegler = "/dev/ttyUSB0";
27.12. 00:16:18 -Zeile gefunden. USB Device kann ausgetauscht werden. Index: 589 // $USBWechselrichter = "/dev/ttyUSB1"; // wird nicht mehr gebraucht.
27.12. 00:16:18 -Zeile gefunden. Raspberry Modell kann eingetragen werden. Index: 608 $Platine = "Raspberry Pi 3 Model B Rev 1.2";

27.12. 00:17:13 |-------------- Start infini_p16.php ------------------------
27.12. 00:18:29 !! -Keine gültigen Daten empfangen.
27.12. 00:18:29 |-------------- Stop infini_p16.php -----------------------

------------
MPI Hybrid 10kW 3Phasen
[27-Dec-2021 22:41:17 Europe/Berlin] PHP Notice: Undefined offset: 2 in /var/www/html/usb_init.php on line 120
[27-Dec-2021 22:41:17 Europe/Berlin] PHP Notice: Undefined offset: 2 in /var/www/html/usb_init.php on line 121

Solaranzeigelog:
7.12. 22:41:17 -Regler: 9
27.12. 22:41:17 -Regler erkannt: /dev/hidraw3
27.12. 22:41:17 -Device: /dev/hidraw3 wird in die user.config.php eingetragen.
27.12. 22:41:17 -Zeile gefunden. USB Device kann ausgetauscht werden. Index: 588 $USBRegler = "/dev/hidraw3";
27.12. 22:41:17 -Zeile gefunden. USB Device kann ausgetauscht werden. Index: 589 // $USBWechselrichter = "/dev/ttyUSB1"; // wird nicht mehr gebraucht.
27.12. 22:41:17 -Zeile gefunden. Raspberry Modell kann eingetragen werden. Index: 608 $Platine = "Raspberry Pi 3 Model B Rev 1.2";

27.12. 22:42:13 |---------------- Start mpi_3phasen_serie.php ---------------
27.12. 22:42:16 -Fehlercode. 00 Warnung: 1
27.12. 22:42:17 * -Daten zur lokalen InfluxDB [ solar ] gesendet.
27.12. 22:42:45 -Fehlercode. 00 Warnung: 1
27.12. 22:42:45 * -Daten zur lokalen InfluxDB [ solar ] gesendet.
27.12. 22:43:07 -OK. Datenübertragung erfolgreich.
27.12. 22:43:07 |---------------- Stop mpi_3phasen_serie.php ---------------

Sry sind etwas gar viele Zeilen.
Soll ich mal alle Regler durchgehen XD
Der WR sendet Daten. Auf meiner Clientsoftware funzt alles.

Wie könnte ich besser vorgehen? Bin für jeden Hinweis dankbar!
M

Benutzeravatar
Ulrich
Administrator
Beiträge: 2990
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 38 Mal
Danksagung erhalten: 193 Mal
Kontaktdaten:

Re: InfiniSolar Hybrid 10kW Erstinstallation klappt nicht

Beitrag von Ulrich »

Der letzte Log Eintrag sieht doch perfekt aus. ( Regler = 9 ) Die Daten werden ausgelesen und in die Datenbank "solar" gespeichert.

Und hier ist dein Fehler. Wenn du die Datenbank umbenennst, dann solltest du auch wissen, was du machst. Alle Standard Dashboards gehen davon aus, dass du den Standard-Datenbanknamen "solaranzeige" auch benutzt.

Es gibt jetzt 2 Möglichkeiten. Entweder du nutzt die Standard-Datenbank "solaranzeige" oder du gehts der Installationsanleitung der Multi-Regler-Version nach, dort steht wie man das Dashboard auf einen anderen Datenbanknamen "umbiegt".
--------------------------------------
Ulrich [Admin]

michu
Beiträge: 6
Registriert: Sa 18. Dez 2021, 20:22

Re: InfiniSolar Hybrid 10kW Erstinstallation klappt nicht

Beitrag von michu »

Super Danke
Wenn man keine Fehler macht, klappt plötzlich alles wunderbar!

Jetzt kann ich mich an die Daly BMS Anbindung wagen ;-)

Antworten