Modbus-Abfrage via LAN quälend langsam

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

solarfanenrico
Beiträge: 622
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 30 Mal
Danksagung erhalten: 38 Mal

Re: Modbus-Abfrage via LAN quälend langsam

Beitrag von solarfanenrico »

anraso hat geschrieben:
Mi 20. Apr 2022, 19:10
Daher eben mein Wunsch, die Abfragen zusammenzufassen. Ich denke, dann wird die Abfrage auch nur noch ein paar Sekunden statt eine Minute dauern.
Die Zeit vergeht ja nicht mit php-Rechenzeit sondern mit dem zigfachen Warten auf den WR.
schon, aber 15 Skunden für zwei Growatts über php oder nur eine mit java. Da kann sich jeder selbst seine Hochrechnung generieren.
Es ist ja kein "muß", sondern ein Angebot.
Einige solaranzeige.de-Funktionen nutze ich parallel auf einem 2.Raspi.
Ich bin jedoch froh, nicht nur an eine Ausleseroutine gebunden zu sein. Die Mischung machts.

Benutzeravatar
Ulrich
Administrator
Beiträge: 3567
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 59 Mal
Danksagung erhalten: 290 Mal
Kontaktdaten:

Re: Modbus-Abfrage via LAN quälend langsam

Beitrag von Ulrich »

Hallo Enrico,

bitte übertreibe es nicht.

Vielen Dank.
--------------------------------------
Ulrich [Admin]

solarfanenrico
Beiträge: 622
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 30 Mal
Danksagung erhalten: 38 Mal

Re: Modbus-Abfrage via LAN quälend langsam

Beitrag von solarfanenrico »

Ulrich hat geschrieben:
Mi 20. Apr 2022, 22:24
Hallo Enrico,

bitte übertreibe es nicht.

Vielen Dank.
Hallo Ulrich,
verstoße ich gegen irgendwelche Regeln? Dann solltest Du mich sperren.
Ich fände es jedoch besser, wenn sich etwas weiterentwickelt.
Enrico

Benutzeravatar
Ulrich
Administrator
Beiträge: 3567
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 59 Mal
Danksagung erhalten: 290 Mal
Kontaktdaten:

Re: Modbus-Abfrage via LAN quälend langsam

Beitrag von Ulrich »

Nach einem Update ist die MODBUS Abfrage bei einem Huawei mit LAN Anschluss jetzt auch "normal schnell"
--------------------------------------
Ulrich [Admin]

Modellbauhütte
Beiträge: 101
Registriert: So 20. Feb 2022, 15:12
Hat sich bedankt: 17 Mal
Danksagung erhalten: 10 Mal

Re: Modbus-Abfrage via LAN quälend langsam

Beitrag von Modellbauhütte »

Ulrich hat geschrieben:
Di 26. Apr 2022, 16:34
Nach einem Update ist die MODBUS Abfrage bei einem Huawei mit LAN Anschluss jetzt auch "normal schnell"
Moin,
gibt es ein Windows-Tool, mit dem man die MODBUS-Abfrage gut testen kann?

Oder wie bekomme ich am besten raus, wie ich meinen SDongle richtig ansprechen muss/kann?

Ich habe installiert:
Modbus Poll
Modbus TCP client

Gruß,
Moritz

Modellbauhütte
Beiträge: 101
Registriert: So 20. Feb 2022, 15:12
Hat sich bedankt: 17 Mal
Danksagung erhalten: 10 Mal

Re: Modbus-Abfrage via LAN quälend langsam

Beitrag von Modellbauhütte »

anraso hat geschrieben:
Sa 16. Apr 2022, 18:49
Hallo,
ich habe einen Huawei WR und nutze die die MODBUS LAN -Abfrage via Regler -62-.
Bis das huawei_Lan.php durchgelaufen ist dauert es fast eine Minute.
Was dauert an der Abfrage eigentlich so lange?
Wenn ich das auf der Konsole ausführe, passiert gar nichts:

root@solaranzeige:~# /usr/bin/php7.3 /var/www/html/huawei_LAN.php
root@solaranzeige:~#

Gruß,
Moritz

Benutzeravatar
Ulrich
Administrator
Beiträge: 3567
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 59 Mal
Danksagung erhalten: 290 Mal
Kontaktdaten:

Re: Modbus-Abfrage via LAN quälend langsam

Beitrag von Ulrich »

Die Abfrage ist jetzt noch einmal überarbeitet. Wenn Ihr jetzt einen Solaranzeigen Update macht, sollte die Abfrage mit dem sDongle schneller und stabiler laufen als bisher.
--------------------------------------
Ulrich [Admin]

Modellbauhütte
Beiträge: 101
Registriert: So 20. Feb 2022, 15:12
Hat sich bedankt: 17 Mal
Danksagung erhalten: 10 Mal

Re: Modbus-Abfrage via LAN quälend langsam

Beitrag von Modellbauhütte »

Moin Ulrich,
vielen Dank, leider bekomme ich weiterhin nur "no data" gemeldet.

Also falls Du Interesse hast, wir können gerne mal eine TeamViewer-Session machen.

Ich weiß im Moment leider nicht, wo ich ansetzen soll, da ich nicht weiß, wo und ob die daten richtig zur Verfügung gestellt werden.

Wie soll eigentlich die MODBUS Datenrate sein, 9600 oder 19200?

Hier der letzte Solaranzeige-LOG-Eintrag:

29.04. 15:24:02 |---------------- Start huawei_LAN.php -----------------------------
29.04. 15:24:04 > -Gerätetyp: SUN2000-6KTL-M1 Modell ID: 427
29.04. 15:24:08 > -Alarm 1 Bits: 0000000000000000
29.04. 15:24:11 * -Daten zur lokalen InfluxDB [ solaranzeige2 ] gesendet.
29.04. 15:24:11 -OK. Datenübertragung erfolgreich.
29.04. 15:24:11 |---------------- Stop huawei_LAN.php ---------------------------

Gruß,
Moritz

Modellbauhütte
Beiträge: 101
Registriert: So 20. Feb 2022, 15:12
Hat sich bedankt: 17 Mal
Danksagung erhalten: 10 Mal

Re: Modbus-Abfrage via LAN quälend langsam

Beitrag von Modellbauhütte »

Moin,
danke an Ulrich, das Problem war, dass Grafana die datenbank nicht kannte, die ich angegeben hatte. Das war mir noch nicht klar. Ich war ja auch noch nicht in die Grafana Admin-Oberfläche gekommen.

Das funktioniert jetzt:
2022-04-29 17_32_32-Huawei Wechselrichter M1 - Grafana.png
Gruß,
Moritz

Antworten