AEconversion INV350-60EU RS485 keine Daten in Solaranzeige

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

CH3795
Beiträge: 3
Registriert: Do 21. Jul 2022, 15:10

AEconversion INV350-60EU RS485 keine Daten in Solaranzeige

Beitrag von CH3795 »

Hallo zusammen,

ich bekomme in der Solaranzeige keine Daten von einem AEconversion INV350-60EU RS485.

Der Wechselrichter kann jedoch problemlos über die Original Software "AEsolar" von AEconversion (in Verbindung mit einem CTI USB RS485 Nano) ausgelesen werden.

Was mache ich falsch?
In der Konfiguration der Solaranzeige, muss ich doch lediglich den Reglertyp auf "5" stellen und die Seriennummer des AEconversion Wechselrichters angeben?

Über Hilfe würde ich mich freuen.
Vielen Dank.

Gruß
Christian

Benutzeravatar
Ulrich
Administrator
Beiträge: 3988
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 92 Mal
Danksagung erhalten: 527 Mal
Kontaktdaten:

Re: AEconversion INV350-60EU RS485 keine Daten in Solaranzeige

Beitrag von Ulrich »

Der RS485 Adapter muss ein FTDI Chipsatz besitzen, sonst fehlt eventuell der Treiber.
---------------------------------------
Ulrich . . . . . . . . [Projektinhaber]

CH3795
Beiträge: 3
Registriert: Do 21. Jul 2022, 15:10

Re: AEconversion INV350-60EU RS485 keine Daten in Solaranzeige

Beitrag von CH3795 »

Hallo Ulrich,

Danke für die schnelle Antwort.

Habe mich bei der Auswahl eines USB RS485 Konverters, an Tipps und Tricks (https://solaranzeige.de/wordpress/?page_id=114)
gehalten.
Der Chipsatz müsste dementsprechend richtig sein?

Der Konverter wird auch erkannt. Mit dem Kommando lsusb habe ich es überprüft.

Veränderungen am USBDevice in der Konfiguration der Solaranzeige brachten leider auch keinen Erfolg.

Gruß
Christian

Benutzeravatar
Ulrich
Administrator
Beiträge: 3988
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 92 Mal
Danksagung erhalten: 527 Mal
Kontaktdaten:

Re: AEconversion INV350-60EU RS485 keine Daten in Solaranzeige

Beitrag von Ulrich »

Kann es sein, dass du die serielle Geschwindigkeit im Wechselrichter mit dem Windows Programm verändert hast? Sie muss auf dem Default Wert von 9600 Baud stehen.
---------------------------------------
Ulrich . . . . . . . . [Projektinhaber]

CH3795
Beiträge: 3
Registriert: Do 21. Jul 2022, 15:10

Re: AEconversion INV350-60EU RS485 keine Daten in Solaranzeige

Beitrag von CH3795 »

Habe nachgeschaut, die Baudrate steht auf 9600.

Benutzeravatar
Ulrich
Administrator
Beiträge: 3988
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 92 Mal
Danksagung erhalten: 527 Mal
Kontaktdaten:

Re: AEconversion INV350-60EU RS485 keine Daten in Solaranzeige

Beitrag von Ulrich »

Was steht denn in der LOG Datei? /var/www/log/solaranzeige.log
---------------------------------------
Ulrich . . . . . . . . [Projektinhaber]

hbe04
Beiträge: 10
Registriert: Mi 16. Jun 2021, 12:48

Re: AEconversion INV350-60EU RS485 keine Daten in Solaranzeige

Beitrag von hbe04 »

Guten Abend allerseits,
versuche mich auch gerade mit der Einbindung eines AEConversion (INV500 über PLC-RS485. Aktuell mit einem USB-RS485 Adapter mit FDTI Chipsatz (FT232). Dieser funktioniert mit WIN7 und der AEConversion SW einwandfrei, damit konnte ich auch die Daten des WR auslesen z.B. die Seriennummer. Das Setup auf einem Raspberry Pi 3 habe ich versucht sorgfältig auzuführen. Leider weigert sich die Anzeige Daten preiszugeben und schreibt wohl auch keine Daten in die Datenbank. Das Log-File habe ich angehängt. Es zeigt auch erste misslungene Versuche mit einem USB-RS485 Adapter mit CH341 Chipsatz. Der WR lief zum Zeitpunkt der letzten Einträge, check mit WIN PC war positiv... Was geht da schief, gibt es Rast?
Dateianhänge
solaranzeige.log
(585.18 KiB) 40-mal heruntergeladen

CK66
Beiträge: 14
Registriert: Di 23. Mär 2021, 18:24

Re: AEconversion INV350-60EU RS485 keine Daten in Solaranzeige

Beitrag von CK66 »

Hallo hbe04

Schau mal hier viewtopic.php?p=15461#p15461

Bei mir ging es um die Leistungsregelung eines INV500 über ein Gateway.
Vielleicht hilft es dir trotzdem.

Interessehalber, welche Win-Software hast du installiert?
Bei mir ist "die" immer abgestürzt, bzw. hat keinen Regler gefunden.

Christian

Benutzeravatar
Ulrich
Administrator
Beiträge: 3988
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 92 Mal
Danksagung erhalten: 527 Mal
Kontaktdaten:

Re: AEconversion INV350-60EU RS485 keine Daten in Solaranzeige

Beitrag von Ulrich »

2 =>
array (
'Device' => '0x7523',
'File' => '/dev/ttyUSB0',
'Vendor' => 'usb 0x1a86 "QinHeng Electronics"',
'Model' => 'QinHeng Electronics HL-340 USB-Serial adapter',
'Driver Modules' => 'usbserial',
'Driver' => 'ch341',
),
Das ist kein Adapter mit FTDI Chipsatz. Der müsste so aussehen:

Code: Alles auswählen

  2 =>
  array (
    'File' => '/dev/ttyUSB0',
    'Vendor' => 'usb 0x0403 "Future Technology Devices International, Ltd"',
    'Device' => '0x6001',
    'Model' => 'Future Technology Devices International 8-bit FIFO',
    'Driver Modules' => 'usbserial, ftdi_sio',
    'Driver' => 'ftdi_sio',
  ),
---------------------------------------
Ulrich . . . . . . . . [Projektinhaber]

hbe04
Beiträge: 10
Registriert: Mi 16. Jun 2021, 12:48

Re: AEconversion INV350-60EU RS485 keine Daten in Solaranzeige

Beitrag von hbe04 »

Das ist richtig - war der erste Versuch mit "unpassendem" Chipsatz.
Weiter unten im Log-File (ab 20.08. 13:49:33 -USB Devices: ) ist der aktuelle eingetragen:

2 =>
array (
'Device' => '0x6001',
'File' => '/dev/ttyUSB0',
'Vendor' => 'usb 0x0403 "Future Technology Devices International, Ltd"',
'Model' => 'Future Technology Devices International FT232 Serial (UART) IC',
'Driver Modules' => 'usbserial, ftdi_sio',
'Driver' => 'ftdi_sio',
),
3 =>
array (
'Device' => '0x2514',
),

Der Eintrag zeigt einen FTDI Chipsatz, aber stimmt nicht 100% mit Deinem Hinweis überein.
Im weiteren Verlauf des Log-Files dann die Verweigerung der Kommunikation.

Antworten