Raspberry Pi Modell B, Webserver startet nicht

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung
Benutzeravatar
Ulrich
Administrator
Beiträge: 684
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Raspberry Pi Modell B, Webserver startet nicht

Beitrag von Ulrich » So 12. Mai 2019, 09:51

Das macht mir Sorgen, da ich den Fehler bis jetzt noch nicht produzieren konnte.

Es soll also bei Raspberry 2B, 3B und auch bei 3B+ auftreten und die Image Version 4.2.9 sowie auch 4.3.0 betreffen. Der Grafana Aufruf über Port 3000 soll lokal und remote nicht funktionieren.

Mir fallen folgende Fehlerquellen ein:
  1. Im setup Script /solaranzeige/setup werden ziemlich am Anfang alle ADDON's von Grafana Upgedated.
    "sudo grafana-cli plugins update-all" Bitte diese Zeile deaktivieren oder rauslöschen. Eventuell macht so ein Grafana Update Probleme
  2. Nach dem Aufspielen des Images wird ja nur ein kleiner Teil der SD-Karte / USB-Stick benutzt. Kann es daran liegen, dass der Fehler auftritt, wenn man die SD-Karte nicht ganz zur Verfügung stellt (Mind. 16 GB)
  3. Es ist Grafana 6.0.1 heraus gekommen. Passiert bei dem ADDON Update eventuelle etwas?
  4. Hat es etwas mit der Raspberry Firmware zu tun?
  5. Ist das Netzteil zu schwach?
Bitte den Update von den Grafana ADDONS aus der setup Datei einmal löschen und ein Resize auf den SD-Karte / USB-Stick machen, ob der Fehler damit behoben werden kann. Eventuell auch die Firmware des Raspberry erneuern mit dem Befehl "sudo rpi-update". Es könnte natürlich auch sein, dass es gerade umgekehrt ist, dass Ihr einen Firmwareupdate gemacht habt und Grafana deshalb nicht funktioniert.

Das der Raspberry zu schwach ist kann nicht sein, da das Image auch auf 2B und noch kleineren Platinen läuft.

Der Fehler schein ja nicht so verbreitet zu sein, da sich bis jetzt nur 2 Mitglieder gemeldet haben.
Könnte Ihr eventuell etwas genauer schreiben, was Ihr genau installiert habt. Auf SD-Karte oder USB-Stick?
--------------------------------------
Ulrich [Admin]

mafe68
Beiträge: 51
Registriert: Mo 4. Mär 2019, 21:18

Re: Raspberry Pi Modell B, Webserver startet nicht

Beitrag von mafe68 » So 12. Mai 2019, 10:14

Morgen Ulrich!

Ich habe hier mit einem RPi B+ der 1. Generation getestet, dass heißt der mit den 512RAM noch. Nicht das hier was falsch verstanden wird. Werde dann mal einen RPi 3 nehmen und mit dem testet.
Lg. Mario

fireblade900rr
Beiträge: 8
Registriert: Di 12. Jun 2018, 11:00

Re: Raspberry Pi Modell B, Webserver startet nicht

Beitrag von fireblade900rr » So 12. Mai 2019, 11:40

Morgen

Wie bereits mafe68 sagte handelt es sich bei mir sogar um den Raspberry Pi Model B 512MB RAM, also keine Sorge was Raspi 2 oder 3 betrifft !

Habe das Firmwareupdate durchgeführt und die resize durchgeführt, keine Änderung.

Leider habe ich heute keine Zeit für weitere Tests, aber ich bleibe dran.

Grüße

fireblade900rr
Beiträge: 8
Registriert: Di 12. Jun 2018, 11:00

Re: Raspberry Pi Modell B, Webserver startet nicht

Beitrag von fireblade900rr » Mo 13. Mai 2019, 11:01

So, mal probiert Update Grafana auf V 6.0.1, kein Erfolg.

Portscanner sagt auch nichts auf Port 3000

Dienst Ausführlich
HTTP 403 - Forbidden (lighttpd 1.4.45)
Port 22 (TCP)
Port 1883 (TCP) mqtt
Port 8086 (TCP)

fireblade900rr
Beiträge: 8
Registriert: Di 12. Jun 2018, 11:00

Re: Raspberry Pi Modell B, Webserver startet nicht

Beitrag von fireblade900rr » Mo 13. Mai 2019, 11:40

Irgendwas stimmt mit grafana nicht. Aus der daemon.log

May 13 11:20:00 solaranzeige systemd[1]: Started Grafana instance.
May 13 11:20:00 solaranzeige systemd[1]: Starting Mosquitto MQTT v3.1/v3.1.1 Broker...
May 13 11:20:01 solaranzeige systemd[1]: Started InfluxDB is an open-source, distributed, time series database.
May 13 11:20:01 solaranzeige dhcpcd[442]: eth0: no useable IA found in lease
May 13 11:20:01 solaranzeige dhcpcd[442]: eth0: dhcp6_readlease: /var/lib/dhcpcd5/dhcpcd-eth0.lease6: No such process
May 13 11:20:01 solaranzeige dhcpcd[442]: eth0: soliciting a DHCPv6 lease
May 13 11:20:01 solaranzeige dhcpcd[442]: eth0: DHCPv6 REPLY: in stateless mode
May 13 11:20:01 solaranzeige systemd[1]: Started Permit User Sessions.
May 13 11:20:01 solaranzeige systemd[1]: Started /etc/rc.local Compatibility.
May 13 11:20:01 solaranzeige systemd[1]: grafana-server.service: Main process exited, code=killed, status=4/ILL
May 13 11:20:01 solaranzeige systemd[1]: grafana-server.service: Unit entered failed state.
May 13 11:20:01 solaranzeige systemd[1]: grafana-server.service: Failed with result 'signal'.
May 13 11:20:02 solaranzeige systemd[1]: Started Mosquitto MQTT v3.1/v3.1.1 Broker.
May 13 11:20:02 solaranzeige systemd[1]: grafana-server.service: Service hold-off time over, scheduling restart.

fireblade900rr
Beiträge: 8
Registriert: Di 12. Jun 2018, 11:00

Re: Raspberry Pi Modell B, Webserver startet nicht

Beitrag von fireblade900rr » Di 14. Mai 2019, 20:56

Ich hab nun die SD Karte in einen Raspberry 3B Plus gesteckt, siehe da läuft sofort. Vielleicht ist der Raspberry B doch zu schwach dafür.

Meinen USR-TCP232-304 konnte ich auch ohne Probleme mit dem Tracer "aktivieren".

Läuft soweit ganz gut.

Ich weiß nicht ob es sich lohnt da nun noch den Fehler zu suchen warm grafana immer wieder beendet wird.

mafe68
Beiträge: 51
Registriert: Mo 4. Mär 2019, 21:18

Re: Raspberry Pi Modell B, Webserver startet nicht

Beitrag von mafe68 » Di 14. Mai 2019, 21:17

Ich habe auch mal mit einem RPi 3 getestet und da ging es auch. Kann das auch nur bestätigen.
Lg. Mario

Antworten