Keine Daten mehr nach Update

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
ba0547
Beiträge: 57
Registriert: Do 23. Jan 2020, 21:03
Wohnort: Baunach
Hat sich bedankt: 4 Mal
Danksagung erhalten: 5 Mal

Keine Daten mehr nach Update

Beitrag von ba0547 »

Hallo,

habe ein Problem mit der Darstellung der Daten meines Hybrid Wechselrichters. Die Logdatei schaut gut aus, verstehe allerdings nicht was die Zeile mit dem USB Port bedeutet.

24.04. 14:07:44 -Die seriellen Schnittstellen werden initialisiert.
24.04. 14:07:44 -Device: /dev/hidraw0 Keine USB / Serielle Schnittstelle.
24.04. 14:07:44 -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 109 $GeraeteNummer = "1";

24.04. 14:07:44 -Zeile gefunden. Raspberry Modell kann eingetragen werden. Index: 467 $Platine = "Raspberry Pi 3 Model B Rev 1.2";

24.04. 14:07:44 -Device: Ethernet Keine USB / Serielle Schnittstelle.
24.04. 14:07:44 -Zeile gefunden. Gerätenummer kann ausgetauscht werden. Index: 109 $GeraeteNummer = "3";

24.04. 14:07:44 -Zeile gefunden. Raspberry Modell kann eingetragen werden. Index: 464 $Platine = "Raspberry Pi 3 Model B Rev 1.2";

24.04. 14:07:44 -Es handelt sich um ein 32 Bit System.
24.04. 14:08:01 -Multi Regler Auslesen [Start].
24.04. 14:08:01 -Verarbeitung von: '1.user.config.php' Regler: 9
24.04. 14:08:01 |---------------- Start mpi_3phasen_serie.php ---------------
24.04. 14:08:01 o -Keine Verbindung möglich. Ausgang! ^P003PI
24.04. 14:08:01 |---------------- Stop mpi_3phasen_serie.php ---------------
24.04. 14:08:02 -Verarbeitung von: '3.user.config.php' Regler: 47
24.04. 14:08:02 |-------------------- Start phoenix_wb.php ---------------------
24.04. 14:08:22 -MQTT Daten zum [ localhost ] senden.
24.04. 14:08:22 -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB Wandkiste gesendet! Curl ErrNo. 7
24.04. 14:08:22 -InfluxDB Fehler -> nochmal versuchen.
24.04. 14:08:22 -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB Wandkiste gesendet! Curl ErrNo. 7
24.04. 14:08:22 -InfluxDB Fehler -> nochmal versuchen.
24.04. 14:08:22 -Multi-Regler-Ausgang. -13
24.04. 14:08:22 -OK. Datenübertragung erfolgreich.
24.04. 14:08:22 |-------------------- Stop phoenix_wb.php ---------------------
24.04. 14:08:23 MQT-MQTT Daten zum Broker gesendet bzw. vom Broker empfangen. Adresse: localhost Port: 1883
24.04. 14:08:24 -Multi Regler Auslesen [Stop].

24.04. 14:09:01 -Multi Regler Auslesen [Start].
24.04. 14:09:01 -Verarbeitung von: '1.user.config.php' Regler: 9
24.04. 14:09:02 |---------------- Start mpi_3phasen_serie.php ---------------
24.04. 14:09:07 -MQTT Daten zum [ localhost ] senden.
24.04. 14:09:07 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
24.04. 14:09:07 -Multi-Regler-Ausgang. 4
24.04. 14:09:08 MQT-MQTT Daten zum Broker gesendet bzw. vom Broker empfangen. Adresse: localhost Port: 1883
24.04. 14:09:11 -OK. Datenübertragung erfolgreich.
24.04. 14:09:11 |---------------- Stop mpi_3phasen_serie.php ---------------
24.04. 14:09:12 -Verarbeitung von: '3.user.config.php' Regler: 47
24.04. 14:09:12 |-------------------- Start phoenix_wb.php ---------------------
24.04. 14:09:21 -MQTT Daten zum [ localhost ] senden.
24.04. 14:09:21 * -Daten zur lokalen InfluxDB [ Wandkiste ] gesendet.
24.04. 14:09:21 -Multi-Regler-Ausgang. -2
24.04. 14:09:21 -OK. Datenübertragung erfolgreich.
24.04. 14:09:21 |-------------------- Stop phoenix_wb.php ---------------------
24.04. 14:09:21 MQT-MQTT Daten zum Broker gesendet bzw. vom Broker empfangen. Adresse: localhost Port: 1883
24.04. 14:09:22 -Multi Regler Auslesen [Stop].

Daten scheinen in der Datenbank anzukommen. Allerdings erscheint in dem "Dasboard" nichts.

Software update durchgeführt von 4.8.0f nach 4.8.3a:

Software Version 4.8.0f [32Bit] update November 2022

Software Version 4.8.3a [32Bit] update März 2023
Last login: Mon Apr 24 14:09:33 2023 from 192.168.2.10

Habe nach dem Fehler hier gesucht allerdings keine passende Lösung gefunden.
Dateianhänge
Bildschirmfoto zu 2023-04-24 19-04-00.png

Benutzeravatar
Ulrich
Administrator
Beiträge: 5687
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 159 Mal
Danksagung erhalten: 902 Mal
Kontaktdaten:

Re: Keine Daten mehr nach Update

Beitrag von Ulrich »

Du hast deine Datenbank "Wandkiste" genannt. In allen Standard Dashboards wird davon ausgegangen, dass die Datenbank "solaranzeige" genannt ist. Das ist dein Problem. Am einfachsten löst man so etwas, wenn man das Dashboard exportiert und wieder importiert. In diesem Fall wird man nach dem Datenbanknamen gefragt und mann kann den geänderten Namen angeben. In der Multi-Regler-Installationsanleitung ist das genau beschrieben.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

ba0547
Beiträge: 57
Registriert: Do 23. Jan 2020, 21:03
Wohnort: Baunach
Hat sich bedankt: 4 Mal
Danksagung erhalten: 5 Mal

Re: Keine Daten mehr nach Update

Beitrag von ba0547 »

Hallo,
ich habe 2 Datenbanken, eine für die Wallbox (Wandkiste) und eine für den Wechselrichter(Solaranzeige). Hat bisher immer alles funktioniert. Habe 2 Datenbanken weil es in der Doku für die Wallbox so steht.

solarfanenrico

Re: Keine Daten mehr nach Update

Beitrag von solarfanenrico »

ba0547 hat geschrieben:
Di 25. Apr 2023, 14:57
Hallo,
ich habe 2 Datenbanken, eine für die Wallbox (Wandkiste) und eine für den Wechselrichter(Solaranzeige). Hat bisher immer alles funktioniert. Habe 2 Datenbanken weil es in der Doku für die Wallbox so steht.
Hallo, die log-Datei sieht eigentlich normal aus. Die anfänglichen Einträge schildern nur, einige Abläufe, da kann es u.U. sogar zu einem php.log_Eintrag kommen. Ab dem Zeitpunkt, wo letzlich Daten zur InfluxDB gesendet werden ist alle o.k.

Die roten Ecken in jedem Daschboard-Panel weisen darauf hin, daß zwischen Grafana und Influx noch etwas bereinigt werden muss. Oft hat sich nur die Datenbankauswahl vertan. z.B könnte nicht "Wandkiste" sondern "Grafana" drinstehen.Wenn soetwas passiert ist, muss sogar noch jedes Measurement und Field neu ausgewählt werden.
Enrico

ba0547
Beiträge: 57
Registriert: Do 23. Jan 2020, 21:03
Wohnort: Baunach
Hat sich bedankt: 4 Mal
Danksagung erhalten: 5 Mal

Re: Keine Daten mehr nach Update

Beitrag von ba0547 »

Hallo, offensichtlich wurde ein paket auf dem solaranzeige rechner nicht installiert oder bei der aktualisierung "vergessen". Ich habe grafana installieren lassen und die Datenquelle "Solaranzeige" mit dem Dashboard meines Wechselrichters neu verknüpft. Jetzt geht es wieder. Danke für eure Hilfe. Konnte das Dashboard nicht exportieren, es gib eine Grafana Anleitung wie man das macht. Konnte es anderweitig wieder richten.

stromvonoben
Beiträge: 43
Registriert: Mi 9. Nov 2022, 15:57
Hat sich bedankt: 2 Mal

Re: Keine Daten mehr nach Update

Beitrag von stromvonoben »

Hallo, Anfängerfrage, wie kann ich die Log Datei aufrufen.
Wechselrichter SUN2000MA-8KTL-M1 8kw
Huawei Speicher LUNA2000 5kW
Huawei Smart Power Sensor 250A
SDongleA
PV Modul LONGI 375Wp, insgesamt 7,88 kwp
Huawei Backup Box-B1
Anlagenstandort München

Benutzeravatar
mr.big
Beiträge: 573
Registriert: Mi 7. Sep 2022, 12:12
Wohnort: tief im Osten...
Hat sich bedankt: 13 Mal
Danksagung erhalten: 118 Mal

Re: Keine Daten mehr nach Update

Beitrag von mr.big »

Code: Alles auswählen

tail -f /var/www/log/solaranzeige.log
zeigt dir "fortlaufend" die solaranzeige.log an. Beenden mit Strg+C

Mit etwas mehr Komfort siehe viewforum.php?f=4

oder im Editor öffnen

Code: Alles auswählen

mcedit /var/www/log/solaranzeige.log

Antworten

Zurück zu „Allgemeines“