Probleme mit MQTT

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Frank_Berg
Beiträge: 25
Registriert: Mi 30. Jun 2021, 22:10
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Probleme mit MQTT

Beitrag von Frank_Berg »

OK, wie es aussieht hat Ulrich genau das gemacht.
Bekomme jetzt Daten im iobroker sowohl vom em3 als auch vom Deye!

An dieser Stelle erstmal Danke an den Support. Wirklich Wahnsinn wie schnell einem geholfen wird.

Danke auch an Mr.Big, der mir auch den richtigen Weg gezeigt hat.

Jedenfalls sollte der Hinweis, vielleicht auch in die Anleitung einfließen.

Vielen Dank nochmal.

Benutzeravatar
mr.big
Beiträge: 587
Registriert: Mi 7. Sep 2022, 12:12
Wohnort: tief im Osten...
Hat sich bedankt: 14 Mal
Danksagung erhalten: 116 Mal

Re: Probleme mit MQTT

Beitrag von mr.big »

Frank_Berg hat geschrieben:
Do 15. Jun 2023, 21:41

Jedenfalls sollte der Hinweis, vielleicht auch in die Anleitung einfließen.
Ähm, ich hatte aus der Anleitung zitiert!! :D

Aber "lesen" ist manchmal auch nicht unbedingt einfach! 👍👍👍

Frank_Berg
Beiträge: 25
Registriert: Mi 30. Jun 2021, 22:10
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Probleme mit MQTT

Beitrag von Frank_Berg »

Schande über mein Haupt.🤦

Ja, Anleitungen komplett durchlesen war schon immer meine ganz große Stärke.... Nicht 🤣

Ich danke euch.

Solarboy
Beiträge: 70
Registriert: Di 25. Okt 2022, 21:20
Hat sich bedankt: 1 Mal

Re: Probleme mit MQTT

Beitrag von Solarboy »

Da häng ich mich mal noch dran:
Ich möchte auch die Daten von 2 WR und einem Stapel Pylontech-Akkus an den IO Broker senden. Soweit habe ich alles lt. Anleitung in den x.user.configs der Solaranzeige konfiguriert. Wenn ich aber sehen möchte welche Daten z.B. vom Akku übertragen werden mit dem Befehl
mosquitto_sub -h 192.168.178.96 -v -t solaranzeige/Pylontech

passiert überhaupt nichts mehr...

In der log sieht für mich alles ok aus:

18.09. 20:45:21 -Verarbeitung von: '3.user.config.php' Regler: 41
18.09. 20:45:21 |--------------- Start us3000_bms.php -----------------
18.09. 20:45:23 -Produkt US2000C
18.09. 20:45:23 -SOC Gesamt:67
18.09. 20:45:23 -MQTT Daten zum [ 192.168.178.96 ] senden.
18.09. 20:45:23 * -Daten zur lokalen InfluxDB [ solaranzeige3 ] gesendet.
18.09. 20:45:23 -Multi-Regler-Ausgang. 5
18.09. 20:45:28 -OK. Datenübertragung erfolgreich.
18.09. 20:45:28 |--------------- Stop us3000_bms.php -----------------
18.09. 20:45:29 -Multi Regler Auslesen [Stop].

18.09. 20:46:02 -Multi Regler Auslesen [Start].
18.09. 20:46:02 -Verarbeitung von: '1.user.config.php' Regler: 48
18.09. 20:46:02 |------------------------- Start growatt.php ---------------------
18.09. 20:46:02 -Protokoll Version: 4
18.09. 20:46:03 -Firmware: 040.06 Warnungen: 0
18.09. 20:46:03 -Auslesen des Gerätes beendet.
18.09. 20:46:03 -MQTT Daten zum [ 192.168.178.96 ] senden.
18.09. 20:46:03 * -Daten zur lokalen InfluxDB [ solaranzeige1 ] gesendet.
18.09. 20:46:03 -Multi-Regler-Ausgang. 8
18.09. 20:46:11 -OK. Datenübertragung erfolgreich.
18.09. 20:46:11 |------------------------- Stop growatt.php ---------------------
18.09. 20:46:11 -Verarbeitung von: '2.user.config.php' Regler: 48
18.09. 20:46:11 |------------------------- Start growatt.php ---------------------
18.09. 20:46:11 -Protokoll Version: 4
18.09. 20:46:12 -Firmware: 040.06 Warnungen: 0
18.09. 20:46:12 -Auslesen des Gerätes beendet.
18.09. 20:46:12 -MQTT Daten zum [ 192.168.178.96 ] senden.
18.09. 20:46:12 * -Daten zur lokalen InfluxDB [ solaranzeige2 ] gesendet.
18.09. 20:46:12 -Multi-Regler-Ausgang. 8

Steh´grad mal wieder auf dem Schlauch :oops:

Benutzeravatar
Ulrich
Administrator
Beiträge: 5754
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 152 Mal
Danksagung erhalten: 821 Mal
Kontaktdaten:

Re: Probleme mit MQTT

Beitrag von Ulrich »

Versuche es bitte einmal hiermit:

mosquitto_sub -h localhost -v -t +/#
-----------------------------------------------------
Ulrich . . . . . . . . [ Admin ]

Solarboy
Beiträge: 70
Registriert: Di 25. Okt 2022, 21:20
Hat sich bedankt: 1 Mal

Re: Probleme mit MQTT

Beitrag von Solarboy »

Danke Ulrich, jetzt wird alles angezeigt. Hatte auch noch im MQTT Client den falschen Port eingetragen, jetzt funzt alles und ich kann weiterbasteln im IOBroker.
Bin mal wieder begeistert 😀👍

Antworten

Zurück zu „Allgemeines“