Probleme bei der Installation

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
e4e
Beiträge: 3
Registriert: Do 10. Okt 2019, 14:30

Probleme bei der Installation

Beitrag von e4e »

Hallo,

ich habe gerade versucht das img zu installieren. Nach der Installation bekomme ich nachfolgende Fehlermeldungen:
Der Raspberry wird jetzt neu gestartet.
Failed to set wall message, ignoring: Interactive authentication required.
Failed to reboot system via logind: Interactive authentication required.
Failed to open initctl fifo: Keine Berechtigung
Failed to talk to init daemon.
mit
sudo reboot
kann ich den RPI neu booten aber wenn ich direkt auf die Website zugreifen möchte bekomme ich
403 Forbidden
Vielen Dank für Tipps

Benutzeravatar
Ulrich
Administrator
Beiträge: 2698
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 32 Mal
Danksagung erhalten: 167 Mal
Kontaktdaten:

Re: Probleme bei der Installation

Beitrag von Ulrich »

Folgende Fehler tauchen bei der Installation auf:

a) Das Image wurde auf einem MAC entpackt. Dann bitte einen anderen Unzipper benutzen.
b) Das Image wird auf einem Raspberry 1B oder auch die älteren 2B benutzt. Da es sich um das neueste Raspbian "Buster" handelt muss ein Raspbian 3B oder 4B benutzt werden. ( Die neueren 2B mit neuerer Firmware funktionieren auch )
--------------------------------------
Ulrich [Admin]

e4e
Beiträge: 3
Registriert: Do 10. Okt 2019, 14:30

Re: Probleme bei der Installation

Beitrag von e4e »

Hallo,

ich habe einen 2B. Kann ich die FW selbst flashen?

Benutzeravatar
Ulrich
Administrator
Beiträge: 2698
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 32 Mal
Danksagung erhalten: 167 Mal
Kontaktdaten:

Re: Probleme bei der Installation

Beitrag von Ulrich »

Google doch einfach einmal.
Das habe ich gefunden:
http://raspberrypiguide.de/howtos/raspb ... re-update/
--------------------------------------
Ulrich [Admin]

RaspiVoila
Beiträge: 17
Registriert: Mo 2. Dez 2019, 17:46

Re: Probleme bei der Installation

Beitrag von RaspiVoila »

Hallo,
versuche gerade solaranzeige auf einem Raspberry 3B V1.2 aufzusetzen. Zum Entpacken des zip zum Image habe ich inzwischen 3 verschiedene Programme (iZip Unarchiver, ExpressZip und BetterZip: auf einem MacBook) angewendet. Zum Flashen habe ich balenaEtcher genommen.
Jedesmal kommen nach dem Setup folgende Fehlermeldungen:

Der Raspberry wird jetzt neu gestartet.
Failed to set wall message, ignoring: Interactive authentication required.
Failed to reboot system via logind: Interactive authentication required.
Failed to open initctl fifo: Keine Berechtigung
Failed to talk to init daemon.

Kann mir jemand einen Tipp geben was da schief gelaufen ist?
VG
Peter

Timo
Beiträge: 32
Registriert: Fr 13. Sep 2019, 19:06

Re: Probleme bei der Installation

Beitrag von Timo »

Das Macht nix die meldung hatte ich auch und kommt bei manchen.

Einfach nach Anleitung weitermachen.

dekaman
Beiträge: 1
Registriert: Di 31. Mär 2020, 08:49

Re: Probleme bei der Installation

Beitrag von dekaman »

Guten Abend,
auch ich nutze einen Mac und habe Probleme beim Zugriff auf "Terminal" um Änderungen vorzunehmen
1. Auf der SD Card für den Raspi 4 B habe ich eine leere Datei "ssh", ohne Endung eingefügt
2. Als Kommando gebe ich im "Terminal" folgendes ein: "ssh pi@192.168.178.43" Enter. Allerdings ohne Erfolg.
Eine Anleitung für Mac gibt es offensichtlich nicht? Oder doch?
Viele Grüße
Micha

Brainbug
Beiträge: 3
Registriert: Fr 13. Aug 2021, 19:00
Hat sich bedankt: 2 Mal

Re: Probleme bei der Installation

Beitrag von Brainbug »

Ich habe jetzt auch dieses Problem. Das Image funktioniert auf einem Rasberry ohne Probleme - jetzt das selbe Image auf einem anderen nicht.

Das Image habe ich installiert. setup vorgenommen und die Einstellungen gesetzt. Danach kommt der automatische Reboot. Dann kann ich die user.config.php nicht mehr bearbeiten und auch keinen reboot vornehmen - Fehlermeldung vom versuchten reboot:

Failed to set wall message, ignoring: Interactive authentication required.
Failed to reboot system via logind: Interactive authentication required.
Failed to open initctl fifo: Keine Berechtigung
Failed to talk to init daemon.

Benutzeravatar
Ulrich
Administrator
Beiträge: 2698
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 32 Mal
Danksagung erhalten: 167 Mal
Kontaktdaten:

Re: Probleme bei der Installation

Beitrag von Ulrich »

Um die user.config.php zu ändern, musst du folgendes eingeben:

sudo mcedit user.config.php

Reboot mit:

sudo reboot
--------------------------------------
Ulrich [Admin]

Brainbug
Beiträge: 3
Registriert: Fr 13. Aug 2021, 19:00
Hat sich bedankt: 2 Mal

Re: Probleme bei der Installation

Beitrag von Brainbug »

Danke, jetzt geht es plötzlich.

Vorher hat es nicht funktioniert, auch mit sudo nicht. :|

Antworten