Dashboard eingefroren

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung
xango
Beiträge: 24
Registriert: Mo 9. Mär 2020, 09:40

Re: Dashboard eingefroren

Beitrag von xango »

Heute wieder das gleiche: Dashboard eingefroren ungefähr nach dem gleichen Zeitraum wie voriges Mal. Und auch nachdem ich den USB Stick angeschlossen habe (an die USB micro Buchse) und den entsprechenden Taster für 3 sec. gedrückt hatte wurde der USB Stick erkannt. Danach das USB Kabel zum Raspi erneut angeschlossen und das Dashboard zeigte wieder aktuelle Werte an.
Da hier wohl niemand die gleiche Erafahrung bisher gemacht hat (???) werde ich erneut MPPSolar dazu kontaktieren. Da hat sich auf meine Nachfrage vom 21.3. bisher niemand gemeldet.

xango
Beiträge: 24
Registriert: Mo 9. Mär 2020, 09:40

Re: Dashboard eingefroren

Beitrag von xango »

Folgende Frage:
Besteht die Möglichkeit eine Art Ping an den WR zu senden, also zu fragen:" kannst Du sprechen oder hast Du Aua? ;)
Vielleicht eine Befehlsfolge über PUTTY?

Benutzeravatar
Ulrich
Administrator
Beiträge: 1275
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Dashboard eingefroren

Beitrag von Ulrich »

Mit PUTTY einloggen und dann

"lsusb"

oder

"hwinfo --usb"

oder

"usb-devices"
--------------------------------------
Ulrich [Admin]

xango
Beiträge: 24
Registriert: Mo 9. Mär 2020, 09:40

Re: Dashboard eingefroren

Beitrag von xango »

Ich habe mal die Befehle ausgeführt und die Ergebnisse im Screenshot angefügt. Mir scheint das sind Infos über die USB Hardware im Raspi oder wo sehe ich das der WR auf dem USB antwortet?
Danke für die Hilfe.
usb1.JPG
Dateianhänge
usb-devices.JPG

Benutzeravatar
Ulrich
Administrator
Beiträge: 1275
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Dashboard eingefroren

Beitrag von Ulrich »

Damit sollst Du heraus bekommen, welche Device die richtige ist.

Wie lautet die denn bei Dir?

Benutzt du ein einfaches USB Kabel oder einen Seriell-Adapter?
--------------------------------------
Ulrich [Admin]

xango
Beiträge: 24
Registriert: Mo 9. Mär 2020, 09:40

Re: Dashboard eingefroren

Beitrag von xango »

Ein einfaches USB Kabel wie USB A - USB Micro B

Christian St.
Beiträge: 8
Registriert: Do 23. Apr 2020, 22:38

Re: Dashboard eingefroren

Beitrag von Christian St. »

Hallo,
gibt es zu dem Punkt schon Erkenntnisse? Ich habe ein ähnliches Problem. Wenn ich die Solaranzeige den ganzen Tag laufen lasse läuft sie perfekt und speichert die Daten lückenlos, aber sobald ich das Dashboard über einen Browser am Handy oder am PC öffne, stoppt der Datenfluss in die InfluxDB. Woran könnte das liegen :?:

Benutzeravatar
Ulrich
Administrator
Beiträge: 1275
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Dashboard eingefroren

Beitrag von Ulrich »

Schaue bitte einmal nach, ob du noch genügend freien Speicher hast. Auf der Konsole: df -h
--------------------------------------
Ulrich [Admin]

Christian St.
Beiträge: 8
Registriert: Do 23. Apr 2020, 22:38

Re: Dashboard eingefroren

Beitrag von Christian St. »

Das ist der derzeit genutzte Speicher:

Code: Alles auswählen

pi@solaranzeige:/var/www/log $ df -h
Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
/dev/root       7,0G    3,6G  3,1G   54% /
devtmpfs        1,8G       0  1,8G    0% /dev
tmpfs           2,0G       0  2,0G    0% /dev/shm
tmpfs           2,0G    113M  1,8G    6% /run
tmpfs           5,0M    4,0K  5,0M    1% /run/lock
tmpfs           2,0G       0  2,0G    0% /sys/fs/cgroup
/dev/mmcblk0p1  253M     53M  200M   21% /boot
tmpfs           391M       0  391M    0% /run/user/1000

Christian St.
Beiträge: 8
Registriert: Do 23. Apr 2020, 22:38

Re: Dashboard eingefroren

Beitrag von Christian St. »

Ich habe mal im Logfile nachgesehen, da kommt es immer zu einem Fehler Nummer : 025. Die Datenübertragung funkioniert da aber noch.

Code: Alles auswählen

16.05. 06:19:02 |------------   Start  aec_wechselrichter.php    -----------------
16.05. 06:19:04    -*010   0  24.4  0.00     0  72.6  0.01     0  50      0
16.05. 06:19:06 ** -Allgemeiner Fehler aufgetreten. Fehler Nummer: 025
16.05. 06:19:06 *  -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
16.05. 06:19:58    -OK. Datenübertragung erfolgreich.
16.05. 06:19:58    -WattstundenGesamtHeute: 0
16.05. 06:19:58 |------------   Stop   aec_wechselrichter.php    -----------------
16.05. 06:20:01 |------------   Start  aec_wechselrichter.php    -----------------
16.05. 06:20:06    -Fehler! Datenlänge: 0 Daten:  Loop: 1
16.05. 06:20:06    -Exit....
16.05. 06:20:51 |------------------- Start wetterdaten.php --------------------
16.05. 06:20:51 o---Wetterdaten ausgeschaltet.
16.05. 06:20:51 |------------------- Stop  wetterdaten.php ---------------------
16.05. 06:21:01 |------------   Start  aec_wechselrichter.php    -----------------
16.05. 06:21:06    -Fehler! Datenlänge: 0 Daten:  Loop: 1
16.05. 06:21:06    -Exit....
16.05. 06:22:01 |------------   Start  aec_wechselrichter.php    -----------------
16.05. 06:22:05    -Der Wechselrichter kann zur Zeit nicht abgefragt werden.
16.05. 06:22:05 !! -Keine gültigen Daten empfangen.
Dann später, sieht der Log so aus (um etwa 9:05 hab ich mir das dashboard am Handy angeschaut):

Code: Alles auswählen

16.05. 09:07:57    -OK. Datenübertragung erfolgreich.
16.05. 09:07:57    -WattstundenGesamtHeute: 0
16.05. 09:07:57 |------------   Stop   aec_wechselrichter.php    -----------------
16.05. 09:08:01 |------------   Start  aec_wechselrichter.php    -----------------
16.05. 09:08:04    -*010   0  30.4  0.96   `r8 236.0  0.11    25  50     19
16.05. 09:08:05    -Daten nicht zur lokalen InfluxDB gesendet! info: array (
  'url' => 'http://localhost/write?db=solaranzeige&precision=s',
  'content_type' => 'application/json',
  'http_code' => 400,
  'header_size' => 390,
  'request_size' => 295,
  'filetime' => -1,
  'ssl_verify_result' => 0,
  'redirect_count' => 0,
  'total_time' => 0.012086,
  'namelookup_time' => 0.002687,
  'connect_time' => 0.002995,
  'pretransfer_time' => 0.003169,
  'size_upload' => 138.0,
  'size_download' => 113.0,
  'speed_download' => 9416.0,
  'speed_upload' => 11500.0,
  'download_content_length' => 113.0,
  'upload_content_length' => 138.0,
  'starttransfer_time' => 0.012004,
  'redirect_time' => 0.0,
  'redirect_url' => '',
  'primary_ip' => '::1',
  'certinfo' =>
  array (
  ),
  'primary_port' => 8086,
  'local_ip' => '::1',
  'local_port' => 47066,
  'http_version' => 2,
  'protocol' => 1,
  'ssl_verifyresult' => 0,
  'scheme' => 'HTTP',
  'appconnect_time_us' => 0,
  'connect_time_us' => 2995,
  'namelookup_time_us' => 2687,
  'pretransfer_time_us' => 3169,
  'redirect_time_us' => 0,
  'starttransfer_time_us' => 12004,
  'total_time_us' => 12086,
)
16.05. 09:08:10    -Daten nicht zur lokalen InfluxDB gesendet! info: array (
  'url' => 'http://localhost/write?db=solaranzeige&precision=s',
  'content_type' => 'application/json',
  'http_code' => 400,
  'header_size' => 390,
  'request_size' => 295,
  'filetime' => -1,
  'ssl_verify_result' => 0,
  'redirect_count' => 0,
  'total_time' => 0.00744,
  'namelookup_time' => 0.000152,
  'connect_time' => 0.000155,
  'pretransfer_time' => 0.000333,
  'size_upload' => 138.0,
  'size_download' => 113.0,
  'speed_download' => 16142.0,
  'speed_upload' => 19714.0,
  'download_content_length' => 113.0,
  'upload_content_length' => 138.0,
  'starttransfer_time' => 0.007346,
  'redirect_time' => 0.0,
  'redirect_url' => '',
  'primary_ip' => '::1',
  'certinfo' =>
  array (
  ),
  'primary_port' => 8086,
  'local_ip' => '::1',
  'local_port' => 47066,
  'http_version' => 2,
  'protocol' => 1,
  'ssl_verifyresult' => 0,
  'scheme' => 'HTTP',
  'appconnect_time_us' => 156,
  'connect_time_us' => 155,
  'namelookup_time_us' => 152,
  'pretransfer_time_us' => 333,
  'redirect_time_us' => 0,
  'starttransfer_time_us' => 7346,
  'total_time_us' => 7440,
)
16.05. 09:08:57    -OK. Datenübertragung erfolgreich.
16.05. 09:08:57    -WattstundenGesamtHeute: 0.42
16.05. 09:08:57 |------------   Stop   aec_wechselrichter.php    -----------------
16.05. 09:09:02 |------------   Start  aec_wechselrichter.php    -----------------
16.05. 09:09:06    -Der Wechselrichter kann zur Zeit nicht abgefragt werden.
16.05. 09:09:06 !! -Keine gültigen Daten empfangen.
16.05. 09:09:06    -WattstundenGesamtHeute: 0.42
16.05. 09:09:06 |------------   Stop   aec_wechselrichter.php    -----------------
Bis jetzt schaut der Log so aus und wird sich nichtmehr ändern bis morgen:

Code: Alles auswählen

16.05. 12:28:05    -Der Wechselrichter kann zur Zeit nicht abgefragt werden.
16.05. 12:28:05 !! -Keine gültigen Daten empfangen.
16.05. 12:28:05    -WattstundenGesamtHeute: 0.42
16.05. 12:28:05 |------------   Stop   aec_wechselrichter.php    -----------------
16.05. 12:29:01 |------------   Start  aec_wechselrichter.php    -----------------
16.05. 12:29:05    -Der Wechselrichter kann zur Zeit nicht abgefragt werden.
16.05. 12:29:05 !! -Keine gültigen Daten empfangen.
16.05. 12:29:05    -WattstundenGesamtHeute: 0.42
16.05. 12:29:05 |------------   Stop   aec_wechselrichter.php    -----------------
16.05. 12:30:01 |------------   Start  aec_wechselrichter.php    -----------------
16.05. 12:30:05    -Der Wechselrichter kann zur Zeit nicht abgefragt werden.
16.05. 12:30:05 !! -Keine gültigen Daten empfangen.
16.05. 12:30:05    -WattstundenGesamtHeute: 0.42
16.05. 12:30:05 |------------   Stop   aec_wechselrichter.php    -----------------

Antworten