Probleme mit Kostal Piko 20 und Solaranzeige - benötige Hilfe

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Isomeer
Beiträge: 12
Registriert: Fr 19. Mär 2021, 14:13
Hat sich bedankt: 3 Mal

Re: Probleme mit Kostal Piko 20 und Solaranzeige - benötige Hilfe

Beitrag von Isomeer »

Der DAU des Tages geht an mich :oops:
Ich habe die Anleitung "Bitte die gesamte Datei durchlesen und die richtigen Angaben machen" auf das pdf bezogen und nicht auf die config-Datei :roll:
OK, es war die config und wenn man die durchgeht, stolpert man auch über die Eingabeparameter für die WR-IP, den Port und die Adresse.

Nachdem ich das kapiert und gemacht habe - läuft es immer noch nicht.
Dashboard startet (Kostal Piko ausgewählt) aber keine Daten.

Fragen (zur Sicherheit...):
  • Der anzugebende Port lautet 1502 oder 502 und beides müsste funktionieren?
  • Die WR-Adresse ist das, was im Piko-Setup unter RS484 die "Wechselrichteradresse" ist (dürfte ja die Modbus-Adresse sein)?
  • Muss diese WR-Adresse mit führender 0 angegeben werden?
  • Beim Bus muss A+ auf A+ und B- auf B-, richtig ?
Mich wundert, dass die tx/rx-LEDs auf dem USB-Adapter nur kurz beim starten de Pi zucken, danach sind sie tot.
Als USB/RS485-Adapter habe ich einen DSD Tech SH-U11 gekauft. Soll einen FTDI Chip haben. Gibt es ggf. dennoch Restrisiken, dass der Adapter vom Pi nicht erkannt wird?

pv-seb
Beiträge: 7
Registriert: Di 29. Dez 2020, 13:58

Re: Probleme mit Kostal Piko 20 und Solaranzeige - benötige Hilfe

Beitrag von pv-seb »

Moin,

ich versuche aus momentan den PIKO 12 und KSEM zum LAufen zu bringen.
Sobald ich es irgendwie geschafft habe stelle ich die Infos hier rein.

Aus dem Forum habe ich noch nichts komplettes gefunden.

Vielleicht kann jemand mit dem PIKO WR und KSEM eine kleine Step by Step Anleitung einstellen.

solarfanenrico
Beiträge: 365
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 20 Mal
Danksagung erhalten: 24 Mal

Re: Probleme mit Kostal Piko 20 und Solaranzeige - benötige Hilfe

Beitrag von solarfanenrico »

Hallo,
ich glaube die meisten Fehler passieren bei "PIKO WR und KSEM "

Versucht es bitte mal mit beiden einzeln als single. und vergesst erstmal, daß es auch die multi_auslesen.php gibt.

Erst wenn beide für sich getrennt laufen, weiß man wo und wie die ausgelesen werden.

Bei der Umstellung auf Multi muß dann sicher auch die entsprechende Anleitung befolgt werden. Das Überspringen von Einzelpunkten ist nicht gut.

Ich habe erst vor kurzem in einem Beitrag gelesen, daß jemand sein persönliches funktionierendes Multi Image beim Nachbarn nutzen wollte.
Der hat einfach den Sinn der Anleitung "Umstellung auf Mult"i nicht verstanden. Raspi und Regler müssen sich erst kennenlernen.

Enrico

Isomeer
Beiträge: 12
Registriert: Fr 19. Mär 2021, 14:13
Hat sich bedankt: 3 Mal

Re: Probleme mit Kostal Piko 20 und Solaranzeige - benötige Hilfe

Beitrag von Isomeer »

solarfanenrico hat geschrieben:
Mi 30. Jun 2021, 11:50
Erst wenn beide für sich getrennt laufen, weiß man wo und wie die ausgelesen werden.
Nachdem ich meine lauffähige Piko-Solaranzeige beim Hochrüsten auf Multi / KSEM zerschossen hatte und eine Neuinstallation als Single für den Piko dann auch nicht mehr laufen wollte, ist das genau mein Plan. Lieber kleine Schritte.

Und falls außer mir noch jemand das Problem haben sollte, selbst in einer frisch installierten single-Version den Piko nicht auslesen zu können:
Bei mir lief es wieder, nachdem ich die kostal_piko.php der 4.7.2 gegen meine ältere Variante aus einem backup ersetzt hatte.
Stehe dazu aber schon mit TeamO im Kontakt - eigentlich sollte ein bug aus der Vorversion (den er bei mir beseitigt hatte) in der 4.7.2 ebenfalls beseitigt sein.
btw: Der support war dabei wirklich klasse!!!

Für alle Fälle hänge ich mal die bei mir lauffähige Version an diesen Beitrag an.
Dateianhänge
kostal_pico.php
(17.95 KiB) 19-mal heruntergeladen

Antworten