Huawei SUN2000

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Fitscher
Beiträge: 12
Registriert: Mo 18. Jan 2021, 13:14

Re: Huawei SUN2000

Beitrag von Fitscher »

Danke für die schnelle Rückmeldung.
Ich habe es gerade nochmals umverdrahtet, jedoch besteht das Problem noch immer.

Fitscher
Beiträge: 12
Registriert: Mo 18. Jan 2021, 13:14

Re: Huawei SUN2000

Beitrag von Fitscher »

Alles bestens. Habe am Gerät nochmals das Setup durchlaufen.

Ich habe Pin 1 & 3 geklemmt. Nun bekommt der Pi die Daten durch den WR.

Theslowman
Beiträge: 95
Registriert: Sa 1. Aug 2020, 13:31
Wohnort: 55278 Dalheim
Hat sich bedankt: 2 Mal
Danksagung erhalten: 3 Mal

Re: Huawei SUN2000

Beitrag von Theslowman »

Bei mir ist der 17KTL-M0 wohl die Zicke. Raspberry Pi4 mit USB SSD und USB RS485 Adapter.
Power Sensor und Netzwerk Dongle sind noch nicht angeschlossen ( kommen Montag ) , dafür aber ein RS485 USB Adapter an Pin1+3 vom WR.
Setup der Solaranzeige hab ich durchlaufen lassen, mit "46" aber ohne Erfolg.

Es kommen nur komische Sachen im Huawei Dashboard

fadd87
Beiträge: 7
Registriert: Mi 17. Mär 2021, 21:58
Danksagung erhalten: 1 Mal

Re: Huawei SUN2000

Beitrag von fadd87 »

Hallo liebe Huawei WR Nutzer,

koennt ihr kurz den aktuellen Stand zusammenfassen. Ich habe mich bislang nicht an die Ansteuerung des WR mit RS485 getraut da die Firmware allein schon noch genug Bugs enthielt, aber nun würde ich gern starten. Funktioniert ggf. eine Kontrolle des Lade-/Entladeverhalten der angeschlossenen Batterien? Kann der mit dem WR gekoppelte DTSU SmartMeter ausgelesen werden und der aktuelle Wert der Netzeinspeisung als Referenz herangezogen werden, um GPIO Signale auszulösen?

Beste Gruesse!

parjanos
Beiträge: 8
Registriert: So 31. Okt 2021, 14:50

Re: Huawei SUN2000

Beitrag von parjanos »

Moin zusammen.
Ich habe einen Huawei 15KTL-M2 und einen Huawei DTSU666-H Smart Power Sensor. Habe Solaranzeige auf der RP am laufen und die RC485 Schnittstelle auf Pin1 -> Data+ (orange) und Pin3 -> Data-(gelb) über folgendes USB Kabel angesteuert. Solaranzeige läuft problemlos, aber die Daten werden nicht übermittelt. Habe die RP auch neu gebootet, aber leider ohne Ergebnis. Kann mir einer helfen?

Vielen Dank!

@Fitcher: was meinst Du mit Setup durchlaufen lassen? Wie und an welchem Gerät?
Dateianhänge
1091572345-499941491.jpg
760958187-1206886296.jpg

Benutzeravatar
Ulrich
Administrator
Beiträge: 2985
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 38 Mal
Danksagung erhalten: 192 Mal
Kontaktdaten:

Re: Huawei SUN2000

Beitrag von Ulrich »

Wenn der RS485 Adapter keinen FTDI Chipsatz hat, wird es nicht funktionieren, da dem Raspberry dann der nötige Treiber fehlt.
--------------------------------------
Ulrich [Admin]

parjanos
Beiträge: 8
Registriert: So 31. Okt 2021, 14:50

Re: Huawei SUN2000

Beitrag von parjanos »

Ulrich hat geschrieben:
Sa 13. Nov 2021, 15:57
Wenn der RS485 Adapter keinen FTDI Chipsatz hat, wird es nicht funktionieren, da dem Raspberry dann der nötige Treiber fehlt.
Soll er angeblich haben (s. Bild). Weist Du woran es noch liegen könnte?
Screenshot_20211113_162633_com.alibaba.aliexpresshd_1.jpg

Benutzeravatar
Ulrich
Administrator
Beiträge: 2985
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 38 Mal
Danksagung erhalten: 192 Mal
Kontaktdaten:

Re: Huawei SUN2000

Beitrag von Ulrich »

Ist eventuell die A + B Ader vertauscht? Dann funktioniert es auch nicht. Nach jeder Änderung der USB Verbindung muss immer der Raspberry neu gestartet werden!
--------------------------------------
Ulrich [Admin]

parjanos
Beiträge: 8
Registriert: So 31. Okt 2021, 14:50

Re: Huawei SUN2000

Beitrag von parjanos »

Ulrich hat geschrieben:
Sa 13. Nov 2021, 16:39
Ist eventuell die A + B Ader vertauscht? Dann funktioniert es auch nicht. Nach jeder Änderung der USB Verbindung muss immer der Raspberry neu gestartet werden!
Leider nein. Orange ist auf 1 und gelb auf 3... Wenn ich es richtig verstanden habe, müsste bei der Übertragung auch die LED im Kabel blinken. Sie leuchtet aber nur ganz kurz auf, wenn ich das Kabel in die RP einstecke, danach nicht mehr... Da sich das smart meter problemlos seine Daten vom WR holt, gehe ich davon aus, dass sonst alle Einstellungen im WR korrekt sind...
IMG_20211113_152440.jpg

Benutzeravatar
Ulrich
Administrator
Beiträge: 2985
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 38 Mal
Danksagung erhalten: 192 Mal
Kontaktdaten:

Re: Huawei SUN2000

Beitrag von Ulrich »

Wenn du das Kabel in den Raspberry steckst, kann nicht viel passieren, da der Raspberry die USB Schnittstelle nur beim Hochfahren initialisiert und die richtige serielle Geschwindigkeit einstellt. Deshalb muss nach jeder USB Änderung der Raspberry neu gestartet werden.
--------------------------------------
Ulrich [Admin]

Antworten