Huawei SUN2000

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

parjanos
Beiträge: 23
Registriert: So 31. Okt 2021, 14:50
Danksagung erhalten: 2 Mal

Re: Huawei SUN2000

Beitrag von parjanos »

Ulrich hat geschrieben:
Sa 13. Nov 2021, 17:03
Wenn du das Kabel in den Raspberry steckst, kann nicht viel passieren, da der Raspberry die USB Schnittstelle nur beim Hochfahren initialisiert und die richtige serielle Geschwindigkeit einstellt. Deshalb muss nach jeder USB Änderung der Raspberry neu gestartet werden.
Habe ich leider schon mehrfach vergeblich gemacht... Werde mal testweise den Adapter von Fitcher auf Seite 2 bestellen...

Benutzeravatar
Ulrich
Administrator
Beiträge: 4001
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 94 Mal
Danksagung erhalten: 530 Mal
Kontaktdaten:

Re: Huawei SUN2000

Beitrag von Ulrich »

Ist im Gerät die serielle Geschwindigkeit auf 9600 Baud eingestellt und stimmt die eingetragene Geräte ID? ($WR_Adrersse)
---------------------------------------
Ulrich . . . . . . . . [Projektinhaber]

parjanos
Beiträge: 23
Registriert: So 31. Okt 2021, 14:50
Danksagung erhalten: 2 Mal

Re: Huawei SUN2000

Beitrag von parjanos »

Ulrich hat geschrieben:
Sa 13. Nov 2021, 17:16
Ist im Gerät die serielle Geschwindigkeit auf 9600 Baud eingestellt und stimmt die eingetragene Geräte ID? ($WR_Adrersse)
Ja, ist bei 9600 Baud. Was meinst du mit eingetragene Geräte ID? ($WR_Adrersse) Wo muss das eingetragen werden? Der WR und die RP haben bei mir feste IP Adressen...

Benutzeravatar
Ulrich
Administrator
Beiträge: 4001
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 94 Mal
Danksagung erhalten: 530 Mal
Kontaktdaten:

Re: Huawei SUN2000

Beitrag von Ulrich »

Irgendwo im Huawei Gerät wird eine Geräte ID eingetragen ( 1 bis 9 ). Die ist wichtig, wenn man mehrere Geräte zusammenschaltet. Diese ID muss in der user.config.php unter $WR_Adresse eingetragen werden.
---------------------------------------
Ulrich . . . . . . . . [Projektinhaber]

parjanos
Beiträge: 23
Registriert: So 31. Okt 2021, 14:50
Danksagung erhalten: 2 Mal

Re: Huawei SUN2000

Beitrag von parjanos »

Ulrich hat geschrieben:
Sa 13. Nov 2021, 17:21
Irgendwo im Huawei Gerät wird eine Geräte ID eingetragen ( 1 bis 9 ). Die ist wichtig, wenn man mehrere Geräte zusammenschaltet. Diese ID muss in der user.config.php unter $WR_Adresse eingetragen werden.
OK, das habe ich noch nicht erledigt... Durchforste mal das Forum. Vielleicht gibt es ja eine Anleitung für den Huawei und den Weg wie es geht... Danke!

parjanos
Beiträge: 23
Registriert: So 31. Okt 2021, 14:50
Danksagung erhalten: 2 Mal

Re: Huawei SUN2000

Beitrag von parjanos »

Vielen Dank Ulrich für Deine Hilfe! Habe es jetzt hinbekommen.
Für alle, die ein ähnliches Problem mit dem Huawei haben... War bei mir eigene Blödheit. Hätte ich mich akribisch an die Anleitung von Ulrich gehalten, hätte es auch auf Anhieb funktioniert. :lol:

SunnyJ
Beiträge: 1
Registriert: So 9. Okt 2022, 19:18
Hat sich bedankt: 1 Mal

Re: Huawei SUN2000

Beitrag von SunnyJ »

Hallo @parjano,

Du schreibst: Hätte ich mich akribisch an die Anleitung von Ulrich gehalten, hätte es auch auf Anhieb funktioniert
Könntest Du sagen an welcher Stelle es auf Anhieb nicht funktioniert hat? Wo muss ich aufpassen? Was ist etwas besonders?

Ich versuche schon längere Zeit, über RS485 die Daten aus dem Huawei WR (-L Modell) auszulesen: Pin 1+3 vor und zurück, andere Pin-Kombinationen ausprobiert, USB-Adapter mit FTDI FT232 (RL) Chip, mit/ohne angegebener Baudrate, ohne Erfolg. Langsam gehen mir die Ideen aus, wie ich das noch zum Laufen bekommen kann.

Der WR ist mit SmartMeter und Huawei Luna Batterie gekoppelt und die Daten über die Fusion App am Handy darstellbar. Das einzige "Ergebnis" das ich erziele ist dass bei bestimmten Pin-Verdrahtungen (insbesondere auch Pin 1 und 3) der WR die Daten der Batterie und/oder des SmartMeter verliert und da in der FusionApp 0 anzeigt (via Cloud und auchDirektverbindung).

Verschiedene GeräteIDs und $WR_ machen keinen Unterschied, wobei im HuaweiWR in der Modbus-Config als ID 1 steht. Auch dort habe ich schon einen anderen Wert eingetragen, mit dem hat die Solaranzeige aber auch keine Verbindung bekommen :-(

Im Dashboard erscheint immer der "20KTL" und als Status "Startup", das entspricht jeweils dem Wert 0.

Ich bin Dankbar für jeden Tipp! SunnyJ

Benutzeravatar
Ulrich
Administrator
Beiträge: 4001
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 94 Mal
Danksagung erhalten: 530 Mal
Kontaktdaten:

Re: Huawei SUN2000

Beitrag von Ulrich »

Hallo Sunny3,

so wird das nie was. Wenn das Auslesen nicht funktioniert, dann muss du nur ein Gerät anschließem und alle Verbindungen zu den anderen Geräten vorübergehend kappen. Dann wirst du sehen, dass der Wechselrichter auch ausgelesen werden kann. Wie sind denn die anderen Geräte mit dem Wechselrichter verbunden? Auch über RS485? Wenn ja, dann wird es kompliziert, da es in einem RS485 Netzwerk nur einen MASTER geben kann und das ist die Solaranzeige. Im Forum sind schon oft die Probleme besprochen worden. Suche einmal nach MASTER und RS485
---------------------------------------
Ulrich . . . . . . . . [Projektinhaber]

Libelle78
Beiträge: 21
Registriert: Sa 7. Mai 2022, 23:10
Danksagung erhalten: 5 Mal

Re: Huawei SUN2000

Beitrag von Libelle78 »

Hallo,
ist es eigentlich möglich beim DTSU-666H die Summen auszulesen?
Also Imp, Exp, Summe

Danke
Gruß

Libelle78
Beiträge: 21
Registriert: Sa 7. Mai 2022, 23:10
Danksagung erhalten: 5 Mal

Re: Huawei SUN2000

Beitrag von Libelle78 »


Antworten