Zugriff über xrdp auf den Raspi-Desktop funktioniert nur kurz

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
msc
Beiträge: 34
Registriert: Fr 5. Jun 2020, 14:38

Zugriff über xrdp auf den Raspi-Desktop funktioniert nur kurz

Beitrag von msc »

Hallo,

ich habe zwei Raspis am laufen auf dem die solaranzeige installiert ist. Auf einem Raspi kann ich wunderbar per xrdp von meinem Windows-Rechner (Remotedesktopverbindung) auf den Desktop zugreifen. Das hatte ich vor einigen Wochen eingerichtet.
Nun wollte ich auch auf den zweiten Raspi per Remote-Desktop zugreifen. Auf dem zweiten Raspi sehe ich nach dem ich die Remotdesktopverbindung initiiert habe einige Sekunden den Raspi-Desktop. Dann öffnet sich aber Grafana. Ich finde einfach keine Möglichkeit Grafana zu schließen und zum Desktop zurückzukehren. Ich habe per Putty schon den Chrome-Browser abgeschossen. Dann ist der Bildschirm nur noch grau.
Hat jemand einen Tip für mich wie ich wieder auf den Desktop zugreifen kann? Oder wie kann man den Autostart von Grafana verhindern?

LG
Marc
PIP MPP 5048

Andreb
Beiträge: 28
Registriert: Mi 15. Jul 2020, 21:01
Wohnort: Stuhr

Re: Zugriff über xrdp auf den Raspi-Desktop funktioniert nur kurz

Beitrag von Andreb »

Hallo,

auch wenn die Antwort fast Off-Topic ist: Warum verbindest Du Dich per xrdp? Günstiger ist eine Verbindung per Browser auf die Grafana Instanz und per SSH (mit Putty) auf den Raspi falls etwas geändert werden muss.

Das mit dem "grauen Bildschirm" klingt für mich nach einem Start des Chromium Browsers im Kiosk Mode. Normalerweise müsste der Desktop vom Raspi angezeigt werden. Versuchen würde ich folgendes:

per SSH einloggen (Putty) und das Raspi Config Programm starten - ob und wenn ja wo hier Autostart Programme stehen müsstest Du suchen, ich bin eher Konsolen-Fuzzy.

Gefunden habe ich im Netz folgendes:
per SSH (Putty ) :mrgreen:
---- Anleitung zum Autostart----
sudo nano /home/pi/.config/lxsession/LXDE-pi/autostart

# Bildschirmschoner deaktivieren
#@xscreensaver -no-splash
@xset s off
@xset -dpms
@xset s noblank

# lädt Chromium im Vollbild bei einem Neustart
@chromium-browser --incognito --kiosk https://itrig.de/kiosk

--- Ende ---

Einfach schauen, ob die Eintragen in der Autostart drin sind, wenn ja auskommentieren mit '#'.
Ich hoffe das es daran hängt.

msc
Beiträge: 34
Registriert: Fr 5. Jun 2020, 14:38

Re: Zugriff über xrdp auf den Raspi-Desktop funktioniert nur kurz

Beitrag von msc »

Hallo Andreb,

ja, bisher habe ich auch nur putty und ssh für die Solaranzeige genutzt. Nun möchte ich aber eclipse installieren. Um Eclipse zu nutzen brauche ich den Desktop. Ich habe keine Lust auf der Console Code zu schreiben und zu complieren.

Ja, und wie ich schon geschrieben habe, sehe ich nach dem Start kurz den Desktop und dann öffnet sich der Chrome-Browser mit Grafana. Das würde ich gerne verhindern. Ich habe auch schon unter Autostart gesucht und nichts gefunden. Keine Ahnung wo das versteckt ist.
Vielleicht kann da der Ulrich helfen?

Dein Autostart-Ordner "/home/pi/.config/lxsession/LXDE-pi/autostart" existiert nicht und den Link: https://itrig.de/kiosk gibt es nicht.
Im Raspi Config Programm finde ich keine Option für Autostart.

Trotzdem Danke für Deine Anregungen. Villeicht hat noch jemand eine Tip.

LG
Marc
PIP MPP 5048

Bogeyof
Beiträge: 492
Registriert: Mi 13. Mai 2020, 10:04
Hat sich bedankt: 4 Mal
Danksagung erhalten: 38 Mal

Re: Zugriff über xrdp auf den Raspi-Desktop funktioniert nur kurz

Beitrag von Bogeyof »

Lies mal diesen Thread:
viewtopic.php?p=3628#p3628
An dieser Stelle wird der Chromium gestartet (bei mir war das alles wie von Ulrich beschrieben vorhanden). Du kannst auch nur den Kiosk-Mode hinten weglöschen, dann kannst du den Browser dank "X" in der rechten oberen Ecke auch selbst schließen.

msc
Beiträge: 34
Registriert: Fr 5. Jun 2020, 14:38

Re: Zugriff über xrdp auf den Raspi-Desktop funktioniert nur kurz

Beitrag von msc »

Ja, geil. Das mit dem Kiosk-Mode weglöschen. Das wars. Daaaaaaaanke!!!!!!!
PIP MPP 5048

Antworten