/dev/root SD Karte läuft voll?

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
andreas_n
Beiträge: 382
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 13 Mal
Danksagung erhalten: 13 Mal

/dev/root SD Karte läuft voll?

Beitrag von andreas_n »

Hallo Forum,

ich steh vor einem Rätsel..hab gestern via putty "df" aufgerufen..
root.jpg

unter /dev/root hab ich schon über 60% Speicher belegt und alle paar Sekunden kommt ein Block hinzu...aber ich finde den Speicherfresser nicht.
Selbst wenn ich unter /var/log die älteren log Dateien lösche, bekomme ich grad mal 1% Speicherplatz zurück.Die SD wird mit ca 1% pro Tag zu geschrieben, aber warum?

Goggel half mir auch nicht weiter.
Selbst wenn ich das auf SSD laufen lasse später, wäre ne Platte binnen Jahr voll, das kanns nicht sein.

Was tun?

Gruss
Andreas
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)

Benutzeravatar
Ulrich
Administrator
Beiträge: 2421
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 12 Mal
Danksagung erhalten: 129 Mal
Kontaktdaten:

Re: /dev/root SD Karte läuft voll?

Beitrag von Ulrich »

Hallo Andreas,

eine 8 GB SD-Karte ist auch etwas klein. Wenn sie größer ist, hast du vergessen den Speicherplatz für die Solaranzeige frei zu geben.
16 GB sollte der Solaranzeige schon mindestens zur Verfügung stehen.
--------------------------------------
Ulrich [Admin]

andreas_n
Beiträge: 382
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 13 Mal
Danksagung erhalten: 13 Mal

Re: /dev/root SD Karte läuft voll?

Beitrag von andreas_n »

Hallo Ulrich
danke fürs schnelle Feedback.

Wenn der Speicherplatzzuwachs so normal ist, dann kein Problem, ich hatte die SD nur auf Originalgrösse, so lange ich noch heftig am programmieren bin,zwecks kleinerer Sicherungsimages.

By the way, der Raspi ist seit letztem komplett Absturz nun 5 Wochen im Dauerbetrieb, ohne jedes Murren. Der Reserve Pi der mitläuft, ebenso.

Der einzige Unterschied...es ist aussen nimmer so warm, wobei ich Tempfehler nicht vermute..
und:

Die Pi´s hängen ebenfalls NOCH NICHT am Wlan. Hmm, das war vorher nicht das stabilste FunkNetz weil hier in der Nachbarschaft alles mögliche Wlangesteuert eingebaut wurde, aber es gab doch teils grosse Datenlücken, sieht man zB wenn man vom SMA Tripower das TempBit als Kurve ausliest, die Funkstrecke in den Keller mit den Fritzen war wackelig. Evtl bekam die Soft dadurch Schluckauf.Es lässt sich schlicht auch nichtmal provozieren.

Da mein Fritz.Nas jetzt läuft..

ich suche verzweifelt die drei InfluxDatenbanken, sind die unter /var/lib/influxdb/ zu finden? Bin mir als Linux DAU nicht sicher was ich wegsichern sollte per crontab.

Sonntagsgruss

Andreas
9kWp S/SO > SMA Tripower (IBN 18.6.20) + 4kWp S/SW > Growatt MIN 3000 TL-XE (IBN 31.3.21) + 2kWp Süd -19° ELWA DC Warmwasser ("IBN" 9.5.21)

Antworten