Steca Solarix PLI 5000-48

Allgemeine Informationen zum Nachbau und zum Forum
Antworten
Lengefelder
Beiträge: 4
Registriert: So 10. Dez 2017, 17:00

Steca Solarix PLI 5000-48

Beitrag von Lengefelder » So 11. Feb 2018, 16:45

Hallo,

mich hat gerade erst die Leidenschaft für Solar gepackt. Ich habe mir einen Steca Solarix Pli 5000-48 zugelegt. Leider wird der noch nicht unterstützt. Wie kann ich bitte helfen, dass sich das ändert?

VG Lengefelder

Benutzeravatar
Ulrich
Administrator
Beiträge: 205
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Steca Solarix PLI 5000-48

Beitrag von Ulrich » So 11. Feb 2018, 19:46

Hallo Herr Lengefelder,

da muss ich mich erst schlau machen. Ich frage einmal bei meinem Kontaktmann bei Steca nach, ob ich die Protocollbeschreibung bekommen kann. Ich melde mich wieder.
--------------------------------------
Ulrich [Admin]

Lengefelder
Beiträge: 4
Registriert: So 10. Dez 2017, 17:00

Re: Steca Solarix PLI 5000-48

Beitrag von Lengefelder » Mo 12. Feb 2018, 08:51

Hallo,

die habe ich bekommen.

VG Lengefelder
Dateianhänge
Solarix_PLI 5000-48_Kommunikationsprotocol_Deutsch.pdf
(178.56 KiB) 249-mal heruntergeladen

Benutzeravatar
Ulrich
Administrator
Beiträge: 205
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Steca Solarix PLI 5000-48

Beitrag von Ulrich » Mo 12. Feb 2018, 12:02

Das ist ja ein sehr einfaches Protokoll. Es gibt 2 Möglichkeiten, das Gerät mit in die möglichen Laderegler der Solaranzeige aufzunehmen:
a) Ich versuche ein Demo Gerät zu bekommen oder
b) Sie installieren einen Raspberry Pi mit der Solaranzeigensoftware an Ihrem Gerät und geben den Support Mode frei, damit ich von außerhalb auf den Raspberry mich einwählen kann.

Dazu muss der Raspberry aber einen Zugang zum Internet haben. Eine feste IP Adresse ist nicht nötig. Die Verbindung vom Wechselrichter zum Raspberry Pi muss mittels des USB Kabels erfolgen. Ich würde ca. 1 Woche für die Programmierung benötigen. Die Anzeige bleibt aber so wie sie im Moment ist. D.h. es werden nur die Daten des Ladereglerteils angezeigt:
PV-Ladestrom, PV-Ladespannung, Batteriespannung, Gerätetemperatur, PV-Leistung, PV Leistung pro Tag?

Es ist später einmal vorgesehen, dass die Anzeige noch etwas umgebaut wird, sodass Daten vom Laderegler und vom Wechselrichter angezeigt werden. Geplant ist das im Juni/Juli diesen Jahres. Falls Sie b) vorschlagen, können wir alles weitere per eMail besprechen: support@solaranzeige.de
--------------------------------------
Ulrich [Admin]

Lengefelder
Beiträge: 4
Registriert: So 10. Dez 2017, 17:00

Re: Steca Solarix PLI 5000-48

Beitrag von Lengefelder » Mo 12. Feb 2018, 15:14

Hallo,

Zugang ist, wie per Mail informiert, bereits eingerichtet mit aktueller Software.

Mir ist der Wechselrichter unwichtig, weil die 230V Strecke bei mir erfasst wird. Für mich ist nur der Ertrag Solar wichtig. Kann aber bei den anderen Nutzern anders sein. Im Raspberry steckt eine noch nicht erweiterte 32GB Micro-SD. Angeschlossen ist ein Original 7" Monitor über das Flachbandkabel.

Bleibt nur Danke zu sagen und viel Erfolg zu wünschen.

VG Lengefelder

Lengefelder
Beiträge: 4
Registriert: So 10. Dez 2017, 17:00

Re: Steca Solarix PLI 5000-48

Beitrag von Lengefelder » Do 22. Feb 2018, 06:59

Hallo,

ich komme nicht weiter. Habe den Raspberry Pi 3 per Wlan angeschlossen und das funktioniert, wenn auch das Signal ein bissel schwach ist. Reicht aber, um z. B. bei Bedarf Updates zu laden.

Ich kann keine Werte ändern. Weder Auflösung, noch Modell, Spannung usw. Ich editiere die Datei user.config.php, speichere sie mit F2 ab und F10 raus. Gebe die Zeit/Datum ein oder auch nicht, spielt keine Rolle, obwohl ich Internetanbindung habe. Bleibt auf 16.02.2018 stehen. Es bleiben immer die Default Werte drin. Auch beim Datum/Uhrzeit. Kann aber auch sein, ich sehe auf dem Monitor nur ein Bild, dass sich nie ändert?

Ändere ich die Werte via SSH und prüfe anschließend, sind meine Werte drin. Der Anzeige ist das aber egal, auch nach einem Reboot.

Was könnte ich falsch machen? Nutze das neuste Image. Aufgespielt mit dem Startmedienersteller unter Lubuntu. Editiere gleich die Dateien für WLAN und stecke die Karte in den Raspi. Habe das Flachbandkabel vom 7" Monitor entfernt und für Moment einen FULL-HD 1080 Monitor dran. Egal ob ich 1,2 oder 3 eingebe, Auflösung bleibt immer 1024x800. Gebe mittels setup meine Werte ein, ohne Erfolg. Ich kann dann setup -f aufrufen, so oft ich will, die Datei sieht immer wieder so aus, als wäre sie neu (Modell wieder 4, Auslösung wie oben, 12V usw.).

Hat bitte einer einen Tipp für mich?

VG Lengefelder
PS: Verzeih bitte Ulrich, ich habe deine funktionierende Installation kaputt gemacht. Hätte sollen vorher selbst ein Image erstellen.

Benutzeravatar
Ulrich
Administrator
Beiträge: 205
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Steca Solarix PLI 5000-48

Beitrag von Ulrich » Do 22. Feb 2018, 09:27

Ich gehe davon aus, dass Du nicht die richtige Berechtigung hast, etwas zu ändern. Der PI user hat keine Admin Rechte. Wenn Du z.B. den Editor "mcedit" starten möchtest, musst Du "sudo" davor schreiben. Damit hast Du dann Admin Rechte.

Also die config Datei mit "sudo mcedit /var/www/html/user.config.php" aufrufen, dann kann man die Datei auch mit den geänderten Werten abspeichern ohne das eine Fehlermeldung kommt. Den MC mit "sudo mc" aufrufen!
--------------------------------------
Ulrich [Admin]

Antworten