Pylontech auslesen funktioniert nicht mehr

Wenn mehr als ein Gerät an den Raspberry angeschlossen werden sollen. Z.B. ein Regler und ein Wechselrichter oder mehrere Wechselrichter. Das Maximum sind 6 Geräte pro Raspberry Pi.

Moderator: Ulrich

Benutzeravatar
gskalle
Beiträge: 10
Registriert: So 19. Jul 2020, 10:47

Re: Pylontech auslesen funktioniert nicht mehr

Beitrag von gskalle »

Scheint zu funktionieren. Werde beobachten und berichten.
Danke für den Support.

Mosti
Beiträge: 54
Registriert: Mo 6. Feb 2023, 15:06
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Pylontech auslesen funktioniert nicht mehr

Beitrag von Mosti »

Bei der Mischung von US2000B/C und US3000B/C kann ich dazu sagen das in der Effekta Anleitung steht:
1. US2000C/3000C Master
2-8. US2000B/3000B
9-16. US2000C/3000C

mehr als 7 Stk. B Varianten geht nicht hab ich selber probiert da kommt sofort alarm!
hier ein ausschnitt der Anleitung von Effekta:
Dateianhänge
Screenshot_2023-01-30-08-30-54-935_com.adobe.reader.jpg

Growatter
Beiträge: 6
Registriert: Mo 8. Mai 2023, 15:43

Re: Pylontech auslesen funktioniert nicht mehr

Beitrag von Growatter »

Habe das problem

das bei Pylontech ging es jetzt 1 Tag alels gut nun liest es die werte der Zelllen und gibt sie in Cyclen usw aus aber im Dashbaord ist auf Field Cyclen eingestellt also wird es nun manchmal falsch eingelesen in die Influx DB falsch geschrieben

Woran könnte das liegen

Aber nur alles bei Pack 1

Hier ein log mit DEBUG TRACE 8

Code: Alles auswählen

13.05. 01:03:02    -Verarbeitung von: '2.user.config.php'   Regler: 41
13.05. 01:03:02 |---------------   Start  us3000_bms.php   ----------------- 
13.05. 01:03:02    -Zentraler Timestamp: 1683932581
13.05. 01:03:02 o  -Hardware Version: 
13.05. 01:03:02 |- -Steuerdatei '2.befehl.steuerung' nicht vorhanden----
13.05. 01:03:02    -Produkt US3000C
13.05. 01:03:02    -SOC Gesamt:81
13.05. 01:03:02    -array (
  'zentralerTimestamp' => 1683932591,
  'PylonTech' => '3000',
  'SOCPacks' => 162.85135135135135,
  'Packs' => '2',
  'Pack1_Zellen' => 15,
  'Pack1_Zelle1' => 3.315,
  'Pack1_Zelle2' => 3.315,
  'Pack1_Zelle3' => 3.315,
  'Pack1_Zelle4' => 3.314,
  'Pack1_Zelle5' => 3.315,
  'Pack1_Zelle6' => 3.315,
  'Pack1_Zelle7' => 3.315,
  'Pack1_Zelle8' => 3.315,
  'Pack1_Zelle9' => 3.315,
  'Pack1_Zelle10' => 3.314,
  'Pack1_Zelle11' => 3.314,
  'Pack1_Zelle12' => 3.314,
  'Pack1_Zelle13' => 3.315,
  'Pack1_Zelle14' => 3.315,
  'Pack1_Zelle15' => 3.315,
  'Pack1_Temp_Anz' => '05',
  'Pack1_Temp1' => 21,
  'Pack1_Temp2' => 19.2,
  'Pack1_Temp3' => 19.2,
  'Pack1_Temp4' => 18.8,
  'Pack1_Temp5' => 19.7,
  'Pack1_Strom' => -1.8,
  'Pack1_Spannung' => 49.721,
  'Pack1_Ah_left' => 65.535,
  'Pack1_Mode' => 4,
  'Pack1_Ah_total' => 65.535,
  'Pack1_Ah_left_2' => 59.52,
  'Pack1_Ah_total_2' => 74,
  'Pack1_cycle' => 72,
  'Pack1_SOC' => 80.43243243243244,
  'Pack1_Status' => 192,
  'Pack1_Warn_Zelle1' => 0,
  'Pack1_Warn_Zelle2' => 0,
  'Pack1_Warn_Zelle3' => 0,
  'Pack1_Warn_Zelle4' => 0,
  'Pack1_Warn_Zelle5' => 0,
  'Pack1_Warn_Zelle6' => 0,
  'Pack1_Warn_Zelle7' => 0,
  'Pack1_Warn_Zelle8' => 0,
  'Pack1_Warn_Zelle9' => 0,
  'Pack1_Warn_Zelle10' => 0,
  'Pack1_Warn_Zelle11' => 0,
  'Pack1_Warn_Zelle12' => 0,
  'Pack1_Warn_Zelle13' => 0,
  'Pack1_Warn_Zelle14' => 0,
  'Pack1_Warn_Zelle15' => 0,
  'Pack1_Warn_Temp1' => 0,
  'Pack1_Warn_Temp2' => 0,
  'Pack1_Warn_Temp3' => 0,
  'Pack1_Warn_Temp4' => 0,
  'Pack1_Warn_Temp5' => 0,
  'Pack1_Warn_LadeStrom' => 0,
  'Pack1_Warn_Spannung' => 0,
  'Pack1_Warn_Entladestrom' => 0,
  'Pack1_Warn_Status1' => 0,
  'Pack1_Warn_Status2' => 14,
  'Pack1_Warn_Status3' => 64,
  'Pack1_Warn_Status4' => 0,
  'Pack1_Warn_Status5' => 0,
  'Pack2_Zellen' => 15,
  'Pack2_Zelle1' => 3.314,
  'Pack2_Zelle2' => 3.314,
  'Pack2_Zelle3' => 3.315,
  'Pack2_Zelle4' => 3.315,
  'Pack2_Zelle5' => 3.314,
  'Pack2_Zelle6' => 3.315,
  'Pack2_Zelle7' => 3.315,
  'Pack2_Zelle8' => 3.315,
  'Pack2_Zelle9' => 3.314,
  'Pack2_Zelle10' => 3.315,
  'Pack2_Zelle11' => 3.315,
  'Pack2_Zelle12' => 3.315,
  'Pack2_Zelle13' => 3.315,
  'Pack2_Zelle14' => 3.315,
  'Pack2_Zelle15' => 3.315,
  'Pack2_Temp_Anz' => '05',
  'Pack2_Temp1' => 20.3,
  'Pack2_Temp2' => 18.3,
  'Pack2_Temp3' => 18.4,
  'Pack2_Temp4' => 18.5,
  'Pack2_Temp5' => 19.4,
  'Pack2_Strom' => -1.8,
  'Pack2_Spannung' => 49.721,
  'Pack2_Ah_left' => 65.535,
  'Pack2_Mode' => 4,
  'Pack2_Ah_total' => 65.535,
  'Pack2_Ah_left_2' => 60.99,
  'Pack2_Ah_total_2' => 74,
  'Pack2_cycle' => 70,
  'Pack2_SOC' => 82.41891891891893,
  'Pack2_Status' => 192,
  'Pack2_Warn_Zelle1' => 0,
  'Pack2_Warn_Zelle2' => 0,
  'Pack2_Warn_Zelle3' => 0,
  'Pack2_Warn_Zelle4' => 0,
  'Pack2_Warn_Zelle5' => 0,
  'Pack2_Warn_Zelle6' => 0,
  'Pack2_Warn_Zelle7' => 0,
  'Pack2_Warn_Zelle8' => 0,
  'Pack2_Warn_Zelle9' => 0,
  'Pack2_Warn_Zelle10' => 0,
  'Pack2_Warn_Zelle11' => 0,
  'Pack2_Warn_Zelle12' => 0,
  'Pack2_Warn_Zelle13' => 0,
  'Pack2_Warn_Zelle14' => 0,
  'Pack2_Warn_Zelle15' => 0,
  'Pack2_Warn_Temp1' => 0,
  'Pack2_Warn_Temp2' => 0,
  'Pack2_Warn_Temp3' => 0,
  'Pack2_Warn_Temp4' => 0,
  'Pack2_Warn_Temp5' => 0,
  'Pack2_Warn_LadeStrom' => 0,
  'Pack2_Warn_Spannung' => 0,
  'Pack2_Warn_Entladestrom' => 0,
  'Pack2_Warn_Status1' => 0,
  'Pack2_Warn_Status2' => 14,
  'Pack2_Warn_Status3' => 64,
  'Pack2_Warn_Status4' => 0,
  'Pack2_Warn_Status5' => 0,
  'Firmware' => 260,
  'Produkt' => 'US3000C',
  'SOC' => 81.0,
  'WattstundenGesamtHeute' => 0,
  'Regler' => '41',
  'Objekt' => 'Pylontech',
)
13.05. 01:03:02 *  -Daten zur lokalen InfluxDB [ solaranzeige2 ] gesendet. 
13.05. 01:03:02    -Multi-Regler-Ausgang. 7
13.05. 01:03:09    -OK. Datenübertragung erfolgreich.
13.05. 01:03:09 |---------------   Stop   us3000_bms.php   ----------------- 

da hat es in der INflux DB die 3.315 und 3.314 als cclen und Spanung usw alles falsch eingetragen.


manchmal geht es wieder richtig für ein paar minuten manchmal nicht kam auf einmal gestern ab mittags 12 uhr ca


Vielen dank im voraus

Growatter
Beiträge: 6
Registriert: Mo 8. Mai 2023, 15:43

Re: Pylontech auslesen funktioniert nicht mehr

Beitrag von Growatter »

Sieht nun statt so
passte es über einen tag
Bild

nun immer so aus dazwischen immer einmal oder alle paar mal richtig
Bild

Bild


wenn es passt wahrscheinlich so bzw so liest es nichts aus.
im log:

Code: Alles auswählen

14.05. 18:02:11    -Verarbeitung von: '2.user.config.php'   Regler: 41
14.05. 18:02:11 |---------------   Start  us3000_bms.php   ----------------- 
14.05. 18:02:20 |---------------   Stop   us3000_bms.php   ----------------- 
und wenn es fehler haft is so aber so sollte doch nichts gespeichert werden in der datenbank
im log als versucht es 2 mal zu schrieben und funktioniert nicht richtig und dann dieser fehler das falsche werte am falschen ort in der InfluxDB sind:

Code: Alles auswählen

14.05. 18:04:11 |---------------   Start  us3000_bms.php   ----------------- 
14.05. 18:04:19    -Produkt US3000C
14.05. 18:04:19    -SOC Gesamt:49
14.05. 18:04:19    -InfluxDB  => [ Pack1 Zellen=15,Zelle1=3.318,Zelle2=3.318,Zelle3=3.318,Zelle4=0.032,Zelle5=0.582,Zelle6=0.24,Zelle7=31.232,Zelle8=0.527,Zelle9=3.318,Zelle10=3.318,Zelle11=3.318,Zelle12=0.032,Zelle13=0.582,Zelle14=0.24,Zelle15=31.232,Temp_Anz=02,Temp1=112.1,Temp2=6025.7,Temp3=6025.7,Temp4=120.5,Temp5=546.3,Strom=1792,Spannung=61.562,Ah_left=0.002,Ah_total=3.318,Ah_left_2=53.088,Ah_total_2=2097.734,Cycle=3318  1684080251
Warnungen_Pack1 Zelle1=0,Zelle2=0,Zelle3=0,Zelle4=0,Zelle5=0,Zelle6=0,Zelle7=0,Zelle8=0,Zelle9=0,Zelle10=0,Zelle11=0,Zelle12=0,Zelle13=0,Zelle14=0,Zelle15=0,Temp1=0,Temp2=0,Temp3=0,Temp4=0,Temp5=0,Ladestrom=0,Spannung=0,Entladestrom=0,Status1=0,Status2=14,Status3=64,Status4=0,Status5=0  1684080251
Pack2 Zellen=15,Zelle1=3.318,Zelle2=3.318,Zelle3=3.318,Zelle4=3.318,Zelle5=3.318,Zelle6=3.318,Zelle7=3.318,Zelle8=3.318,Zelle9=3.318,Zelle10=3.318,Zelle11=3.318,Zelle12=3.318,Zelle13=3.318,Zelle14=3.318,Zelle15=3.318,Temp_Anz=05,Temp1=20.7,Temp2=18.8,Temp3=19,Temp4=19,Temp5=19.7,Strom=-0.6,Spannung=49.77,Ah_left=65.535,Ah_total=65.535,Ah_left_2=71.277,Ah_total_2=74,Cycle=71  1684080251
Warnungen_Pack2 Zelle1=0,Zelle2=0,Zelle3=0,Zelle4=0,Zelle5=0,Zelle6=0,Zelle7=0,Zelle8=0,Zelle9=0,Zelle10=0,Zelle11=0,Zelle12=0,Zelle13=0,Zelle14=0,Zelle15=0,Temp1=0,Temp2=0,Temp3=0,Temp4=0,Temp5=0,Ladestrom=0,Spannung=0,Entladestrom=0,Status1=0,Status2=14,Status3=64,Status4=0,Status5=0  1684080251
Service Anzahl_Packs=2,Pack1_Status=,Pack2_Status=192,Be_Entladung=1791.4,Restkapazitaet_Gesamt=124.365,SOC=49  1684080251
Batterie SOC=49  1684080251
 ]
14.05. 18:04:19    -Daten nicht zur lokalen InfluxDB gesendet! info: array (
  'url' => 'http://localhost/write?db=solaranzeige2&precision=s',
  'content_type' => 'application/json',
  'http_code' => 400,
  'header_size' => 477,
  'request_size' => 1704,
  'filetime' => -1,
  'ssl_verify_result' => 0,
  'redirect_count' => 0,
  'total_time' => 0.010239,
  'namelookup_time' => 0.001148,
  'connect_time' => 0.001968,
  'pretransfer_time' => 0.002191,
  'size_upload' => 1545.0,
  'size_download' => 199.0,
  'speed_download' => 19900.0,
  'speed_upload' => 154500.0,
  'download_content_length' => 199.0,
  'upload_content_length' => 1545.0,
  'starttransfer_time' => 0.010158,
  'redirect_time' => 0.0,
  'redirect_url' => '',
  'primary_ip' => '::1',
  'certinfo' => 
  array (
  ),
  'primary_port' => 8086,
  'local_ip' => '::1',
  'local_port' => 56014,
  'http_version' => 2,
  'protocol' => 1,
  'ssl_verifyresult' => 0,
  'scheme' => 'HTTP',
  'appconnect_time_us' => 0,
  'connect_time_us' => 1968,
  'namelookup_time_us' => 1148,
  'pretransfer_time_us' => 2191,
  'redirect_time_us' => 0,
  'starttransfer_time_us' => 10158,
  'total_time_us' => 10239,
)
14.05. 18:04:24    -InfluxDB  => [ Pack1 Zellen=15,Zelle1=3.318,Zelle2=3.318,Zelle3=3.318,Zelle4=0.032,Zelle5=0.582,Zelle6=0.24,Zelle7=31.232,Zelle8=0.527,Zelle9=3.318,Zelle10=3.318,Zelle11=3.318,Zelle12=0.032,Zelle13=0.582,Zelle14=0.24,Zelle15=31.232,Temp_Anz=02,Temp1=112.1,Temp2=6025.7,Temp3=6025.7,Temp4=120.5,Temp5=546.3,Strom=1792,Spannung=61.562,Ah_left=0.002,Ah_total=3.318,Ah_left_2=53.088,Ah_total_2=2097.734,Cycle=3318  1684080251
Warnungen_Pack1 Zelle1=0,Zelle2=0,Zelle3=0,Zelle4=0,Zelle5=0,Zelle6=0,Zelle7=0,Zelle8=0,Zelle9=0,Zelle10=0,Zelle11=0,Zelle12=0,Zelle13=0,Zelle14=0,Zelle15=0,Temp1=0,Temp2=0,Temp3=0,Temp4=0,Temp5=0,Ladestrom=0,Spannung=0,Entladestrom=0,Status1=0,Status2=14,Status3=64,Status4=0,Status5=0  1684080251
Pack2 Zellen=15,Zelle1=3.318,Zelle2=3.318,Zelle3=3.318,Zelle4=3.318,Zelle5=3.318,Zelle6=3.318,Zelle7=3.318,Zelle8=3.318,Zelle9=3.318,Zelle10=3.318,Zelle11=3.318,Zelle12=3.318,Zelle13=3.318,Zelle14=3.318,Zelle15=3.318,Temp_Anz=05,Temp1=20.7,Temp2=18.8,Temp3=19,Temp4=19,Temp5=19.7,Strom=-0.6,Spannung=49.77,Ah_left=65.535,Ah_total=65.535,Ah_left_2=71.277,Ah_total_2=74,Cycle=71  1684080251
Warnungen_Pack2 Zelle1=0,Zelle2=0,Zelle3=0,Zelle4=0,Zelle5=0,Zelle6=0,Zelle7=0,Zelle8=0,Zelle9=0,Zelle10=0,Zelle11=0,Zelle12=0,Zelle13=0,Zelle14=0,Zelle15=0,Temp1=0,Temp2=0,Temp3=0,Temp4=0,Temp5=0,Ladestrom=0,Spannung=0,Entladestrom=0,Status1=0,Status2=14,Status3=64,Status4=0,Status5=0  1684080251
Service Anzahl_Packs=2,Pack1_Status=,Pack2_Status=192,Be_Entladung=1791.4,Restkapazitaet_Gesamt=124.365,SOC=49  1684080251
Batterie SOC=49  1684080251
 ]
14.05. 18:04:24    -Daten nicht zur lokalen InfluxDB gesendet! info: array (
  'url' => 'http://localhost/write?db=solaranzeige2&precision=s',
  'content_type' => 'application/json',
  'http_code' => 400,
  'header_size' => 477,
  'request_size' => 1704,
  'filetime' => -1,
  'ssl_verify_result' => 0,
  'redirect_count' => 0,
  'total_time' => 0.010573,
  'namelookup_time' => 0.000246,
  'connect_time' => 0.000248,
  'pretransfer_time' => 0.000587,
  'size_upload' => 1545.0,
  'size_download' => 199.0,
  'speed_download' => 19900.0,
  'speed_upload' => 154500.0,
  'download_content_length' => 199.0,
  'upload_content_length' => 1545.0,
  'starttransfer_time' => 0.010425,
  'redirect_time' => 0.0,
  'redirect_url' => '',
  'primary_ip' => '::1',
  'certinfo' => 
  array (
  ),
  'primary_port' => 8086,
  'local_ip' => '::1',
  'local_port' => 56014,
  'http_version' => 2,
  'protocol' => 1,
  'ssl_verifyresult' => 0,
  'scheme' => 'HTTP',
  'appconnect_time_us' => 0,
  'connect_time_us' => 248,
  'namelookup_time_us' => 246,
  'pretransfer_time_us' => 587,
  'redirect_time_us' => 0,
  'starttransfer_time_us' => 10425,
  'total_time_us' => 10573,
)
14.05. 18:04:29    -Multi-Regler-Ausgang. -11
14.05. 18:04:29    -OK. Datenübertragung erfolgreich.
14.05. 18:04:29 |---------------   Stop   us3000_bms.php   ----------------- 
Woran könnte das liegen kam da vom einen Auf den Anderen Tag ohne Änderung gemacht zu haben.

Benutzeravatar
Ulrich
Administrator
Beiträge: 5592
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 890 Mal
Kontaktdaten:

Re: Pylontech auslesen funktioniert nicht mehr

Beitrag von Ulrich »

Du hast irgendein Problem mit dem Auslesen von Pack 1.

Warum die Fehlermeldung kommt ist, weil der Status aus Pack 1 nicht ausgelesen werden kann. Du musst einmal prüfen, was mit dem Auslesen von Pack1 anders ist als Pack2. Schon an der Grafiken siehst du ja den Unterschied.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

Growatter
Beiträge: 6
Registriert: Mo 8. Mai 2023, 15:43

Re: Pylontech auslesen funktioniert nicht mehr

Beitrag von Growatter »

Danke

Ja es ging ja einen Tag dann plötzlich diese falschen werte es schreibt die Zellen werte in die Cyclen und anderen Spalten also falsch

Wie kann das vom ein auf den anderen moment falsch sein bei Packs sind ja über das selbe RS485 kabel verbunden also das Pack1 ist am RS485 angeschlossen

Wie kann man da den fehler finden wenn man nichts geändert hat und es einfach gekommen ist.


Pack1 und Pack 2 sieht gleich aus beim auslesen.

Code: Alles auswählen

13.05. 01:03:02    -Verarbeitung von: '2.user.config.php'   Regler: 41
13.05. 01:03:02 |---------------   Start  us3000_bms.php   ----------------- 
13.05. 01:03:02    -Zentraler Timestamp: 1683932581
13.05. 01:03:02 o  -Hardware Version: 
13.05. 01:03:02 |- -Steuerdatei '2.befehl.steuerung' nicht vorhanden----
13.05. 01:03:02    -Produkt US3000C
13.05. 01:03:02    -SOC Gesamt:81
13.05. 01:03:02    -array (
  'zentralerTimestamp' => 1683932591,
  'PylonTech' => '3000',
  'SOCPacks' => 162.85135135135135,
  'Packs' => '2',
  'Pack1_Zellen' => 15,
  'Pack1_Zelle1' => 3.315,
  'Pack1_Zelle2' => 3.315,
  'Pack1_Zelle3' => 3.315,
  'Pack1_Zelle4' => 3.314,
  'Pack1_Zelle5' => 3.315,
  'Pack1_Zelle6' => 3.315,
  'Pack1_Zelle7' => 3.315,
  'Pack1_Zelle8' => 3.315,
  'Pack1_Zelle9' => 3.315,
  'Pack1_Zelle10' => 3.314,
  'Pack1_Zelle11' => 3.314,
  'Pack1_Zelle12' => 3.314,
  'Pack1_Zelle13' => 3.315,
  'Pack1_Zelle14' => 3.315,
  'Pack1_Zelle15' => 3.315,
  'Pack1_Temp_Anz' => '05',
  'Pack1_Temp1' => 21,
  'Pack1_Temp2' => 19.2,
  'Pack1_Temp3' => 19.2,
  'Pack1_Temp4' => 18.8,
  'Pack1_Temp5' => 19.7,
  'Pack1_Strom' => -1.8,
  'Pack1_Spannung' => 49.721,
  'Pack1_Ah_left' => 65.535,
  'Pack1_Mode' => 4,
  'Pack1_Ah_total' => 65.535,
  'Pack1_Ah_left_2' => 59.52,
  'Pack1_Ah_total_2' => 74,
  'Pack1_cycle' => 72,
  'Pack1_SOC' => 80.43243243243244,
  'Pack1_Status' => 192,
  'Pack1_Warn_Zelle1' => 0,
  'Pack1_Warn_Zelle2' => 0,
  'Pack1_Warn_Zelle3' => 0,
  'Pack1_Warn_Zelle4' => 0,
  'Pack1_Warn_Zelle5' => 0,
  'Pack1_Warn_Zelle6' => 0,
  'Pack1_Warn_Zelle7' => 0,
  'Pack1_Warn_Zelle8' => 0,
  'Pack1_Warn_Zelle9' => 0,
  'Pack1_Warn_Zelle10' => 0,
  'Pack1_Warn_Zelle11' => 0,
  'Pack1_Warn_Zelle12' => 0,
  'Pack1_Warn_Zelle13' => 0,
  'Pack1_Warn_Zelle14' => 0,
  'Pack1_Warn_Zelle15' => 0,
  'Pack1_Warn_Temp1' => 0,
  'Pack1_Warn_Temp2' => 0,
  'Pack1_Warn_Temp3' => 0,
  'Pack1_Warn_Temp4' => 0,
  'Pack1_Warn_Temp5' => 0,
  'Pack1_Warn_LadeStrom' => 0,
  'Pack1_Warn_Spannung' => 0,
  'Pack1_Warn_Entladestrom' => 0,
  'Pack1_Warn_Status1' => 0,
  'Pack1_Warn_Status2' => 14,
  'Pack1_Warn_Status3' => 64,
  'Pack1_Warn_Status4' => 0,
  'Pack1_Warn_Status5' => 0,
  'Pack2_Zellen' => 15,
  'Pack2_Zelle1' => 3.314,
  'Pack2_Zelle2' => 3.314,
  'Pack2_Zelle3' => 3.315,
  'Pack2_Zelle4' => 3.315,
  'Pack2_Zelle5' => 3.314,
  'Pack2_Zelle6' => 3.315,
  'Pack2_Zelle7' => 3.315,
  'Pack2_Zelle8' => 3.315,
  'Pack2_Zelle9' => 3.314,
  'Pack2_Zelle10' => 3.315,
  'Pack2_Zelle11' => 3.315,
  'Pack2_Zelle12' => 3.315,
  'Pack2_Zelle13' => 3.315,
  'Pack2_Zelle14' => 3.315,
  'Pack2_Zelle15' => 3.315,
  'Pack2_Temp_Anz' => '05',
  'Pack2_Temp1' => 20.3,
  'Pack2_Temp2' => 18.3,
  'Pack2_Temp3' => 18.4,
  'Pack2_Temp4' => 18.5,
  'Pack2_Temp5' => 19.4,
  'Pack2_Strom' => -1.8,
  'Pack2_Spannung' => 49.721,
  'Pack2_Ah_left' => 65.535,
  'Pack2_Mode' => 4,
  'Pack2_Ah_total' => 65.535,
  'Pack2_Ah_left_2' => 60.99,
  'Pack2_Ah_total_2' => 74,
  'Pack2_cycle' => 70,
  'Pack2_SOC' => 82.41891891891893,
  'Pack2_Status' => 192,
  'Pack2_Warn_Zelle1' => 0,
  'Pack2_Warn_Zelle2' => 0,
  'Pack2_Warn_Zelle3' => 0,
  'Pack2_Warn_Zelle4' => 0,
  'Pack2_Warn_Zelle5' => 0,
  'Pack2_Warn_Zelle6' => 0,
  'Pack2_Warn_Zelle7' => 0,
  'Pack2_Warn_Zelle8' => 0,
  'Pack2_Warn_Zelle9' => 0,
  'Pack2_Warn_Zelle10' => 0,
  'Pack2_Warn_Zelle11' => 0,
  'Pack2_Warn_Zelle12' => 0,
  'Pack2_Warn_Zelle13' => 0,
  'Pack2_Warn_Zelle14' => 0,
  'Pack2_Warn_Zelle15' => 0,
  'Pack2_Warn_Temp1' => 0,
  'Pack2_Warn_Temp2' => 0,
  'Pack2_Warn_Temp3' => 0,
  'Pack2_Warn_Temp4' => 0,
  'Pack2_Warn_Temp5' => 0,
  'Pack2_Warn_LadeStrom' => 0,
  'Pack2_Warn_Spannung' => 0,
  'Pack2_Warn_Entladestrom' => 0,
  'Pack2_Warn_Status1' => 0,
  'Pack2_Warn_Status2' => 14,
  'Pack2_Warn_Status3' => 64,
  'Pack2_Warn_Status4' => 0,
  'Pack2_Warn_Status5' => 0,
  'Firmware' => 260,
  'Produkt' => 'US3000C',
  'SOC' => 81.0,
  'WattstundenGesamtHeute' => 0,
  'Regler' => '41',
  'Objekt' => 'Pylontech',
)
13.05. 01:03:02 *  -Daten zur lokalen InfluxDB [ solaranzeige2 ] gesendet. 
13.05. 01:03:02    -Multi-Regler-Ausgang. 7
13.05. 01:03:09    -OK. Datenübertragung erfolgreich.
13.05. 01:03:09 |---------------   Stop   us3000_bms.php   ----------------- 

Kaluschke
Beiträge: 92
Registriert: Fr 1. Jan 2021, 10:11
Hat sich bedankt: 28 Mal
Danksagung erhalten: 8 Mal

Re: Pylontech auslesen funktioniert nicht mehr

Beitrag von Kaluschke »

Hi,
ich habe auch 2 Pylontech US3000C Akkus im Keller.
Aber das Auslesen klappt absolut nicht..
Ich habe schon 2 FTDI USB Adapter probiert.
Master Batterie ist auf 115200 Baud eingestellt.
und das Kabel in den B/RS485 gesteckt.
A + B schon in beiden Klemmvarianten ausprobiert..
nur PIN 7+8 von der Pylontech genommen, da ja die C-Variante.

In Log kommt nur:
Screenshot 2023-10-07 142329.png
Muss ich den USB-Adapter noch irgendwie in der Solaranzeige anmelden/konfigurieren?
Er wird unter USB0 gelistet und ich sehe kurz bei der Abfrage eine Rote LED aufleuchten und das war es dann..
Pylontech schon neugestartet... Solaranzeige neugestartet... leider kein Erfolg.. Kabel durchgemessen... alles ok..
Solaranzeige mit SMA, GoeCharger und Tibber

Tibber-Einladungslink, 100% nachhaltiger Strom + 50€ Prämie für dich https://invite.tibber.com/ycynl893

Benutzeravatar
mr.big
Beiträge: 543
Registriert: Mi 7. Sep 2022, 12:12
Wohnort: tief im Osten...
Hat sich bedankt: 11 Mal
Danksagung erhalten: 114 Mal

Re: Pylontech auslesen funktioniert nicht mehr

Beitrag von mr.big »

115200 Baud ?

ich fahre mit

Code: Alles auswählen

$SerielleGeschwindigkeit = 9600 ;
in der .config
Und da kommen bei mir auch Daten an! :roll:
Als Adapter nehme ich den hier!

Kaluschke
Beiträge: 92
Registriert: Fr 1. Jan 2021, 10:11
Hat sich bedankt: 28 Mal
Danksagung erhalten: 8 Mal

Re: Pylontech auslesen funktioniert nicht mehr

Beitrag von Kaluschke »

ja, so wie hier beschrieben,..steht extra 115200
viewtopic.php?f=13&t=1069

Also hast du Dip 1 an deiner Masterbatterie auf 1 = 9600...

dann probiere ich nochmal auf 9600 an der Batterie und extra 9600 in der Konfig-datei..
Melde mich dann gleich wieder.. :-) Der Keller ist nicht so weit weg...
Solaranzeige mit SMA, GoeCharger und Tibber

Tibber-Einladungslink, 100% nachhaltiger Strom + 50€ Prämie für dich https://invite.tibber.com/ycynl893

Benutzeravatar
mr.big
Beiträge: 543
Registriert: Mi 7. Sep 2022, 12:12
Wohnort: tief im Osten...
Hat sich bedankt: 11 Mal
Danksagung erhalten: 114 Mal

Re: Pylontech auslesen funktioniert nicht mehr

Beitrag von mr.big »

Habe 4 US3000C und dip stehen am Master wie auf dem Bild auf 9600
dip.jpg
dip.jpg (12.22 KiB) 527 mal betrachtet

Antworten

Zurück zu „Multi-Regler-Version [ bis zu 6 Geräten an einem Raspberry Pi ]“