Wallboxsteuerung funktioniert nicht go-eCharger

PV Überschussladen mit Wallboxen. (intelligenten Ladestationen) Alles was mit der eingebauten Wallbox-Steuerung zu tun hat.

Moderator: Ulrich

Benutzeravatar
Ulrich
Administrator
Beiträge: 5604
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 891 Mal
Kontaktdaten:

Re: Wallboxsteuerung funktioniert nicht go-eCharger

Beitrag von Ulrich »

In der INI Datei weiter oben hast du angegeben, dass du keine Batterie angeschlossen hast. Wenn du das Dokument Wallbox-Steuerung liest, dann steht da, wenn keine Batterie angeschlossen ist, dann wird SOC immer zu 100% angenommen.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

Muffin
Beiträge: 46
Registriert: Do 30. Jun 2022, 07:39
Hat sich bedankt: 4 Mal
Danksagung erhalten: 1 Mal

Re: Wallboxsteuerung funktioniert nicht go-eCharger

Beitrag von Muffin »

Moin,

Das hatte ich Testweise auf no weil die Steuerung nicht laufen wollte.
(mit der Automation habe ich auch Probleme mit dem Akku... da muss ich unterschiedliche Regler auswählen aber das Läuft so ohne Probleme)
Bild


Stand jetzt:

;/ In diese Datei werden Kommentare mit einem Semikolon gestartet! [ ; ]
;*****************************************************************************
[Allgemein]
Breitengrad = 50.1143999 ; Default Wert für Frankfurt
Laengengrad = 8.6585178 ; Default Wert für Frankfurt
Neutral = no ; [yes/no] Soll die Ladeeinstellung
; nach der Ladung auf neutral
; gestellt werden?
Batterie = yes ; [yes/no] Ist eine Batterie am
; Wechselrichter angeschlossen
Einspeisung = no ; Steht die Einspeisung in Watt
; zur Verfügung und soll der Wert mit
; verarbeitet werden?
; Nur bei Stromquelle-Netz
Phasen = 3 ; 1/2/3 Mit wieviel Phasen wird geladen?
; Nicht mit wieviel die Wallbox laden
; kann, sondern wie viele Phasen
; benutzt werden.


[Geraete]
Wechselrichter = "1.user.config.php" ; Die x.user.config.php
Wallbox = "2.user.config.php" ; Die x.user.config.php
; Mögliche Geräte:
; Wechselrichter, Wallbox, BMS und Smartmeter
; Alle Kombinationen sind möglich. Nur die
; Wallbox muss immer mit dabei sein.


[PV-Quelle]
Sonnenaufgang = no ; [yes/no] Nur nach Sonnenaufgang?
VonUhrzeit = 00:00 ; Fühester Begin der Ladung
BisUhrzeit = 24:00 ; Spätester Begin der Ladung
MinMilliAmpere = 6000 ; Milliampere! 6000 = 6 Ampere
MaxMilliAmpere = 12000 ; Milliampere! 13000 = 13 Ampere
AbSOC = 80 ; Batteriekapazität 0 bis 100 %
BisSOC = 55 ; Niedrigste Batteriekapazität 50 %
MinSolarleistung = 3500 ; Minimale PV Solarleistung in Watt
; ab der die Ladung beginnt.
MaxEnergie = 0 ; Maximale Ladung in Wattstunden
; 0 = Option ausgeschaltet
; 1000 = minimum (1kWh)
; Funktioniert nicht bei allen Wallboxen
Inselanlage = no ; [yes/no] Handelt es sich um
; eine Inselanlage?
Eigenverbrauch = 1000 ; geschätzter Eigenverbrauch, der nicht
; zum Laden der Autobatterie zur Verfügung
; steht.
NurBeiSonne = yes ; [yes/no] Ladung nur bei PV Leistung > 300 W
; Kleiner 300 W wird die Ladung unterbrochen.
Intervall = 3 ; [Minuten] Wie oft sollen Änderungen am
; Ladestrom vorgenommen werden?
; 3 = alle 3 Minuten werden Änderungen,
; falls erforderlich, durchgeführt.
; Gültige Werte = 1 bis 9 | Default = 3


[Batterie-Quelle]
Sonnenaufgang = no ; [yes/no] Nur nach Sonnenaufgang?
VonUhrzeit = 00:00 ; Fühester Begin der Ladung
BisUhrzeit = 24:00 ; Spätester Begin der Ladung
MinMilliAmpere = 6000 ; Milliampere! 6000 = 6 Ampere
MaxMilliAmpere = 8000 ; Milliampere! 13000 = 13 Ampere
AbSOC = 80 ; Batteriekapazität 0 bis 100 %
BisSOC = 55 ; Niedrigste Batteriekapazität 50 %
Kap60 = 60 ; Batteriekapazität in % bis wann
; das Auto mit MaxMilliAmpere geladen
; werden soll
MaxEnergie = 0 ; Maximale Ladung in Wattstunden
; 0 = Option ausgeschaltet
; 1000 = minimum (1kWh)


[Netz-Quelle]
Sonnenaufgang = no ; [yes/no] Nur nach Sonnenaufgang?
VonUhrzeit = 00:00 ; Fühester Begin der Ladung
BisUhrzeit = 24:00 ; Spätester Begin der Ladung
MinMilliAmpere = 6000 ; Milliampere! 6000 = 6 Ampere
MaxMilliAmpere = 16000 ; Milliampere! 13000 = 13 Ampere
AbSOC = 90 ; Batteriekapazität 0 bis 100 %
BisSOC = 55 ; Niedrigste Batteriekapazität 50 %
Kap60 = 60 ; Batteriekapazität in % bis wann
; das Auto mit MaxMilliAmpere geladen
; werden soll
MaxEnergie = 0 ; Maximale Ladung in Wattstunden
; 0 = Option ausgeschaltet
; 1000 = minimum (1kWh)





Es wird mir immer angezeigt das der SOC100% ist egal welche einstellungen ich vornehme.

WR und Speicher von Huawei und mit Modbus angeschlossen nicht per LAN/W LAN.

über hilfe wäre ich sehr dankbar.
Dateianhänge
Screenshot 2023-03-24 174354.png

Benutzeravatar
Ulrich
Administrator
Beiträge: 5604
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 891 Mal
Kontaktdaten:

Re: Wallboxsteuerung funktioniert nicht go-eCharger

Beitrag von Ulrich »

Du verwechselt hier etwas. Die Automation ist eine einfache Steuerung für Sonoff /Shelly Relais.

Die Wallbox Steuerung ist eine Steuerung ausschließlich für bestimmte Walboxen. Bitte lese die dazugehörigen Dokumente.

Was ist denn dein Anliegen? Geht es um die Wallbox Steuerung oder um die Automation? Beide haben miteinander nichts zu tun.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

Muffin
Beiträge: 46
Registriert: Do 30. Jun 2022, 07:39
Hat sich bedankt: 4 Mal
Danksagung erhalten: 1 Mal

Re: Wallboxsteuerung funktioniert nicht go-eCharger

Beitrag von Muffin »

Das die beiden nichts miteinander zu tun haben ist mir klar.

Bei der Wallbox Steuerung wird mir immer ein SOC100% angezeigt und somit funktioniert die Steuerung anscheind nicht richtig.

Das mit der Automatiotion habe ich nur mit eingebunden weil wen ich den Regler auf 62 statt auf 56 stellen muss damit der SOC Stand ermittelt werden kann.

(es kann ja sein das diese Probleme zusammen hängen?)

Huptsächlich geht es um die Wallbox. warum er immer ein SOC von 100 ausliest?

Benötigst du evtl die Dateien für Walbox Steuerung usw?

TeamO
Beiträge: 1150
Registriert: Mo 22. Jun 2020, 08:58
Wohnort: Ulm / Neu-Ulm
Hat sich bedankt: 24 Mal
Danksagung erhalten: 231 Mal

Re: Wallboxsteuerung funktioniert nicht go-eCharger

Beitrag von TeamO »

@Ulrich:
Schau Dir mal Zeilen 477-481 in der wallbox_steuerung.php an. Ich denke da liegt der Hund begraben :)
Für Regler 56 wird der Wert vom SOC nicht abgefragt und somit auf 100 gesetzt.
Und bei der Automation ist in der Datenbank datenauswahl.sqlite3 auch kein Eintrag bei Regler 56 für BMSMeasurement und SOC

@Muffin:
Teste mal die hier angehängte wallbox_steuerung.php
Hier habe ich es entsprechend eingefügt.

Die datenauswahl.sqlite3 für die Automation kann ich leider nicht angepasst anhängen. Der Dateityp wird nicht unterstützt.
Dateianhänge
wallbox_steuerung.php
(88 KiB) 103-mal heruntergeladen
Gruß Timo

Auflistung Geräte/Dashboards/Anschlussart
Datenbankfelder der einzelnen Geräte
GANZ WICHTIG: Überblick der vorhandenen Anleitungen

Fertige Komplett-Systeme gibt es hier anfragen[AT]bauer-timo[.]de

Tibber Invite (100% Öko-Strom + 50€ Bonus)

Benutzeravatar
Ulrich
Administrator
Beiträge: 5604
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 891 Mal
Kontaktdaten:

Re: Wallboxsteuerung funktioniert nicht go-eCharger

Beitrag von Ulrich »

OK. Jetzt habe ich es begriffen. Im Update ist es jetzt korrigiert.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

Muffin
Beiträge: 46
Registriert: Do 30. Jun 2022, 07:39
Hat sich bedankt: 4 Mal
Danksagung erhalten: 1 Mal

Re: Wallboxsteuerung funktioniert nicht go-eCharger

Beitrag von Muffin »

Moin zusammen,

@TeamO: ja da lag der Fehler.

hier der Log nach dem ändern:
24.03. 19:29:01 |--> - - - - - - - - - Start WB Steuerung - - - - - - - -
24.03. 19:29:01 INFO Grundlage der Steuerung ist die INI Datei '2.wallbox.steuerung.ini'.
24.03. 19:29:01 INFO Ladung nur bei genügend Sonnenenergie. [ INI > NurBeiSonne = yes ]
24.03. 19:29:01 INFO Eigenverbrauch laut INI Datei: 1000 Watt
24.03. 19:29:03 INFO aktuelle Solarleistung - Eigenverbrauch: -1000 Watt
24.03. 19:29:03 INFO aktueller SOC der Batterie: 100%
24.03. 19:29:03 INFO Ladestation bereit zum Laden.
24.03. 19:29:03 INFO Kabel angeschlossen und beidseitig verriegelt.
24.03. 19:29:03 INFO Ladestatus: 2
24.03. 19:29:03 INFO Ladepause: 1
24.03. 19:29:03 INFO StationBereit: 0
24.03. 19:29:03 INFO Intervall: 3
24.03. 19:29:03 INFO Solarleistung: 0
24.03. 19:29:03 INFO Kabelstatus: 7
24.03. 19:29:03 INFO Ladequelle: PV-Module.
24.03. 19:29:03 INFO Die Einschaltzeit stimmt: 19:29
24.03. 19:29:03 WARN Es soll nur bei Sonne geladen werden.
24.03. 19:29:03 INFO Die Minimale Solarleistung von 3500 Watt ist noch nicht erreicht.
24.03. 19:29:03 ENDE |
24.03. 19:29:03 ENDE ---------------------------------------------------------
24.03. 19:30:01 |--> - - - - - - - - - Start WB Steuerung - - - - - - - -
24.03. 19:30:01 INFO Grundlage der Steuerung ist die INI Datei '2.wallbox.steuerung.ini'.
24.03. 19:30:01 INFO Ladung nur bei genügend Sonnenenergie. [ INI > NurBeiSonne = yes ]
24.03. 19:30:01 INFO Eigenverbrauch laut INI Datei: 1000 Watt
24.03. 19:30:03 INFO aktuelle Solarleistung - Eigenverbrauch: -1000 Watt
24.03. 19:30:03 INFO aktueller SOC der Batterie: 1%
24.03. 19:30:03 INFO Ladestation bereit zum Laden.
24.03. 19:30:03 INFO Kabel angeschlossen und beidseitig verriegelt.
24.03. 19:30:03 INFO Ladestatus: 2
24.03. 19:30:03 INFO Ladepause: 1
24.03. 19:30:03 INFO StationBereit: 0
24.03. 19:30:03 INFO Intervall: 3
24.03. 19:30:03 INFO Solarleistung: 0
24.03. 19:30:03 INFO Kabelstatus: 7
24.03. 19:30:03 INFO Ladequelle: PV-Module.
24.03. 19:30:03 INFO Die Einschaltzeit stimmt: 19:30
24.03. 19:30:03 WARN Es soll nur bei Sonne geladen werden.
24.03. 19:30:03 INFO Die Minimale Solarleistung von 3500 Watt ist noch nicht erreicht.
24.03. 19:30:03 ENDE |
24.03. 19:30:03 ENDE ---------------------------------------------------------

So sollte es klappen :)

Morgen soll es wieder Wechselhaft werden vom Wetter da kann ich das genau beobachten und noch genauer einstellen.
(duch das ganze probieren muss ich dann noch ein Paar Feineinstellungen machen)

Klasse vielen Dank euch allen.

Und wegen der Automatisierung das funktioniert ja so mit den unterschiedlichen Reglern. Das habe ich auch nur durch ausprobieren herausgefunden.

bin mit diesem Projekt "Solaranzeige" eucht sehr zufrieden (obwohl auch einiges etwas Knifflig ist wenn die Technik nicht mitspielen will)

Habe immer alles auf einem Tablet im Blick und die Frau wollte auch eine Anzeige haben damit sie bescheid weiss wann die Wäsche Fertig ist :D

Echt Cool auch das hier immer schnell Hilfe gefunden wird. sowas gibt es nicht mal in manchen Freundeskreisen ;)

Ich werde das Moin mal ausgibig Testen und noch mal Feedback geben :geek:

micha.kopf@gmail.com
Beiträge: 5
Registriert: Di 12. Apr 2022, 16:27

Re: Wallboxsteuerung funktioniert nicht go-eCharger

Beitrag von micha.kopf@gmail.com »

Hallo Ihr Lieben,
ich bin durch die Suchfunktion auf den Thread gestoßen und habe leider ein ähnliches Problem.
Bei mir ist der SOC auch immer auf 100%. Ich benuzte FRONIUS SYMO WR und Go-e V3 Wallbox.
Durch den SOC 100% wird der Ladesstrom bei SOC 60% und bis SOC nicht runter geregelt.

Wo wird denn in der wallbox_steuerung.php der SOC ausgelesen. Konnte es nicht finden.

Ein update mit sudo_update habe ich gemacht.. Jemand eine Idee?

Danke schonmal für eine Rückmeldung. Ich hoffe mir kann jemand helfen :-)

micha.kopf@gmail.com
Beiträge: 5
Registriert: Di 12. Apr 2022, 16:27

Re: Wallboxsteuerung funktioniert nicht go-eCharger

Beitrag von micha.kopf@gmail.com »

Guten Morgen,
mir ist aufgefallen, dass für den Regler 12 der SOC nicht aus "Batterie" ausgelesen wird, sondern aus der "Service" mit Akkustand_SOC.
Ich habe die Abfrage jetzt draufhin in der wallbox_steuerung.php ab Zeile 390 unter Case 12 geändert. Unelegant wahrscheinlich mit meinen überschaubaren PHP Schulkenntnissen, aber bisher funktioniert die Anzeige SOC korrekt. Heute Mittag weiß ich ob die Steuerung damit auch funktioniert.

Code: Alles auswählen

//case 12 Symo WR von Hand eingefügt	    
	    case 12:
	        $ch = curl_init( 'http://localhost/query?db='.$wrDatenbankname.'&precision=s&q='.urlencode( 'select * from Service order by time desc limit 1' ));
        	$rc = datenbank( $ch );
	          if (!isset($rc["JSON_Ausgabe"]["results"][0]["series"])) {
        	    log_schreiben( "Es fehlt die Datenbank '".$wrDatenbankname."' mit dem Measurement Batterie oder sie ist leer.", "|- ", 1 );
        	    log_schreiben( "Wenn es das Measurement nicht gibt, dann bitte Batterie=no in der INI Datei eintragen. Es geht auch ohne Batterieüberwachung.", "|- ", 1 );
        	    goto Ausgang;
        	}
        	for ($h = 1; $h < count( $rc["JSON_Ausgabe"]["results"][0]["series"][0]["columns"] ); $h++) {
        	$DB3[$rc["JSON_Ausgabe"]["results"][0]["series"][0]["columns"][$h]] = $rc["JSON_Ausgabe"]["results"][0]["series"][0]["values"][0][$h];
        	}
        	log_schreiben( "Datenbank: '".$wrDatenbankname."' ".print_r( $DB2, 1 ), "", 4 );
		$SOC =$DB3["Akkustand_SOC"];
		break;

//Ende eigener Eingabe

Antworten

Zurück zu „Wallbox Steuerung [intelligente Ladestationen ]“