JK-BMS Frage

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Hat se nicht alle
Beiträge: 122
Registriert: Fr 6. Aug 2021, 07:27
Hat sich bedankt: 17 Mal
Danksagung erhalten: 24 Mal

Re: JK-BMS Frage

Beitrag von Hat se nicht alle »

Ähhh.... ich hab jetzt mal keine Ahnung WAS du da ausgelesen hast, aber die

/var/www/log/solaranzeige.log

ist das nicht, denn das Ergebnis sollte in etwa so aussehen:

09.03. 06:17:35 |------------ Start JK_bms.php ----------------------------
09.03. 06:17:35 -MQTT Daten zum [ localhost ] senden.
09.03. 06:17:35 -Start DB transfer
09.03. 06:17:35 * -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
09.03. 06:17:35 -Multi-Regler-Ausgang. 7
09.03. 06:17:35 MQT-MQTT Daten zum Broker gesendet bzw. vom Broker empfangen. Adresse: localhost Port: 1883
09.03. 06:17:45 -Die seriellen Schnittstellen werden initialisiert.
09.03. 06:17:46 -Device: /dev/hidraw0 Keine USB / Serielle Schnittstelle.
Infini 10k - 15kWp - 16kW LiFePO4 - JK BMS - SDM630 - 10kW WP

xango
Beiträge: 124
Registriert: Mo 9. Mär 2020, 09:40
Hat sich bedankt: 1 Mal

Re: JK-BMS Frage

Beitrag von xango »

doch doch, ich habe nur die hinteren Zeile betreffs USB kopiert. Im Anfang steht ebenso das was Du gelistet hast. Allerdings ohne daß das BMS ausgelesen wurde. Da heißt es:
Start JKBMS
Stop JKBMS
Kann ich aber auch nochmal posten. Muß dazu wieder auf JKBMS umkonfigurieren. Aktuell läuft auf dem PI die Abfrage des WR.
Wenn es dann mit dem BMS klappt habe ich vor eine Multiregler Adaption zu machen. Erstmal muß das mit dem BMS als Single funktionieren.

xango
Beiträge: 124
Registriert: Mo 9. Mär 2020, 09:40
Hat sich bedankt: 1 Mal

Re: JK-BMS Frage

Beitrag von xango »

10.03. 11:57:28 -Regler: 83
10.03. 11:57:28 -Regler erkannt: /dev/ttyUSB0
10.03. 11:57:28 -Device: /dev/ttyUSB0 wird in die user.config.php eingetragen
10.03. 11:57:28 -Zeile gefunden. USB Device kann ausgetauscht werden. Index:

10.03. 11:57:28 -Zeile gefunden. Raspberry Modell kann eingetragen werden. In

10.03. 11:57:28 -Es handelt sich um ein 32 Bit System.
10.03. 11:58:13 |------------ Start JK_bms.php ---------------------------
10.03. 11:58:13 -no answer from USB in 210ms)!
10.03. 11:58:13 !! -Fehler USB Command
10.03. 11:58:13 |------------ Stop JK_bms.php (0s) -----------------------
10.03. 11:59:01 |------------ Start JK_bms.php ---------------------------
10.03. 11:59:01 -no answer from USB in 210ms)!
10.03. 11:59:01 !! -Fehler USB Command
10.03. 11:59:01 |------------ Stop JK_bms.php (0s) -----------------------
10.03. 12:00:02 |------------ Start JK_bms.php ---------------------------
10.03. 12:00:02 -no answer from USB in 210ms)!
10.03. 12:00:02 !! -Fehler USB Command

Hat se nicht alle
Beiträge: 122
Registriert: Fr 6. Aug 2021, 07:27
Hat sich bedankt: 17 Mal
Danksagung erhalten: 24 Mal

Re: JK-BMS Frage

Beitrag von Hat se nicht alle »

Na also... geht doch.

Die Nachricht ist eindeutig: Keine Antwort von der USB Schnittstelle innerhalb von 210ms.

Jetzt müssen wir nur noch herausfinden warum nicht, oder Ulrich hat noch eine weitere Erklärung dafür, denn er weiß welches Modul diese
Meldung in die Log Datei geschrieben hat.

Der verwendete USB RS484 Adapter hat wie ich gesehen habe für Senden und Empfangen je eine LED.

1. Leuchtet eine der LED (TX) im Minutentakt auf?
2. Leuchtet die andere LED (RX) dann auch auf?
Infini 10k - 15kWp - 16kW LiFePO4 - JK BMS - SDM630 - 10kW WP

xango
Beiträge: 124
Registriert: Mo 9. Mär 2020, 09:40
Hat sich bedankt: 1 Mal

Re: JK-BMS Frage

Beitrag von xango »

TX leuchtet im ca. 1min Takt auf aber nicht RX. Wenn ich aber den daneben anstecke (bezeichnet mit CAN) leuchtet auch die RX auf. Das ERgebnis ist dann das:

)
10.03. 15:26:40 -Regler: 83
10.03. 15:26:40 -Regler erkannt: /dev/ttyUSB0
10.03. 15:26:40 -Device: /dev/ttyUSB0 wird in die user.config.php eingetragen
10.03. 15:26:40 -Zeile gefunden. USB Device kann ausgetauscht werden. Index:

10.03. 15:26:40 -Zeile gefunden. Raspberry Modell kann eingetragen werden. In

10.03. 15:26:40 -Es handelt sich um ein 32 Bit System.
10.03. 15:27:01 |------------ Start JK_bms.php ---------------------------
10.03. 15:27:01 !! -invalid frame! ff instead of 0x79
10.03. 15:27:01 -ff80ff80ffffffff80ffffffffff80ffffffff
10.03. 15:27:01 |------------ Stop JK_bms.php (0s) --------------------

Habe das ganze auch an einem neuen 2ten BMS angeschlossen. Dort ist ein R-Teiler mit 10 R's dran die quasi eine Batterie simuliert. Dort funktioniert es auch nicht.
Hmmm?
Ich hatte es auch schon mit einem USB-Ser Adapter alleine (TX/RX/GND) probiert. Geht auch nicht.

Hat se nicht alle
Beiträge: 122
Registriert: Fr 6. Aug 2021, 07:27
Hat sich bedankt: 17 Mal
Danksagung erhalten: 24 Mal

Re: JK-BMS Frage

Beitrag von Hat se nicht alle »

xango hat geschrieben:
Fr 10. Mär 2023, 15:34
TX leuchtet im ca. 1min Takt auf aber nicht RX. Wenn ich aber den daneben anstecke (bezeichnet mit CAN) leuchtet auch die RX auf. Das ERgebnis ist dann das:

Ok, ich versuch mal den Trouble zu shooten:

Wenn TX leuchtet, dann geht die Anfrage von der Solaranzeige bis zum JK RS485 Adapter raus.
Ob der JK RS485 Adapter die Anfrage an das BMS weiterleitet ist weiter offen.
Wenn RX nicht leuchtet, dann kommt keine Antwort vom JK RS485 Adapter an
Ob der JK RS485 Adapter vom BMS eine Antwort bekommen hat ist weiterhin offen
Der CAN Anschluss kann zwar keine richtige Antwort liefern, aber....er zeigt dass der JK RS485 Adapter zumindest eine Antwort an das USB interface weiterreicht.

Damit lässt sich feststellen, dass die Konfiguration des USB Adapters und der Adapter mit hoher Wahrscheinlichkeit richtig funktioniert.
Ob der JK RS485 Adapter funktioniert bleibt weiter fraglich


)
10.03. 15:26:40 -Regler: 83
10.03. 15:26:40 -Regler erkannt: /dev/ttyUSB0
10.03. 15:26:40 -Device: /dev/ttyUSB0 wird in die user.config.php eingetragen
10.03. 15:26:40 -Zeile gefunden. USB Device kann ausgetauscht werden. Index:

10.03. 15:26:40 -Zeile gefunden. Raspberry Modell kann eingetragen werden. In

10.03. 15:26:40 -Es handelt sich um ein 32 Bit System.
10.03. 15:27:01 |------------ Start JK_bms.php ---------------------------
10.03. 15:27:01 !! -invalid frame! ff instead of 0x79
10.03. 15:27:01 -ff80ff80ffffffff80ffffffffff80ffffffff
10.03. 15:27:01 |------------ Stop JK_bms.php (0s) --------------------

Habe das ganze auch an einem neuen 2ten BMS angeschlossen. Dort ist ein R-Teiler mit 10 R's dran die quasi eine Batterie simuliert. Dort funktioniert es auch nicht.

Somit scheidet das BMS als Fehlerquelle weitgehend aus, weil statistisch gesehen "der Bär" nicht zweimal hinter dem gleichen Busch sitzt".
Es verbleibt der JK RS485 Adapter als wahrscheinlichste Fehlerquelle


Hmmm?
Ich hatte es auch schon mit einem USB-Ser Adapter alleine (TX/RX/GND) probiert. Geht auch nicht.
Gut, das kann auch nicht gehen, weil die Solaranzeige ein RS485 Frame erwartet und keinen reinen seriellen Datenstrom...

Ich würde nun vermuten, dass das JK RS485 Interface die Fehlerquelle ist. Wenn das nicht der Fall ist, dann liegt es an deinem Karma... :mrgreen: :mrgreen:
Infini 10k - 15kWp - 16kW LiFePO4 - JK BMS - SDM630 - 10kW WP

xango
Beiträge: 124
Registriert: Mo 9. Mär 2020, 09:40
Hat sich bedankt: 1 Mal

Re: JK-BMS Frage

Beitrag von xango »

Ich meine gelesen zu haben das Ulrich mal schrieb das es mit einem reinen USB-UART (ser) Adapter funktionieren würde.

Habe soeben das auch noch ma probiert. Stelle aber fest das der Adapter nicht erkannt wird. Vemute das meine USB Mini B Kabel nur die Stromversorgung beinhaltet denn am PC angesteckt meldet der sich nicht mit einem COM Port.
Nächste Woche werde ich ein neues Kabel kaufen. Im übrigen ist der Ser Adapter ein AZdelivery Clone.
20230310_155659_HDR.jpg

xango
Beiträge: 124
Registriert: Mo 9. Mär 2020, 09:40
Hat sich bedankt: 1 Mal

Re: JK-BMS Frage

Beitrag von xango »

Leider wird der oben gezeigte USB-Ser Adapter nicht erkannt auch mit neuem USB Mini B Kabel.
Beim anstecken leuchtet die Power LED und ganz kurz die beiden TEN/REN LEDs auf.
Und das bei Beiden dieser Teile die ich habe.
Habe auch diverse andere Adapter probiert: Prolifiric, CH340. Die Beiden letzten werden erkannt kommen aber keine Daten bzw. falsche
Und wie schon einige Beiträge vorher beschrieben: mit der Kombi USB-RS485 und RS485-JKBMS funktioniert es auch nicht.

Deshalb die Frage an alle JKBMS Betreiber hier im Forum: mit welchem Adapter funktioniert es bei Euch?

septemberregen
Beiträge: 17
Registriert: Do 9. Mär 2023, 10:35

Re: JK-BMS Frage

Beitrag von septemberregen »

xango hat geschrieben:
Mo 13. Mär 2023, 17:09
Deshalb die Frage an alle JKBMS Betreiber hier im Forum: mit welchem Adapter funktioniert es bei Euch?
Ich hätte die gleich Frage, gibt es ein fertiges Kabel vom BMS zum Pi 4, wenn ja wo, oder muss man es selber herstellen, wenn ja aus welchen Komponenten?

Ich habe ein Jikong BMS JK-B2A24S-15P (aktuell gekauft):
Dateianhänge
Bild19.jpg

xango
Beiträge: 124
Registriert: Mo 9. Mär 2020, 09:40
Hat sich bedankt: 1 Mal

Re: JK-BMS Frage

Beitrag von xango »

Ist das gleiche BMS was ich vor kurzem von ICGOGOGO gekauft habe.

Habe mittlerweile direkt bei AZdelivery einen usb-uart adapter gekauft in der Hoffnung das dieser funktioniert. Falls ja wären die Beiden beim Ali gekauften Fakes. (Fehler: usb port kann nicht geöffnet werden laut Solaranzeige.log)

Antworten

Zurück zu „Allgemeines“