Alles in 12 Volt Ausführung....

Anzeigen in Fahrzeugen wie Wohnmobilen oder Schiffen.
Benutzeravatar
Ulrich
Administrator
Beiträge: 122
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Alles in 12 Volt Ausführung....

Beitragvon Ulrich » Mo 29. Aug 2016, 19:25

Diese Rubrik ist für alle speziellen Fragen zum Nachbau, wenn alles mit 12 Volt laufen soll. Also Fragen zum 12 Volt Monitor, 12 Volt Router, 12 - 5 Volt Raspberry Pi Netzteil usw.
--------------------------------------
Ulrich [Admin]

Jooker
Beiträge: 5
Registriert: Do 13. Apr 2017, 00:15

Re: Alles in 12 Volt Ausführung....

Beitragvon Jooker » Mi 19. Apr 2017, 23:40

Sehr geehrter Ulrich,
ich habe mich in Ihrem Forum in den letzen Wochen informiert und möchte Ihnen mein Hochachtung für Ihre Arbeit aussprechen.

Da ich schon immer etwas mit einem Raspberry machen wollte, konnte ich das nun mit Ihrer Anwendung durchführen.
Ich verwende einen Raspberry Pi3 Modell B mit einem SCplus 15A Solarcontroller, an welchem ich ein 12V / 10W Solarmodul und eine 12 V / 7Ah Batterie angeschlossen habe. Zum Test habe ich am Lastausgang eine Autosteckdose verbunden und diverse Geräte betrieben und geladen.
Leider wird am Raspberry in der großen Anzeige links oben kein Solar Ladestrom angezeigt und das Diagramm daneben zeigt nur eine 0-Linie mit der Uhrzeit. Daher gibt es auch keine Balken bei der Gesamtleistung. Nur die kleinen Instrumente Batterie, Solarpanel und Verbrauch, zeigen Daten an. Ist vielleicht das Solarmodul zu schwach?
Leider konnte ich das Problem nicht beheben und möcht fragen an was das liegen könnte. Ich muss noch erwähnen, dass ich am Solar-Controller mit der geräteeigenen Windows Software keine Einstellungen verändert habe. Müsste man hier vielleicht etwas konfigurieren?

Mit freundlichem Dank für einen Tip und Grüße aus Österreich,
Reinhard

Ps: Falls Sie für eine Diagnose Fotos benötigen, werd ich diese nachreichen.

Benutzeravatar
Ulrich
Administrator
Beiträge: 122
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Alles in 12 Volt Ausführung....

Beitragvon Ulrich » Do 20. Apr 2017, 08:49

Hallo Reinhard,

hängt der Raspberry am Internet? Dann wäre die schnellste und einfachste Lösung, dass Du Strg + Alt + F1 drückst und in dem Command Fenster erst statusmail + ENTER eingeben und dann support und ENTER eingeben.

Danach kann ich in Deinem Raspberry mal nachsehen, was da nicht richtig läuft.

Falls der Raspberry nicht am Internet hängt, könntest Du mir die LOG Datei per eMail zusenden? Die liegt unter /var/www/log
Falls sie zu groß ist, dann einmal die Datei löschen und den Raspberry danach noch einmal 5 Minuten laufen lassen. Dann sollte sie nicht mehr so groß sein.
--------------------------------------
Ulrich [Admin]

Jooker
Beiträge: 5
Registriert: Do 13. Apr 2017, 00:15

Re: Alles in 12 Volt Ausführung....

Beitragvon Jooker » Do 20. Apr 2017, 11:12

Hallo Ulrich,

vielen Dank für die rasche Antwort.
Ich habe meinen Raspberry zwar im Wlan und kann am Notebook die Anzeige aufrufen, aber die komplette Internetverbindung habe ich nich nicht eingerichtet. Daher hänge ich die LOG Datei im Code-Fenster an diesen Beitrag an.

Möchte noch anmerken, dass ich dine Debain/Linux Newbie bin. Ich kenn zwar die gundlegenden Dinge, aber mit dem Interpretieren von LOG Dateien bin ich dann doch etwas überfordert. Ich weiß nicht, ob eventuell die Verwendung meiner Funktastatur mit Touchpad durch den USB Empfänger einen Fehler beim Auslesen verursacht.

Danke fürs durchsehen,
Lg Reinhard

Code: Alles auswählen

20.04. 10:43:52 |-----------   Stop  usb_ivt_auslesen.php   ------------------- 
20.04. 10:45:08 
T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh= 1
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=04.04
S:  Manufacturer=Linux 4.4.38-v7+ dwc_otg_hcd
S:  Product=DWC OTG Controller
S:  SerialNumber=3f980000.usb
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480 MxCh= 5
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=02 MxPS=64 #Cfgs=  1
P:  Vendor=0424 ProdID=9514 Rev=02.00
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=2mA
I:  If#= 0 Alt= 1 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=02 Driver=hub

T:  Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#=  3 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=ff(vend.) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=0424 ProdID=ec00 Rev=02.00
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=2mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=ff Driver=smsc95xx

T:  Bus=01 Lev=02 Prnt=02 Port=02 Cnt=02 Dev#=  4 Spd=12  MxCh= 0
D:  Ver= 1.01 Cls=02(commc) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=ffff ProdID=0005 Rev=01.00
S:  Manufacturer=LPCUSB
S:  Product=SC/SCD Series Solar Charger
S:  SerialNumber=SN.
C:  #Ifs= 2 Cfg#= 1 Atr=c0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
I:  If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm

T:  Bus=01 Lev=02 Prnt=02 Port=04 Cnt=03 Dev#=  5 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=24ae ProdID=1001 Rev=01.07
S:  Manufacturer=MOSART Semi.
S:  Product=Rapoo 2.4G Wireless Touch Desktop 
C:  #Ifs= 2 Cfg#= 1 Atr=a0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=01 Driver=usbhid
I:  If#= 1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=usbhid

20.04. 10:45:09 array (
  18 => 'None 00.0: 11300 Partition',
  '' => '[Created at block.414]',
  'Unique ID' => 'l7UW.SE1wIdpsiiC',
  'Parent ID' => 'HAKk.Fxp0d3BezAE',
  'SysFS ID' => '/class/block/mmcblk0/mmcblk0p1',
  'Hardware Class' => 'partition',
  'Model' => '"Partition"',
  'Device File' => '/dev/mmcblk0p1',
  'Device Files' => '/dev/mmcblk0p1, /dev/disk/by-id/mmc-SL16G_0x62291f88-part1, /dev/disk/by-label/boot, /dev/disk/by-path/platform-3f202000.sdhost-part1, /dev/disk/by-uuid/04FE-51E9',
  'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
  'Attached to' => '#17 (Disk)',
)
20.04. 10:45:09 array (
  19 => 'None 00.0: 11300 Partition',
  '' => '[Created at block.414]',
  'Unique ID' => 'CJka.SE1wIdpsiiC',
  'Parent ID' => 'HAKk.Fxp0d3BezAE',
  'SysFS ID' => '/class/block/mmcblk0/mmcblk0p2',
  'Hardware Class' => 'partition',
  'Model' => '"Partition"',
  'Device File' => '/dev/mmcblk0p2',
  'Device Files' => '/dev/mmcblk0p2, /dev/disk/by-id/mmc-SL16G_0x62291f88-part2, /dev/disk/by-path/platform-3f202000.sdhost-part2, /dev/disk/by-uuid/e6e7f776-11a4-4cd7-b4fd-c44ecdbfcf90',
  'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
  'Attached to' => '#17 (Disk)',
)
20.04. 10:45:09 array (
  20 => 'USB 00.0: 0200 Ethernet controller',
  '' => '[Created at usb.122]',
  'Unique ID' => 'lfzD.Sed3PcmdZ23',
  'Parent ID' => 'ADDn.IKhPgutgmvF',
  'SysFS ID' => '/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1:1.0',
  'SysFS BusID' => '1-1.1:1.0',
  'Hardware Class' => 'network',
  'Model' => '"Standard Microsystems Ethernet controller"',
  'Hotplug' => 'USB',
  'Vendor' => 'usb 0x0424 "Standard Microsystems Corp."',
  'Device' => 'usb 0xec00',
  'Revision' => '"2.00"',
  'Driver' => '"smsc95xx"',
  'Driver Modules' => '"smsc95xx"',
  'Device File' => 'eth0',
  'Speed' => '480 Mbps',
  'HW Address' => 'b8:27:eb:f6:fd:79',
  'Link detected' => 'no',
  'Module Alias' => '"usb:v0424pEC00d0200dcFFdsc00dp01icFFisc00ipFFin00"',
  'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
  'Attached to' => '#26 (Hub)',
)
20.04. 10:45:09 array (
  21 => 'USB 00.0: 10200 Modem',
  '' => '[Created at usb.122]',
  'Unique ID' => 'dwDZ.h46mvUF1JD6',
  'Parent ID' => 'ADDn.IKhPgutgmvF',
  'SysFS ID' => '/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0',
  'SysFS BusID' => '1-1.3:1.0',
  'Hardware Class' => 'modem',
  'Model' => '"LPCUSB SC/SCD Series Solar Charger"',
  'Hotplug' => 'USB',
  'Vendor' => 'usb 0xffff "LPCUSB"',
  'Device' => 'usb 0x0005 "SC/SCD Series Solar Charger"',
  'Revision' => '"1.00"',
  'Serial ID' => '"SN."',
  'Driver' => '"cdc_acm"',
  'Driver Modules' => '"cdc_acm"',
  'Device File' => '/dev/ttyACM0',
  'Device Files' => '/dev/ttyACM0, /dev/serial/by-id/usb-LPCUSB_SC_SCD_Series_Solar_Charger_SN.-if00, /dev/serial/by-path/platform-3f980000.usb-usb-0:1.3:1.0',
  'Speed' => '12 Mbps',
  'Module Alias' => '"usb:vFFFFp0005d0100dc02dsc00dp00ic02isc02ip01in00"',
  'Driver Info #0' => '',
  'Driver Status' => 'cdc_acm is active',
  'Driver Activation Cmd' => '"modprobe cdc_acm"',
  'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
  'Attached to' => '#26 (Hub)',
)
20.04. 10:45:09 array (
  22 => 'USB 00.1: 0000 Unclassified device',
  '' => '[Created at usb.122]',
  'Unique ID' => '46Ud.0LGQn1D9WAC',
  'Parent ID' => 'ADDn.IKhPgutgmvF',
  'SysFS ID' => '/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.1',
  'SysFS BusID' => '1-1.3:1.1',
  'Hardware Class' => 'unknown',
  'Model' => '"LPCUSB SC/SCD Series Solar Charger"',
  'Hotplug' => 'USB',
  'Vendor' => 'usb 0xffff "LPCUSB"',
  'Device' => 'usb 0x0005 "SC/SCD Series Solar Charger"',
  'Revision' => '"1.00"',
  'Serial ID' => '"SN."',
  'Driver' => '"cdc_acm"',
  'Driver Modules' => '"cdc_acm"',
  'Speed' => '12 Mbps',
  'Module Alias' => '"usb:vFFFFp0005d0100dc02dsc00dp00ic0Aisc00ip00in01"',
  'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
  'Attached to' => '#26 (Hub)',
)
20.04. 10:45:09 array (
  23 => 'USB 00.0: 10800 Keyboard',
  '' => '[Created at usb.122]',
  'Unique ID' => 'VBUu.wnPn5qKoX55',
  'Parent ID' => 'ADDn.IKhPgutgmvF',
  'SysFS ID' => '/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5:1.0',
  'SysFS BusID' => '1-1.5:1.0',
  'Hardware Class' => 'keyboard',
  'Model' => '"MOSART Semi Rapoo 2.4G Wireless Touch Desktop"',
  'Hotplug' => 'USB',
  'Vendor' => 'usb 0x24ae "MOSART Semi."',
  'Device' => 'usb 0x1001 "Rapoo 2.4G Wireless Touch Desktop"',
  'Revision' => '"1.07"',
  'Driver' => '"usbhid"',
  'Driver Modules' => '"usbhid"',
  'Speed' => '12 Mbps',
  'Module Alias' => '"usb:v24AEp1001d0107dc00dsc00dp00ic03isc01ip01in00"',
  'Driver Info #0' => '',
  'XkbRules' => 'xfree86',
  'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
  'Attached to' => '#26 (Hub)',
)
20.04. 10:45:09 array (
  24 => 'USB 00.1: 10503 USB Mouse',
  '' => '[Created at usb.122]',
  'Unique ID' => 'yMky.rRUBmwTn5d9',
  'Parent ID' => 'ADDn.IKhPgutgmvF',
  'SysFS ID' => '/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5:1.1',
  'SysFS BusID' => '1-1.5:1.1',
  'Hardware Class' => 'mouse',
  'Model' => '"MOSART Semi Rapoo 2.4G Wireless Touch Desktop"',
  'Hotplug' => 'USB',
  'Vendor' => 'usb 0x24ae "MOSART Semi."',
  'Device' => 'usb 0x1001 "Rapoo 2.4G Wireless Touch Desktop"',
  'Revision' => '"1.07"',
  'Compatible to' => 'int 0x0200 0x0001 "Wortzensur USB Mouse"',
  'Driver' => '"usbhid"',
  'Driver Modules' => '"usbhid"',
  'Speed' => '12 Mbps',
  'Module Alias' => '"usb:v24AEp1001d0107dc00dsc00dp00ic03isc01ip02in01"',
  'Driver Info #0' => '',
  'XFree86 Protocol' => 'explorerps/2',
  'GPM Protocol' => 'exps2',
  'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
  'Attached to' => '#26 (Hub)',
)
20.04. 10:45:09 array (
  25 => 'USB 00.0: 10a00 Hub',
  '' => '[Created at usb.122]',
  'Unique ID' => 'k4bc.D6ER+lJeRh3',
  'SysFS ID' => '/devices/platform/soc/3f980000.usb/usb1/1-0:1.0',
  'SysFS BusID' => '1-0:1.0',
  'Hardware Class' => 'hub',
  'Model' => '"Linux 4.4.38-v7+ dwc_otg_hcd DWC OTG Controller"',
  'Hotplug' => 'USB',
  'Vendor' => 'usb 0x1d6b "Linux 4.4.38-v7+ dwc_otg_hcd"',
  'Device' => 'usb 0x0002 "DWC OTG Controller"',
  'Revision' => '"4.04"',
  'Serial ID' => '"3f980000.usb"',
  'Driver' => '"hub"',
  'Driver Modules' => '"usbcore"',
  'Speed' => '480 Mbps',
  'Module Alias' => '"usb:v1D6Bp0002d0404dc09dsc00dp01ic09isc00ip00in00"',
  'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
)
20.04. 10:45:09 array (
  26 => 'USB 00.0: 10a00 Hub',
  '' => '',
  'Unique ID' => 'ADDn.IKhPgutgmvF',
  'Parent ID' => 'k4bc.D6ER+lJeRh3',
  'SysFS ID' => '/devices/platform/soc/3f980000.usb/usb1/1-1/1-1:1.0',
  'SysFS BusID' => '1-1:1.0',
  'Hardware Class' => 'hub',
  'Model' => '"Standard Microsystems Hub"',
  'Hotplug' => 'USB',
  'Vendor' => 'usb 0x0424 "Standard Microsystems Corp."',
  'Device' => 'usb 0x9514',
  'Revision' => '"2.00"',
  'Driver' => '"hub"',
  'Driver Modules' => '"usbcore"',
  'Speed' => '480 Mbps',
  'Module Alias' => '"usb:v0424p9514d0200dc09dsc00dp02ic09isc00ip02in00"',
  'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
  'Attached to' => '#25 (Hub)',
)
20.04. 10:45:09 array (
  1 => 
  array (
    'File' => 'eth0',
    'Vendor' => 'usb 0x0424 "Standard Microsystems Corp."',
    'Device' => '0xec00',
    'Model' => 'Standard Microsystems Ethernet controller',
    'Driver Modules' => 'smsc95xx',
    'Driver' => 'smsc95xx',
  ),
  2 => 
  array (
    'File' => '/dev/ttyACM0',
    'Vendor' => 'usb 0xffff "LPCUSB"',
    'Device' => '0x0005',
    'Model' => 'LPCUSB SC/SCD Series Solar Charger',
    'Driver Modules' => 'cdc_acm',
    'Driver' => 'cdc_acm',
  ),
)
20.04. 10:46:10 |-----------   Start usb_ivt_auslesen.php   ------------------- 
20.04. 10:47:01 |-----------   Start usb_ivt_auslesen.php   ------------------- 
20.04. 10:47:01 |-----------   Stop  usb_ivt_auslesen.php   ------------------- 
20.04. 10:47:52 |-----------   Stop  usb_ivt_auslesen.php   ------------------- 
20.04. 10:48:01 |-----------   Start usb_ivt_auslesen.php   ------------------- 
20.04. 10:48:52 |-----------   Stop  usb_ivt_auslesen.php   ------------------- 
20.04. 10:49:01 |-----------   Start usb_ivt_auslesen.php   ------------------- 
20.04. 10:49:52 |-----------   Stop  usb_ivt_auslesen.php   ------------------- 
20.04. 10:50:01 |-----------   Start usb_ivt_auslesen.php   ------------------- 
20.04. 10:50:01 |-----------   Start graph.php ------------------
20.04. 10:50:02 Die History Tabelle wird bereinigt.
20.04. 10:50:02 |-----------   Stop  graph.php ------------------
20.04. 10:50:52 Daten in die History Datenbank geschrieben. rc: 1
20.04. 10:50:52 |-----------   Stop  usb_ivt_auslesen.php   ------------------- 
20.04. 10:51:02 |-----------   Start usb_ivt_auslesen.php   ------------------- 
20.04. 10:51:52 |-----------   Stop  usb_ivt_auslesen.php   ------------------- 
20.04. 10:52:01 |-----------   Start usb_ivt_auslesen.php   ------------------- 
20.04. 10:52:52 |-----------   Stop  usb_ivt_auslesen.php   ------------------- 
20.04. 10:53:01 |-----------   Start usb_ivt_auslesen.php   ------------------- 
20.04. 10:53:52 |-----------   Stop  usb_ivt_auslesen.php   ------------------- 
20.04. 10:54:01 |-----------   Start usb_ivt_auslesen.php   ------------------- 
20.04. 10:54:52 |-----------   Stop  usb_ivt_auslesen.php   ------------------- 
20.04. 10:55:01 |-----------   Start usb_ivt_auslesen.php   ------------------- 
20.04. 10:55:52 |-----------   Stop  usb_ivt_auslesen.php   ------------------- 

Benutzeravatar
Ulrich
Administrator
Beiträge: 122
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Alles in 12 Volt Ausführung....

Beitragvon Ulrich » Do 20. Apr 2017, 18:13

Hallo Reinhard,

das Problem ist, dass es keine Verbindung zum Regler gibt. Ich nehme an, dass die USB Schnittstelle nicht richtig initialisiert wird. Deine Tasttatur / Maus hat aber damit nichts zu tun.

In der user.config.php gibt es folgenden Eintrag:

// -----------------------------------------------------------------------------
//
// USB Device manuelle Eingabe...
// Falls die Software nicht den richtigen USB Port findet, dann kann hier
// der richtige Device Name angegeben werden. Beispiel: /dev/ttyUSB0
// Nur angeben und aktivieren, wenn es unbedingt nötig ist!
// $USBDevice = "/dev/ttyACM0";
// $USB_GPS = "/dev/ttyUSB1";
// ------------------------------------------------------------------------------

Kann es sein, dass Du hier etwas geändert oder aktiviert hast?
Bitte prüfe das einmal. In der Datei muss alles genau so stehen und darf nicht geändert werden.

Falls Du keine Abweichung feststellen kannst, drücke doch bitte noch einmal Strg + Alt + F1 und ENTER und gebe im Command Fenster noch einmal ' setup -f ' ein. Damit erzwingst Du das Setup noch einmal zu durchlaufen. (Ohne die Hochkomma eingeben)
--------------------------------------
Ulrich [Admin]

Jooker
Beiträge: 5
Registriert: Do 13. Apr 2017, 00:15

Re: Alles in 12 Volt Ausführung....

Beitragvon Jooker » Do 20. Apr 2017, 20:37

Hallo Ulrich,

in diesem Abschnitt habe ich nichts geändert. In der Datei steht alles so wie du es angegeben hast.
Ich habe beim Messen nur bemerkt, dass mein Solarmodul momenan wegen des Wetters nur mA liefert.
Kann man die Anzeige "Solar Ladestrom" und das Diagramm "Ladestrom" auf mA umstellen?
Ich habe heute ein anderes Solarmodul angeschlossen und damit wird auch nichts angezeigt. Auch nicht mit der Software des Herstellers, weil die auch nur in Ampere misst und nicht in mA. Ich hoffe, dass mein Solar Modul Anschluss nicht defekt ist.

Ich denke schon, dass Daten über USB gesendet werden, da meine Anzeige so aussieht:
IMG_20170420_201747.jpg
Anzeige
Hier lade ich eben nur ein Handy.

Lg und Danke für Deine Hilfe,
Reinhard

Benutzeravatar
Ulrich
Administrator
Beiträge: 122
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Alles in 12 Volt Ausführung....

Beitragvon Ulrich » Fr 21. Apr 2017, 08:38

Hallo Reinhard,
auf dem Bild ist deutlich zu sehen, dass Dein Solarpanel keinen Ladestrom liefert. Damit die Ladung einsetzt, muss auf dem unteren Instrument in der Mitte "Solarpanel" mindestens 14 Volt zu sehen sein. Der Regler startet die Ladung erst ab einer ganz bestimmten Spannung. (Steht in der Bedienungsanleitung) Liefert das Panel nicht so viel Spannung, dann bleibt der Ladestrom auch immer auf 0 (ab 100 mA Ladung würde man das auf der Anzeige schon sehen)
Bitte beleuchte das Panel einmal so, dass die Ladung einsetzt und schicke mir dann bitte noch einmal so ein Bild.
Im Moment kann ich keinen Fehler feststellen, außer dass das Solarpanel nicht geügend Leistung bringt. Die Leerlaufspannung des Panels muss ca. 18 Volt betragen.
Ich verwende einen Raspberry Pi3 Modell B mit einem SCplus 15A Solarcontroller, an welchem ich ein 12V / 10W Solarmodul und eine 12 V / 7Ah Batterie angeschlossen habe. Zum Test habe ich am Lastausgang eine Autosteckdose verbunden und diverse Geräte betrieben und geladen.

Es ist nicht ganz klar, was Du mit einem 12V / 10W Solarmodul meinst. Der Regler benötigt ein Solarmodul was eine Leerlaufspannung von mindestens 18 Volt liefert. Mit einem Modul, was nur eine Leerlaufspannung von 12 Volt hat, kannst Du keine 12 Volt Batterie laden. Damit der Regler die Ladung überhaupt startet, muss die Panelspannung ca. 5 Volt höher sein als die momentane Batteriespannung.
--------------------------------------
Ulrich [Admin]

Jooker
Beiträge: 5
Registriert: Do 13. Apr 2017, 00:15

Re: Alles in 12 Volt Ausführung....

Beitragvon Jooker » Fr 21. Apr 2017, 14:35

Lieber Ulrich,

ich danke nochmals für deine Hilfe.
Offenbar hatte ich in den letzten Tagen zu wenig Sonnenlicht, aber heute haben wir hier in Wiener Neustadt strahlenden Sonnenschein und - siehe da - es funktioniert alles. Ich habe aber auch ein größeres Mono-Si Solarmodul (Leistung lt Datenblatt 24V / 50W - http://westech-pv.com/Solarmodul-50W-CL ... miflexibel) angeschlossen, welches gegenwärtig um die 22 Volt an den Steckern liefert.

Ich hatte zuerst den Verdacht, dass mein Solar Controller defekt ist, aber ich habe den SCplus genommen, um kein Konverterkabel verwenden zu müssen. Also, ich bin jetzt sehr zufrieden und werde demnächt eine große Anlage für mein Wohnmobil daraus machen.
Natürlich muss ich in der user.config die Werte dann wieder ändern. Habe jetzt $Anzeige1Max auf "1" gestellt, um etwas angezeigt zu bekommen.
Hier nochmal ein Foto von der Anzeige mit allen Daten. Am Lastausgang hängt hier gerade ein 12V/230V Wandler mit Schukosteckdose für's Auto an dem ein Handy zum Laden angesteckt ist.
Screenshot1.PNG
Anzeige 21.04.2017
Vielen herzlichen Dank,
Reinhard :D

Benutzeravatar
Ulrich
Administrator
Beiträge: 122
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Alles in 12 Volt Ausführung....

Beitragvon Ulrich » Fr 21. Apr 2017, 15:43

SUPER, dass jetzt alles funktioniert!
--------------------------------------
Ulrich [Admin]

Jooker
Beiträge: 5
Registriert: Do 13. Apr 2017, 00:15

Re: Alles in 12 Volt Ausführung....

Beitragvon Jooker » Fr 21. Apr 2017, 19:02

Ja, finde ich klasse.
Gibts noch eine Möglichkeit, die Daten in ein XLS, TXT oder CSV zu exportieren und die Alktualisierungszeit von 6s auf 3s zu setzen ?
Habe im Forum dazu nichts gefunden.

Lg Reinhard


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste