Erstanschluss SolarMax 4200S - keine Daten

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung
Antworten
AB-SolarMax
Beiträge: 8
Registriert: Do 2. Jan 2020, 10:35

Erstanschluss SolarMax 4200S - keine Daten

Beitrag von AB-SolarMax »

Irgendwie ist das Thema während meiner Antwort verschwunden ...
Deshalb weiter unten auch noch die bisherige Kommunikation, glücklicherweise noch im zu retten war.

Hallo Ulrich,

Danke für die schnelle Rückmeldung!

WLAN habe ich beim Raspberry konfiguriert. Darüber ist er auch mit meinem Router verbunden. Den SolarMax habe ich direkt mit einem Ethernet-Kabel mit dem Raspberry verbunden. So hatte ich die Anleitung verstanden. Eine direkte Verbindung zu meinem Router hat der SolarMax somit nicht.

Wenn ich Dich nun richtig verstanden habe, müssen aber der SolarMax und der Raspberry über einen Router verbunden sein, damit die Kommunikation funktioniert. Das ist bei mir räumlich etwas schwieriger, da der SolarMax nur einen LAN-Anschluss hat und kein LAN-Kabel zum Router in der Nähe ist. Da muss ich mir dann noch etwas einfallen lassen. Aber zumindest ist mit dann klarer, wie das Ganze funktioniert. Ich hatte die Dokumentation bisher so interpretiert, dass sich der SolarMax und der Raspberry sich irgendwie auf "magische" Weise direkt über ein Ethernet-Kabel unterhalten, ohne dass der SolarMax mit dem Router des Netzwerks, in dem sich der Raspberry befindet, verbunden ist.

Viele Grüße
Andreas

———————————

Hallo AB-SolarMax,

aus den Bildern entnehme ich, dass Du kein Ethernet Kabel angeschlossen hast, oder das Kabel keine Verbindung zu Deinem Router hat. Vielmehr versucht der Raspberry eine WLAN Verbindung aufzubauen. Das Image ist jedoch für WLAN noch nicht konfiguriert. Dazu musst Du erst raspi-config aufrufen und WLAN konfigurieren. Du kannst nicht das LAN Kabel direkt in den SolarMax stecken! Beide Geräte müssen über einen Router geführt werden. Der Raspberry sollte eine Verbindung zum Internet haben, da er sich von dort die Uhrzeit holt.

Soll der Raspberry denn über WLAN mit dem SolarMax verbunden werden oder über ein LAN Kabel?

————————————

Die Solaranlage auf unserem Wohnhaus ist in zwei Felder aufgeteilt. Die Wechselrichter sind ein SolarMax 4200S und ein SolarMax 2000S. Ich bin damit gestartet, zunächst den 4200S einzubinden.

Die Installation der Solaranzeige auf dem Pi (Modell 4B) hat problemlos funktioniert. Der Pi ist per WLAN im Internet und der SolarMax über ein LAN-Kabel mit dem Pi verbunden. Beim Solarmax ist das Ethernet eingeschaltet und wird auch im Display angezeigt.
Im Menü des SolarMax sind folgende Wert eingestellt: Adresse 191, IP 192.168.001.191, Netmask 255.255.255.0, TCP-Port 12345
Diese Daten habe ich auch entsprechend in der Konfigurationsdatei der Solaranzeige eingestellt (siehe Anhang). Alle Zusatzfunktionen (Homematic, Wett etc.) sind wie voreingestellt ausgeschaltet.

Leider bekomme ich aber keine Daten angezeigt. Auch nach längerer Wartezeit tut sich nichts.

Ich vermute, dass die Verbindung zwischen Pi und SolarMax noch nicht funktioniert. Ein ping auf 192.168.001.191 bringt jedenfalls keine Antwort. Mit ifconfig und ip addr show sehe ich aber am LAN-Anschluss eine IP aus einem ganz anderen Nummernkreis. Wobei mit arp tatsächlich die 192.168.001.191 angezeigt wird, allerdings mit unvollständigen Informationen. Die Ausgaben der Aufrufe habe ich ebenfalls angehängt.

Bzgl. Hardware-Kommunikation bin ich leider ein kompletter Laie. Deshalb wäre ich für jeden Hinweis dankbar, wo mein Problem liegt. Denn dass es funktionieren sollte, haben ja andere Anwender der Solaranzeige schon gezeigt.

Benutzeravatar
Ulrich
Administrator
Beiträge: 1361
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Erstanschluss SolarMax 4200S - keine Daten

Beitrag von Ulrich »

Hallo Andreas,

Entschuldigung, ich habe in der Zwischenzeit eine neue phpBB Version eingespielt und die funktionierte nicht richtig. Deshalb war das Board zeitweise nicht zu erreichen und hatte Datenbankprobleme.


Jetzt zu Deiner Antwort:

Theoretisch würde das, so wie du es vorhast, funktionieren. Die LAN Konfiguration des Raspberry ist aber dann erheblich schwieriger. Da muss man schon wissen wie es geht.
--------------------------------------
Ulrich [Admin]

AB-SolarMax
Beiträge: 8
Registriert: Do 2. Jan 2020, 10:35

Re: Erstanschluss SolarMax 4200S - keine Daten

Beitrag von AB-SolarMax »

Hallo Ulrich,

ich werde versuchen, den SolarMax mit meinem Router zu verbinden. Das ist ja vermutlich die beste Lösung.

Viele Grüße
Andreas

Benutzeravatar
Ulrich
Administrator
Beiträge: 1361
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Erstanschluss SolarMax 4200S - keine Daten

Beitrag von Ulrich »

Ja, das ist die beste Lösung, da dann auch bei einem Update es keine Probleme gibt.
--------------------------------------
Ulrich [Admin]

AB-SolarMax
Beiträge: 8
Registriert: Do 2. Jan 2020, 10:35

Re: Erstanschluss SolarMax 4200S - keine Daten

Beitrag von AB-SolarMax »

Kurze Erfolgsmeldung: Ich habe einen alten Router als Bridge nutzen können und dank der tollen Dokumentation hat die Einrichtung von beiden Wechselrichtern und die Anzeige im Dashboard problemlos funktioniert. Klasse!
Als nächstes steht nun die Homematic-Integration an ...
Viele Grüße
Andreas

Antworten