Mehrere Probleme

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung
TeamO
Beiträge: 10
Registriert: Mo 22. Jun 2020, 08:58

Mehrere Probleme

Beitrag von TeamO »

Hallo zusammen,

erstmal vielen Dank an Ulrich für dieses super Forum und die Solaranzeige generell!
Ich bereibe eine PV-Anlage mit 92 325Wp Winaico Modulen und 29,9kWp Leistung an einem SolarEdge SE27,6k Wechselrichter und einem Senec Home 10.0 Li V2.1 Akku (derzeit noch nicht installiert) und wollte mit der Solaranzeige einfach eine kleine Übersicht unabhängig vom SE-Portal aufbauen.
Die installation und Grundkonfiguration hat ohne weiteres geklappt.
Leider habe ich trotzdem verschiedene Probleme, die ich irgendwie nicht behoben bekomme. Ich bin zwar IT-ler, habe mich bisher aber nicht wirklich mit RasPi und Linux beschäftigt.
Aber jetzt kurz zu mal zwei Problemen die ich habe:

1. Ich werde bei Grafana immer nach kürzester Zeit ausgeloggt. Das ist natürlich blöd, wenn man etwas versucht zu ändern und dann direkt die Meldung
bekommen, dass man nicht authorisiert ist.
-> Wie kann man die Zeit für das automatische ausloggen abschalten oder erhöhen?

2. Im Log ist bei mir immer folgender Entrag enthalten:
-Curl Fehler! Daten nicht zur lokalen InfluxBD gesendet! Curl ErrNo. 28
-> Woran kann dieser Fehler liegen?

3. Im Dashboard wird mir immer wieder ein falscher Status vom Wechelrichter angezeit.
-> Wie kann ich das prüfen?

Es wäre super, wenn mir hier jemand weiterhelfen könnte. Auch ist es schwierig mit der neuen Grafana Version zu arbeiten, wenn die Anleitungen noch Bilder von der alten zeigen, wo einiges ganz anders ist :lol:

Danke und Gruß
Timo

TeamO
Beiträge: 10
Registriert: Mo 22. Jun 2020, 08:58

Re: Mehrere Probleme

Beitrag von TeamO »

So, nachdem auf meine Fragen bisher keine Antwort gekommen ist mal einen Zwischenstand:
1. leider habe ich hierzu noch keine Lösung gefunden. Ich werde weiterhin nach kurzer Zeit bei Grafana ausgeloggt.

2. hier habe ich leider auch noch keine Lösung gefunden.

3. Diesen "Fehler" konnte ich jetzt nachvollziehen. Es liegt an den übertragenen Werten vom WR. Leider habe ich hier noch kein Übersicht zu den Bedeutungen der übertragenen Werte von SolarEdge gefunden um das zu beheben.

Dafür habe ich für ein paar andere "Probleme", wohl durch die neueren Versionen von Grafana und influxdb, Lösungen gefunden, die ich gerne teilen möchte:

- Darstellung der Wetterdaten ist ohne Einheiten:
mit der neuen Version müssen die Einheiten über "Overides" auf der rechten Seite angepasst werden:
Wetterdaten.jpg
- Unter Tageleistung wird nur der aktuelle Tag angezeigt:
es scheint, als wenn die Query mit "time(1d)" nicht mehr funktioniert. Bei "time(1h)" werden die Werte der letzten Tage richtig dargestellt.
Bei der Überprüfung der Abfrage direkt in der Datenbank auf dem Raspi habe ich immer den Fehler "ERR: GROUP BY requires at least one aggregate function" erhalten. Mit der Abfrage "select Max(Wert) from Statistik group by time(1d)" funktionierte es.
Somit sollte die Darstellung der Tagesleistung auf folgendes angepasst werden:
Tagesleistung.jpg
Tagesleistung.jpg (22.18 KiB) 274 mal betrachtet

Benutzeravatar
Ulrich
Administrator
Beiträge: 1277
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Mehrere Probleme

Beitrag von Ulrich »

Deine Punkte 1 und 2 deuten auf zu wenig Hauptspeicher hin, oder auf ein instabiles Netzteil.
--------------------------------------
Ulrich [Admin]

TeamO
Beiträge: 10
Registriert: Mo 22. Jun 2020, 08:58

Re: Mehrere Probleme

Beitrag von TeamO »

Hmmm. Handelt sich um den Raspi 3b+ der hier vorgeschlagen wurde von ELV. Einzig das angegebene Netzteil gibt es nicht mehr und ich musste hier ein anderes nehmen. Das hat nur 2,4A.

Benutzeravatar
Ulrich
Administrator
Beiträge: 1277
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Mehrere Probleme

Beitrag von Ulrich »

Hast du eventuell ein sehr gutes Handy Ladegerät, was du einmal ausprobieren könntest?
Ich habe hier einige Netzteile, die alle über 2 A liefern sollten, aber trotzdem bei Belastung einbrechen. Auf das Aufgedruckte kann man sich nicht immer verlassen. da hilft nur Ausprobieren.
--------------------------------------
Ulrich [Admin]

TeamO
Beiträge: 10
Registriert: Mo 22. Jun 2020, 08:58

Re: Mehrere Probleme

Beitrag von TeamO »

Müsste ich mal versuchen.
Aber ich habe wohl eine Lösung gefunden um den Fehler zu "umgehen". Ich hatte im Setup $Wiederholungen auf "6" gestellt. Nach Änderung auf default "1" tritt der Fehler wohl nicht mehr auf. Somit scheint es wirklich mit dem Netzteil zusammen zuhangen. Dadurch wird der Pi weniger belastet.

EDIT: Fehler tritt auch nach Reduzierung auf. Dann muss ich mir wohl mal nen anderes Netzteil besorgen.

TeamO
Beiträge: 10
Registriert: Mo 22. Jun 2020, 08:58

Re: Mehrere Probleme

Beitrag von TeamO »

Hallo Ulrich,
ich habe jetzt endlich ein Netzteil mit 3A bekommen, trotzdem werde ich über Web immer nach kurzer Zeit abgemeldet. Fällt Dir da noch was ein?

Benutzeravatar
Ulrich
Administrator
Beiträge: 1277
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Kontaktdaten:

Re: Mehrere Probleme

Beitrag von Ulrich »

Schaue doch bitte einmal hier:

https://grafana.com/docs/grafana/latest ... iguration/

unter [auth] müsstest du fündig werden.

Es kann ja nur etwas mit der Konfiguration zu tun haben. Die Session Daten werden in ein Cookie geschrieben. Hast Du eventuell bei deinem Browser keine Cookies zugelassen? Suche einmal in diese Richtung.

Warum willst Du denn als Admin dauerhaft angemeldet sein? Änderungen am Dashboard werden doch nur gelegentlich gemacht.
Oder möchtest du, dass immer das gleiche Dashboard startet? Dann bist do auf dem falschen Weg.
--------------------------------------
Ulrich [Admin]

TeamO
Beiträge: 10
Registriert: Mo 22. Jun 2020, 08:58

Re: Mehrere Probleme

Beitrag von TeamO »

Cookies sind zugelassen, habe jetzt aber mal explizit angegeben, dass von solaranzeige.local alles gespeichert werden soll.
Ich will ja nicht dauerhaft angemeldet bleiben, nur kann ich über die Weboberfläche an Grafana kaum was ändern, da ich nach einigen Sekunden direkt die Meldung bekomme, dass ich nicht berechtigt bin, weil ich im Hintergrund abgemeldet wurde.
Da sind Anpassungen schwer zu machen.

TeamO
Beiträge: 10
Registriert: Mo 22. Jun 2020, 08:58

Re: Mehrere Probleme

Beitrag von TeamO »

So, hier jetzt mal ein Update.
Ich habe mir jetzt noch einen Raspi 4 geholt und dort mal eine zweite "Solaranzeige" installiert und von ersten Raspi die DB über die config auf den neuen zusätzlich schreiben lassen.
Der neue Raspi hängt an einem 21,5" Touchscreen und ist somit nicht nur remote erreichbar. Dadurch gibt es auch keine automatische Abmeldung bei Grafana mehr.
Sobald ich den Raspi 3 durch den Raspi 4 ausgetauscht habe, werde ich da mal weiter testen. Eventuell passiert die Abmeldung nur, wenn ich von einem anderen Rechner auf Grafana zugreife.

@Ulrich: Da ich das Dispplay nicht nur für die Solaranzeige, sondern auch für meine Kameras nutzen würde, habe ich eine kleine Frage. Wie bekomme ich den Kiosk-Mode von Chromium beim Start raus? Ich möchte eigentlich, das Chromium beim Boot startet und ich zwei verschiedene Tabs angezeigt bekomme.

Antworten