Dockerimage

Solaranzeige und Docker
Alles was mit der Docker Version zu tun hat.

Moderatoren: Ulrich, DeBaschdi

the-grosser
Beiträge: 19
Registriert: Mo 6. Sep 2021, 08:45
Wohnort: Trebendorf
Hat sich bedankt: 6 Mal

Re: Dockerimage

Beitrag von the-grosser »

Ok, das führt dann irgendwie dazu das in Grafana immer bei der Abfrage alle Daten weg sind und nach der Abfrage die Werte wieder da stehen. Die Kurve wird dadurch immer wieder unterbrochen. Gibt es dafür eine Lösung? Kann ich das irgendwie anpassen?

DeBaschdi
Beiträge: 298
Registriert: Mo 10. Aug 2020, 08:13
Hat sich bedankt: 15 Mal
Danksagung erhalten: 55 Mal

Re: Dockerimage

Beitrag von DeBaschdi »

Moin,
ab sofort steht ein Legacy Image für Synology User bereit, installierbar mit dem tag :legacy
Siehe :
https://github.com/DeBaschdi/docker.sol ... requisites

Das sollte es ermöglichen den Apache innerhalb des Containers auch mit dem Synology "uralt" Kernel zu nutzen.

LichtiMC
Beiträge: 4
Registriert: So 13. Nov 2022, 19:42

Re: Dockerimage

Beitrag von LichtiMC »

Hi DeBaschdi,

bei mir startet grafana nicht im Docker Container (rpi4).
Die Installation ist bis auf das user.config file unberührt und ich hab auch schonmal alle Daten in den persistant-Ordnern gelöscht und den Container neu aufgesetzt. Es startet einfach nicht.

Log:

Code: Alles auswählen

logger=settings t=2022-11-14T03:16:52.299013591+01:00 level=info msg="Starting Grafana" version=9.2.0 commit=c7eea48209 branch=HEAD compiled=2022-10-11T12:11:15+02:00
logger=settings t=2022-11-14T03:16:52.299552106+01:00 level=info msg="Config loaded from" file=/usr/share/grafana/conf/defaults.ini
logger=settings t=2022-11-14T03:16:52.299602847+01:00 level=info msg="Config loaded from" file=/etc/grafana/grafana.ini
logger=settings t=2022-11-14T03:16:52.299634476+01:00 level=info msg="Config overridden from command line" arg="default.paths.data=/var/lib/grafana"
logger=settings t=2022-11-14T03:16:52.299665124+01:00 level=info msg="Config overridden from command line" arg="default.paths.logs=/var/www/log/grafana"
logger=settings t=2022-11-14T03:16:52.299694772+01:00 level=info msg="Config overridden from command line" arg="default.paths.plugins=/var/lib/grafana/plugins"
logger=settings t=2022-11-14T03:16:52.299725865+01:00 level=info msg="Config overridden from command line" arg="default.paths.provisioning=/etc/grafana/provisioning"
logger=settings t=2022-11-14T03:16:52.299755791+01:00 level=info msg="Path Home" path=/usr/share/grafana
logger=settings t=2022-11-14T03:16:52.29978455+01:00 level=info msg="Path Data" path=/var/lib/grafana
logger=settings t=2022-11-14T03:16:52.299815346+01:00 level=info msg="Path Logs" path=/var/www/log/grafana
logger=settings t=2022-11-14T03:16:52.29984392+01:00 level=info msg="Path Plugins" path=/var/lib/grafana/plugins
logger=settings t=2022-11-14T03:16:52.299875401+01:00 level=info msg="Path Provisioning" path=/etc/grafana/provisioning
logger=settings t=2022-11-14T03:16:52.299903456+01:00 level=info msg="App mode production"
logger=sqlstore t=2022-11-14T03:16:52.300107955+01:00 level=info msg="Connecting to DB" dbtype=sqlite3
logger=sqlstore t=2022-11-14T03:16:52.301165005+01:00 level=warn msg="SQLite database file has broader permissions than it should" path=/var/lib/grafana/grafana.db mode=-rwxrwxrwx expected=-rw-r-----
logger=migrator t=2022-11-14T03:16:52.346491963+01:00 level=info msg="Starting DB migrations"
logger=migrator t=2022-11-14T03:16:52.356728167+01:00 level=info msg="Executing migration" id="Add is_service_account column to user"
Wechsel ich manuell nach /usr/share/grafana und starte dann in der console grafana-server, startet es ganz normal.
Hast du eine Idee was da sein kann?

PS: Vielen Dank für das Docker-Image!

DeBaschdi
Beiträge: 298
Registriert: Mo 10. Aug 2020, 08:13
Hat sich bedankt: 15 Mal
Danksagung erhalten: 55 Mal

Re: Dockerimage

Beitrag von DeBaschdi »

Starte mal den Container neu und poste mal dein log, erreichbar mit dem Befehl

Code: Alles auswählen

docker logs Solaranzeige

LichtiMC
Beiträge: 4
Registriert: So 13. Nov 2022, 19:42

Re: Dockerimage

Beitrag von LichtiMC »

Hallo nochmal,

danke für deine Antwort, ich hab mich jetzt mal tiefer reingearbeitet und gesehen, dass ein cifs-mount der persistant-Ordner nicht mit sqlite kompatibel ist. Deswegen startete grafana nicht.

Also hab ich es nun lokal. Jetzt bin ich aber noch auf folgenden Fehler aufmerksam geworden:
Beim Start des docker-images wird ja /usr/local/sbin/solaranzeige.update aufgerufen. Hier werden per sshfs die neuesten Dateien auf den eigenen Server kopiert.

Hast du bei dir auch das Problem, dass dabei sämtliche Ordner als Dateien mit 0kb angelegt werden? (Also die, die es noch nicht gibt. Bei den bereits vorhandenen erscheint im Log ein Fehler, z.B. "14.11. 17:53:49 X Datei database kann nicht in das lokale Verzeichnis geschrieben werden.")
Z.B. die Ordner api und automation im persistant-Ordner /www/html/ .
ls -al schaut dann so aus:
-rwxrwxrwx 1 root root 0 Nov 14 18:09 api
-rwxrwxrwx 1 root root 0 Nov 14 18:09 automation

Somit wird bei mir nicht alles ordentlich upgedated glaub ich, weil der die Ordner aus irgendeinem Grund als Dateien behandelt.

DeBaschdi
Beiträge: 298
Registriert: Mo 10. Aug 2020, 08:13
Hat sich bedankt: 15 Mal
Danksagung erhalten: 55 Mal

Re: Dockerimage

Beitrag von DeBaschdi »

Ja, der fehler ist mir heute auch aufgefallen, in dem fall bitte das neue image 0.1.6 verwenden, also clean install :)

Den exportierten grafana, influx und deine user.config kannst du sichern, nach dem clean install zurück spielen und container neu starten ;)

Ulrich hatte an dem update skript gearbeitet, hatte das nicht mitbekommen, deshalb vieröief das im sand, vllt kann @Ulrich mich da auf dem laufenden halten wenn sein "update" oder "steuerung-update" überarbeitet wird.

LichtiMC
Beiträge: 4
Registriert: So 13. Nov 2022, 19:42

Re: Dockerimage

Beitrag von LichtiMC »

Ja, danke, das wars, jetzt funktioniert es mit lokalem docker-volumes.
Aber wenn die docker-volumes per nfs am raspi eingebunden sind, startet grafana nicht, weil sqlite immer sagt "database locked".
Hat das jemand mit Netzwerk-Ordner am Laufen und kann mir einen Tipp geben, wie ich das gelöst bekomme? Ich probier schon den ganzen Tag / Nacht herum. :|

Edit: Im WAL Modus läufts. (sqlite3 grafana.db 'PRAGMA journal_mode=WAL;')

the-grosser
Beiträge: 19
Registriert: Mo 6. Sep 2021, 08:45
Wohnort: Trebendorf
Hat sich bedankt: 6 Mal

Re: Dockerimage

Beitrag von the-grosser »

Hallo DeBaschdi,

muss noch mal auf meinen Eintrag zurückkommen, da hab ich irgendwie keine Lösung.
Grundsätzlich funktioniert es, und der im Moment noch laufenden Pi4 funktioniert tadellos.
Anzeige über den Pi läuft
Anzeige über den Pi läuft
Nur im Dockercontainer wird beschrieben immer wieder die Verbindung getrennt, was dazu führt das es keine nahtlose Aufzeichnung der Daten gibt.
Siehe auch angehängte Bilder.
Anzeige über den Docker Container der auf dem QNAP läuft
Anzeige über den Docker Container der auf dem QNAP läuft
Grafana zeigt dann immer wieder an das der WR startet und das jede Minute. Wie kann ich das abstellen oder so einstellen das es funktioniert?

Vielen Dank für die Hilfe.
the-grosser hat geschrieben:
Fr 4. Nov 2022, 07:17
Ok, das führt dann irgendwie dazu das in Grafana immer bei der Abfrage alle Daten weg sind und nach der Abfrage die Werte wieder da stehen. Die Kurve wird dadurch immer wieder unterbrochen. Gibt es dafür eine Lösung? Kann ich das irgendwie anpassen?

fmc
Beiträge: 52
Registriert: So 4. Sep 2022, 11:10

Re: Dockerimage

Beitrag von fmc »

Hallo Zusammen,

ich probiere hier mal mein Glück :-)

Mein Docker Image auf Portainer lief bis zum Neustart, habe dann aus Verzweiflung ein Update versucht.
Ich bekomme folgende Fehlermeldung:

Code: Alles auswählen

Curl Fehler[1]! Daten nicht zur lokalen InfluxDB homematicip gesendet! Curl ErrNo. 7

Code: Alles auswählen

08.03. 20:59:09    -Multi-Regler-Ausgang. 2
08.03. 20:59:09    -OK. Datenübertragung erfolgreich.
08.03. 20:59:09 |----------------   Stop   huawei_LAN.php    --------------------------- 
08.03. 20:59:10    -Verarbeitung von: '2.user.config.php'   Regler: 72
08.03. 20:59:10 |----------------   Start  hm_geraet.php    -------------------------- 
08.03. 20:59:10    -HomeMatic: 192.168.20.200 Port: 80 GeräteID: 1
08.03. 20:59:10 +  -Die Daten werden ausgelesen...
08.03. 20:59:14    -Alle 10 Minuten werden die Statistikdaten übertragen.
08.03. 20:59:14    -Curl Fehler[1]! Daten nicht zur lokalen InfluxDB homematicip gesendet! Curl ErrNo. 7
08.03. 20:59:14    -Lokale InfluxDB Fehler -> nochmal versuchen.
08.03. 20:59:14    -Curl Fehler[1]! Daten nicht zur lokalen InfluxDB homematicip gesendet! Curl ErrNo. 7
08.03. 20:59:14    -Lokale InfluxDB Fehler -> nochmal versuchen.
08.03. 20:59:14    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB homematicip gesendet! Curl ErrNo. 7
08.03. 20:59:14    -InfluxDB Fehler -> nochmal versuchen.
08.03. 20:59:14    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB homematicip gesendet! Curl ErrNo. 7
08.03. 20:59:14    -InfluxDB Fehler -> nochmal versuchen.
08.03. 20:59:14    -Multi-Regler-Ausgang. 3
08.03. 20:59:17    -OK. Datenübertragung erfolgreich.
08.03. 20:59:17 |----------------   Stop   hm_geraet.php    -------------------------- 
08.03. 20:59:19    -Multi Regler Auslesen [Stop].
08.03. 21:00:01    -Multi Regler Auslesen [Start].
08.03. 21:00:01    -Verarbeitung von: '1.user.config.php'   Regler: 62
08.03. 21:00:01 |----------------   Start  huawei_LAN.php  ----------------------------- 
08.03. 21:00:01    -Huawei: 192.168.20.202 Port: 502 GeräteID: 1
08.03. 21:00:07 >  -Gerätetyp:   Modell ID: 0
08.03. 21:00:11 >  -Alarm 1 Bits: 0000000000000000
08.03. 21:00:14    -Alle 10 Minuten werden die Statistikdaten übertragen.
08.03. 21:00:14    -Curl Fehler[1]! Daten nicht zur lokalen InfluxDB solaranzeige gesendet! Curl ErrNo. 7
08.03. 21:00:14    -Lokale InfluxDB Fehler -> nochmal versuchen.
08.03. 21:00:14    -Curl Fehler[1]! Daten nicht zur lokalen InfluxDB solaranzeige gesendet! Curl ErrNo. 7
08.03. 21:00:14    -Lokale InfluxDB Fehler -> nochmal versuchen.
08.03. 21:00:14    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB solaranzeige gesendet! Curl ErrNo. 7
08.03. 21:00:14    -InfluxDB Fehler -> nochmal versuchen.
08.03. 21:00:14    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB solaranzeige gesendet! Curl ErrNo. 7
08.03. 21:00:14    -InfluxDB Fehler -> nochmal versuchen.
08.03. 21:00:14    -Multi-Regler-Ausgang. -4
08.03. 21:00:14    -OK. Datenübertragung erfolgreich.
08.03. 21:00:14 |----------------   Stop   huawei_LAN.php    --------------------------- 
08.03. 21:00:14    -Verarbeitung von: '2.user.config.php'   Regler: 72
08.03. 21:00:14 |----------------   Start  hm_geraet.php    -------------------------- 
08.03. 21:00:14    -HomeMatic: 192.168.20.200 Port: 80 GeräteID: 1
08.03. 21:00:14 +  -Die Daten werden ausgelesen...
08.03. 21:00:19    -Alle 10 Minuten werden die Statistikdaten übertragen.
08.03. 21:00:19    -Curl Fehler[1]! Daten nicht zur lokalen InfluxDB homematicip gesendet! Curl ErrNo. 7
08.03. 21:00:19    -Lokale InfluxDB Fehler -> nochmal versuchen.
08.03. 21:00:19    -Curl Fehler[1]! Daten nicht zur lokalen InfluxDB homematicip gesendet! Curl ErrNo. 7
08.03. 21:00:19    -Lokale InfluxDB Fehler -> nochmal versuchen.
08.03. 21:00:19    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB homematicip gesendet! Curl ErrNo. 7
08.03. 21:00:19    -InfluxDB Fehler -> nochmal versuchen.
08.03. 21:00:19    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB homematicip gesendet! Curl ErrNo. 7
08.03. 21:00:19    -InfluxDB Fehler -> nochmal versuchen.
08.03. 21:00:19    -Multi-Regler-Ausgang. 2
08.03. 21:00:21    -OK. Datenübertragung erfolgreich.
08.03. 21:00:21 |----------------   Stop   hm_geraet.php    -------------------------- 
08.03. 21:00:23    -Multi Regler Auslesen [Stop].
08.03. 21:01:01    -Multi Regler Auslesen [Start].
08.03. 21:01:01    -Verarbeitung von: '1.user.config.php'   Regler: 62
08.03. 21:01:01 |----------------   Start  huawei_LAN.php  ----------------------------- 
08.03. 21:01:01    -Huawei: 192.168.20.202 Port: 502 GeräteID: 1
08.03. 21:01:04 >  -Gerätetyp: SUN2000-5KTL-M1  Modell ID: 426
08.03. 21:01:08 >  -Alarm 1 Bits: 0000000000000000
08.03. 21:01:11    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB solaranzeige gesendet! Curl ErrNo. 7
08.03. 21:01:11    -InfluxDB Fehler -> nochmal versuchen.
08.03. 21:01:11    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB solaranzeige gesendet! Curl ErrNo. 7
08.03. 21:01:11    -InfluxDB Fehler -> nochmal versuchen.
08.03. 21:01:11    -Multi-Regler-Ausgang. -1
08.03. 21:01:11    -OK. Datenübertragung erfolgreich.
08.03. 21:01:11 |----------------   Stop   huawei_LAN.php    --------------------------- 
08.03. 21:01:12    -Verarbeitung von: '2.user.config.php'   Regler: 72
08.03. 21:01:12 |----------------   Start  hm_geraet.php    -------------------------- 
08.03. 21:01:12    -HomeMatic: 192.168.20.200 Port: 80 GeräteID: 1
08.03. 21:01:12 +  -Die Daten werden ausgelesen...
08.03. 21:01:16    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB homematicip gesendet! Curl ErrNo. 7
08.03. 21:01:16    -InfluxDB Fehler -> nochmal versuchen.
08.03. 21:01:16    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB homematicip gesendet! Curl ErrNo. 7
08.03. 21:01:16    -InfluxDB Fehler -> nochmal versuchen.
08.03. 21:01:16    -Multi-Regler-Ausgang. 3
08.03. 21:01:19    -OK. Datenübertragung erfolgreich.
08.03. 21:01:19 |----------------   Stop   hm_geraet.php    -------------------------- 
08.03. 21:01:21    -Multi Regler Auslesen [Stop].
08.03. 21:02:01    -Multi Regler Auslesen [Start].
08.03. 21:02:01    -Verarbeitung von: '1.user.config.php'   Regler: 62
08.03. 21:02:01 |----------------   Start  huawei_LAN.php  ----------------------------- 
08.03. 21:02:01    -Huawei: 192.168.20.202 Port: 502 GeräteID: 1
08.03. 21:02:03 >  -Gerätetyp: SUN2000-5KTL-M1  Modell ID: 426
08.03. 21:02:07 >  -Alarm 1 Bits: 0000000000000000
08.03. 21:02:11    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB solaranzeige gesendet! Curl ErrNo. 7
08.03. 21:02:11    -InfluxDB Fehler -> nochmal versuchen.
08.03. 21:02:11    -Curl Fehler[2]! Daten nicht zur lokalen InfluxDB solaranzeige gesendet! Curl ErrNo. 7
08.03. 21:02:11    -InfluxDB Fehler -> nochmal versuchen.
08.03. 21:02:11    -Multi-Regler-Ausgang. -1
08.03. 21:02:11    -OK. Datenübertragung erfolgreich.
08.03. 21:02:11 |----------------   Stop   huawei_LAN.php    --------------------------- 
08.03. 21:02:11    -Verarbeitung von: '2.user.config.php'   Regler: 72
08.03. 21:02:11 |----------------   Start  hm_geraet.php    -------------------------- 
08.03. 21:02:11    -HomeMatic: 192.168.20.200 Port: 80 GeräteID: 1
08.03. 21:02:11 +  -Die Daten werden ausgelesen...

Code: Alles auswählen

root@solaranzeige:/# influx
Failed to connect to http://localhost:8086: Get http://localhost:8086/ping: dial tcp 127.0.0.1:8086: connect: connection refused
Please check your connection settings and ensure 'influxd' is running.
root@solaranzeige:/# 

Code: Alles auswählen

AH00558: apache2: Could not reliably determine the server's fully qualified domain name 
Ulrich meinte: "Kann es sein, dass dein Raspberry überhaupt kein Netzwerk öffnet? Kontrolliere bitte erst einmal ob dein Netzwerk richtig funktioniert und ob die IP Adressen nach dem neu booten, auch noch richtig sind."

Das es ggf. hierdran liegt.

Ich habe keine Ahnung, was jetzt falsch läuft.
Kennt Ihr das Problem oder habt Ihr eine Idee, wie ich dem Problem auf die Spur kommen kann ?

Vielen Dank

DeBaschdi
Beiträge: 298
Registriert: Mo 10. Aug 2020, 08:13
Hat sich bedankt: 15 Mal
Danksagung erhalten: 55 Mal

Re: Dockerimage

Beitrag von DeBaschdi »

Scheint als ob einfach deine influxdb nicht läuft,
was passiert denn nach einem

Code: Alles auswählen

service influxdb status
Ggf dann

Code: Alles auswählen

service influxdb start


?

Du willst doch auf die Influxdb innerhalb des Images schreiben, oder eine andere, auf einem anderen Gerät / Container ?

Mehr Details :)

Antworten

Zurück zu „Docker Container“