Goodwe GW20-ET

Alles was mit der Solaranzeige Image Installation und Betrieb zu tun hat. Einfache Konfiguration mit einem Gerät.

Moderator: Ulrich

Benutzeravatar
Ulrich
Administrator
Beiträge: 5202
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 130 Mal
Danksagung erhalten: 757 Mal
Kontaktdaten:

Re: Goodwe GW20-ET

Beitrag von Ulrich »

Für Experten: ja das reicht! Möglichst 10 Sekunden vor der vollen Minute ausführen. Dann kommt man mit dem crontab nicht in die Quere.
Bei der Multi-Regler-Version dann entsprechend die multi_usb_init.php
---------------------------------------
Ulrich . . . . . . . . [Projektinhaber]

Tiloklom
Beiträge: 5
Registriert: Di 25. Jul 2023, 23:46
Hat sich bedankt: 2 Mal

Re: Goodwe GW20-ET

Beitrag von Tiloklom »

Hallo Ulrich,

wie schaut es denn mit dem Logfile von mir aus? Kannst du da was zu sagen? Ich bin echt am verzweifeln inzwischen. Ich bekomme keine gültigen Daten laut Logfile. Die S/N erkennt er aber richtig?!..

Benutzeravatar
Ulrich
Administrator
Beiträge: 5202
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 130 Mal
Danksagung erhalten: 757 Mal
Kontaktdaten:

Re: Goodwe GW20-ET

Beitrag von Ulrich »

Ich hatte dir eine eMail gesendet.
---------------------------------------
Ulrich . . . . . . . . [Projektinhaber]

Tiloklom
Beiträge: 5
Registriert: Di 25. Jul 2023, 23:46
Hat sich bedankt: 2 Mal

Re: Goodwe GW20-ET

Beitrag von Tiloklom »

Ulrich hat geschrieben:
Sa 19. Aug 2023, 14:36
Ich hatte dir eine eMail gesendet.
Sorry habe ich gar nicht gesehen. Ist aktiv :-) Ich bin gespannt, ob du was findest. LG

Benutzeravatar
Ulrich
Administrator
Beiträge: 5202
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 130 Mal
Danksagung erhalten: 757 Mal
Kontaktdaten:

Re: Goodwe GW20-ET

Beitrag von Ulrich »

Dein Gerät meldet als Gerätetyp "00000000". Das war der Fehler. Handelt es sich hier um ein baugleiches Gerät? Ich habe die Abfrage jetzt etwas geändert, sodass der Gerätetyp nicht mehr entscheidend ist.
---------------------------------------
Ulrich . . . . . . . . [Projektinhaber]

Tiloklom
Beiträge: 5
Registriert: Di 25. Jul 2023, 23:46
Hat sich bedankt: 2 Mal

Re: Goodwe GW20-ET

Beitrag von Tiloklom »

Ulrich hat geschrieben:
Sa 19. Aug 2023, 15:06
Dein Gerät meldet als Gerätetyp "00000000". Das war der Fehler. Handelt es sich hier um ein baugleiches Gerät? Ich habe die Abfrage jetzt etwas geändert, sodass der Gerätetyp nicht mehr entscheidend ist.
Hallo Urlich, vielen Dank !!
Ja es handelt sich um das baugleiche Gerät wie der TE es besitzt. Kannst du mir genau sagen, wo du etwas geändert hast? Damit ich es beim nächsten mal nachvollziehen kann. Eventuell hat ja hier noch jemand mal so ein Problem.

Kann man eigentlich die Abfrage Intervalle ändern? Aktuell holt sich der Raspi glaub alle 30sekunden die Daten?

Benutzeravatar
Ulrich
Administrator
Beiträge: 5202
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 130 Mal
Danksagung erhalten: 757 Mal
Kontaktdaten:

Re: Goodwe GW20-ET

Beitrag von Ulrich »

Die Änderung ist im Update jetzt auch enthalten. Du brauchst nicht mehr zu ändern später bei einem Update. Alle anderen bekommen das Problem auch nicht mehr.
Wie man das Intervall ändert, steht in der Installationsanleitung genau drin.

download/Installation_mit_Grafana_Dashboard.pdf

Seite 5

"$Wiederholungen = "1";"
---------------------------------------
Ulrich . . . . . . . . [Projektinhaber]

Tiloklom
Beiträge: 5
Registriert: Di 25. Jul 2023, 23:46
Hat sich bedankt: 2 Mal

Re: Goodwe GW20-ET

Beitrag von Tiloklom »

Ulrich hat geschrieben:
Sa 19. Aug 2023, 15:23
Die Änderung ist im Update jetzt auch enthalten. Du brauchst nicht mehr zu ändern später bei einem Update. Alle anderen bekommen das Problem auch nicht mehr.
Wie man das Intervall ändert, steht in der Installationsanleitung genau drin.

download/Installation_mit_Grafana_Dashboard.pdf

Seite 5

"$Wiederholungen = "1";"
Nochmals tausend Dank :-) Bis jetzt läuft alles wie es sollte. Werde mich jetzt an die GUI begeben. Wenn das Dashboard fertig ist, werd ich es euch allen zur Verfügung stellen. Donation geht später aus raus!

elektrofisch
Beiträge: 5
Registriert: Di 1. Aug 2023, 21:36

Re: Goodwe GW20-ET

Beitrag von elektrofisch »

Ulrich hat geschrieben:
Sa 19. Aug 2023, 15:06
Dein Gerät meldet als Gerätetyp "00000000". Das war der Fehler. Handelt es sich hier um ein baugleiches Gerät? Ich habe die Abfrage jetzt etwas geändert, sodass der Gerätetyp nicht mehr entscheidend ist.
Hallo Ulrich,

das Problem ist gelöst.

besten Dank :)

Daniel

Koebes100
Beiträge: 4
Registriert: So 30. Jul 2023, 10:47
Wohnort: Frechen
Hat sich bedankt: 1 Mal

Re: Goodwe GW20-ET

Beitrag von Koebes100 »

Guten Tag zusammen,

ich habe ebenfalls das beschriebene Problem, bekomme keine Daten und die entsprechende Fehlermeldung im Log - File.

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 1
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0002 Rev=06.01
S: Manufacturer=Linux 6.1.21-v8+ xhci-hcd
S: Product=xHCI Host Controller
S: SerialNumber=0000:01:00.0
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 4
D: Ver= 2.10 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=2109 ProdID=3431 Rev=04.21
S: Product=USB2.0 Hub
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=100mA
I: If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=01 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0403 ProdID=6001 Rev=06.00
S: Manufacturer=FTDI
S: Product=FT232R USB UART
S: SerialNumber=AQ043OCW
C: #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=90mA
I: If#=0x0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=ftdi_sio

T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=5000 MxCh= 4
D: Ver= 3.00 Cls=09(hub ) Sub=00 Prot=03 MxPS= 9 #Cfgs= 1
P: Vendor=1d6b ProdID=0003 Rev=06.01
S: Manufacturer=Linux 6.1.21-v8+ xhci-hcd
S: Product=xHCI Host Controller
S: SerialNumber=0000:01:00.0
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

28.08. 11:43:09 -Daten:
array (
13 => 'None 00.0: 11300 Partition',
'' => '[Created at block.434]',
'Unique ID' => 'l7UW.SE1wIdpsiiC',
'Parent ID' => 'HAKk.Fxp0d3BezAE',
'SysFS ID' => '/class/block/mmcblk0/mmcblk0p1',
'Hardware Class' => 'partition',
'Model' => '"Partition"',
'Device File' => '/dev/mmcblk0p1',
'Device Files' => '/dev/mmcblk0p1, /dev/disk/by-label/bootfs, /dev/disk/by-path/platform-fe340000.mmc-part1, /dev/disk/by-uuid/CEE7-0DF0, /dev/disk/by-partuuid/8f690866-01, /dev/disk/by-id/mmc-SN32G_0xfaa73fa1-part1',
'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
'Attached to' => '#12 (Disk)',
)
28.08. 11:43:09 -Daten:
array (
14 => 'None 00.0: 11300 Partition',
'' => '[Created at block.434]',
'Unique ID' => 'CJka.SE1wIdpsiiC',
'Parent ID' => 'HAKk.Fxp0d3BezAE',
'SysFS ID' => '/class/block/mmcblk0/mmcblk0p2',
'Hardware Class' => 'partition',
'Model' => '"Partition"',
'Device File' => '/dev/mmcblk0p2',
'Device Files' => '/dev/mmcblk0p2, /dev/disk/by-uuid/ebadab55-bd70-46a9-8f18-995c136fb5b2, /dev/disk/by-partuuid/8f690866-02, /dev/disk/by-id/mmc-SN32G_0xfaa73fa1-part2, /dev/disk/by-label/rootfs, /dev/disk/by-path/platform-fe340000.mmc-part2',
'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
'Attached to' => '#12 (Disk)',
)
28.08. 11:43:09 -Daten:
array (
28 => 'USB 00.0: 0700 Serial controller',
'' => '[Created at usb.122]',
'Unique ID' => '33sj.7myTOCc6yM4',
'Parent ID' => 'ADDn.mUqILwxEtWB',
'SysFS ID' => '/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.4/1-1.4:1.0',
'SysFS BusID' => '1-1.4:1.0',
'Hardware Class' => 'unknown',
'Model' => '"Future Technology Devices International FT232 Serial (UART) IC"',
'Hotplug' => 'USB',
'Vendor' => 'usb 0x0403 "Future Technology Devices International, Ltd"',
'Device' => 'usb 0x6001 "FT232 Serial (UART) IC"',
'Revision' => '"6.00"',
'Serial ID' => '"AQ043OCW"',
'Driver' => '"ftdi_sio"',
'Driver Modules' => '"usbserial", "ftdi_sio"',
'Device File' => '/dev/ttyUSB0',
'Device Files' => '/dev/ttyUSB0, /dev/serial/by-path/platform-fd500000.pcie-pci-0000:01:00.0-usb-0:1.4:1.0-port0',
'Device Number' => 'char 188:0',
'Tags' => 'mouse, modem',
'Speed' => '12 Mbps',
'Module Alias' => '"usb:v0403p6001d0600dc00dsc00dp00icFFiscFFipFFin00"',
'Driver Info #0' => '',
'Driver Status' => 'ftdi_sio is active',
'Driver Activation Cmd' => '"modprobe ftdi_sio"',
'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
'Attached to' => '#30 (Hub)',
)
28.08. 11:43:09 -Daten:
array (
29 => 'USB 00.0: 10a00 Hub',
'' => '[Created at usb.122]',
'Unique ID' => 'k4bc.kNaPe9SZft4',
'Parent ID' => 'VCu0.m2lGPNk7Xc4',
'SysFS ID' => '/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-0:1.0',
'SysFS BusID' => '1-0:1.0',
'Hardware Class' => 'hub',
'Model' => '"Linux Foundation 2.0 root hub"',
'Hotplug' => 'USB',
'Vendor' => 'usb 0x1d6b "Linux Foundation"',
'Device' => 'usb 0x0002 "2.0 root hub"',
'Revision' => '"6.01"',
'Serial ID' => '"0000:01:00.0"',
'Driver' => '"hub"',
'Driver Modules' => '"usbcore"',
'Speed' => '480 Mbps',
'Module Alias' => '"usb:v1D6Bp0002d0601dc09dsc00dp01ic09isc00ip00in00"',
'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
'Attached to' => '#1 (USB Controller)',
)
28.08. 11:43:09 -Daten:
array (
30 => 'USB 00.0: 10a00 Hub',
'' => '[Created at usb.122]',
'Unique ID' => 'ADDn.mUqILwxEtWB',
'Parent ID' => 'k4bc.kNaPe9SZft4',
'SysFS ID' => '/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1:1.0',
'SysFS BusID' => '1-1:1.0',
'Hardware Class' => 'hub',
'Model' => '"VIA Hub"',
'Hotplug' => 'USB',
'Vendor' => 'usb 0x2109 "VIA Labs, Inc."',
'Device' => 'usb 0x3431 "Hub"',
'Revision' => '"4.21"',
'Driver' => '"hub"',
'Driver Modules' => '"usbcore"',
'Speed' => '480 Mbps',
'Module Alias' => '"usb:v2109p3431d0421dc09dsc00dp01ic09isc00ip00in00"',
'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
'Attached to' => '#29 (Hub)',
)
28.08. 11:43:09 -Daten:
array (
31 => 'USB 00.0: 10a00 Hub',
'' => '',
'Unique ID' => 'pBe4.djic47EFb5E',
'Parent ID' => 'VCu0.m2lGPNk7Xc4',
'SysFS ID' => '/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb2/2-0:1.0',
'SysFS BusID' => '2-0:1.0',
'Hardware Class' => 'hub',
'Model' => '"Linux Foundation 3.0 root hub"',
'Hotplug' => 'USB',
'Vendor' => 'usb 0x1d6b "Linux Foundation"',
'Device' => 'usb 0x0003 "3.0 root hub"',
'Revision' => '"6.01"',
'Serial ID' => '"0000:01:00.0"',
'Driver' => '"hub"',
'Driver Modules' => '"usbcore"',
'Module Alias' => '"usb:v1D6Bp0003d0601dc09dsc00dp03ic09isc00ip00in00"',
'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
'Attached to' => '#1 (USB Controller)',
)
28.08. 11:43:09 -USB Devices:
array (
1 =>
array (
'Device' => '0x6001',
'File' => '/dev/ttyUSB0',
'Vendor' => 'usb 0x0403 "Future Technology Devices International, Ltd"',
'Model' => 'Future Technology Devices International FT232 Serial (UART) IC',
'Driver Modules' => 'usbserial, ftdi_sio',
'Driver' => 'ftdi_sio',
),
2 =>
array (
'Device' => '0x0003',
),
)
28.08. 11:43:09 -Regler: 64
28.08. 11:43:09 -Regler erkannt: /dev/ttyUSB0
28.08. 11:43:09 -Device: /dev/ttyUSB0 wird in die user.config.php eingetragen.
28.08. 11:43:09 -Zeile gefunden. USB Device kann ausgetauscht werden. Index: 716 $USBRegler = "/dev/ttyUSB0";

28.08. 11:43:09 -Zeile gefunden. Raspberry Modell kann eingetragen werden. Index: 735 $Platine = "Raspberry Pi 4 Model B Rev 1.2";

28.08. 11:43:09 -Es handelt sich um ein 32 Bit System.
28.08. 11:44:17 |------------------------- Start goodwe_ET.php ---------------------
28.08. 11:44:17 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:17 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:17 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:17 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:17 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:17 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:18 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:18 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:18 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:18 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:18 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:18 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:19 -Lesefehler > [ f703020002f190 ]
28.08. 11:44:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:19 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:20 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:20 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:20 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:20 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:20 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:20 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:20 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:21 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:21 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:21 -Lesefehler > [ f7030200fef1d1 ]
28.08. 11:44:21 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:21 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:21 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:21 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:22 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:22 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:22 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:22 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:22 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:22 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:22 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:23 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:23 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:23 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:23 -Lesefehler > [ f70310393635303045545532333257303331309044 ]
28.08. 11:44:23 -S/N:
28.08. 11:44:23 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:23 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:23 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:24 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:24 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:24 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:24 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:24 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:24 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:24 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:25 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:25 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:25 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:25 -Falsche Daten kommen zurück. Noch einmal versuchen.
28.08. 11:44:25 -Lesefehler > [ f7030a4757362e354b4e2d45545c65 ]
28.08. 11:44:25 !! -Keine gültigen Daten empfangen.
28.08. 11:44:25 |------------------------- Stop goodwe_ET.php ---------------------
28.08. 11:45:01 |------------------------- Start goodwe_ET.php ---------------------

Leider kann ich aus den Beträgen nicht genau herauslesen was ich nun genau machen muss...Kann mir einer der Kollegen einen Tip geben ?

Sorry bin ebenfalls Anfänger in diesem Thema.

Besten Dank

Antworten

Zurück zu „Image Installation [ Single-Regler Version ]“