USB/RS485-Adapter- welche funktionieren?

Die benötigte Hardware zum Nachbau. Bitte hier nur Hardware posten, die man auch selber ausprobiert hat. Nichts posten, nur weil es neu ist.

Moderator: Ulrich

Forumsregeln
Bitte nur Hardware posten, die man selber auch ausprobiert bzw. in Verwendung hat.
SolarVogel
Beiträge: 128
Registriert: Mi 15. Jul 2020, 19:43
Wohnort: Ellerbek
Hat sich bedankt: 1 Mal

Re: USB/RS485-Adapter- welche funktionieren?

Beitrag von SolarVogel »

Moin Moin,

ich schreibe den Thread mal fort, weil auch bei mir geht es nicht per RS485.

- Adapter (der von Team0) ist auf ttyUSB0 erkannt und auf 19200 kB eingestellt.
- die TX LED blinkt jede min, so wie es sollte
- die RX LED ist mausetot, das tut sich nix.
- User.config.php m.E. auch ok, Regler 21, die IP auf 0.0.0.0 ist auch eingestellt. Ansonsten ist da ja nix zu tun.
- im Pico auch so wie hier beschrieben. Protokoll: KOSTAL, beide Häckchen Abschluss und Busvorspannung sind gesetzt.

Hat jemand noch eine Idee?

Gruß Michael

Benutzeravatar
Ulrich
Administrator
Beiträge: 2312
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 9 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: USB/RS485-Adapter- welche funktionieren?

Beitrag von Ulrich »

Prüfe einmal ob nicht die A + B Ader vertauscht ist. Das ist der häufigste Grund, wenn es nicht funktioniert. Anders als bei einer seriellen Leitung dürfen die beiden Adern nicht vertauscht werden. Nach dem Tauschen unbedingt immer den Raspberry neu starten.
--------------------------------------
Ulrich [Admin]

SolarVogel
Beiträge: 128
Registriert: Mi 15. Jul 2020, 19:43
Wohnort: Ellerbek
Hat sich bedankt: 1 Mal

Re: USB/RS485-Adapter- welche funktionieren?

Beitrag von SolarVogel »

Moin Ulrich,

danke für den Hinweis. Nach Tausch blinken nun tatsächlich beide LED's TX und RX, obwohl die Kabel (nach jeweiligem A/B Aufdruck) nun eigentlich überkreuz angeschlossen sind. Im Pino Dashboard wird aber immer noch nix, sprich "no Data" angezeigt.

Gibt es irgendwo ein LOG, oder auf Linux Ebene eine Möglichkeit zu schauen ob die Daten auch ankommen?

Wenn ich cat /dev/ttyUSB0 eingebe, sollte doch was zu sehen sein. Tut es aber nicht.

Gruß Michael

SolarVogel
Beiträge: 128
Registriert: Mi 15. Jul 2020, 19:43
Wohnort: Ellerbek
Hat sich bedankt: 1 Mal

Re: USB/RS485-Adapter- welche funktionieren?

Beitrag von SolarVogel »

hier die Log der Solaranzeige. Danach ist die Datenübertragung ja ok, aber es kommt nix....

27.04. 11:52:57 -OK. Datenübertragung erfolgreich.
27.04. 11:52:57 |---------------- Stop kostal_piko.php --------------------
27.04. 11:53:01 |---------------- Start kostal_piko.php ---------------------
27.04. 11:53:02 + -Die Daten werden ausgelesen...
27.04. 11:53:04 -InfluxDB => [ AC Spannung_R=0,Spannung_S=0,Spannung_T=0,Strom_R=0,Strom_S=0,Strom_T=0,Leistung_R=,Leistung_S=,Leistung_T= 1619517191
PV String1_Spannung=0,String2_Spannung=0,String3_Spannung=0,String1_Strom=0,String2_Strom=0,String3_Strom=0,String1_Leistung=,String2_Leistung=,String3_Leistung=,String1_Nummer="1",String2_Nummer="2",String3_Nummer="3",Leistung=0 1619517191
Service FehlerCode=,Status=,Fehler=,Strings=0,Phasen=0 1619517191
Summen Wh_Heute=0,Wh_Gesamt=0,AC_Leistung_Gesamt=0,PV_Leistung_Gesamt=0 1619517191
]
27.04. 11:53:04 -Daten nicht zur lokalen InfluxDB gesendet! info: array (
'url' => 'http://localhost/write?db=solaranzeige&precision=s',
'content_type' => 'application/json',
'http_code' => 400,
'header_size' => 860,
'request_size' => 670,
'filetime' => -1,
'ssl_verify_result' => 0,
'redirect_count' => 0,
'total_time' => 0.009249,
'namelookup_time' => 0.003267,
'connect_time' => 0.004054,
'pretransfer_time' => 0.005099,
'size_upload' => 513.0,
'size_download' => 591.0,
'speed_download' => 65666.0,
'speed_upload' => 57000.0,
'download_content_length' => 591.0,
'upload_content_length' => 513.0,
'starttransfer_time' => 0.009077,
'redirect_time' => 0.0,
'redirect_url' => '',
'primary_ip' => '::1',
'certinfo' =>
array (
),
'primary_port' => 8086,
'local_ip' => '::1',
'local_port' => 57444,
'http_version' => 2,
'protocol' => 1,
'ssl_verifyresult' => 0,
'scheme' => 'HTTP',
'appconnect_time_us' => 0,
'connect_time_us' => 4054,
'namelookup_time_us' => 3267,
'pretransfer_time_us' => 5099,
'redirect_time_us' => 0,
'starttransfer_time_us' => 9077,
'total_time_us' => 9249,
)
27.04. 11:53:09 -InfluxDB => [ AC Spannung_R=0,Spannung_S=0,Spannung_T=0,Strom_R=0,Strom_S=0,Strom_T=0,Leistung_R=,Leistung_S=,Leistung_T= 1619517191
PV String1_Spannung=0,String2_Spannung=0,String3_Spannung=0,String1_Strom=0,String2_Strom=0,String3_Strom=0,String1_Leistung=,String2_Leistung=,String3_Leistung=,String1_Nummer="1",String2_Nummer="2",String3_Nummer="3",Leistung=0 1619517191
Service FehlerCode=,Status=,Fehler=,Strings=0,Phasen=0 1619517191
Summen Wh_Heute=0,Wh_Gesamt=0,AC_Leistung_Gesamt=0,PV_Leistung_Gesamt=0 1619517191
]
27.04. 11:53:09 -Daten nicht zur lokalen InfluxDB gesendet! info: array (
'url' => 'http://localhost/write?db=solaranzeige&precision=s',
'content_type' => 'application/json',
'http_code' => 400,
'header_size' => 860,
'request_size' => 670,
'filetime' => -1,
'ssl_verify_result' => 0,
'redirect_count' => 0,
'total_time' => 0.004868,
'namelookup_time' => 0.000116,
'connect_time' => 0.000119,
'pretransfer_time' => 0.00036,
'size_upload' => 513.0,
'size_download' => 591.0,
'speed_download' => 147750.0,
'speed_upload' => 128250.0,
'download_content_length' => 591.0,
'upload_content_length' => 513.0,
'starttransfer_time' => 0.004781,
'redirect_time' => 0.0,
'redirect_url' => '',
'primary_ip' => '::1',
'certinfo' =>
array (
),
'primary_port' => 8086,
'local_ip' => '::1',
'local_port' => 57444,
'http_version' => 2,
'protocol' => 1,
'ssl_verifyresult' => 0,
'scheme' => 'HTTP',
'appconnect_time_us' => 120,
'connect_time_us' => 119,
'namelookup_time_us' => 116,
'pretransfer_time_us' => 360,
'redirect_time_us' => 0,
'starttransfer_time_us' => 4781,
'total_time_us' => 4868,
)

Benutzeravatar
Ulrich
Administrator
Beiträge: 2312
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 9 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: USB/RS485-Adapter- welche funktionieren?

Beitrag von Ulrich »

Nein, die Daten sind nicht OK. Das Gerät wird nicht (richtig) ausgelesen.
Wenn das Auslesen funktioniert erscheint auch diese Fehlermeldung nicht mehr.
--------------------------------------
Ulrich [Admin]

SolarVogel
Beiträge: 128
Registriert: Mi 15. Jul 2020, 19:43
Wohnort: Ellerbek
Hat sich bedankt: 1 Mal

Re: USB/RS485-Adapter- welche funktionieren?

Beitrag von SolarVogel »

aber warum???

Benutzeravatar
Ulrich
Administrator
Beiträge: 2312
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 9 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: USB/RS485-Adapter- welche funktionieren?

Beitrag von Ulrich »

Prüfe einmal bitte ob im Pico die serielle Geschwindigkeit der RS485 Schnittstelle auf 19200 Baud steht.

Kannst Du nicht erst einmal mit einem LAPTOP und einem Windows Programm die Verbindung prüfen. Es gibt doch bestimmt irgend ein Windwos Programm zum Auslesen des Piko über RS485
--------------------------------------
Ulrich [Admin]

SolarVogel
Beiträge: 128
Registriert: Mi 15. Jul 2020, 19:43
Wohnort: Ellerbek
Hat sich bedankt: 1 Mal

Re: USB/RS485-Adapter- welche funktionieren?

Beitrag von SolarVogel »

pico ist auf 19200 eingestellt.

Das kann ich machen. Haste Du einen Terminal-Befehl den ich an den Pico senden kann.

Benutzeravatar
Ulrich
Administrator
Beiträge: 2312
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 9 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: USB/RS485-Adapter- welche funktionieren?

Beitrag von Ulrich »

Ist der Piko eventuell schon über RS485 mit irgend einem anderen Gerät verbunden?
--------------------------------------
Ulrich [Admin]

SolarVogel
Beiträge: 128
Registriert: Mi 15. Jul 2020, 19:43
Wohnort: Ellerbek
Hat sich bedankt: 1 Mal

Re: USB/RS485-Adapter- welche funktionieren?

Beitrag von SolarVogel »

nein, die Klemmen waren frei. Allerdings berichtet er per Lan ins Kostal-Portal. Das tut's auch gut. Kann man ggf. nicht beides parallel betreiben.

Dankend Gruß Michael

Antworten