Problem Daly BMS, RS485 Pin-Belegung

Die benötigte Hardware zum Nachbau. Bitte hier nur Hardware posten, die man auch selber ausprobiert hat. Nichts posten, nur weil es neu ist.

Moderator: Ulrich

Forumsregeln
Bitte nur Hardware posten, die man selber auch ausprobiert bzw. in Verwendung hat.
solarfanenrico
Beiträge: 513
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 27 Mal
Danksagung erhalten: 34 Mal

Re: Problem Daly BMS, RS485 Pin-Belegung

Beitrag von solarfanenrico »

Hallo e-l-k-e,
Dies scheint ein RS232 zu USB-Adapter zu sein. Und mit den anderen herstellerseitigen Komponenten und Programmen wird das funktionieren.

07.10. 21:45:05 -Daten:
array (
24 => 'USB 00.0: 0700 Serial controller',
'' => '[Created at usb.122]',
'Unique ID' => 'dwDZ.zv7lh3BJnp7',
'Parent ID' => 'ADDn.IKhPgutgmvF',
'SysFS ID' => '/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0',
'SysFS BusID' => '1-1.3:1.0',
'Hardware Class' => 'unknown',
'Model' => '"QinHeng Electronics HL-340 USB-Serial adapter"',
'Hotplug' => 'USB',
'Vendor' => 'usb 0x1a86 "QinHeng Electronics"',
'Device' => 'usb 0x7523 "HL-340 USB-Serial adapter"',
'Revision' => '"2.64"',
'Driver' => '"ch341"',
'Driver Modules' => '"usbserial"',
'Device File' => '/dev/ttyUSB0',
'Device Files' => '/dev/ttyUSB0, /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0, /dev/serial/by-path/platform-3f980000.usb-usb-0:1.3:1.0-port0',
'Device Number' => 'char 188:0',
'Speed' => '12 Mbps',
'Module Alias' => '"usb:v1A86p7523d0264dcFFdsc00dp00icFFisc01ip02in00"',
'Driver Info #0' => '',
'Driver Status' => 'ch341 is active',
'Driver Activation Cmd' => '"modprobe ch341"',
'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
'Attached to' => '#27 (Hub)',
)
07.10. 21:45:05 -Daten:
array (
25 => 'USB 00.0: 10a00 Hub',
'' => '[Created at usb.122]',
'Unique ID' => 'k4bc.D6ER+lJeRh3',
'Parent ID' => '3t9U.TAOITtdfnIE',
'SysFS ID' => '/devices/platform/soc/3f980000.usb/usb1/1-0:1.0',
'SysFS BusID' => '1-0:1.0',
'Hardware Class' => 'hub',
'Model' => '"Linux Foundation 2.0 root hub"',
'Hotplug' => 'USB',
'Vendor' => 'usb 0x1d6b "Linux Foundation"',
'Device' => 'usb 0x0002 "2.0 root hub"',
'Revision' => '"5.10"',
'Serial ID' => '"3f980000.usb"',
'Driver' => '"hub"',
'Driver Modules' => '"usbcore"',
'Speed' => '480 Mbps',
'Module Alias' => '"usb:v1D6Bp0002d0510dc09dsc00dp01ic09isc00ip00in00"',
'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
'Attached to' => '#1 (USB Controller)',
)
07.10. 21:45:05 -Daten:
array (
26 => 'USB 00.0: 0200 Ethernet controller',
'' => '[Created at usb.122]',
'Unique ID' => 'lfzD.Sed3PcmdZ23',
'Parent ID' => 'ADDn.IKhPgutgmvF',
'SysFS ID' => '/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1:1.0',
'SysFS BusID' => '1-1.1:1.0',
'Hardware Class' => 'network',
'Model' => '"Standard Microsystems SMSC9512/9514 Fast Ethernet Adapter"',
'Hotplug' => 'USB',
'Vendor' => 'usb 0x0424 "Standard Microsystems Corp."',
'Device' => 'usb 0xec00 "SMSC9512/9514 Fast Ethernet Adapter"',
'Revision' => '"2.00"',
'Driver' => '"smsc95xx"',
'Driver Modules' => '"smsc95xx"',
'Device File' => 'eth0',
'Speed' => '480 Mbps',
'HW Address' => 'b8:27:eb:2d:17:a5',
'Permanent HW Address' => 'b8:27:eb:2d:17:a5',
'Link detected' => 'no',
'Module Alias' => '"usb:v0424pEC00d0200dcFFdsc00dp01icFFisc00ipFFin00"',
'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
'Attached to' => '#27 (Hub)',
)
07.10. 21:45:05 -Daten:
array (
27 => 'USB 00.0: 10a00 Hub',
'' => '',
'Unique ID' => 'ADDn.IKhPgutgmvF',
'Parent ID' => 'k4bc.D6ER+lJeRh3',
'SysFS ID' => '/devices/platform/soc/3f980000.usb/usb1/1-1/1-1:1.0',
'SysFS BusID' => '1-1:1.0',
'Hardware Class' => 'hub',
'Model' => '"Standard Microsystems SMC9514 Hub"',
'Hotplug' => 'USB',
'Vendor' => 'usb 0x0424 "Standard Microsystems Corp."',
'Device' => 'usb 0x9514 "SMC9514 Hub"',
'Revision' => '"2.00"',
'Driver' => '"hub"',
'Driver Modules' => '"usbcore"',
'Speed' => '480 Mbps',
'Module Alias' => '"usb:v0424p9514d0200dc09dsc00dp02ic09isc00ip02in00"',
'Config Status' => 'cfg=new, avail=yes, need=no, active=unknown',
'Attached to' => '#25 (Hub)',
)
Dieses Protokoll könnte man vielleicht anlegen, aber es kann nur Ulrich machen.
Der Aufwand lohnt sich aber nur, wenn es viele benötigen.

In der Liste der Geräte ist ja ein RS485zusUSB mit FTDI empfohlen, der wird schon klappen.

Enrico

solarfanenrico
Beiträge: 513
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 27 Mal
Danksagung erhalten: 34 Mal

Re: Problem Daly BMS, RS485 Pin-Belegung

Beitrag von solarfanenrico »

Hallo e-l-k-e,
ich habe mir gerade mal ein Video zu einem Daly BMS angesehen, und gleich eine Frage.
https://www.youtube.com/watch?v=uM3z__xYmx0
Gibt es eine Anleitung, wo der Adapter angesteckt wird, und wo das lange Ende des USB-Kabels.

So wie ich dieses Video interpretiere muß der Adapter in den Raspberry und der einfache Stecker(falls vorhanden) ins Daly BMS.

Ich denke, daß andere Lösungen, in denen 2 Adern (+/-) an einen RS485 zu USB Adapter geklemmt werden nicht funktionieren werden.
Ich kann jedoch auch komplett daneben liegen.
Bisher habe ich auch noch keinen Thread gefunden, wo der Daly BMS erfolgreich integriert wurde. Die ReglerNr.57 besagt zwar etwas anderes, naja warten wir mal ab.

Enrico

e-i-k-e
Beiträge: 34
Registriert: Do 9. Apr 2020, 21:10
Hat sich bedankt: 6 Mal
Danksagung erhalten: 1 Mal

Re: Problem Daly BMS, RS485 Pin-Belegung

Beitrag von e-i-k-e »

Hallo Enrico,

meine BMS sieht etwas anders aus und hat auch eine Buchse für 485 (3 PINs). Ich kann auch darüber das BMS mit einem Windows PC + Daly Software auslesen. Und dies klappt mit dem originalen Adapter sowie den bekannten von gestern und auch mit den zwei neuen, die heute geliefert worden sind. Einer der beiden hat einen FTDI Chip.

Aber ich erhalte bei allen 4 Adapter immer den selben Fehler. Was läuft hier falsch? :? :?
neu_mit_teuer_serial.JPG
fehler_neu_teuer2.JPG

e-i-k-e
Beiträge: 34
Registriert: Do 9. Apr 2020, 21:10
Hat sich bedankt: 6 Mal
Danksagung erhalten: 1 Mal

Re: Problem Daly BMS, RS485 Pin-Belegung

Beitrag von e-i-k-e »

Ich habe soeben einen weiteren Raspberry neu mit Solaranzeige ausgestattet und nur das DalyBMS eingerichtet.
Gleicher Fehler... :evil: :roll:

Adapter.JPG

Code: Alles auswählen

09.10. 00:09:01 |------------   Start  daly_bms.php    ---------------------------- 
09.10. 00:09:01    -USB Port: /dev/ttyUSB0
09.10. 00:09:03 !! -Datenfehler, nochmal... a58090080000000000000000
09.10. 00:09:05 !! -Datenfehler, nochmal... a58090080000000000000000
09.10. 00:09:07 !! -Datenfehler, nochmal... a58090080000000000000000
09.10. 00:09:09 !! -Datenfehler, nochmal... a58090080000000000000000
09.10. 00:09:11 !! -Datenfehler, nochmal... a58090080000000000000000
09.10. 00:09:13 !! -Datenfehler, nochmal... a58090080000000000000000
09.10. 00:09:15 !! -Datenfehler, nochmal... a58090080000000000000000
09.10. 00:09:17 !! -Datenfehler, nochmal... a58090080000000000000000
09.10. 00:09:19 !! -Datenfehler, nochmal... a58090080000000000000000
09.10. 00:09:21 !! -Datenfehler, nochmal... a58090080000000000000000
09.10. 00:09:21 !! -Keine gültigen Daten empfangen.
09.10. 00:09:21 |------------   Stop   daly_bms.php    ---------------------------- 

solarfanenrico
Beiträge: 513
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 27 Mal
Danksagung erhalten: 34 Mal

Re: Problem Daly BMS, RS485 Pin-Belegung

Beitrag von solarfanenrico »

Hallo e-l-k-e,
der andy64 in diesem viewtopic.php?f=4&t=1705Thread scheint der einzige zu sein, der Daly BMS mit solaranzeige benutzen kann. Eigentlich warst Du auch schon einmal dort.
Ulrich empfiehlt etwas mit der Baudrate und andy64 hat GND verwendet.Erst danach kamen Daten an.
Da ich dies leider nicht nutze, kann ich nichts testen.
Enrico

e-i-k-e
Beiträge: 34
Registriert: Do 9. Apr 2020, 21:10
Hat sich bedankt: 6 Mal
Danksagung erhalten: 1 Mal

Re: Problem Daly BMS, RS485 Pin-Belegung

Beitrag von e-i-k-e »

Hallo Enrico,

die Baudrate steht auf 9600, mein Masse hat Verbindung zum Erdungspotential. Somit schließe ich dies erstmal aus.
Neben der 485 Schnittstelle, besteht auch eine UART Schnittstelle.
Screenshot_20211009-220235_Samsung Internet.jpg
In dieser Steckt aktuell der BT Sender.
Muss evtl. diese Schnittstelle verwenden werden ?
Könnte ich dafür auch mein rs485 Adapter mit dem FTDI Chip verwenden?

Benutzeravatar
Ulrich
Administrator
Beiträge: 2731
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 32 Mal
Danksagung erhalten: 172 Mal
Kontaktdaten:

Re: Problem Daly BMS, RS485 Pin-Belegung

Beitrag von Ulrich »

Bitte probiere doch beides einmal aus. Nach jedem Umstecken unbedingt den Raspberry jedes mal neu starten.
--------------------------------------
Ulrich [Admin]

solarfanenrico
Beiträge: 513
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 27 Mal
Danksagung erhalten: 34 Mal

Re: Problem Daly BMS, RS485 Pin-Belegung

Beitrag von solarfanenrico »

Hallo e-l-k-e,
leider habe ich doch kein BMS, um es zu testen.
Aber aus dem Video hatte ich gesehen, daß die UART auch für Bluetooth war. Hier vermute ich eine RS232, also würde ich sagen RS485 nein.

Aber am RS485 Adapter mit FTDI sollten eigentlich 3 Adern klemmbar sein. +, - und GND. Und ich denke, daß andy64 diesen GND gemeint hat, der zusätzlich auf besagte Masse gezogen wurde. Welche kann ich aber auch nicht sagen. Schreibe doch andy64 deswegen mal an. Vielleicht antwortet er.

Es wäre kein Problem, wenn ich ein DalyBMS hätte. Ich würde das Risiko des Test's auf mich nehmen, und dann empfehlen. Ansonsten kann ich aber keine Garantie für Erfolg oder Zerstörung geben.

Enrico

e-i-k-e
Beiträge: 34
Registriert: Do 9. Apr 2020, 21:10
Hat sich bedankt: 6 Mal
Danksagung erhalten: 1 Mal

Re: Problem Daly BMS, RS485 Pin-Belegung

Beitrag von e-i-k-e »

Hallo Enrico,
Ich habe mir einen rs232 Adapter bestellt und werde dann beides an der UART Schnittstelle testen.
Hoffentlich habe ich Erfolg!

Was ich aber nicht verstehe, warum funktioniert die 485 Schnittstelle an meinem Windows PC und der Daly Software? Und das mit jedem Adapter den ich mittlerweile besitze.

solarfanenrico
Beiträge: 513
Registriert: Mi 20. Jan 2021, 19:49
Hat sich bedankt: 27 Mal
Danksagung erhalten: 34 Mal

Re: Problem Daly BMS, RS485 Pin-Belegung

Beitrag von solarfanenrico »

e-i-k-e hat geschrieben:
So 10. Okt 2021, 21:43
Hallo Enrico,
Ich habe mir einen rs232 Adapter bestellt und werde dann beides an der UART Schnittstelle testen.
Hoffentlich habe ich Erfolg!

Was ich aber nicht verstehe, warum funktioniert die 485 Schnittstelle an meinem Windows PC und der Daly Software? Und das mit jedem Adapter den ich mittlerweile besitze.
Hallo e-l-k-e,
habe gerade gesehen, simon.s ist nahe dran, und Du bereits auf seiner Spur.
Enrico

Antworten