RS 485 am GoodWe ET

Die benötigte Hardware zum Nachbau. Bitte hier nur Hardware posten, die man auch selber ausprobiert hat. Nichts posten, nur weil es neu ist.

Moderator: Ulrich

Forumsregeln
Bitte nur Hardware posten, die man selber auch ausprobiert bzw. in Verwendung hat.
Benutzeravatar
Lionking1982
Beiträge: 48
Registriert: Mi 6. Okt 2021, 19:57
Wohnort: Bayern
Danksagung erhalten: 6 Mal

Re: RS 485 am GoodWe ET

Beitrag von Lionking1982 »

Also ich nutze nur Grün-Grün/Weiß
Grün/Weis - RS485A
Grün - RS485B
Klappt problemlos auf 40 Meter Entfernung
Dateianhänge
IMG_8368.JPG
Goodwe GW10K-ET, 9.6 Kwp, BYD HVM 13.8, Go-eCharger 10kw Home Fix, BMW i3S, TA-Aton E-Heitzstab 2x3Kw

Spike219
Beiträge: 8
Registriert: Do 14. Jul 2022, 08:47
Hat sich bedankt: 2 Mal

Re: RS 485 am GoodWe ET

Beitrag von Spike219 »

Ich habe nun auch soweit alle Komponenten zusammen, jedoch funktioniert bei mir die Datenübermittlung aus dem Wechselrichter nicht. (Raspberry Pi läuft, Grafana läuft) Ich habe einen SH-U 11 Adapter von DSD Tech gekauft. dieser hat insgesamt 5 Anschlüsse (1 Erde). Ich habe Grün-weis und Grün an 1 und 2 angeschlossen. und auch die WR Adresse 247 eingetragen (ist ein Goodwe Gw10k ET) einzig mit der Einstellung der Baudrate kann ich nichts anfangen/ weiss nicht wo ich das machen soll. Ist vielleicht noch etwas am Wechselrichter zu ändern? Hat vielleicht noch jemand den selben USB Adapter und kann mir weiterhelfen?

Spike219
Beiträge: 8
Registriert: Do 14. Jul 2022, 08:47
Hat sich bedankt: 2 Mal

Re: RS 485 am GoodWe ET

Beitrag von Spike219 »

Spike219 hat geschrieben:
So 24. Jul 2022, 09:12
Ich habe nun auch soweit alle Komponenten zusammen, jedoch funktioniert bei mir die Datenübermittlung aus dem Wechselrichter nicht. (Raspberry Pi läuft, Grafana läuft) Ich habe einen SH-U 11 Adapter von DSD Tech gekauft. dieser hat insgesamt 5 Anschlüsse (1 Erde). Ich habe Grün-weis und Grün an 1 und 2 angeschlossen. und auch die WR Adresse 247 eingetragen (ist ein Goodwe Gw10k ET) einzig mit der Einstellung der Baudrate kann ich nichts anfangen/ weiss nicht wo ich das machen soll. Ist vielleicht noch etwas am Wechselrichter zu ändern? Hat vielleicht noch jemand den selben USB Adapter und kann mir weiterhelfen?
Gelöst, mehrmaliges (nicht nur einmal) Neustarten am Pi hat die Lösung gebracht.

Nächste Frage: Einspeisung gemäß SEMS Portal 25 kW

In Grafana unter Wh_NetzeinspeisungHeute werden 34,3 kWh angezeigt, also einiges an Abweichung.

Die Tagesproduktion stimmt bis auf eine Kommastelle genau.

zzcruiser
Beiträge: 2
Registriert: Do 20. Okt 2022, 09:02

Re: RS 485 am GoodWe ET

Beitrag von zzcruiser »

Hallo,

ich bin neu hier.
Seit 5 Tagen bin ich stolzer Besitzer eines Goodwe GW10ET-K Plus und einer BYD 5.1 , Goodwe GM 3000 Smartmeter.
Ich versuche seit 2 Tagen den Wechselrichter Daten zu entlocken.
Welches Kabel auf dem Foto benutzt du? Ist es die Leitung die vom WR --> BMS oder WR --> Smartmeter ?

Lg. Marco

Benutzeravatar
Lionking1982
Beiträge: 48
Registriert: Mi 6. Okt 2021, 19:57
Wohnort: Bayern
Danksagung erhalten: 6 Mal

Re: RS 485 am GoodWe ET

Beitrag von Lionking1982 »

Hallo Marco,

Es ist die dritte von 2 Möglickeiten :D
Die Solaranzeige wird am Anschluss "EMS" angeschlossen.
Die Buchse ist der zweite Anschluss unter der Abdeckung vom Smart Meter Anschluss.
Als Kabel kannst du einfach ein Netzwerkkabel abschneiden und die Grüne + Weiß/Grüne Leitung mit dem RS485 Adapter verbinden.(Siehe Bild weiter Oben)

Grüße Lion
Goodwe GW10K-ET, 9.6 Kwp, BYD HVM 13.8, Go-eCharger 10kw Home Fix, BMW i3S, TA-Aton E-Heitzstab 2x3Kw

zzcruiser
Beiträge: 2
Registriert: Do 20. Okt 2022, 09:02

Re: RS 485 am GoodWe ET

Beitrag von zzcruiser »

Hallo Lionking,

ich habe das Orange und Orange-Weise genommem welches zum BMS geht.
BMS BYD habe ich per CAN H und L am WR angeschlossen.
Daten bekomme ich nun.
Leider kann ich noch nichts damit anfangen.

Slave ID:247 ,Read Holding Register 0x03, Start Adresse 35000 , Num of coils 33

f7 03 42 00 01 27 10 00 fe 39 30 31 30 4b 45 54 55 32 32 35 57 32 33 36 30 47 57 31 30 4b 2d 45 54 20 20 00 08 00 08 00 9f 00 14 00 e1 30 34 30 32 39 2d 30 38 2d 53 31 31 30 32 30 34 31 2d 31 39 2d 53 30 30 e2 b7

Aus dem Register Dokument von Goodwe werde ich noch nicht schlau.
Gibt es eine Möglichkeit die Daten lesbar zu machen?

Lg. Marco

Nachtrag:
Hab hier noch etwas gefunden was man zum übersetzen benutzen kann.

https://loxwiki.atlassian.net/wiki/spac ... BUS+TCP+IP
https://downloads.vodnici.net/uploads/w ... series.pdf

vielleicht hilft es dem ein oder andern auch weiter.

Benutzeravatar
Lionking1982
Beiträge: 48
Registriert: Mi 6. Okt 2021, 19:57
Wohnort: Bayern
Danksagung erhalten: 6 Mal

Re: RS 485 am GoodWe ET

Beitrag von Lionking1982 »

Super wenn es Daten schon mal Funktionieren.

Mit der Auswertung kann ich dir leider nicht Helfen.

Schon mal einen der Beiden vorhandenen Goodwe Wechselrichter versucht z.B. Regler 64 ?
Goodwe GW10K-ET, 9.6 Kwp, BYD HVM 13.8, Go-eCharger 10kw Home Fix, BMW i3S, TA-Aton E-Heitzstab 2x3Kw

MB1983k
Beiträge: 47
Registriert: Mo 19. Sep 2022, 20:18
Hat sich bedankt: 7 Mal
Danksagung erhalten: 1 Mal

Re: RS 485 am GoodWe ET

Beitrag von MB1983k »

Lionking1982 hat geschrieben:
Mi 13. Apr 2022, 13:25
Also ich nutze nur Grün-Grün/Weiß
Grün/Weis - RS485A
Grün - RS485B
Klappt problemlos auf 40 Meter Entfernung
Welchen RS485 zu USB Konverter verwendest du hier?

Benutzeravatar
Lionking1982
Beiträge: 48
Registriert: Mi 6. Okt 2021, 19:57
Wohnort: Bayern
Danksagung erhalten: 6 Mal

Re: RS 485 am GoodWe ET

Beitrag von Lionking1982 »

Goodwe GW10K-ET, 9.6 Kwp, BYD HVM 13.8, Go-eCharger 10kw Home Fix, BMW i3S, TA-Aton E-Heitzstab 2x3Kw

gerald_z
Beiträge: 6
Registriert: Do 4. Aug 2022, 12:34

Re: RS 485 am GoodWe ET

Beitrag von gerald_z »

Ich habe eine kleines Bild angefertigt. Soweit ich das verstanden habe sollte es so angeklemmt werden.
Kann das zur Sicherheit jemand bestätigen?
InkedGoodwe ET RS2485.jpg


Gruß Gerald

Antworten