Probleme beim Einbinden des 2. WR

Wenn mehr als ein Gerät an den Raspberry angeschlossen werden sollen. Z.B. ein Regler und ein Wechselrichter oder mehrere Wechselrichter. Das Maximum sind 6 Geräte pro Raspberry Pi.

Moderator: Ulrich

Antworten
ManuelM
Beiträge: 4
Registriert: Mi 27. Okt 2021, 07:19

Probleme beim Einbinden des 2. WR

Beitrag von ManuelM »

Hallo zusammen, mit meinem 1. Wechselrichter läuft die Solaranzeige wie sie soll.
Bei der Einbindung des 2. WR bekomme ich folgende Fehlermeldungen im Log (siehe Anhang).

Wechselrichter ist ein SMA Tripower 5000TL-20.

TCP Modbus wurde eingeschaltet.
Über Ethernet und Sunny Explorer kann ich auf den Wechselrichter zugreifen.

Danke für eure Hilfe!
Dateianhänge
fehler2.png
fehler2.png (10.28 KiB) 220 mal betrachtet
fehler.png

TeamO
Beiträge: 423
Registriert: Mo 22. Jun 2020, 08:58
Hat sich bedankt: 4 Mal
Danksagung erhalten: 67 Mal

Re: Probleme beim Einbinden des 2. WR

Beitrag von TeamO »

Da scheint in Deiner 2.user.config.php ein Fehler zu sein.
Lad mal bitte beide user.config.php hoch, damit ich mir das anschauen kann.

ManuelM
Beiträge: 4
Registriert: Mi 27. Okt 2021, 07:19

Re: Probleme beim Einbinden des 2. WR

Beitrag von ManuelM »

Also inzwischen habe ich alle Fehler wegbekommen (Zahlendreher in der IP-Adresse), bis auf den syntax error.

Anbei der Log sowie die beiden Abschnitte aus der User.config.
Dateianhänge
Fehler5.png
Fehler4.png
Fehler3.png

ManuelM
Beiträge: 4
Registriert: Mi 27. Okt 2021, 07:19

Re: Probleme beim Einbinden des 2. WR

Beitrag von ManuelM »

Ok, Problem hat sich erledigt. Hier ist irgendetwas beim Kopieren schief gelaufen. Ein ";" hat gefehlt.

Danke für die schnelle Hilfe!

TeamO
Beiträge: 423
Registriert: Mo 22. Jun 2020, 08:58
Hat sich bedankt: 4 Mal
Danksagung erhalten: 67 Mal

Re: Probleme beim Einbinden des 2. WR

Beitrag von TeamO »

Wollte ich gerade schreiben, das bei $WR_Adresse das ";" am Ende fehlt.
Weiterhin sollte Deine user.config.php eigentlich 1.user.config.php heisen. Eventuell hast du aber auch einfach nur die "falsche" als Bild angehängt ;)

Gruß
Timo

Antworten