Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Wenn mehr als ein Gerät an den Raspberry angeschlossen werden sollen. Z.B. ein Regler und ein Wechselrichter oder mehrere Wechselrichter. Das Maximum sind 6 Geräte pro Raspberry Pi.

Moderator: Ulrich

Antworten
Andi1976
Beiträge: 6
Registriert: Do 18. Nov 2021, 16:51
Hat sich bedankt: 1 Mal

Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von Andi1976 »

Hallo,

ich bin neu hier und gerade dabei mir die Solaranzeige einzurichten.

Bitte um HILFE!

Ich habe mit einem Growatt Wechselrichter begonnen, und dieser läuft auch.

Habe dann umgestellt auf Multi-Regler da ich mein SDM630 hinzu fügen wollte.
Soweit hat auch alles geklappt.

Aber ich bekomme keine Daten in Grafana. Im solaranzeige.log steht folgendes:
29.12. 14:53:01 -Multi Regler Auslesen [Start].
29.12. 14:53:01 -Verarbeitung von: '1.user.config.php' Regler: 48
29.12. 14:53:01 |------------------------- Start growatt.php ---------------------
29.12. 14:53:04 -Firmware: GH1.0 Warnungen: 00000000
29.12. 14:53:04 -Auslesen des Gerätes beendet.
29.12. 14:53:04 * -Daten zur lokalen InfluxDB [ solaranzeigemulti ] gesendet.
29.12. 14:53:04 -OK. Datenübertragung erfolgreich.
29.12. 14:53:04 |------------------------- Stop growatt.php ---------------------
29.12. 14:53:04 -Verarbeitung von: '2.user.config.php' Regler: 34
29.12. 14:53:04 + -WR_ID: 002
29.12. 14:53:04 |------------ Start SDM630_meter.php -------------------------
29.12. 14:53:15 -AC Leistung: Watt
29.12. 14:53:18 -InfluxDB => [ AC Spannung=,Strom=,Frequenz=,Leistung=,Leistungsfaktor=,Spannung_R=,Spannung_S=,Spannung_T=,Strom_R=,Strom_S=,Strom_T=,Leistung_R=,Leistung_S=,Leistung_T=,Leistungsfaktor_R=,Leistungsfaktor_S=,Leistungsfaktor_T= 1640785991
Summen Wh_GesamtBezug=0,Wh_GesamtEinspeisung=0,GesamtLeistungsbedarf= 1640785991
]
29.12. 14:53:18 -Daten nicht zur lokalen InfluxDB gesendet! info: array (
'url' => 'http://localhost/write?db=smartmeter&precision=s',
'content_type' => 'application/json',
'http_code' => 400,
'header_size' => 674,
'request_size' => 462,
'filetime' => -1,
'ssl_verify_result' => 0,
'redirect_count' => 0,
'total_time' => 0.002881,
'namelookup_time' => 0.000518,
'connect_time' => 0.00072,
'pretransfer_time' => 0.000818,
'size_upload' => 307.0,
'size_download' => 398.0,
'speed_download' => 199000.0,
'speed_upload' => 153500.0,
'download_content_length' => 398.0,
'upload_content_length' => 307.0,
'starttransfer_time' => 0.002831,
'redirect_time' => 0.0,
'redirect_url' => '',
'primary_ip' => '::1',
'certinfo' =>
array (
),
'primary_port' => 8086,
'local_ip' => '::1',
'local_port' => 58682,
'http_version' => 2,
'protocol' => 1,
'ssl_verifyresult' => 0,
'scheme' => 'HTTP',
'appconnect_time_us' => 0,
'connect_time_us' => 720,
'namelookup_time_us' => 518,
'pretransfer_time_us' => 818,
'redirect_time_us' => 0,
'starttransfer_time_us' => 2831,
'total_time_us' => 2881,
)
29.12. 14:53:23 -InfluxDB => [ AC Spannung=,Strom=,Frequenz=,Leistung=,Leistungsfaktor=,Spannung_R=,Spannung_S=,Spannung_T=,Strom_R=,Strom_S=,Strom_T=,Leistung_R=,Leistung_S=,Leistung_T=,Leistungsfaktor_R=,Leistungsfaktor_S=,Leistungsfaktor_T= 1640785991
Summen Wh_GesamtBezug=0,Wh_GesamtEinspeisung=0,GesamtLeistungsbedarf= 1640785991
]
29.12. 14:53:23 -Daten nicht zur lokalen InfluxDB gesendet! info: array (
'url' => 'http://localhost/write?db=smartmeter&precision=s',
'content_type' => 'application/json',
'http_code' => 400,
'header_size' => 674,
'request_size' => 462,
'filetime' => -1,
'ssl_verify_result' => 0,
'redirect_count' => 0,
'total_time' => 0.001441,
'namelookup_time' => 0.00014,
'connect_time' => 0.000143,
'pretransfer_time' => 0.00037,
'size_upload' => 307.0,
'size_download' => 398.0,
'speed_download' => 398000.0,
'speed_upload' => 307000.0,
'download_content_length' => 398.0,
'upload_content_length' => 307.0,
'starttransfer_time' => 0.001367,
'redirect_time' => 0.0,
'redirect_url' => '',
'primary_ip' => '::1',
'certinfo' =>
array (
),
'primary_port' => 8086,
'local_ip' => '::1',
'local_port' => 58682,
'http_version' => 2,
'protocol' => 1,
'ssl_verifyresult' => 0,
'scheme' => 'HTTP',
'appconnect_time_us' => 144,
'connect_time_us' => 143,
'namelookup_time_us' => 140,
'pretransfer_time_us' => 370,
'redirect_time_us' => 0,
'starttransfer_time_us' => 1367,
'total_time_us' => 1441,
)
29.12. 14:53:28 -Multi-Regler-Ausgang. -15
29.12. 14:53:28 -OK. Datenübertragung erfolgreich.
29.12. 14:53:28 |------------ Stop SDM630_meter.php -----------------------
29.12. 14:53:28 -Multi Regler Auslesen [Stop].
Die Daten werden über RS485 mit einem FTDI USB Adapter ausgelesen. Beiden wurden mit festen Namen versehen.
Auch über ttyUSB0 - ttyUSB1 keine Änderung.
Anderer USB-RS485 Adapter versucht.
Kabel A+B getauscht
Anderes Netzteil probiert
Alle Drahtpaare im LAN Kabel vom SDM630 zum Raspi probiert.

Was mir aufgefallen ist, am USB-RS485 Adapter leuchtet nur eine LED beim auslesen des SDM630
Hat jemand eine Lösung? Muss am SDM630 etwas eingestellt werden? Baud ist auf 19200 wie in der Anleitung!

Vielen Dank schon mal.

Gruß
Andi

Benutzeravatar
Ulrich
Administrator
Beiträge: 2990
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 38 Mal
Danksagung erhalten: 193 Mal
Kontaktdaten:

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von Ulrich »

Welche Geräte ID ist in dem SDM630 eingestellt? Das muss irgendwo im Menü zu finden sein.
--------------------------------------
Ulrich [Admin]

Andi1976
Beiträge: 6
Registriert: Do 18. Nov 2021, 16:51
Hat sich bedankt: 1 Mal

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von Andi1976 »

Hi,
Geräte ID im SDM 630 ist 002.

wyky
Beiträge: 13
Registriert: Do 12. Aug 2021, 15:48
Danksagung erhalten: 1 Mal

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von wyky »

Hallo Andi,
leuchtet am SDM630 der "Telefonhörer" bei einer Anfrage auf?

Gruß Udo

Andi1976
Beiträge: 6
Registriert: Do 18. Nov 2021, 16:51
Hat sich bedankt: 1 Mal

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von Andi1976 »

Hallo Udo,

also ich weiß das der Hörer schon mal geleuchtet hat, aber ob er aktuell leuchtet bei einer Abfrage wei0 ich nicht.
Schau ich nach.

Gruß Andi

Benutzeravatar
Ulrich
Administrator
Beiträge: 2990
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 38 Mal
Danksagung erhalten: 193 Mal
Kontaktdaten:

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von Ulrich »

Steht in der x.user.config.php den auch die richtige Adresse "2" ?

Code: Alles auswählen

//  Ethernet Kabelverbindung:          Local Area Network  (LAN)
//  Alle Geräte, die über das LAN angesprochen und ausgelesen werden,
//  oder ein Serial Device Server, wie z.B. der HF2211 oder der Elfin-EW11,
//  dazwischen geschaltet haben, bitte hier IP und Port eintragen und
//  falls erforderlich die Device ID. (Geräteadresse = WR_Adresse)
//  Die Geräte Adresse wird auch manchmal bei RS485 Verbindungen benutzt.
//  -------------------------------------------------------------------
//  Bitte die Daten aus dem Gerät übernehmen
//
$WR_IP = "0.0.0.0";    //  Keine führenden Nullen!  67.xx Ja!, 067.xx Nein!
$WR_Port = "12345";
$WR_Adresse = "2";
$WR_Adresse = "2";
--------------------------------------
Ulrich [Admin]

wyky
Beiträge: 13
Registriert: Do 12. Aug 2021, 15:48
Danksagung erhalten: 1 Mal

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von wyky »

Hallo Andi,

bei mir steht in der x.user.config.php folgendes:
$WR_IP = "192.168.178.50"; // Keine führenden Nullen! 67.xx Ja!, 067.xx Nein!
$WR_Port = "502";
$WR_Adresse = "2";
In der "solaranzeige.log" wird folgendes protokolliert:
30.12. 00:02:20 -Verarbeitung von: '3.user.config.php' Regler: 34
30.12. 00:02:20 + -WR_ID: 02
30.12. 00:02:20 |------------ Start SDM630_meter.php -------------------------
Also die "$WR_Adresse" ohne führende "Nullen" eingeben !

Den Port 502 habe ich genommen, weil das der offizielle Port für die Modbus/TCP – Modbus/UDP Kommunikation
ist. Ob das hier ausschlaggebend ist, weis ich nicht.

Du kannst den SDM630 auch mal direkt an einen Windows-PC per USB hängen und diesen dann mit dem Programm
"EEM Meter Setting V2.0.0" abfragen. Hier siehtst Du dann auch das der "Telefonhörer" bei dem SDM630 bei einer
Abfrage aufleuchtet. Somit weist Du dann auch, das die Kabel richtig angeschlossen sind.

Gruß Udo

Andi1976
Beiträge: 6
Registriert: Do 18. Nov 2021, 16:51
Hat sich bedankt: 1 Mal

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von Andi1976 »

Guten Morgen,

ihr seid Genies.

Die WR ID habe ich gestern schon versucht. Also 002 und 2.
Nix...

Vorhin habe ich 02 eingetragen, und siehe da, es tut😊

Ich kann ja dann mal testen ob es mit der "2" jetzt auch funktioniert.

Vielen vielen Dank an euch.

@Ulrich: "Spende" kommt die Tage

Eine Frage: ich habe 1 WR, 1 Smartmeter und 4 Gosund Sp1 laufen.
Bräuchte aber eigentlich noch 2 Gosund Sp1. Das würde nur mit einem 2 Raspi funktionieren oder? Können diese 2 Raspis dann miteinander an Grafana liefern oder wie muss ich mir das vorstellen?

Benutzeravatar
Ulrich
Administrator
Beiträge: 2990
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 38 Mal
Danksagung erhalten: 193 Mal
Kontaktdaten:

Re: Multi-Regler Version SDM630 sendet keine Daten zu influxdb

Beitrag von Ulrich »

Bei 8 Geräten benötigst du 2 Raspberrys. Man kann die Daten des einen Raspberry zusätzlich an die Datenbank des anderen Raspberry schicken. Damit hätte man dann alle 8 Datenbanken auf einem Raspberry. Das ist aber alles in den Dokumentationen hier auf dem Support Server beschrieben.
--------------------------------------
Ulrich [Admin]

Antworten