[gelöst] Plötzlich keine USB Verbindung mehr zum WR

Wenn mehr als ein Gerät an den Raspberry angeschlossen werden sollen. Z.B. ein Regler und ein Wechselrichter oder mehrere Wechselrichter. Das Maximum sind 6 Geräte pro Raspberry Pi.

Moderator: Ulrich

Benutzeravatar
mr.big
Beiträge: 571
Registriert: Mi 7. Sep 2022, 12:12
Wohnort: tief im Osten...
Hat sich bedankt: 12 Mal
Danksagung erhalten: 118 Mal

Re: [gelöst] Plötzlich keine USB Verbindung mehr zum WR

Beitrag von mr.big »

Roetty hat geschrieben:
Fr 12. Mai 2023, 12:25
Kann es sein, das wenn mitten im Betrieb des SA-PIs die USB Verbindung unterbrochen- und dann wieder hergestellt wird der hidraw auf 1 gesetzt wird?

VG Rötty
Ja, das wäre eine sehr schlüssige Erklärung des Problems!

Roetty
Beiträge: 27
Registriert: So 5. Sep 2021, 08:29
Hat sich bedankt: 3 Mal

Re: Plötzlich keine USB Verbindung mehr zum WR

Beitrag von Roetty »

Hm... ne. Scheint es nicht zu sein. Ich habe einfach mal den USB vom WR gezogen und wieder gesteckt. Es bleibt hidraw0. Habs 2x getestet.

Echt seltsam...
WR: MPI5K
Module: 10 x 375W Trina + 12 x 385W Trina
AKKU: 14kw-DIY-Akku 16x EVE 280Ah - Daly-BMS

Roetty
Beiträge: 27
Registriert: So 5. Sep 2021, 08:29
Hat sich bedankt: 3 Mal

Re: [gelöst] Plötzlich keine USB Verbindung mehr zum WR

Beitrag von Roetty »

Naja... ich werde wohl oder übel Solaranzeige wieder abknipsen und meine Anlage wie zuvor mit ioBroker monitoren. Ich komme mit diesem Hidraw-geraffel einfach nicht weiter. Heute hatte ich auch wieder einen "Aussetzer". Das ärgerliche ist, das dann eben auch Daten verloren gehen.

Trotzdem Danke an alle die versucht haben zu helfen.

VG
WR: MPI5K
Module: 10 x 375W Trina + 12 x 385W Trina
AKKU: 14kw-DIY-Akku 16x EVE 280Ah - Daly-BMS

Andi8875
Beiträge: 4
Registriert: Mo 29. Jan 2018, 18:06
Wohnort: Solingen
Danksagung erhalten: 1 Mal

Re: [gelöst] Plötzlich keine USB Verbindung mehr zum WR

Beitrag von Andi8875 »

Moin Moin!
Ich hab den PIP5000MK.
das mit der USB Schnittstelle zum Raspi ist nicht dolle... warum auch immer.
Also deine Probleme kann ich nur bestätigen.

LG
Andreas

Heiner
Beiträge: 23
Registriert: Di 17. Nov 2020, 23:58

Re: [gelöst] Plötzlich keine USB Verbindung mehr zum WR

Beitrag von Heiner »

Ich hatte ein ähnliches Problem mit der USB-Verbindung zwischen Solaranzeige-Raspi und meinem Hybrid-Wechselrichter Outback Power SPC III 5000-48 über ein 5m USB-Kabel. Ursache war bei mir eindeutig das lange Kabel. Mit einem Kurzen zum testen lief's immer.
Bei mir ist aber immer die USB-Schnittstelle im Wechselrichter abgestürzt. Nach Wechselrichter-Neustart war dann alles wieder OK. Manchmal für Wochen und manchmal nur für ein paar Minuten.
Gelöst habe ich das Problem nun (hoffentlich) durch die Verwendung eines selbst gebauten USB-Kabels ohne Schirm und mehreren Windungen des Kabels durch jeweils einen Klapp-Ferrit-Kern an 3 Stellen.

Antworten

Zurück zu „Multi-Regler-Version [ bis zu 6 Geräten an einem Raspberry Pi ]“