Fronius Symo API Keine gültigen Daten empfangen.

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
sollog
Beiträge: 12
Registriert: Mo 18. Mai 2020, 18:38

Fronius Symo API Keine gültigen Daten empfangen.

Beitrag von sollog »

Hallo zusammen,
ich habe meinen Wechselrichter Fronius Symo Hybrid 5.0-3-S Upgedatet, Firmware Version 1.18.6-1
Nun bekomme ich keine Daten mehr angezeigt.
Fehlermeldung:
31.05. 19:02:01 |---------------- Start fronius_symo_serie.php ---------------
31.05. 19:02:02 -API Version: 1 CompatibilityRange: 1.6-3
31.05. 19:02:20 !! -Keine gültigen Daten empfangen.
31.05. 19:02:20 |---------------- Stop fronius_symo_serie.php ---------------

Da ich selbst täglich eine Datei vom Wechselrichter abhole
"url = "http://" + self.hostname + "/solar_api/v1/GetArchiveData.cgi?Scope=System&StartDate=" + \"
und dies weiterhin funktioniert gehe ich mal davon aus, dass es an einer Kleinigkeit der Solaranzeige liegt.

Gruß und Danke!

Benutzeravatar
Ulrich
Administrator
Beiträge: 3783
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 64 Mal
Danksagung erhalten: 316 Mal
Kontaktdaten:

Re: Fronius Symo API Keine gültigen Daten empfangen.

Beitrag von Ulrich »

Kannst Du bitte einmal die beiden LOG Dateien hier posten:

/var/www/log/php.log
/var/www/log/solaranzeige.log

Die letzten 10 Minuten reichen wenn die Datei sehr groß ist.
--------------------------------------
Ulrich [Admin]

sollog
Beiträge: 12
Registriert: Mo 18. Mai 2020, 18:38

Re: Fronius Symo API Keine gültigen Daten empfangen.

Beitrag von sollog »

Anbei die Logs als Anhang.

Nachtrag:
Der Wechselrichter mit der Fehlermeldung hat die IP 192.168.130.16
Dateianhänge
php.log
(1.05 MiB) 119-mal heruntergeladen
solaranzeige.log
(1.12 MiB) 120-mal heruntergeladen

Benutzeravatar
Ulrich
Administrator
Beiträge: 3783
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 64 Mal
Danksagung erhalten: 316 Mal
Kontaktdaten:

Re: Fronius Symo API Keine gültigen Daten empfangen.

Beitrag von Ulrich »

Kannst Du bitte ein Solaranzeigen Update machen, dann sollte das Problem beseitigt sein.
--------------------------------------
Ulrich [Admin]

sollog
Beiträge: 12
Registriert: Mo 18. Mai 2020, 18:38

Re: Fronius Symo API Keine gültigen Daten empfangen.

Beitrag von sollog »

Hallo Ulrich,
habe das Update gemacht.
Software Version 4.7.2a update April 2021
Last login: Mon May 31 20:44:25 2021

Weiterhin keine Daten und selbe Fehlermeldung

31.05. 20:48:01 -Multi Regler Auslesen [Start].
31.05. 20:48:01 -Verarbeitung von: '1.user.config.php' Regler: 12
31.05. 20:48:01 |---------------- Start fronius_symo_serie.php ---------------
31.05. 20:48:01 -API Version: 1 CompatibilityRange: 1.6-3
31.05. 20:48:10 !! -Keine gültigen Daten empfangen.
31.05. 20:48:10 |---------------- Stop fronius_symo_serie.php ---------------

Benutzeravatar
Ulrich
Administrator
Beiträge: 3783
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 64 Mal
Danksagung erhalten: 316 Mal
Kontaktdaten:

Re: Fronius Symo API Keine gültigen Daten empfangen.

Beitrag von Ulrich »

Ich meinte ein Update am 31.05.2021 nach 20:00 Uhr. Die Versionsnummer bleibt dabei gleich.
Ich melde mich Morgen per eMail.
--------------------------------------
Ulrich [Admin]

gdig
Beiträge: 3
Registriert: Fr 16. Okt 2020, 09:58

Re: Fronius Symo API Keine gültigen Daten empfangen.

Beitrag von gdig »

Hallo Ulrich,

habe heute zusätzlich zu Fronius Symo eine Batterie dazubekommen. Seit dem Wiedereinschalten des WR gibt es keine Daten mehr. Habe selbe Fehlermeldung wie Kollege in diesem Thread.

Habe folgendes gemacht:
- WR kann angepingt werden (auch mit Port 80)
- Update auf aktuelle Version Solaranzeige
- Reboot

Anbei Auszüge aus den Logfiles (php und solaranzeige):
- vor dem Abschalten
- während des Ausgeschaltensein
- nach dem Einschalten
- nach Update/Reboot

Bitte um Unterstützung, was ich noch beachten muss

lg
Gernot Dirnberger

Log_20210621.txt
(7.61 KiB) 133-mal heruntergeladen

Benutzeravatar
Ulrich
Administrator
Beiträge: 3783
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 64 Mal
Danksagung erhalten: 316 Mal
Kontaktdaten:

Re: Fronius Symo API Keine gültigen Daten empfangen.

Beitrag von Ulrich »

Der Fehler ist beseitigt. Es war ein Schreibfehler im Script. Das Update hat den Fehler nicht mehr.
--------------------------------------
Ulrich [Admin]

Meyer94
Beiträge: 1
Registriert: So 8. Mai 2022, 10:37

Re: Fronius Symo API Keine gültigen Daten empfangen.

Beitrag von Meyer94 »

Hallo zusammen,

Ich bin bei Googeln meines Problems, auf diesen Forenbeitrag gestoßen.
Und zwar habe ich auch das problem, das ich keine Verbindung bzw. Daten von meinem Fronius Symo 10 Wechselrichters in meine Solaranzeige bekomme.

Ich habe die Solaranzeige mit meinem Senec Speicher bereits in betrieb.
Den Fronius habe ich nach der Multi-Regler Anleitgung nun auch mit eingebunden. Aber leider bekomme ich hier keine Daten vom Wechselrichter.

Ich bin leider nicht soo sehr vertraut mit der Programmierung, aber villeicht habt ihr ja eine Idee woran es liegen könnte.

Sonnige Grüße, und Danke!
Dateianhänge
Solaranzeige.log.png
php.log.png

Antworten