Letzter Versuch zur Steuerung einer Keba 30

PV Überschussladen mit Wallboxen. (intelligenten Ladestationen) Alles was mit der eingebauten Wallbox-Steuerung zu tun hat.

Moderator: Ulrich

Antworten
Janniman
Beiträge: 148
Registriert: Mi 13. Okt 2021, 09:52
Hat sich bedankt: 9 Mal
Danksagung erhalten: 7 Mal

Letzter Versuch zur Steuerung einer Keba 30

Beitrag von Janniman »

Moin.
Trotz intensiver Studie (ca. 20x) der Anleitungen zur Steuerung einer Wallbox, hier der Keba c30, bekomme ich es nicht hin.
Die RFID-Funktionalität der Wallbox wurde ausgeschaltet, also kann jeder jederzeit laden (sehr ungünstig).

Das php.log hat keine Meldungen für mich.
Die wallbox.log vermeldet:

Code: Alles auswählen

27.03. 07:56:01 |--> - - - - - - - - -    Start WB Steuerung   - - - - - - - -
27.03. 07:56:01      Es ist keine 1.wallbox.steuerung.ini vorhanden.
27.03. 07:56:01      Es ist keine 2.wallbox.steuerung.ini vorhanden.
27.03. 07:56:01      Es ist keine 3.wallbox.steuerung.ini vorhanden.
27.03. 07:56:01 INFO Grundlage der Steuerung ist die INI Datei '4.wallbox.steuerung.ini'.
27.03. 07:56:01 ERRO Steuerung nicht aktiviert. Keine Ladequelle ausgesucht. Ausgang...
27.03. 07:56:01      Es ist keine 5.wallbox.steuerung.ini vorhanden.
27.03. 07:56:01      Es ist keine 6.wallbox.steuerung.ini vorhanden.
27.03. 07:56:01 ENDE ---------------------------------------------------------
Die Befehle auf dem Keba-Dashboard funktionieren alle NICHT. Egal ob mit solaranzeige.local, localhost, IP, ich lande immer hier
Fehler-Wallboxsteuerung2.jpg
Bei den drei Schaltflächen zur Auswahl der Steuerung passiert NICHTS.
Meine Datenbank "steuerung" beinhaltet außer dem Measurement "Wallbox" NICHTS
Fehler-Wallboxsteuerung1.jpg
Fehler-Wallboxsteuerung1.jpg (22.83 KiB) 1374 mal betrachtet
Da ich selbst kein E-Auto habe, das meines Mieters erst im Herbst kommen wird, habe ich nicht viele Varianten dies zu testen.
Ich vermute entweder einen falschen Port bei der Keba, oder die Angabe des WR-Adresse.
Fehler-Wallboxsteuerung3.jpg
Fehler-Wallboxsteuerung4.jpg
Sieht vielleicht jemand, wo ich meinen Fehler eingebaut habe?

Der Fehlertext ist eindeutig:
27.03. 07:56:01 INFO Grundlage der Steuerung ist die INI Datei '4.wallbox.steuerung.ini'.
27.03. 07:56:01 ERRO Steuerung nicht aktiviert. Keine Ladequelle ausgesucht. Ausgang...

Nur hilft mir das irgendwie nicht, weil ich nichts auswählen kann. Besser: wie suche ich (wenigstens manuell) eine Ladequelle aus, wenn schon nicht über die Buttons?
Bei den drei linken Buttons, da kann ich den Raspi neu starten (funktioniert), sehe aber KEIN LOG beim zweiten Button (wblog.php gibt es bei mir nicht, wohl aber eine wallbox.log) und habe NULL Funktion bei "WB-Steuerung aus"

Ich drehe mich seit Monaten im Kreis.

Jan

KaMaKi
Beiträge: 24
Registriert: Mo 29. Nov 2021, 11:51
Danksagung erhalten: 2 Mal

Re: Letzter Versuch zur Steuerung einer Keba 30

Beitrag von KaMaKi »

Du musst die Links der drei Buttons anpassen. Bei mir war es so, dass ich in den Links "solaranzeige.local" durch die IP-Adresse des Raspi ersetzen musste.
Dann kopierst Du noch den gesamten Link nach "Data links" und schon klappt das mit der Auswahl der Quelle.

Janniman
Beiträge: 148
Registriert: Mi 13. Okt 2021, 09:52
Hat sich bedankt: 9 Mal
Danksagung erhalten: 7 Mal

Re: Letzter Versuch zur Steuerung einer Keba 30

Beitrag von Janniman »

Hallo KaMaKi.

Danke für die Antwort. Das hatte ich schon geändert und in vielen Varianten probiert. Das ist nicht das bei mir vorliegende Problem.

Der nächste bitte… 😬

Jan

KaMaKi
Beiträge: 24
Registriert: Mo 29. Nov 2021, 11:51
Danksagung erhalten: 2 Mal

Re: Letzter Versuch zur Steuerung einer Keba 30

Beitrag von KaMaKi »

Warum hast Du eigentlich alle sechs möglichen Regler installiert, wenn Du nur zwei verwendest?
Ich an deiner Stelle würde mit einer sauberen Neuinstallation anfangen und nur den zweiten Regler der Multi-Regler-Variante nutzen.
Bei deinen Links hast Du schon am Ende "&config=4" stehen?
PS: hast Du die ID deines Dashboards geändert? Die Vorlage hat die ID 99Keba0001, nicht 99KebaS001 wie aus deinem Screenshot ersichtlich.

Janniman
Beiträge: 148
Registriert: Mi 13. Okt 2021, 09:52
Hat sich bedankt: 9 Mal
Danksagung erhalten: 7 Mal

Re: Letzter Versuch zur Steuerung einer Keba 30

Beitrag von Janniman »

Moin KaMaKi.
Ich habe die sechs (Software-) möglichen Regler NICHT installiert.
Das erscheint nur deshalb im LOG, weil ich den TraceLevel auf 4 gesetzt habe (Debugging). Dann erscheinen alle Ausgaben.
Bei mir sind vier Regler installiert und ich nutze auch nur
1.user.config.php - solaranzeige WR1
2.user.config.php - solaranzeige2 WR2
3.user.config.php - solaranzeige3 KSEM
4.user.config.php - solaranzeige4 Wallbox
PS: hast Du die ID deines Dashboards geändert? Die Vorlage hat die ID 99Keba0001, nicht 99KebaS001 wie aus deinem Screenshot ersichtlich.
Genau so etwas habe ich bei mir erwartet und suche dahingehend den Fehler!
Aber ja, ich habe die ID geändert, bzw. eine Kopie des Dashboards geladen und dadurch die ID geändert. Das ursprüngliche Dashboard war kaputt-designt. Ich kontrolliere aber nochmals. ... Minuten später ...
Zwischenablage01.jpg
Die ID des Dashboards stimmt mit der ID in den Links überein.

Die Suche geht weiter. Trotzdem Danke für den Input!

Jan

Alsfar
Beiträge: 18
Registriert: Di 26. Sep 2023, 20:09
Hat sich bedankt: 2 Mal
Danksagung erhalten: 3 Mal

Re: Letzter Versuch zur Steuerung einer Keba 30

Beitrag von Alsfar »

Moin,
und bist du fündig geworden?

Hast du mal probiert ob du auf teile der URL drauf kommst?

Grüße Alsfar

Janniman
Beiträge: 148
Registriert: Mi 13. Okt 2021, 09:52
Hat sich bedankt: 9 Mal
Danksagung erhalten: 7 Mal

Re: Letzter Versuch zur Steuerung einer Keba 30

Beitrag von Janniman »

Moin und Entschuldigung für die späte Rückmeldung.

Nein, ich bin nicht weiter gekommen.
Liegt aber daran, dass ich mir ein EV erstmal nicht zulegen werde.
Meine Solaranlage ist mit den inzwischen 16 kW einfach zu klein. Es gibt trotz vielfacher Anfragen niemanden, der zu einem vernünftigen Preis nochmal 14 kW auf das freie Dach bauen möchte (damit in den Kostal-Schwarm hinein).
Ich bekomme sogar jetzt schon den 7,7 kW Speicher nicht voll. Selbst wenn dieser voll wäre, dann ist er am nächsten Morgen leer. Heute am 01.11.23 habe ich den Speicher von 10% auf nur 30% geladen bekommen, daher ist eine Erweiterung sinnlos. Dazu kommt, es soll nun auch eine Wärmepumpe eingebaut werden. Warum also einen EV? Meinen Diesel habe ich nach einem Unfall gerade reparieren lassen und werde diesen einfach weiterfahren, weil günstiger und energetischer.
Nächster Punkt, mein Mieter hat seine EV-Pläne jetzt auch kurzfristig geändert.
Ich habe also eine Wallbox ohne Nutzen. :-(

Ich würde aber dennoch gerne eine vernünftige Steuerung hinbekommen, nur eben irgendwann.

Sorry und trotzdem viel Erfolg bei deinem Vorhaben!
Ich lese mit und wenn es jemand Kund tut, dass es läuft, dann werde ich mich auch wieder damit beschäftigen.

Antworten

Zurück zu „Wallbox Steuerung [intelligente Ladestationen ]“