Nach kurzer Zeit keine Daten mehr vom Wechselrichter

Alles was mit der Solaranzeige Image Installation und Betrieb zu tun hat. Einfache Konfiguration mit einem Gerät.

Moderator: Ulrich

Tommy23
Beiträge: 12
Registriert: Sa 10. Jun 2023, 13:08

Re: Nach kurzer Zeit keine Daten mehr vom Wechselrichter

Beitrag von Tommy23 »

Hi ich mal wieder und immer noch das Problem mit den fehlenden Daten. Ich habe nun vieles ausprobiert ohne ein brauchbares Ergebnis. Was mir aber aufgefallen ist, jedesmal wenn der WR in den Standby Modus geht, habe ich auch keine Datenübertragung. Ein Reboot bringt nichts, erst ein kompletter Neustart ist erfolgreich. WR und Dongle sind auf dem letzten SW-Stand. Ich werde mal den Dongle auf die 133er SW downgraden, so wie es timbow1899 gemacht hat und beobachten ob dann die Daten wieder geschrieben werden.

Update zum Eintrag oben:
Seit dem 20.11. läuft jetzt die Datenabfrage mit der 133er Dongle SW. Allerdings werden in der solaranzeige.log noch andere Einträge geschrieben (siehe Screenshot), die diese unnötig 'aufblähen'. Diese Einträge kommen in unregelmäßigen Abständen. Sind diese Einträge 'bedenkenlos' bzw kann man diese irgendwo/-wie abschalten?
Den Pi habe ich jetzt an einem WIMAXIT 10.1 Zoll Raspberry Pi 4 Touchscreen montiert und über das WLAN im Netzwerk eingebunden. Funktioniert tadellos, habe verschiedene Dashboards am laufen (in 4 Reitern im Firefox-esr), wo ich umherschalten kann. An einem, für mich passendes Board, will ich mich demnächst wagen.
Dateianhänge
Screenshot_20231124_095642_RaspController.jpg
Screenshot_20231124_100204_RaspController.jpg

timbow1899
Beiträge: 11
Registriert: Mi 28. Jun 2023, 13:10

Re: Nach kurzer Zeit keine Daten mehr vom Wechselrichter

Beitrag von timbow1899 »

Hallo zusammen,

habe nun wieder die FW Version V200R022C10SPC108 auf den Dongle gespielt und wieder habe ich das Problem das nach einigen Stunden, manchmal auch Tage plötzlich keine Daten mehr ankommen. Hat kein anderer hier das Problem mit der FW V200R022C10SPC108?

Grüße

Timo

Benutzeravatar
Ulrich
Administrator
Beiträge: 5587
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 890 Mal
Kontaktdaten:

Re: Nach kurzer Zeit keine Daten mehr vom Wechselrichter

Beitrag von Ulrich »

Hast du in der user.config.php immer noch
$Wiederholungen = 3;
drin?
Dann setze das bitte wieder auf 1
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

timbow1899
Beiträge: 11
Registriert: Mi 28. Jun 2023, 13:10

Re: Nach kurzer Zeit keine Daten mehr vom Wechselrichter

Beitrag von timbow1899 »

Hi Ulrich,

steht auf 1 :?:

root@solaranzeige:~# grep '$Wiederholungen' /var/www/html/user.config.php
$Wiederholungen = 1;
root@solaranzeige:~#

Benutzeravatar
Ulrich
Administrator
Beiträge: 5587
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 890 Mal
Kontaktdaten:

Re: Nach kurzer Zeit keine Daten mehr vom Wechselrichter

Beitrag von Ulrich »

Das Problem musst du eher in deinem lokalen LAN / WLAN suchen. Bitte gebe einmal auf der Konsole folgendes ein:

nmap -p 502 192.168.178.44

und

ping -c 20 192.168.178.44
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

timbow1899
Beiträge: 11
Registriert: Mi 28. Jun 2023, 13:10

Re: Nach kurzer Zeit keine Daten mehr vom Wechselrichter

Beitrag von timbow1899 »

Hi,

der Fehler liegt definitiv nicht am LAN, glaube mir ich weiss was ich IP mäßig mache.

Und wie gesagt wenn ich die alte FW benutze habe gar keine Probleme.
Ich werde nun nochmal auf Version: V100R001C00SPC133 zurückfallen -

Hier der TCP dump wenn es nicht funktioniert der

00:18:01.473665 IP solaranzeige.fritz.box.37320 > wechslrichter-smart-dongle.fritz.box.502: Flags [S], seq 2622665142, win 64240, options [mss 1460,sackOK,TS val 3385628697 ecr 0,nop,wscale 7], length 0
00:18:01.474474 IP wechslrichter-smart-dongle.fritz.box.502 > solaranzeige.fritz.box.37320: Flags [S.], seq 1157586823, ack 2622665143, win 1500, options [mss 536,nop,wscale 0], length 0
00:18:01.474507 IP solaranzeige.fritz.box.37320 > wechslrichter-smart-dongle.fritz.box.502: Flags [.], ack 1, win 502, length 0
00:18:02.457844 IP wechslrichter-smart-dongle.fritz.box.502 > solaranzeige.fritz.box.37320: Flags [F.], seq 1, ack 1, win 1500, length 0
00:18:02.459498 IP solaranzeige.fritz.box.37320 > wechslrichter-smart-dongle.fritz.box.502: Flags [.], ack 2, win 502, length 0
00:18:03.274906 IP solaranzeige.fritz.box.37320 > wechslrichter-smart-dongle.fritz.box.502: Flags [P.], seq 1:13, ack 2, win 502, length 12
00:18:03.275472 IP wechslrichter-smart-dongle.fritz.box.502 > solaranzeige.fritz.box.37320: Flags [R.], seq 2, ack 13, win 56325, length 0
00:19:01.347521 IP solaranzeige.fritz.box.33854 > wechslrichter-smart-dongle.fritz.box.502: Flags [S], seq 2907551746, win 64240, options [mss 1460,sackOK,TS val 3385688571 ecr 0,nop,wscale 7], length 0
00:19:01.348549 IP wechslrichter-smart-dongle.fritz.box.502 > solaranzeige.fritz.box.33854: Flags [S.], seq 1163246349, ack 2907551747, win 1500, optio

Tommy23
Beiträge: 12
Registriert: Sa 10. Jun 2023, 13:08

Re: Nach kurzer Zeit keine Daten mehr vom Wechselrichter

Beitrag von Tommy23 »

Hallo timbow1899,
ich habe seit gut 24h jetzt die SPC112 auf meinem Dongle und es werden weiterhin Daten geloggt so wie unter der 133er Version. Es muss also an der
108er Version liegen und nicht, wie Ulrich vermutet, am Netzwerk. Die anderen Versionen sind: WR SPC160 und Luna: SPC123. Das System ist heute
auch aus dem Standby ohne Probleme aufgewacht. Spiele mal die letzte Version auf den Dongle.

timbow1899
Beiträge: 11
Registriert: Mi 28. Jun 2023, 13:10

Re: Nach kurzer Zeit keine Daten mehr vom Wechselrichter

Beitrag von timbow1899 »

Hallo Tommy23,

leider kann ich die Firmware 112 gar nicht auswählen. Wie bekomme ich diese ins update Management ?

Grüße

timbow1899

Tommy23
Beiträge: 12
Registriert: Sa 10. Jun 2023, 13:08

Re: Nach kurzer Zeit keine Daten mehr vom Wechselrichter

Beitrag von Tommy23 »

timbow1899 hat geschrieben:
Di 16. Jan 2024, 22:39
Hallo Tommy23,

leider kann ich die Firmware 112 gar nicht auswählen. Wie bekomme ich diese ins update Management ?

Grüße

timbow1899
Hi, entweder die ZIP-Datei über die Huawei Webseite oder über die Photomate-Seite (https://photomate.zendesk.com/hc/en-gb).
Wenn Du diese ZIP-Datei hast, musst Du diese dann direkt über die Anlageneinrichtung am WR einspielen.

MfG Thomas

timbow1899
Beiträge: 11
Registriert: Mi 28. Jun 2023, 13:10

Re: Nach kurzer Zeit keine Daten mehr vom Wechselrichter

Beitrag von timbow1899 »

Hi

gibt es dazu eine Beschreibung ?

Grüße

timbow1899

PS: seit dem ich wieder auf der xxxxx133 bin nicht einen Aussetzer .

Antworten

Zurück zu „Image Installation [ Single-Regler Version ]“