64 Bit 5.0.7 kein WLAN und keine Daten von Effecta AX2

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
lumei
Beiträge: 2
Registriert: So 7. Aug 2022, 20:33

64 Bit 5.0.7 kein WLAN und keine Daten von Effecta AX2

Beitrag von lumei »

Ich hab kürzlich meine Solaranlage aufgebaut. Wechselrichter Effekta AX M2 und 2 x Pylon US2000C.
Da mir zur Überwachung der Daten die "Solaranzeige" sehr zu sagte, hab ich mir alles besorgt (RPi400).
Zuerst die Version 4.8.0 installiert, Setup gemacht Wechselrichter mit USB Kabel verbunden. Mehrmals neu gestarte und mehrmals Setup durchgeführt.
Das Ergebnis - keine Daten! Vielleicht hat jemand damit schon Erfahrung?
Nun dachte ich, versuche mal die Version 5.0.7. Das erste war, das sich kein WLAN aktivieren lässt. Ich habe die Hinweise und Vorschläge zu diesem Thema aus dem Forum ausprobiert, leider erfolglos. Weder in der angegebenen config.txt noch in der etc/network/interfaces habe ich etwas zum Aktivieren des WLAN gefunden. Ich vermute, dass die Version 5.0.7 für WLAN nicht vorgesehen ist oder anders programmiert, als die Vorgängerversionen.
Mit der Anzeige von Daten ist es genauso wie in der Version 4.8.0. Nichts zu sehen. In den Beschreibungen der Solaranzeige ist es immer so einfach beschrieben: Hardware beschaffen, Installieren, Zusammenschalten, Setup durchführen, Dashboard auswählen und los gehts. Bei mir leider nicht.
Da ich das Programmieren nicht gelernt habe, möchte ich auch nicht gern ohne Anleitung etwas in der Software verändern.
Vielleicht hat jemand die Gelegenheit mir ein paar gute Tips zu geben.
Übrigens mit einem PC und der mit der Solaranlage mitgelieferten Software kann ich mit USB die Daten auslesen.
Lumei

Benutzeravatar
Ulrich
Administrator
Beiträge: 5583
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 889 Mal
Kontaktdaten:

Re: 64 Bit 5.0.7 kein WLAN und keine Daten von Effecta AX2

Beitrag von Ulrich »

Hallo Lumei,
hast du auch ein USB Kabel mit Stecker A und Micro Stecker an den Enden? So sehen Handy Ladekabel aus, die in der Regel keine Datenleitungen enthalten. In fast allen der Fälle, wenn keine Daten ausgelesen werden können, werden "vorhandene Ladekabel" benutzt die dafür nicht geeignet sind.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

lumei
Beiträge: 2
Registriert: So 7. Aug 2022, 20:33

Re: 64 Bit 5.0.7 kein WLAN und keine Daten von Effecta AX2

Beitrag von lumei »

Hallo Ulrich,
naturlich habe ich so ein Kabel verwendet und mit dem gleichen Kabel auch den PC mit WatchPower verbunden, was funktioniert.
Wie kann ich bei der 64Bit Version 5.0.7 WLAN aktivieren?
Lumei

Benutzeravatar
Ulrich
Administrator
Beiträge: 5583
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 889 Mal
Kontaktdaten:

Re: 64 Bit 5.0.7 kein WLAN und keine Daten von Effecta AX2

Beitrag von Ulrich »

Hallo Lumei,

da gibt es im Internet viele Anleitungen für. Am einfachsten geht es mit dem Programm raspi-config. WLAN einzuschalten hat nichts primär mit der Solaranzeige zu tun. Es ist eine Funktion des Betriebssystems.

Vorher bitte in der Datei /boot/config.txt folgende Zeile löschen: (Falls die noch vorhanden ist)

# Bluetooth ausschalten
dtoverlay=pi3-disable-wifi <= löschen!
dtoverlay=pi3-disable-bt

Danach bitte ein reboot machen und dann mit raspi-config konfigurieren.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

otti469
Beiträge: 1
Registriert: Di 12. Apr 2022, 21:06

Re: 64 Bit 5.0.7 kein WLAN und keine Daten von Effecta AX2

Beitrag von otti469 »

Hallo lumei,
ich hatte auch das WLAN Problem bei meinem RPI4B. Irgendwo im www fand ich den Hinweis eth0 auf DHCP und wlan0 mit fester IP zu versehen. So funktioniert es bei mir. Die IP muss natürlich aus dem eigenen Netz verwendet werden und darf nicht bereits einem anderen Netzwerkgerät zugewiesen sein.

Hier meine Einstellungen in /etc/network/interfaces :
auto eth0
allow-hotplug eth0
iface eth0 inet dhcp

auto wlan0
allow-hotplug wlan0
iface wlan0 inet static
address 192.168.178.5
netmask 255.255.255.0
gateway 192.168.178.1
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Antworten

Zurück zu „Allgemeines“