grafana startet nicht

Solaranzeige und Docker
Alles was mit der Docker Version zu tun hat.

Moderatoren: Ulrich, DeBaschdi

Antworten
j1gg
Beiträge: 6
Registriert: Di 18. Apr 2023, 10:37
Danksagung erhalten: 1 Mal

grafana startet nicht

Beitrag von j1gg »

Hallo zusammen,

ich bekomme es nicht hin, dass Grafana startet. Habe das Image komplett gelöscht und von 0 mit der Einrichtung begonnen. Es kommt immer wieder die Meldung, dass Grafana nicht starten kann.

service grafana-server restart
Stopping Grafana Server:start-stop-daemon: matching on world-writable pidfile /var/run/grafana-server.pid is insecure


eine anderen Output habe ich leider nicht.



edit:

bin auf das :legacy image gegangen und nun gehts :)

solarfanenrico

Re: grafana startet nicht

Beitrag von solarfanenrico »

j1gg hat geschrieben:
Mi 19. Apr 2023, 11:16
Hallo zusammen,

ich bekomme es nicht hin, dass Grafana startet. Habe das Image komplett gelöscht und von 0 mit der Einrichtung begonnen. Es kommt immer wieder die Meldung, dass Grafana nicht starten kann.

service grafana-server restart
Stopping Grafana Server:start-stop-daemon: matching on world-writable pidfile /var/run/grafana-server.pid is insecure


eine anderen Output habe ich leider nicht.



edit:

bin auf das :legacy image gegangen und nun gehts :)
Hallo,
die Befehle waren falsch.
Auf einen Raspberry gibt man folgende Befehle ein, damit man einen Zustand abfragen oder ändern kann. Bei Grafana lauten diese folgendermassen.
Statusabfrage
systemctl status grafana-server
Grafana stoppen
systemctl stop grafana-server
Grafana starten
systemctl start grafana-server
Grafana neu starten
systemctl restart grafana-server
Je nachdem auf welche Weise Grafana installiert wurde, muß man es jedoch auch dem System bekannt machen. Dafür sind dann aber andere Befehle nötig.
Du hattest ja geschrieben , komplett von vorn angefangen zu haben. Dieser Beginn sollte für eine genaue Fragestellung auch definiert sein.
Enrico

DeBaschdi
Beiträge: 300
Registriert: Mo 10. Aug 2020, 08:13
Hat sich bedankt: 15 Mal
Danksagung erhalten: 55 Mal

Re: grafana startet nicht

Beitrag von DeBaschdi »

solarfanenrico hat geschrieben:
Mi 19. Apr 2023, 16:12

Hallo,
die Befehle waren falsch.
Auf einen Raspberry gibt man folgende Befehle ein .....

Je nachdem auf welche Weise Grafana installiert wurde.....
Und auch hier :
Ein Dockerimage ist KEIN Raspberry ! und welches OS sich innerhalb des Images verbirgt kannst du garnicht wissen.

Die Befehle waren erstens : richtig, und zweitens hat der Fragesteller mit meinem Legacy Image (für alte Kernel Hostversionen) sich helfen können.
Danke, ich habe auch hier fertig, am besten du gaggerst nur noch wenn du weißt wovon du schreibst.

solarfanenrico

Re: grafana startet nicht

Beitrag von solarfanenrico »

DeBaschdi hat geschrieben:
Mi 26. Apr 2023, 02:31
solarfanenrico hat geschrieben:
Mi 19. Apr 2023, 16:12

Hallo,
die Befehle waren falsch.
Auf einen Raspberry gibt man folgende Befehle ein .....

Je nachdem auf welche Weise Grafana installiert wurde.....
Und auch hier :
Ein Dockerimage ist KEIN Raspberry ! und welches OS sich innerhalb des Images verbirgt kannst du garnicht wissen.

Die Befehle waren erstens : richtig, und zweitens hat der Fragesteller mit meinem Legacy Image (für alte Kernel Hostversionen) sich helfen können.
Danke, ich habe auch hier fertig, am besten du gaggerst nur noch wenn du weißt wovon du schreibst.
@Debaschdi,
erstens wird "garnicht" gar nicht zusammengeschrieben, und zweitens was hast Du für ein Problem, so angepisst zu reagieren ? Es deutet auf ein ernstes Problem Deiner momentanen Verfassung hin. Her hilft eine Therapie.

Jeder meiner Beiträge durchläuft eine sogenannte Zensur, mit diesem Hinweis "Dieser Beitrag kann von anderen Benutzer nicht gelesen werden, bis er von einem Moderator freigegeben wurde. " Der sogenannte Moderator entscheidet letztlich, ob und wann der Betrag hier veröffentlicht wird, oder auch nicht. Rede doch mal mit dem Verantwortlichen, dann kann soetwas gar nicht passieren.
Enrico

DeBaschdi
Beiträge: 300
Registriert: Mo 10. Aug 2020, 08:13
Hat sich bedankt: 15 Mal
Danksagung erhalten: 55 Mal

Re: grafana startet nicht

Beitrag von DeBaschdi »

Oh, prima, jetzt wird die Nadel im Heuhaufen meiner Beiträge gesucht, scheinbar fehlen dir Argumente.
Aber sei beruhigt, mir geht es super.
Den Rest ignoriere ich einfach mal, da ich keine Lust habe dich fortlaufend zu belehren, einen hab ich aber noch :
solarfanenrico hat geschrieben:
Mi 26. Apr 2023, 08:51
Her hilft eine Therapie.
Liest sich mit "Hier hilft eine Therapie" besser.

Benutzeravatar
mr.big
Beiträge: 527
Registriert: Mi 7. Sep 2022, 12:12
Wohnort: tief im Osten...
Hat sich bedankt: 11 Mal
Danksagung erhalten: 106 Mal

Re: grafana startet nicht

Beitrag von mr.big »

Könnt ihr bitte euern "Beef" per PN fortsetzen!

Es nervt langsam!

j1gg
Beiträge: 6
Registriert: Di 18. Apr 2023, 10:37
Danksagung erhalten: 1 Mal

Re: grafana startet nicht

Beitrag von j1gg »

ists denn generell soll, dass das Docker Image nur via legacy Version läuft?

DeBaschdi
Beiträge: 300
Registriert: Mo 10. Aug 2020, 08:13
Hat sich bedankt: 15 Mal
Danksagung erhalten: 55 Mal

Re: grafana startet nicht

Beitrag von DeBaschdi »

Nein,
das Legacy ist für ältere X86 Kernel z.b Synology Kernel 3.X

Antworten

Zurück zu „Docker Container“