Sungrow plötzlich keine Daten mehr

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
Locutus_359
Beiträge: 2
Registriert: So 7. Mai 2023, 12:38

Sungrow plötzlich keine Daten mehr

Beitrag von Locutus_359 »

Moin,

ich bin neu im Thema PV Bereich. Wir haben letzte Woche eine PV Anlage aufgebaut bekommen, mit einen Sungrow WR sh8.0rt und einem Axitec Speicher.

In der iSolarcloud habe ich aktuell noch keine Daten, das soll laut Elektriker bis zu 2 Wochen dauern?

Da mich die Daten aber schon interessieren und über das Webinterface vom WR ja Daten einsehbar sind, bin ich auf der Suche nach einer schöneren Auswertung direkt aus dem WR auf Solaranzeige gestoßen. Einen Raspberry Pi 3b+ hatte ich noch von einem anderen Project liegen (Retropie).

Gestern habe ich das ganze Eingerichtet, Farben im Dashboard etwas angepasst (rot/grün Schwäche). Alles wunderbar, nur seit heute 15:18 kommen keine Daten mehr an? Auf das Interface vom WR komme ich aber direkt drauf. Die Daten dort werden auch aktualisiert.

Den Raspberry habe ich schon neugestartet, beide sind im gleichen Netz. Vom Rapberry kann ich den WR auch anpingen. Im Log finde ich das hier:

Code: Alles auswählen

08.05. 15:17:01 |----------------   Start  sungrow.php    --------------------------
08.05. 15:17:01    -Sungrow: 192.168.1.106 Port: 502 GeräteID: 1
08.05. 15:17:01 +  -Die Daten werden ausgelesen...
08.05. 15:17:01    -Firmware: ARM_SAPPHIRE-H_V11_V01_B
08.05. 15:17:02    -Seriennummer: A22A280xxxxx
08.05. 15:17:09 *  -Daten zur lokalen InfluxDB [ solaranzeige ] gesendet.
08.05. 15:17:57    -Schleife 1 Ausgang...
08.05. 15:17:57    -OK. Datenübertragung erfolgreich.
08.05. 15:17:57 |----------------   Stop   sungrow.php    --------------------------
08.05. 15:18:01 |----------------   Start  sungrow.php    --------------------------
08.05. 15:18:01    -Sungrow: 192.168.1.106 Port: 502 GeräteID: 1
08.05. 15:18:01 +  -Die Daten werden ausgelesen...
08.05. 15:18:01    -Firmware: ARM_SAPPHIRE-H_V11_V01_B
08.05. 15:18:02    -Seriennummer: A22A280xxxxx
08.05. 15:18:10    -Lesefehler => Ausgang.
08.05. 15:18:10 |----------------   Stop   sungrow.php    --------------------------
08.05. 15:19:01 |----------------   Start  sungrow.php    --------------------------
08.05. 15:19:01    -Sungrow: 192.168.1.106 Port: 502 GeräteID: 1
08.05. 15:19:01 +  -Die Daten werden ausgelesen...
08.05. 15:19:08    -Lesefehler => Ausgang.
08.05. 15:19:08 |----------------   Stop   sungrow.php    --------------------------
08.05. 15:20:02 |----------------   Start  sungrow.php    --------------------------
08.05. 15:20:02    -Sungrow: 192.168.1.106 Port: 502 GeräteID: 1
08.05. 15:20:02 +  -Die Daten werden ausgelesen...
08.05. 15:20:09    -Lesefehler => Ausgang.
08.05. 15:20:09 |----------------   Stop   sungrow.php    --------------------------.
Der Plan ist, irgendwann die Solaranzeige direkt auf einem 7" Raspberry Bildschirm anzeigen zu lassen.

Benutzeravatar
Ulrich
Administrator
Beiträge: 5607
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 891 Mal
Kontaktdaten:

Re: Sungrow plötzlich keine Daten mehr

Beitrag von Ulrich »

Ich tippe einmal auf den RS485 zu USB Adapter. Hast du um15:00 Uhr ein weiteres USB Kabel angesteckt? Ist der Adapter eventuell defekt?
Wenn du nicht weiterkommst, schreibe eine eMail an hilfe@sol....
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

Locutus_359
Beiträge: 2
Registriert: So 7. Mai 2023, 12:38

Re: Sungrow plötzlich keine Daten mehr

Beitrag von Locutus_359 »

Moin,

Danke für deine Antwort.

Ich hatte gestern noch etwas mit dem iobroker auf einem Notebook probiert, das war ca. drei Stunden vorher.

Am WR habe ich zu der Zeit nichts angesteckt. Der SunGrow WR hängt per LAN im Netz.

Ich habe gestern nochmal den Switch im Keller neu gestartet. Danach lief auch Solaranzeige wieder. :?: Ping ging, aber scheinbar kam etwas anderes nicht durch. Ping alleine sagt ja nicht soviel aus.

Seit ca. 14 Stunden läuft es jetzt wieder.

Werde Mal nach den benötigten Komponenten für die Anzeige suchen.

PV muss ich leider heute eh wieder abschalten und auf Inbetriebnahme der Stadtwerke warten :cry: die ganze schöne verschenkte Sonnenenergie...

Gruß Christian

Antworten

Zurück zu „Allgemeines“