Einstellungen für Solaredge WR

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

misc2000
Beiträge: 21
Registriert: Sa 15. Mai 2021, 13:40
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Einstellungen für Solaredge WR

Beitrag von misc2000 »

Update: Ich habe jetzt meinen PV-Zähler vom Versorger über die optische Schnittstelle angebunden und lese die Werte mit vzlogger aus.
Soweit klappt das alles auch sehr gut. Nur irgendwie schaltet sich mein Raspberry Pi (2b) immer als 5-6h einfach ab.
Er ist irgendwann per Netzt nicht mehr erreichbar und dann ist nur noch die rote LED an und ab und die ersten paar mal blinkte die grüne zusätzlich noch 4x.
Ich habe gestern mal noch die Raspberry Desktop Oberfläche abgeschaltet um die Last etwas zu reduzieren und lasse den PI jetzt nur noch ins Terminal booten. Hat aber nichts geholfen.
Ich habe aktuell keine Ahnung ob das ein HW- oder SW-Problem ist, bzw. wo ich überhaupt nach dem Grund für die Abschaltung schauen könnte...

Hat irgendjemand eine Idee?

Benutzeravatar
Ulrich
Administrator
Beiträge: 5752
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 151 Mal
Danksagung erhalten: 820 Mal
Kontaktdaten:

Re: Einstellungen für Solaredge WR

Beitrag von Ulrich »

Es kann mehrere Gründe haben:

1. Der Raspberry 2B ist für das aktuelle Image nicht mehr geeignet.
2. Die SD Karte hat Speicherfehler
3. Die SD Karte ist voll (mal df -h in der Konsole eingeben)
-----------------------------------------------------
Ulrich . . . . . . . . [ Admin ]

misc2000
Beiträge: 21
Registriert: Sa 15. Mai 2021, 13:40
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: Einstellungen für Solaredge WR

Beitrag von misc2000 »

Hallo, Danke für die Info ich hatte auch schon die SD-Karte in verdacht.
Freier Speicher war gestern noch im Filesystem.
Nur gestern hat sich diese dann leider komplett verabschiedet.
Zum Glück erst nachdem ich die 2 wichtigsten Config Files gesichert hatte.
Bin gerade dabei alles neu aufzusetzen.
Da ich aber aktuell nur mit VZlogger Daten erfasse muss ich die Konfiguration von Solaranzeige erst mal leer lassen und später kommen da die Wallboxen rein. Ich hoffe das macht erst mal keine Probleme.

Der Pi 2b war hier noch verfügbar und wird erst mal für Tests benutzt, später mache ich alles mit einem 4er

Mein 1. Problem (PV-Produktionswerte und Eigenverbrauch zu bekommen) habe ich ja jetzt im Prinzip über VZlogger gelöst.

Jetzt muss ich mich noch für 2 Wallboxen entscheiden die ich ja eigentlich steuern will.
Welche der im Konfig-File stehenden kann man empfehlen wenn man 2 gleichzeitig anbinden will?
Wollte vielleicht eine 11kw und eine 22kw beschaffen oder doch "nur" 2 x 22kw
Ich bin mich noch am einlesen und tendiere gerade zu KEBA oder OpenWB !?!?

uluru
Beiträge: 1
Registriert: So 12. Jul 2020, 14:50

Einstellungen für Solaredge WR SE 12,5k ohne Display

Beitrag von uluru »

Hallo Gemeinde

Problem identifiziert (log ausgelesen) dass WR (SE12.5k ohne Display) nicht gefunden wird nach Erstinstallation/Konfiguration.

Ich habe Zugriff mit WLAN vom Wechselrichter über die mySolarEdge App, folgende Anzeigen:
Unter Kommunikation: LAN Ethernet verbunden, RS485-1 Modbus 1von 1, RS485-2 SE Slave.
Unter Zähler: Einspeisezähler SN*****, RS485-1 Modbus-ID #2, Status ok

Diese Idee geht bei mir nicht:
https://github.com/jbuehl/solaredge/iss ... -593628584
Ist die Adresse http://172.16.0.1 oder http://172.16.0.15, bei beiden wird die Seite nicht geöffnet.

Was genau muss nun bei Support SolarEdge freigeschaltet werden, resp wie lautet die technische Bezeichnung?

Danke
René

TeamO
Beiträge: 1174
Registriert: Mo 22. Jun 2020, 08:58
Wohnort: Ulm / Neu-Ulm
Hat sich bedankt: 17 Mal
Danksagung erhalten: 151 Mal

Re: Einstellungen für Solaredge WR

Beitrag von TeamO »

Bei Solaredge brauchst Du erstmal die IP in Deinem Netzwerk.
Wahrscheinlich irgend etwas mit 192.168.xxx.xxx
Dann muss durch Deinen Solarteur oder durch den SolarEdge-Support auf dem Wechselrichter ModbusTCP aktiviert werden.
Desweiteren benötigst Du dann von Deinem Solarteur oder vom SE-Support die Info zum ModbusTCP-Port und die WR-ID. Diese wird dort ebenfalls eingetragen/angezeigt.
Danach die entsprechenden Daten in der (x.)user.config.php eintragen, Solaranzeige/Raspi neu starten und danach dann den Wechselrichter ebenfalls neu starten.
Gruß Timo

Auflistung Geräte/Dashboards/Anschlussart
Datenbankfelder der einzelnen Geräte
GANZ WICHTIG: Überblick der vorhandenen Anleitungen

Fertige Komplett-Systeme gibt es hier anfragen[AT]bauer-timo[.]de

Tibber Invite (100% Öko-Strom + 50€ Bonus)

Goran
Beiträge: 2
Registriert: Sa 12. Dez 2020, 10:59

Solaredge WR liefert nach Neuinstallation keine Daten mehr

Beitrag von Goran »

Hallo,

mit meinem SE7k RWS lief die Solaranzeige bis Ende letzten Jahres problemlos. Im Winter stieg sie irgendwamm aus und ich bin erst jetzt dazu gekommen, sie wieder in Gang zu setzen.

Ich habe die Solaranzeige komplett neu eingerichtet mit neuestem Image. Der Raspberry kommuniziert offenbar mit dem WR, IP und Port stimmen, es gibt keine Fehlemeldungen in den Logs, MODBUS-TCP ist aktiviert.

Das Problem: Es sind alle gelesenen Daten Null bzw. werden von den Skripten zu Null konvertiert. Ich sehe das im Log mit Trace-Level des Regler Skrips auf 10 gesetzt. Werte wie Firmwareversion etc. sind auch Null.

Im damaligen Setup habe ich Regler Nummer 16 benutzt, jetzt habe ich es mit 16 und 20 (Solaredge 3-Phasen bzw. Solaredge 3-Phasen ohne MODBUS-Zähler) versucht, jeweils mit dem gleichen Ergebnis.

Unterschiedsmenge zum funktionierenden System vor wenigen Monaten:
- Solaranzeige 5.1 32 Bit statt vorher 4.6.9
- Am WR ist jetzt ein Einspeisezähler von SE ist angeschlossen, welcher korrekt arbeitet. Im alten funktionierenden Setup hatte ich erst keinen Zähler und dann einen Eastron 530-MT (in Multi-Regler-Konfig).
- Inzwischen hat der WR neuere Firmware bekommen, da ich mit SetApp den Einspeisezähler am WR eingerichtet habe und vor dem Verbinden immer auf die neueste Firmware upgedatet wird.

Was könnte die Ursache sein? Haben sich mit den letzten Firmwareupdates von SE vielleicht Adressen geändert?
In der MySolaredge-App wurden und werden alle Daten korrekt angezeigt.

Vielen Dank im Voraus
Goran

TeamO
Beiträge: 1174
Registriert: Mo 22. Jun 2020, 08:58
Wohnort: Ulm / Neu-Ulm
Hat sich bedankt: 17 Mal
Danksagung erhalten: 151 Mal

Re: Einstellungen für Solaredge WR

Beitrag von TeamO »

Hier könnte die WR-ID das Problem sein. Da jetzt ja an einem "Port" der Zähler am Wechselrichter angeschlossen, und entsprechend konfiguriert ist, muss für die Solaranzeige jetzt der zweite "Port" auf Sunspec mit eigener ID eingerichtet werden. Die Solaranzeige muss dann auf dieser ID auslesen.
Gruß Timo

Auflistung Geräte/Dashboards/Anschlussart
Datenbankfelder der einzelnen Geräte
GANZ WICHTIG: Überblick der vorhandenen Anleitungen

Fertige Komplett-Systeme gibt es hier anfragen[AT]bauer-timo[.]de

Tibber Invite (100% Öko-Strom + 50€ Bonus)

Goran
Beiträge: 2
Registriert: Sa 12. Dez 2020, 10:59

Re: Einstellungen für Solaredge WR

Beitrag von Goran »

Das war's! WR_Adresse auf 2 gestellt und es werden plausible Daten ausgelesen! Danke für die schnelle und kompetente Antwort und Viele Grüße
Goran

Antworten

Zurück zu „Allgemeines“