Von Einzel auf Multi

Wenn mehr als ein Gerät an den Raspberry angeschlossen werden sollen. Z.B. ein Regler und ein Wechselrichter oder mehrere Wechselrichter. Das Maximum sind 6 Geräte pro Raspberry Pi.

Moderator: Ulrich

Antworten
Benutzeravatar
Maxwell_Smart
Beiträge: 7
Registriert: Mo 19. Dez 2022, 19:41
Wohnort: Sauerland
Hat sich bedankt: 2 Mal

Von Einzel auf Multi

Beitrag von Maxwell_Smart »

Servus,
bin dabei meine Einzelversion auf die Multiversion zu heben. Geräte: Esmart3 und Tracer XTRA funktionieren in der EV einwandfrei. Vorgehen
nach der Anleitung von Ulrich. Erstes Gerät aus EV in die 1.user.config.php kopiert nach Anleitung geändert... läuft. Dann 1.user* in die 2.user
kopiert nach Anleitung geändert, Datenbank angelegt und bekannt gemacht und USB eingestöpselt... nix läuft. In der 2.user* habe ich die Baudrate
auf 38400 gesetzt diese wir aber in der LogDatei mit 115000 angezeigt.
Was mache ich da nicht richtig ?

Gruss Jürgen
2.user.config.php
(31.73 KiB) 108-mal heruntergeladen
solaranzeige.log
(5.93 KiB) 88-mal heruntergeladen
1.user.config.php
(31.74 KiB) 91-mal heruntergeladen
6xJAM60S21-375/MR = 4KW 48V DIY LIFEPO4 Speicher = Epever Xtra 40A = SUN-1000GTIL2 = ABB A44 Platinum

Benutzeravatar
Ulrich
Administrator
Beiträge: 5583
Registriert: Sa 7. Nov 2015, 10:33
Wohnort: Essen
Hat sich bedankt: 157 Mal
Danksagung erhalten: 889 Mal
Kontaktdaten:

Re: Von Einzel auf Multi

Beitrag von Ulrich »

Bitte die serielle Geschwindigkeit in beiden config Dateien herausnehmen. Dieser Eintrag wird nicht benötigt, wenn die Geräte nicht verstellt wurden.
Ist denn sicher, dass ttyUSB1 auch wirklich der Tracer ist? Am besten erst mit einem Gerät es versuchen. Wenn das läuft, das 2. Gerät dazu stecken. Die USB Verbindung zum 1. Gerät nicht mehr entfernen.
Für mich sieht das so aus, als ob /dev/ttyUSB0 und /dev/ttyUSB1 vertauscht sind.
-----------------------------------------------------
Ulrich . . . . . . . . [Projekt Administrator]

Benutzeravatar
Maxwell_Smart
Beiträge: 7
Registriert: Mo 19. Dez 2022, 19:41
Wohnort: Sauerland
Hat sich bedankt: 2 Mal

Re: Von Einzel auf Multi

Beitrag von Maxwell_Smart »

In der Liste der unterstützten Geräte steht bei Regler 19 : Mit FTDI Chipsatz Serielle Geschwindigkeit 9600 Baud
In der EV laufen beide Geräte mit der eingestellten Serielle Geschwindigkeit (esmart3 9600 und Xtra 38400) einwandfrei.
Ich probiere aber mal die Einstellungen aus deinem Post.
6xJAM60S21-375/MR = 4KW 48V DIY LIFEPO4 Speicher = Epever Xtra 40A = SUN-1000GTIL2 = ABB A44 Platinum

Benutzeravatar
Maxwell_Smart
Beiträge: 7
Registriert: Mo 19. Dez 2022, 19:41
Wohnort: Sauerland
Hat sich bedankt: 2 Mal

Re: Von Einzel auf Multi

Beitrag von Maxwell_Smart »

Es lag an den RS485-USB Adaptern. Die billigen China Dinger mit der festen ID würfeln beim Reboot oder beim Power On/Off die Ports durcheinander. Mal ist der eine ttyUSB0 oder ttyUSB1 mal der andere. Das machen die komischerweise auch wenn man die Port-Zuordnung per Symlink in der Rules macht. Bei der Einzelversion fällt das ja nicht auf... da funktionieren die Clone. Anmerkung: Mit den gesetzten Baudraten (esmart3 9600 und Xtra 38400) läuft alles einwandfrei.

Danke Ulrich für deine Hilfe.
6xJAM60S21-375/MR = 4KW 48V DIY LIFEPO4 Speicher = Epever Xtra 40A = SUN-1000GTIL2 = ABB A44 Platinum

Antworten

Zurück zu „Multi-Regler-Version [ bis zu 6 Geräten an einem Raspberry Pi ]“