SMA Zähler saldiert nicht?!

Allgemeine Informationen zum Nachbau und zum Forum.
PV-Monitorung / PV Überwachung

Moderator: Ulrich

Antworten
andreas_n
Beiträge: 1359
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 23 Mal
Danksagung erhalten: 83 Mal

SMA Zähler saldiert nicht?!

Beitrag von andreas_n »

Hallo @Ulrich

root@piONE:~# influx -host localhost -port 8086 -database SHM -precision rfc3339 -execute "select * from AC order by time desc limit 5"
name: AC
time Bezug Einspeisung Frequenz Leistung Leistung_R Leistung_S Leistung_T Leistungsfaktor Leistungsfaktor_R Leistungsfaktor_S Leistungsfaktor_T Spannung Spannung_R Spannung_S Spannung_T Strom Strom_R Strom_S Strom_T
---- ----- ----------- -------- -------- ---------- ---------- ---------- --------------- ----------------- ----------------- ----------------- -------- ---------- ---------- ---------- ----- ------- ------- -------
2023-08-27T09:28:11Z 901.1 864 50 37.1 -284.2 -579.8 901.1 0.248 1 0.99 0.997 231.22 231.22 231.9 231.59 7.943 1.242 2.549 4.152

oben steht eine Zeile aus der Influx des SMA Zählers..ich meine schonmal vor so 2 Jahren die Frage aufgeworfen zu haben, ob denn der Zähler saldierend über die energy.php erfasst wird. Scheinbar kommt die Routine nicht mit negativen Werten zu recht, jedenfalls werden diese irgendwie "verworfen", obwohl der Hybrid sauber über L3 ausregelt, sagt die Zähler Influx, es sei "Einspeisung"?!
Das macht sich dann bemerkbar bei der Automation, obwohl das Relais bei unter zb 500W Einspeisung abfallen soll, wird immer noch eine Einspeisung auf L1 und L2 addiert, und lässt das Relais angezogen. Auf L3 ("Leistung_T") hängt der Hybrid, das Dashboard funktioniert auch, nur irgendwie verhaspelt sich die Automation. Wenn ich in die sma_energy.php reinschau, find ich nix verdächtiges :?
lg Andreas
SMA Tripower 8 / Growatt MIN 3000 TL-XE / ELWA DC WW 300L / Growatt SPH 4600 an 4 ARK LV , 20,5kWp / 10kWh

andreas_n
Beiträge: 1359
Registriert: Do 25. Jun 2020, 13:40
Hat sich bedankt: 23 Mal
Danksagung erhalten: 83 Mal

Re: SMA Zähler saldiert nicht?!

Beitrag von andreas_n »

Ergänzung:

Hab mal in der sma_energy.php in der Zeile von Einspeisung ergänzend die WErte bezug mit (-) hinzugefügt, damit geht alles wie es sein soll.
Screenshot 2023-08-27 at 12-23-48 SMA Energy Meter - Dashboards - Dashboards - Grafana.jpg
weisse Pfeil nach Änderung der .php

grad gefunden, ursprünglicher Faden

viewtopic.php?p=11455&hilit=sma+HM2+sal ... cht#p11455
SMA Tripower 8 / Growatt MIN 3000 TL-XE / ELWA DC WW 300L / Growatt SPH 4600 an 4 ARK LV , 20,5kWp / 10kWh

Antworten

Zurück zu „Allgemeines“